Update to 9.0.3
Add upstream patch to fix Mayavi crash (bz#1966135)
This commit is contained in:
parent
baa123e14b
commit
9b4d485b83
2
.gitignore
vendored
2
.gitignore
vendored
@ -23,3 +23,5 @@ vtk-5.6.0.tar.gz
|
||||
/VTKData-9.0.1.tar.gz
|
||||
/VTK-9.0.2.tar.gz
|
||||
/VTKData-9.0.2.tar.gz
|
||||
/VTK-9.0.3.tar.gz
|
||||
/VTKData-9.0.3.tar.gz
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (VTK-9.0.2.tar.gz) = 65c6bce3023b45f2d145023ae6bf224257a6d89cdf7bbd4acda3d6a25cb6b8c947f0e9a44129bd1882d6d8a8d46fd4caef0463bfb94afc9f4edcca8566bc2393
|
||||
SHA512 (VTKData-9.0.2.tar.gz) = 3f4f9e5d241b69b514a72bad9e5b956a5d60e1335edb3feb66666b58e2813039c1ed9ed90e521a377bfaef03453eda6bbadc265df42e9f1f4057d2cb5018f138
|
||||
SHA512 (VTK-9.0.3.tar.gz) = 00528011f9206444d09fc6cea05c46930745bb70ea02be6244ab3eb510ae82af772157c025157b1761dc4c6a9ab538b57f814c03a708f30aa3598a421fdc6ae2
|
||||
SHA512 (VTKData-9.0.3.tar.gz) = 28ab2ecb32860d820f736e9ceb4345bcd03471f0a35b90f8c9ccbe05454f7a95a4de3c99bae2f4b9db87a27ef8fe50159cd283f5e921f4e6e69b06a50a0570c6
|
||||
|
19
vtk-openslidereader.patch
Normal file
19
vtk-openslidereader.patch
Normal file
@ -0,0 +1,19 @@
|
||||
commit 27e159a06042fd144dd9d30183cb38b1eba943d7
|
||||
Author: Aleksei Nikiforov <darktemplar@basealt.ru>
|
||||
Date: Fri Jun 25 11:36:29 2021 +0300
|
||||
|
||||
Fix crash in vtkOpenSlideReader destructor due to uninitialized pointer use
|
||||
|
||||
diff --git a/Domains/Microscopy/vtkOpenSlideReader.h b/Domains/Microscopy/vtkOpenSlideReader.h
|
||||
index 0e6daf8667..18a767886f 100644
|
||||
--- a/Domains/Microscopy/vtkOpenSlideReader.h
|
||||
+++ b/Domains/Microscopy/vtkOpenSlideReader.h
|
||||
@@ -73,7 +73,7 @@ protected:
|
||||
void ExecuteDataWithInformation(vtkDataObject* out, vtkInformation* outInfo) override;
|
||||
|
||||
private:
|
||||
- openslide_t* openslide_handle;
|
||||
+ openslide_t* openslide_handle = nullptr;
|
||||
|
||||
vtkOpenSlideReader(const vtkOpenSlideReader&) = delete;
|
||||
void operator=(const vtkOpenSlideReader&) = delete;
|
12
vtk.spec
12
vtk.spec
@ -45,8 +45,8 @@
|
||||
|
||||
Summary: The Visualization Toolkit - A high level 3D visualization library
|
||||
Name: vtk
|
||||
Version: 9.0.2
|
||||
Release: 6%{?dist}
|
||||
Version: 9.0.3
|
||||
Release: 1%{?dist}
|
||||
# This is a variant BSD license, a cross between BSD and ZLIB.
|
||||
# For all intents, it has the same rights and restrictions as BSD.
|
||||
# http://fedoraproject.org/wiki/Licensing/BSD#VTKBSDVariant
|
||||
@ -62,6 +62,9 @@ Patch2: vtk-includes.patch
|
||||
# Duplicate define conflict with Xutil, see:
|
||||
# https://gitlab.kitware.com/vtk/vtk/-/issues/18048
|
||||
Patch3: vtk-AllValues.patch
|
||||
# Upstream fix for openslidereader initialization that causes Mayavi to crash
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1966135
|
||||
Patch4: vtk-openslidereader.patch
|
||||
# Proj 5 support - backport https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7731
|
||||
Patch5: vtk-proj5.patch
|
||||
|
||||
@ -440,6 +443,7 @@ programming languages.
|
||||
%patch1 -p1 -b .limits
|
||||
%patch2 -p1 -b .includes
|
||||
%patch3 -p1 -b .AllValues
|
||||
%patch4 -p1 -b .openslidereader
|
||||
%patch5 -p1 -b .proj5
|
||||
# Remove included thirdparty sources just to be sure
|
||||
# TODO - diy2 - not yet packaged
|
||||
@ -803,6 +807,10 @@ cat xorg.log
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Sep 15 2021 Orion Poplawski <orion@nwra.com> - 9.0.3-1
|
||||
- Update to 9.0.3
|
||||
- Add upstream patch to fix Mayavi crash (bz#1966135)
|
||||
|
||||
* Tue Aug 10 2021 Orion Poplawski <orion@nwra.com> - 9.0.2-6
|
||||
- Rebuild for hdf5 1.10.7/netcdf 4.8.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user