Abandon system sqlite for now

This commit is contained in:
Orion Poplawski 2013-12-27 21:59:54 -07:00
parent 21516557d8
commit 94c0db44b3
2 changed files with 1 additions and 17 deletions

View File

@ -25,19 +25,3 @@ diff -up VTK6.0.0/CMakeLists.txt.system VTK6.0.0/CMakeLists.txt
# The third party macros are still used in one or two third party builds.
include(vtkThirdParty)
diff -up VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt.system VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt
--- VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt.system 2013-06-12 13:47:10.000000000 -0600
+++ VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt 2013-12-27 21:21:16.058122214 -0700
@@ -1,4 +1,9 @@
set(vtksqlite_THIRD_PARTY 1)
-set(vtksqlite_LIBRARIES vtksqlite)
-vtk_module_export_info()
-add_subdirectory(vtksqlite)
+if(VTK_USE_SYSTEM_SQLITE)
+ set(vtksqlite_LIBRARIES sqlite3)
+ vtk_module_export_info()
+else(VTK_USE_SYSTEM_SQLITE)
+ set(vtksqlite_LIBRARIES vtksqlite)
+ vtk_module_export_info()
+ add_subdirectory(vtksqlite)
+endif(VTK_USE_SYSTEM_SQLITE)

View File

@ -178,7 +178,7 @@ programming languages.
%patch2 -p1 -b .vtkpython
%patch3 -p1 -b .netcdf
# Remove included thirdparty sources just to be sure
for x in expat freetype gl2ps hdf5 jpeg libxml2 netcdf oggtheora png sqlite tiff zlib
for x in expat freetype gl2ps hdf5 jpeg libxml2 netcdf oggtheora png tiff zlib
do
rm -r ThirdParty/${x}/vtk${x}
done