Add patch to fix building with GCC 10 (bz#1800240)
This commit is contained in:
parent
322fa6f351
commit
8877cff153
32
vtk-gcc10.patch
Normal file
32
vtk-gcc10.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -up VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c.gcc10 VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c
|
||||||
|
--- VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c.gcc10 2019-01-30 10:15:13.000000000 -0700
|
||||||
|
+++ VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c 2020-05-08 21:38:46.401363001 -0600
|
||||||
|
@@ -614,5 +614,5 @@ int ex_create_par_int(const char *path,
|
||||||
|
* Prevent warning in some versions of ranlib(1) because the object
|
||||||
|
* file has no symbols.
|
||||||
|
*/
|
||||||
|
-const char exodus_unused_symbol_dummy_1;
|
||||||
|
+const char exodus_unused_symbol_dummy_ex_create_par;
|
||||||
|
#endif
|
||||||
|
diff -up VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c.gcc10 VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c
|
||||||
|
--- VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c.gcc10 2019-01-30 10:15:13.000000000 -0700
|
||||||
|
+++ VTK-8.2.0/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c 2020-05-08 21:38:46.402363007 -0600
|
||||||
|
@@ -474,5 +474,5 @@ int ex_open_par_int(const char *path, in
|
||||||
|
* Prevent warning in some versions of ranlib(1) because the object
|
||||||
|
* file has no symbols.
|
||||||
|
*/
|
||||||
|
-const char exodus_unused_symbol_dummy_1;
|
||||||
|
+const char exodus_unused_symbol_dummy_ex_open_par;
|
||||||
|
#endif
|
||||||
|
diff -up VTK-8.2.0/CMake/VTKGenerateExportHeader.cmake.gcc10 VTK-8.2.0/CMake/VTKGenerateExportHeader.cmake
|
||||||
|
--- VTK-8.2.0/CMake/VTKGenerateExportHeader.cmake.gcc10 2019-01-30 10:15:13.000000000 -0700
|
||||||
|
+++ VTK-8.2.0/CMake/VTKGenerateExportHeader.cmake 2020-05-26 21:07:24.625840251 -0600
|
||||||
|
@@ -174,7 +174,7 @@ macro(_vtk_test_compiler_hidden_visibili
|
||||||
|
execute_process(COMMAND ${CMAKE_C_COMPILER} --version
|
||||||
|
OUTPUT_VARIABLE _gcc_version_info
|
||||||
|
ERROR_VARIABLE _gcc_version_info)
|
||||||
|
- string(REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]*"
|
||||||
|
+ string(REGEX MATCH "[1-9][0-9]*\\.[0-9]+\\.[0-9]+"
|
||||||
|
_gcc_version "${_gcc_version_info}")
|
||||||
|
# gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
|
||||||
|
# patch level, handle this here:
|
7
vtk.spec
7
vtk.spec
@ -30,6 +30,9 @@ Source3: FindPEGTL.cmake
|
|||||||
Patch0: https://gitlab.kitware.com/vtk/vtk/merge_requests/5883.patch
|
Patch0: https://gitlab.kitware.com/vtk/vtk/merge_requests/5883.patch
|
||||||
# Proj 6 support
|
# Proj 6 support
|
||||||
Patch1: vtk-proj6_compat.patch
|
Patch1: vtk-proj6_compat.patch
|
||||||
|
# GCC 10 support based on:
|
||||||
|
# https://gitlab.kitware.com/vtk/vtk/-/merge_requests/6420
|
||||||
|
Patch2: vtk-gcc10.patch
|
||||||
|
|
||||||
URL: http://vtk.org/
|
URL: http://vtk.org/
|
||||||
|
|
||||||
@ -541,6 +544,7 @@ programming languages.
|
|||||||
%setup -q -b 1 -n VTK-%{version}
|
%setup -q -b 1 -n VTK-%{version}
|
||||||
%patch0 -p1 -b .py38
|
%patch0 -p1 -b .py38
|
||||||
%patch1 -p1 -b .proj6
|
%patch1 -p1 -b .proj6
|
||||||
|
%patch2 -p1 -b .gcc10
|
||||||
# Remove included thirdparty sources just to be sure
|
# Remove included thirdparty sources just to be sure
|
||||||
# TODO - diy2 - not yet packaged
|
# TODO - diy2 - not yet packaged
|
||||||
# TODO - exodusII - not yet packaged
|
# TODO - exodusII - not yet packaged
|
||||||
@ -987,6 +991,9 @@ cat xorg.log
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 27 2020 Orion Poplawski <orion@nwra.com> - 8.2.0-14
|
||||||
|
- Add patch to fix building with GCC 10 (bz#1800240)
|
||||||
|
|
||||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 8.2.0-14
|
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 8.2.0-14
|
||||||
- Rebuilt for Python 3.9
|
- Rebuilt for Python 3.9
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user