Add patch to support netcdf 4.9.0
This commit is contained in:
parent
794f8053f0
commit
770c1d7af0
13
vtk-netcdf.patch
Normal file
13
vtk-netcdf.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up VTK-9.1.0/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c.netcdf VTK-9.1.0/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c
|
||||
--- VTK-9.1.0/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c.netcdf 2021-11-04 13:48:20.000000000 -0600
|
||||
+++ VTK-9.1.0/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c 2022-06-28 07:04:11.574398570 -0600
|
||||
@@ -1770,7 +1770,9 @@ void ex__compress_variable(int exoid, in
|
||||
*/
|
||||
|
||||
/* const int NC_SZIP_EC = 4; */ /* Selects entropy coding method for szip. */
|
||||
+#if !defined(NC_SZIP_NN)
|
||||
const int NC_SZIP_NN = 32; /* Selects nearest neighbor coding method for szip. */
|
||||
+#endif
|
||||
/* Even and between 4 and 32; typical values are 8, 10, 16, 32 */
|
||||
const int SZIP_PIXELS_PER_BLOCK =
|
||||
file->compression_level == 0 ? 32 : file->compression_level;
|
13
vtk.spec
13
vtk.spec
@ -35,7 +35,7 @@
|
||||
Summary: The Visualization Toolkit - A high level 3D visualization library
|
||||
Name: vtk
|
||||
Version: 9.1.0
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
# This is a variant BSD license, a cross between BSD and ZLIB.
|
||||
# For all intents, it has the same rights and restrictions as BSD.
|
||||
# http://fedoraproject.org/wiki/Licensing/BSD#VTKBSDVariant
|
||||
@ -47,6 +47,9 @@ Source2: xorg.conf
|
||||
Patch0: vtk-libharu.patch
|
||||
# Upstream patch to link kissfft with libm
|
||||
Patch1: vtk-kissfft-libm.patch
|
||||
# Upstream patch to support netcdf 4.9.0
|
||||
# https://gitlab.kitware.com/vtk/vtk/-/issues/18576
|
||||
Patch2: vtk-netcdf.patch
|
||||
# Duplicate define conflict with Xutil, see:
|
||||
# https://gitlab.kitware.com/vtk/vtk/-/issues/18048
|
||||
Patch3: vtk-AllValues.patch
|
||||
@ -463,10 +466,7 @@ programming languages.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -b 1 -n VTK-%{version}
|
||||
%patch0 -p1 -b .libharu
|
||||
%patch1 -p1 -b .kissfft-libm
|
||||
%patch3 -p1 -b .AllValues
|
||||
%autosetup -p1 -b 1 -n VTK-%{version}
|
||||
# Remove included thirdparty sources just to be sure
|
||||
# TODO - diy2 - not yet packaged
|
||||
# TODO - exodusII - not yet packaged
|
||||
@ -824,6 +824,9 @@ cat xorg.log
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 28 2022 Orion Poplawski <orion@nwra.com> - 9.1.0-13
|
||||
- Add patch to support netcdf 4.9.0
|
||||
|
||||
* Fri Jun 24 2022 Orion Poplawski <orion@nwra.com> - 9.1.0-12
|
||||
- Set VTK_PYTHON_OPTIONAL_LINK=OFF (bz#1979611)
|
||||
- Link libvtkkissfft.so.1 against libm (bz#2100573)
|
||||
|
Loading…
Reference in New Issue
Block a user