Initial 6.0.0 test

This commit is contained in:
Orion Poplawski 2013-04-08 12:11:50 -06:00
parent e9a928d961
commit 3d9534218a
5 changed files with 34 additions and 75 deletions

View File

@ -1,33 +0,0 @@
--- VTK/Utilities/DICOMParser/DICOMAppHelper.cxx.gcc43 2008-03-19 21:22:17.000000000 +0100
+++ VTK/Utilities/DICOMParser/DICOMAppHelper.cxx 2008-10-05 11:46:08.000000000 +0200
@@ -32,7 +32,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
-#include <string>
+#include <cstring>
#include <math.h>
#include <algorithm>
#if defined(__BORLANDC__)
--- VTK/Utilities/DICOMParser/DICOMFile.cxx.gcc43 2008-03-19 21:22:17.000000000 +0100
+++ VTK/Utilities/DICOMParser/DICOMFile.cxx 2008-10-05 11:46:02.000000000 +0200
@@ -27,7 +27,7 @@
#include <stdio.h>
#include <string.h>
-#include <string>
+#include <cstring>
DICOMFile::DICOMFile() : InputStream()
{
--- VTK/Utilities/DICOMParser/DICOMParser.cxx.gcc43 2008-07-21 19:03:03.000000000 +0200
+++ VTK/Utilities/DICOMParser/DICOMParser.cxx 2008-10-05 11:45:56.000000000 +0200
@@ -40,7 +40,7 @@
#endif
#include <string.h>
-#include <string>
+#include <cstring>
// Define DEBUG_DICOM to get debug messages sent to dicom_stream::cerr
// #define DEBUG_DICOM

View File

@ -1,26 +0,0 @@
diff -up VTK/CMakeLists.txt.system VTK/CMakeLists.txt
--- VTK/CMakeLists.txt.system 2010-09-27 14:40:00.000000000 -0600
+++ VTK/CMakeLists.txt 2011-02-08 14:08:29.367122550 -0700
@@ -106,6 +106,11 @@ IF(CMAKE_CONFIGURATION_TYPES)
ENDIF(CMAKE_CONFIGURATION_TYPES)
#-----------------------------------------------------------------------------
+# Do we try to use system libraries by default?
+OPTION(VTK_USE_SYSTEM_LIBRARIES "Use the system's libraries by default." OFF)
+MARK_AS_ADVANCED(VTK_USE_SYSTEM_LIBRARIES)
+
+#-----------------------------------------------------------------------------
# Load some macros.
INCLUDE(vtkDependentOption)
INCLUDE(vtkThirdParty)
diff -up VTK/CMake/vtkThirdParty.cmake.system VTK/CMake/vtkThirdParty.cmake
--- VTK/CMake/vtkThirdParty.cmake.system 2010-09-27 14:40:00.000000000 -0600
+++ VTK/CMake/vtkThirdParty.cmake 2011-02-08 14:07:46.424662568 -0700
@@ -1,6 +1,6 @@
#-----------------------------------------------------------------------------
MACRO(VTK_THIRD_PARTY_OPTION upper lower)
- OPTION(VTK_USE_SYSTEM_${upper} "Use the system's ${lower} library." OFF)
+ OPTION(VTK_USE_SYSTEM_${upper} "Use the system's ${lower} library." ${VTK_USE_SYSTEM_LIBRARIES})
MARK_AS_ADVANCED(VTK_USE_SYSTEM_${upper})
IF(VTK_USE_SYSTEM_${upper})
IF(EXISTS ${CMAKE_ROOT}/Modules/Find${upper}.cmake)

29
vtk-6.0.0-system.patch Normal file
View File

@ -0,0 +1,29 @@
diff --git a/CMake/vtkModuleMacros.cmake b/CMake/vtkModuleMacros.cmake
index 3e746a6..9ef38fd 100644
--- a/CMake/vtkModuleMacros.cmake
+++ b/CMake/vtkModuleMacros.cmake
@@ -563,7 +563,7 @@ macro(vtk_module_third_party _pkg)
message(FATAL_ERROR "Cannot specify both LIBRARIES and NO_LIBRARIES")
endif()
- option(VTK_USE_SYSTEM_${_upper} "Use system-installed ${_pkg}" OFF)
+ option(VTK_USE_SYSTEM_${_upper} "Use system-installed ${_pkg}" ${VTK_USE_SYSTEM_LIBRARIES})
mark_as_advanced(VTK_USE_SYSTEM_${_upper})
if(VTK_USE_SYSTEM_${_upper})
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d1dda8..b3e1801 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,6 +97,11 @@ set(VTK_INSTALL_INCLUDE_DIR_CM24 ${VTK_INSTALL_INCLUDE_DIR})
set(VTK_INSTALL_DOXYGEN_DIR_CM24 ${VTK_INSTALL_DATA_DIR}/doxygen)
#-----------------------------------------------------------------------------
+# Do we try to use system libraries by default?
+OPTION(VTK_USE_SYSTEM_LIBRARIES "Use the system's libraries by default." OFF)
+MARK_AS_ADVANCED(VTK_USE_SYSTEM_LIBRARIES)
+
+#-----------------------------------------------------------------------------
# The third party macros are still used in one or two third party builds.
include(vtkThirdParty)

View File

@ -1,11 +0,0 @@
diff -up VTK/Utilities/vtknetcdf/CMakeLists.txt.soname VTK/Utilities/vtknetcdf/CMakeLists.txt
--- VTK/Utilities/vtknetcdf/CMakeLists.txt.soname 2012-05-12 05:59:27.000000000 -0600
+++ VTK/Utilities/vtknetcdf/CMakeLists.txt 2012-05-24 11:49:32.069811561 -0600
@@ -350,6 +350,7 @@ TARGET_LINK_LIBRARIES(vtkNetCDF_cxx vtkN
# Apply user-defined properties to the library target.
IF(VTK_LIBRARY_PROPERTIES)
SET_TARGET_PROPERTIES(vtkNetCDF PROPERTIES ${VTK_LIBRARY_PROPERTIES})
+ SET_TARGET_PROPERTIES(vtkNetCDF_cxx PROPERTIES ${VTK_LIBRARY_PROPERTIES})
ENDIF(VTK_LIBRARY_PROPERTIES)
#-----------------------------------------------------------------------------

View File

@ -11,8 +11,8 @@
Summary: The Visualization Toolkit - A high level 3D visualization library
Name: vtk
Version: 5.10.1
Release: 4%{?dist}
Version: 6.0.0
Release: 0.1%{?dist}
# This is a variant BSD license, a cross between BSD and ZLIB.
# For all intents, it has the same rights and restrictions as BSD.
# http://fedoraproject.org/wiki/Licensing/BSD#VTKBSDVariant
@ -25,7 +25,7 @@ Patch1: vtk-5.2.0-gcc43.patch
Patch2: vtk-soname.patch
# Use system libraries
# http://public.kitware.com/Bug/view.php?id=11823
Patch5: vtk-5.6.1-system.patch
Patch5: vtk-6.0.0-system.patch
URL: http://vtk.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@ -142,8 +142,8 @@ programming languages.
%prep
%setup -q -n VTK%{version}
%patch1 -p1 -b .gcc43
%patch2 -p1 -b .soname
#patch1 -p1 -b .gcc43
#patch2 -p1 -b .soname
%patch5 -p1 -b .system
# Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}