Add VTK_USE_SYSTEM_SQLITE; VTK_USE_SYSTEM_NETCDF

This commit is contained in:
Orion Poplawski 2013-12-27 21:01:09 -07:00
parent 62eb30503f
commit 27d36c602d
2 changed files with 29 additions and 12 deletions

View File

@ -1,8 +1,7 @@
diff --git a/CMake/vtkModuleMacros.cmake b/CMake/vtkModuleMacros.cmake
index 3e746a6..9ef38fd 100644
--- a/CMake/vtkModuleMacros.cmake
+++ b/CMake/vtkModuleMacros.cmake
@@ -563,7 +563,7 @@ macro(vtk_module_third_party _pkg)
diff -up VTK6.0.0/CMake/vtkModuleMacros.cmake.system VTK6.0.0/CMake/vtkModuleMacros.cmake
--- VTK6.0.0/CMake/vtkModuleMacros.cmake.system 2013-06-12 13:47:10.000000000 -0600
+++ VTK6.0.0/CMake/vtkModuleMacros.cmake 2013-12-27 20:52:29.299431600 -0700
@@ -613,7 +613,7 @@ macro(vtk_module_third_party _pkg)
message(FATAL_ERROR "Cannot specify both LIBRARIES and NO_LIBRARIES")
endif()
@ -11,11 +10,10 @@ index 3e746a6..9ef38fd 100644
mark_as_advanced(VTK_USE_SYSTEM_${_upper})
if(VTK_USE_SYSTEM_${_upper})
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d1dda8..b3e1801 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,6 +97,11 @@ set(VTK_INSTALL_INCLUDE_DIR_CM24 ${VTK_INSTALL_INCLUDE_DIR})
diff -up VTK6.0.0/CMakeLists.txt.system VTK6.0.0/CMakeLists.txt
--- VTK6.0.0/CMakeLists.txt.system 2013-06-12 13:47:10.000000000 -0600
+++ VTK6.0.0/CMakeLists.txt 2013-12-27 20:52:29.299431600 -0700
@@ -107,6 +107,11 @@ set(VTK_INSTALL_INCLUDE_DIR_CM24 ${VTK_I
set(VTK_INSTALL_DOXYGEN_DIR_CM24 ${VTK_INSTALL_DATA_DIR}/doxygen)
#-----------------------------------------------------------------------------
@ -27,3 +25,19 @@ index 0d1dda8..b3e1801 100644
# The third party macros are still used in one or two third party builds.
include(vtkThirdParty)
diff -up VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt.system VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt
--- VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt.system 2013-06-12 13:47:10.000000000 -0600
+++ VTK6.0.0/ThirdParty/sqlite/CMakeLists.txt 2013-12-27 20:58:33.672959677 -0700
@@ -1,4 +1,9 @@
set(vtksqlite_THIRD_PARTY 1)
-set(vtksqlite_LIBRARIES vtksqlite)
-vtk_module_export_info()
-add_subdirectory(vtksqlite)
+if(VTK_USE_SYTEM_SQLITE)
+ set(vtksqlite_LIBRARIES sqlite3)
+ vtk_module_export_info()
+else(VTK_USE_SYTEM_SQLITE)
+ set(vtksqlite_LIBRARIES vtksqlite)
+ vtk_module_export_info()
+ add_subdirectory(vtksqlite)
+endif(VTK_USE_SYTEM_SQLITE)

View File

@ -60,11 +60,12 @@ BuildRequires: boost-devel
BuildRequires: hdf5-devel
BuildRequires: libtheora-devel
BuildRequires: mysql-devel
BuildRequires: netcdf-cxx-devel
BuildRequires: netcdf-devel
BuildRequires: postgresql-devel
BuildRequires: R-devel
BuildRequires: PyQt4-devel
BuildRequires: sip-devel
BuildRequires: sqlite-devel
BuildRequires: wget
BuildRequires: %{_includedir}/Xm
BuildRequires: blas-devel
@ -244,7 +245,9 @@ pushd build
-DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
-DVTK_USE_OGGTHEORA_ENCODER=ON \
-DVTK_USE_SYSTEM_LIBRARIES=ON \
-DVTK_USE_SYSTEM_LIBPROJ4=OFF
-DVTK_USE_SYSTEM_LIBPROJ4=OFF \
-DVTK_USE_SYSTEM_NETCDF=ON \
-DVTK_USE_SYSTEM_SQLITE=ON
# TODO - MPI
#-DVTK_Group_MPI:BOOL=ON \