add python 2.7 compat patch ; add missing patch (rhbz#620067)
This commit is contained in:
parent
359bad50c0
commit
1ceaf7f6bc
13
vtk-5.6.0-python27.patch
Normal file
13
vtk-5.6.0-python27.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/CMake/FindPythonLibs.cmake b/CMake/FindPythonLibs.cmake
|
||||
index 1ba21b5..217e7e9 100644
|
||||
--- a/CMake/FindPythonLibs.cmake
|
||||
+++ b/CMake/FindPythonLibs.cmake
|
||||
@@ -27,7 +27,7 @@ INCLUDE(CMakeFindFrameworks)
|
||||
# Search for the python framework on Apple.
|
||||
CMAKE_FIND_FRAMEWORKS(Python)
|
||||
|
||||
-FOREACH(_CURRENT_VERSION 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
|
||||
+FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
|
||||
STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
|
||||
IF(WIN32)
|
||||
FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
|
20
vtk-5.6.0-testcxxjavaremove.patch
Normal file
20
vtk-5.6.0-testcxxjavaremove.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- VTK/Graphics/Testing/Cxx/CMakeLists.txt.testcxxjava 2010-03-31 18:44:26.000000000 +0200
|
||||
+++ VTK/Graphics/Testing/Cxx/CMakeLists.txt 2010-07-10 11:29:39.943549435 +0200
|
||||
@@ -107,17 +107,3 @@
|
||||
ENDFOREACH (test)
|
||||
ENDIF (VTK_USE_RENDERING AND VTK_USE_DISPLAY)
|
||||
|
||||
-IF (VTK_WRAP_JAVA)
|
||||
- ADD_EXECUTABLE(TestJavaProgrammableFilter TestJavaProgrammableFilter.cxx)
|
||||
- ADD_TEST(TestJavaProgrammableFilter
|
||||
- ${CXX_TEST_PATH}/TestJavaProgrammableFilter
|
||||
- -j ${LIBRARY_OUTPUT_PATH}/vtk.jar
|
||||
- -cp ${LIBRARY_OUTPUT_PATH}/vtk.jar
|
||||
- -class vtk/SampleAlgorithm
|
||||
- )
|
||||
- TARGET_LINK_LIBRARIES(TestJavaProgrammableFilter
|
||||
- vtkGraphicsJava
|
||||
- ${JAVA_AWT_LIBRARY}
|
||||
- ${JAVA_JVM_LIBRARY}
|
||||
- )
|
||||
-ENDIF (VTK_WRAP_JAVA)
|
10
vtk.spec
10
vtk.spec
@ -7,7 +7,7 @@
|
||||
Summary: The Visualization Toolkit - A high level 3D visualization library
|
||||
Name: vtk
|
||||
Version: 5.6.0
|
||||
Release: 35%{?dist}
|
||||
Release: 36%{?dist}
|
||||
# This is a variant BSD license, a cross between BSD and ZLIB.
|
||||
# For all intents, it has the same rights and restrictions as BSD.
|
||||
# http://fedoraproject.org/wiki/Licensing/BSD#VTKBSDVariant
|
||||
@ -17,6 +17,10 @@ Source: http://www.vtk.org/files/release/5.6/%{name}-%{version}.tar.gz
|
||||
Patch0: vtk-5.2.0-pythondestdir.patch
|
||||
Patch1: vtk-5.2.0-gcc43.patch
|
||||
Patch2: vtk-5.6.0-testcxxjavaremove.patch
|
||||
|
||||
# Python 2.7 compatibility: not yet sent upstream:
|
||||
Patch3: vtk-5.6.0-python27.patch
|
||||
|
||||
URL: http://vtk.org/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: cmake >= 2.0.4
|
||||
@ -118,6 +122,7 @@ programming languages.
|
||||
%patch0 -p1 -b .pythondestdir
|
||||
%patch1 -p1 -b .gcc43
|
||||
%patch2 -p1 -b .testcxxjava
|
||||
%patch3 -p1 -b .python27
|
||||
|
||||
# Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}
|
||||
# otherwise it will break on symlinks.
|
||||
@ -415,6 +420,9 @@ rm -rf %{buildroot}
|
||||
%doc vtk-examples-5.6/Examples
|
||||
|
||||
%changelog
|
||||
* Sat Jul 31 2010 David Malcolm <dmalcolm@redhat.com> - 5.6.0-36
|
||||
- add python 2.7 compat patch
|
||||
|
||||
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 5.6.0-35
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user