Fixed python detection

Resolves: rhbz#1928144
This commit is contained in:
Jaroslav Škarvada 2021-02-15 22:55:33 +01:00
parent 9f40b1a506
commit 25ac31df02
2 changed files with 20 additions and 1 deletions

View File

@ -0,0 +1,13 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8bd74a..2d9a714 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -139,7 +139,7 @@ endif()
# Python
include(VolkPython) #sets PYTHON_EXECUTABLE and PYTHON_DASH_B
-VOLK_PYTHON_CHECK_MODULE("python >= 3.4" sys "sys.version.split()[0] >= '3.4'" PYTHON_MIN_VER_FOUND)
+VOLK_PYTHON_CHECK_MODULE("python >= 3.4" sys "sys.version_info > (3, 4)" PYTHON_MIN_VER_FOUND)
VOLK_PYTHON_CHECK_MODULE("mako >= 0.4.2" mako "mako.__version__ >= '0.4.2'" MAKO_FOUND)
if(NOT PYTHON_MIN_VER_FOUND)

View File

@ -1,12 +1,14 @@
Name: volk
Version: 2.4.1
Release: 3%{?dist}
Release: 4%{?dist}
Summary: The Vector Optimized Library of Kernels
License: GPLv3+
URL: https://github.com/gnuradio/%{name}
Source0: https://github.com/gnuradio/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.gz
Source1: https://github.com/gnuradio/volk/releases/download/v%{version}/%{name}-%{version}.tar.gz.asc
Source2: https://github.com/gnuradio/volk/releases/download/v2.4.1/gpg_volk_release_key.asc
# https://github.com/gnuradio/volk.git
Patch0: volk-2.4.1-python-detection-fix.patch
BuildRequires: gnupg2
BuildRequires: make
@ -118,6 +120,10 @@ rm -f %{buildroot}%{_libdir}/libcpu_features.a
%changelog
* Mon Feb 15 2021 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.1-4
- Fixed python detection
Resolves: rhbz#1928144
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild