79 lines
4.5 KiB
Diff
79 lines
4.5 KiB
Diff
Note: for some reason vigra uses a non-standard LIBDIR_SUFFIX definition
|
|
whereas usually this is LIB_SUFFIX. This patch fixes this since fedora expects
|
|
to use the standard.
|
|
|
|
diff -baur vigra-1.7.1/CMakeLists.txt vigra-1.7.1.new/CMakeLists.txt
|
|
--- vigra-1.7.1/CMakeLists.txt 2010-12-03 17:40:34.000000000 +0000
|
|
+++ vigra-1.7.1.new/CMakeLists.txt 2011-01-24 21:31:37.000000000 +0000
|
|
@@ -118,6 +118,8 @@
|
|
ENDIF()
|
|
|
|
|
|
+set(LIB_SUFFIX "" CACHE STRING "Define suffix of lib directory name (32/64)" )
|
|
+
|
|
##################################################
|
|
#
|
|
# global installation commands
|
|
@@ -177,10 +179,10 @@
|
|
|
|
# export targets:
|
|
INSTALL(EXPORT vigra-targets
|
|
- DESTINATION lib${LIBDIR_SUFFIX}/vigra)
|
|
+ DESTINATION lib${LIB_SUFFIX}/vigra)
|
|
INSTALL(FILES ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfig.cmake
|
|
${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfigVersion.cmake
|
|
- DESTINATION lib${LIBDIR_SUFFIX}/vigra)
|
|
+ DESTINATION lib${LIB_SUFFIX}/vigra)
|
|
EXPORT(TARGETS vigraimpex FILE vigra-targets.cmake)
|
|
|
|
##################################################
|
|
@@ -239,7 +241,7 @@
|
|
MESSAGE( STATUS "---------------------------------------------------------" )
|
|
|
|
MESSAGE( STATUS " includes will be installed at: ${CMAKE_INSTALL_PREFIX}/include")
|
|
-MESSAGE( STATUS " libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib${LIBDIR_SUFFIX}")
|
|
+MESSAGE( STATUS " libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
|
|
|
|
IF (MSVC)
|
|
MESSAGE( STATUS " binaries and DLLs will be installed at: ${CMAKE_INSTALL_PREFIX}/bin")
|
|
diff -baur vigra-1.7.1/doc/vigra/Installation.html vigra-1.7.1.new/doc/vigra/Installation.html
|
|
--- vigra-1.7.1/doc/vigra/Installation.html 2010-12-03 17:49:58.000000000 +0000
|
|
+++ vigra-1.7.1.new/doc/vigra/Installation.html 2011-01-24 21:34:48.000000000 +0000
|
|
@@ -57,8 +57,8 @@
|
|
<dd>build VIGRA Python bindings (default: 1). Pass -DWITH_VIGRANUMPY=0 to suppress vigranumpy. </dd>
|
|
<dt>-DWITH_HDF5=1 </dt>
|
|
<dd>build VIGRA with HDF5 support (default: 1). Pass -DDWITH_HDF5=0 to compile without HDF5. </dd>
|
|
-<dt>-DLIBDIR_SUFFIX=64 </dt>
|
|
-<dd>define suffix of lib directory name (default: empty string, i.e. no suffix). Use -DLIBDIR_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64. </dd>
|
|
+<dt>-DLIB_SUFFIX=64 </dt>
|
|
+<dd>define suffix of lib directory name (default: empty string, i.e. no suffix). Use -DLIB_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64. </dd>
|
|
</dl>
|
|
<p>
|
|
More fine-grained customization (e.g. specification of explicit paths for all dependencies, customization of compiler flags) is possible by editing the file <vigra_build_path>/CMakeCache.txt. This is best done by means of the interactive programs <b>ccmake</b> or <b>cmake-gui</b>. Consult the <a href="http://www.cmake.org/cmake/help/documentation.html">cmake documentation</a> for more detailed help.<p>
|
|
diff -baur vigra-1.7.1/docsrc/installation.dxx vigra-1.7.1.new/docsrc/installation.dxx
|
|
--- vigra-1.7.1/docsrc/installation.dxx 2010-12-03 17:40:34.000000000 +0000
|
|
+++ vigra-1.7.1.new/docsrc/installation.dxx 2011-01-24 21:34:20.000000000 +0000
|
|
@@ -50,9 +50,9 @@
|
|
vigranumpy.
|
|
<DT> -DWITH_HDF5=1
|
|
<DD> build VIGRA with HDF5 support (default: 1). Pass -DDWITH_HDF5=0 to compile without HDF5.
|
|
- <DT> -DLIBDIR_SUFFIX=64
|
|
+ <DT> -DLIB_SUFFIX=64
|
|
<DD> define suffix of lib directory name (default: empty string, i.e. no suffix). Use
|
|
- -DLIBDIR_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64.
|
|
+ -DLIB_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64.
|
|
</DL>
|
|
|
|
More fine-grained customization (e.g. specification of explicit paths for all dependencies, customization of compiler flags) is possible by editing the file <vigra_build_path>/CMakeCache.txt. This is best done by means of the interactive programs <b>ccmake</b> or <b>cmake-gui</b>. Consult the <a href="http://www.cmake.org/cmake/help/documentation.html">cmake documentation</a> for more detailed help.
|
|
diff -baur vigra-1.7.1/src/impex/CMakeLists.txt vigra-1.7.1.new/src/impex/CMakeLists.txt
|
|
--- vigra-1.7.1/src/impex/CMakeLists.txt 2010-12-03 17:40:34.000000000 +0000
|
|
+++ vigra-1.7.1.new/src/impex/CMakeLists.txt 2011-01-24 21:37:17.000000000 +0000
|
|
@@ -64,5 +64,5 @@
|
|
INSTALL(TARGETS vigraimpex
|
|
EXPORT vigra-targets
|
|
RUNTIME DESTINATION bin
|
|
- LIBRARY DESTINATION lib${LIBDIR_SUFFIX}
|
|
- ARCHIVE DESTINATION lib${LIBDIR_SUFFIX})
|
|
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
|
|
+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
|