New upstream release + patch for gcc-4.6.0 + x86_64 install patch

This commit is contained in:
Bruno Postle 2011-02-04 23:42:07 +00:00
parent f49bf8b006
commit 7dcee0b016
5 changed files with 123 additions and 6 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
vigra-1.7.0-src.tar.gz
/vigra-1.7.1-src.tar.gz

View File

@ -1 +1 @@
a8e5326433ee7bf77f6daa3dd00d6c61 vigra-1.7.0-src.tar.gz
2bde208e0fd7626770169dd4fa097282 vigra-1.7.1-src.tar.gz

33
vigra-1.7.1.gcc460.patch Normal file
View File

@ -0,0 +1,33 @@
diff -baur vigra-1.7.1.old/include/vigra/random_forest.hxx vigra-1.7.1/include/vigra/random_forest.hxx
--- vigra-1.7.1.old/include/vigra/random_forest.hxx 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1/include/vigra/random_forest.hxx 2011-01-28 00:16:32.000000000 +0000
@@ -43,6 +43,7 @@
#include <set>
#include <list>
#include <numeric>
+#include <stddef.h>
#include "mathutil.hxx"
#include "array_vector.hxx"
#include "sized_int.hxx"
diff -baur vigra-1.7.1.old/include/vigra/sifImport.hxx vigra-1.7.1/include/vigra/sifImport.hxx
--- vigra-1.7.1.old/include/vigra/sifImport.hxx 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1/include/vigra/sifImport.hxx 2011-01-28 00:23:31.000000000 +0000
@@ -57,6 +57,7 @@
#include <fstream>
#include <cstring>
#include <vector>
+#include <stddef.h>
#include "vigra/multi_array.hxx"
namespace vigra {
diff -baur vigra-1.7.1.old/include/vigra/multi_iterator.hxx vigra-1.7.1/include/vigra/multi_iterator.hxx
--- vigra-1.7.1.old/include/vigra/multi_iterator.hxx 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1/include/vigra/multi_iterator.hxx 2011-01-28 00:23:31.000000000 +0000
@@ -41,6 +41,7 @@
#define VIGRA_MULTI_ITERATOR_HXX
#include <sys/types.h>
+#include <stddef.h>
#include "tinyvector.hxx"
#include "iteratortags.hxx"

View File

@ -0,0 +1,78 @@
Note: for some reason vigra uses a non-standard LIBDIR_SUFFIX definition
whereas usually this is LIB_SUFFIX. This patch fixes this since fedora expects
to use the standard.
diff -baur vigra-1.7.1/CMakeLists.txt vigra-1.7.1.new/CMakeLists.txt
--- vigra-1.7.1/CMakeLists.txt 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1.new/CMakeLists.txt 2011-01-24 21:31:37.000000000 +0000
@@ -118,6 +118,8 @@
ENDIF()
+set(LIB_SUFFIX "" CACHE STRING "Define suffix of lib directory name (32/64)" )
+
##################################################
#
# global installation commands
@@ -177,10 +179,10 @@
# export targets:
INSTALL(EXPORT vigra-targets
- DESTINATION lib${LIBDIR_SUFFIX}/vigra)
+ DESTINATION lib${LIB_SUFFIX}/vigra)
INSTALL(FILES ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfig.cmake
${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfigVersion.cmake
- DESTINATION lib${LIBDIR_SUFFIX}/vigra)
+ DESTINATION lib${LIB_SUFFIX}/vigra)
EXPORT(TARGETS vigraimpex FILE vigra-targets.cmake)
##################################################
@@ -239,7 +241,7 @@
MESSAGE( STATUS "---------------------------------------------------------" )
MESSAGE( STATUS " includes will be installed at: ${CMAKE_INSTALL_PREFIX}/include")
-MESSAGE( STATUS " libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib${LIBDIR_SUFFIX}")
+MESSAGE( STATUS " libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
IF (MSVC)
MESSAGE( STATUS " binaries and DLLs will be installed at: ${CMAKE_INSTALL_PREFIX}/bin")
diff -baur vigra-1.7.1/doc/vigra/Installation.html vigra-1.7.1.new/doc/vigra/Installation.html
--- vigra-1.7.1/doc/vigra/Installation.html 2010-12-03 17:49:58.000000000 +0000
+++ vigra-1.7.1.new/doc/vigra/Installation.html 2011-01-24 21:34:48.000000000 +0000
@@ -57,8 +57,8 @@
<dd>build VIGRA Python bindings (default: 1). Pass -DWITH_VIGRANUMPY=0 to suppress vigranumpy. </dd>
<dt>-DWITH_HDF5=1 </dt>
<dd>build VIGRA with HDF5 support (default: 1). Pass -DDWITH_HDF5=0 to compile without HDF5. </dd>
-<dt>-DLIBDIR_SUFFIX=64 </dt>
-<dd>define suffix of lib directory name (default: empty string, i.e. no suffix). Use -DLIBDIR_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64. </dd>
+<dt>-DLIB_SUFFIX=64 </dt>
+<dd>define suffix of lib directory name (default: empty string, i.e. no suffix). Use -DLIB_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64. </dd>
</dl>
<p>
More fine-grained customization (e.g. specification of explicit paths for all dependencies, customization of compiler flags) is possible by editing the file &lt;vigra_build_path&gt;/CMakeCache.txt. This is best done by means of the interactive programs <b>ccmake</b> or <b>cmake-gui</b>. Consult the <a href="http://www.cmake.org/cmake/help/documentation.html">cmake documentation</a> for more detailed help.<p>
diff -baur vigra-1.7.1/docsrc/installation.dxx vigra-1.7.1.new/docsrc/installation.dxx
--- vigra-1.7.1/docsrc/installation.dxx 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1.new/docsrc/installation.dxx 2011-01-24 21:34:20.000000000 +0000
@@ -50,9 +50,9 @@
vigranumpy.
<DT> -DWITH_HDF5=1
<DD> build VIGRA with HDF5 support (default: 1). Pass -DDWITH_HDF5=0 to compile without HDF5.
- <DT> -DLIBDIR_SUFFIX=64
+ <DT> -DLIB_SUFFIX=64
<DD> define suffix of lib directory name (default: empty string, i.e. no suffix). Use
- -DLIBDIR_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64.
+ -DLIB_SUFFIX=64 when you want to install libraries in $CMAKE_INSTALL_PREFIX/lib64.
</DL>
More fine-grained customization (e.g. specification of explicit paths for all dependencies, customization of compiler flags) is possible by editing the file &lt;vigra_build_path&gt;/CMakeCache.txt. This is best done by means of the interactive programs <b>ccmake</b> or <b>cmake-gui</b>. Consult the <a href="http://www.cmake.org/cmake/help/documentation.html">cmake documentation</a> for more detailed help.
diff -baur vigra-1.7.1/src/impex/CMakeLists.txt vigra-1.7.1.new/src/impex/CMakeLists.txt
--- vigra-1.7.1/src/impex/CMakeLists.txt 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1.new/src/impex/CMakeLists.txt 2011-01-24 21:37:17.000000000 +0000
@@ -64,5 +64,5 @@
INSTALL(TARGETS vigraimpex
EXPORT vigra-targets
RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib${LIBDIR_SUFFIX}
- ARCHIVE DESTINATION lib${LIBDIR_SUFFIX})
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ ARCHIVE DESTINATION lib${LIB_SUFFIX})

View File

@ -1,12 +1,13 @@
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
Summary: Generic Programming for Computer Vision
Name: vigra
Version: 1.7.0
Release: 2%{?dist}
Version: 1.7.1
Release: 1%{?dist}
License: MIT
Group: Development/Libraries
Source: http://hci.iwr.uni-heidelberg.de/%{name}/%{name}-%{version}-src.tar.gz
Patch1: vigra-1.7.0.lib_suffix.patch
Patch1: vigra-1.7.1.lib_suffix.patch
Patch2: vigra-1.7.1.gcc460.patch
URL: http://hci.iwr.uni-heidelberg.de/vigra/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel libjpeg-devel libpng-devel libtiff-devel fftw-devel >= 3
@ -39,15 +40,15 @@ Requires: numpy numpy-f2py
The vigra-python package provides python bindings for vigra
%prep
%setup -q -n %{name}-%{version}-src
%setup -q
%patch1 -p1
%patch2 -p1
%build
%cmake .
make VERBOSE=1 %{?_smp_mflags}
# cleanup
rm -f doc/vigranumpy/.buildinfo
chmod -x LICENSE.txt README.txt
find ./doc/ -type f | xargs chmod -x
%install
@ -69,6 +70,7 @@ rm -rf %{buildroot}
%files devel
%defattr(-, root, root,-)
%{_includedir}/vigra
%{_bindir}/vigra-config
%{_libdir}/libvigraimpex.so
%{_libdir}/vigra
%doc doc/vigra doc/vigranumpy
@ -78,6 +80,9 @@ rm -rf %{buildroot}
%{python_sitearch}/vigra
%changelog
* Sun Jan 23 2011 Bruno Postle <bruno@postle.net> 1.7.1-1
- upstream release
* Fri Jul 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> 1.7.0-2
- Rebuild for new python release