new 1.7.0 upstream with cmake replacing autotools and vigra-python

sub-package.
This commit is contained in:
bpostle 2010-04-21 21:28:14 +00:00
parent 3fcdc4a131
commit 05e51cd293
4 changed files with 98 additions and 30 deletions

View File

@ -1 +1 @@
vigra1.6.0.tar.gz
vigra-1.7.0-src.tar.gz

View File

@ -1 +1 @@
d62650a6f908e85643e557a236ea989c vigra1.6.0.tar.gz
a8e5326433ee7bf77f6daa3dd00d6c61 vigra-1.7.0-src.tar.gz

View File

@ -0,0 +1,55 @@
diff -ur vigra-1.7.0-src/CMakeLists.txt vigra-1.7.0-src.new/CMakeLists.txt
--- vigra-1.7.0-src/CMakeLists.txt 2010-04-15 19:27:25.000000000 +0100
+++ vigra-1.7.0-src.new/CMakeLists.txt 2010-04-21 00:09:48.000000000 +0100
@@ -113,6 +113,8 @@
INSTALL(DIRECTORY ${PROJECT_SOURCE_DIR}/include/vigra DESTINATION include)
INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/include/vigra DESTINATION include)
+set(LIB_SUFFIX "" CACHE STRING "Define suffix of lib directory name (32/64)" )
+
##################################################
#
# enable CPack package generation
@@ -145,8 +147,8 @@
# export targets:
#export(TARGETS all FILE
-INSTALL(EXPORT vigra-targets DESTINATION lib/vigra)
-INSTALL(FILES ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfig.cmake DESTINATION lib/vigra)
+INSTALL(EXPORT vigra-targets DESTINATION lib${LIB_SUFFIX}/vigra)
+INSTALL(FILES ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfig.cmake DESTINATION lib${LIB_SUFFIX}/vigra)
EXPORT(TARGETS vigraimpex FILE vigra-targets.cmake)
##################################################
@@ -205,7 +207,7 @@
MESSAGE( STATUS "---------------------------------------------------------" )
MESSAGE( STATUS " includes will be installed at: ${CMAKE_INSTALL_PREFIX}/include")
-MESSAGE( STATUS " libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib")
+MESSAGE( STATUS " libraries will be installed at: ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
IF (MSVC)
MESSAGE( STATUS " binaries and DLLs will be installed at: ${CMAKE_INSTALL_PREFIX}/bin")
diff -ur vigra-1.7.0-src/config/FindVIGRANUMPY_DEPENDENCIES.cmake vigra-1.7.0-src.new/config/FindVIGRANUMPY_DEPENDENCIES.cmake
--- vigra-1.7.0-src/config/FindVIGRANUMPY_DEPENDENCIES.cmake 2010-04-15 19:27:25.000000000 +0100
+++ vigra-1.7.0-src.new/config/FindVIGRANUMPY_DEPENDENCIES.cmake 2010-04-20 23:30:16.000000000 +0100
@@ -36,7 +36,7 @@
######################################################################
IF(NOT DEFINED VIGRANUMPY_INSTALL_DIR OR VIGRANUMPY_INSTALL_DIR MATCHES "^$")
execute_process ( COMMAND ${PYTHON_EXECUTABLE} -c
- "from distutils.sysconfig import *; print get_python_lib()"
+ "from distutils.sysconfig import *; print get_python_lib(1)"
OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
FILE(TO_CMAKE_PATH ${PYTHON_SITE_PACKAGES} VIGRANUMPY_INSTALL_DIR)
ENDIF()
diff -ur vigra-1.7.0-src/src/impex/CMakeLists.txt vigra-1.7.0-src.new/src/impex/CMakeLists.txt
--- vigra-1.7.0-src/src/impex/CMakeLists.txt 2010-04-15 19:27:39.000000000 +0100
+++ vigra-1.7.0-src.new/src/impex/CMakeLists.txt 2010-04-20 23:24:44.000000000 +0100
@@ -62,5 +62,5 @@
INSTALL(TARGETS vigraimpex
EXPORT vigra-targets
RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib)
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ ARCHIVE DESTINATION lib${LIB_SUFFIX})

View File

@ -1,14 +1,16 @@
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
Summary: Generic Programming for Computer Vision
Name: vigra
Version: 1.6.0
Release: 2%{?dist}
Version: 1.7.0
Release: 1%{?dist}
License: MIT
Group: Development/Libraries
Source: http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/%{name}%{version}.tar.gz
URL: http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
Source: http://hci.iwr.uni-heidelberg.de/%{name}/%{name}-%{version}-src.tar.gz
Patch1: vigra-1.7.0.lib_suffix.patch
URL: http://hci.iwr.uni-heidelberg.de/vigra/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel libjpeg-devel libpng-devel libtiff-devel
BuildRequires: fftw3-devel
BuildRequires: zlib-devel libjpeg-devel libpng-devel libtiff-devel fftw-devel >= 3
BuildRequires: cmake hdf5-devel boost-devel boost-python doxygen python-sphinx numpy-f2py
%description
VIGRA stands for "Vision with Generic Algorithms". It's a novel computer vision
@ -18,37 +20,39 @@ Template Library, you can easily adapt any VIGRA component to the needs of your
application without thereby giving up execution speed.
%package devel
Summary: Development tools for programs which will use the vigra library
Group: Development/Libraries
Requires: vigra = %{version}-%{release}
Requires: libjpeg-devel libtiff-devel libpng-devel zlib-devel
Requires: fftw3-devel
Summary: Development tools for programs which will use the vigra library
Group: Development/Libraries
Requires: vigra = %{version}-%{release}
Requires: libjpeg-devel libtiff-devel libpng-devel zlib-devel fftw-devel >= 3
Requires: hdf5-devel boost-devel boost-python numpy-f2py
%description devel
The vigra-devel package includes the header files necessary for developing
programs that use the vigra library.
%package python
Summary: Python interface for the vigra computer vision library
Requires: vigra = %{version}-%{release}
Requires: numpy numpy-f2py
%description python
The vigra-python package provides python bindings for vigra
%prep
%setup -q -n %{name}%{version}
%setup -q -n %{name}-%{version}-src
%patch1 -p1
%build
export CXXFLAGS="$RPM_OPT_FLAGS"
./configure \
--prefix=/usr \
--with-tiff \
--with-jpeg \
--with-png \
--with-zlib \
--with-fftw \
--enable-shared \
--disable-static \
--libdir=%{_libdir}
make
%cmake .
make VERBOSE=1 %{?_smp_mflags}
# cleanup
rm -f doc/vigranumpy/.buildinfo
chmod -x LICENSE.txt README.txt
find ./doc/ -type f | xargs chmod -x
%install
rm -rf %{buildroot}
%makeinstall
rm -f %{buildroot}/%{_libdir}/libvigraimpex.la
make install DESTDIR=%{buildroot}
rm -rf %{buildroot}/usr/doc
%post -p /sbin/ldconfig
@ -64,12 +68,21 @@ rm -rf %{buildroot}
%files devel
%defattr(-, root, root,-)
%{_bindir}/vigra-config
%{_includedir}/vigra
%{_libdir}/libvigraimpex.so
%doc doc/vigra/*.html doc/vigra/*.css doc/vigra/*.png doc/vigra/*.gif doc/vigra/*.ps doc/vigra/documents/
%{_libdir}/vigra
%doc doc/vigra doc/vigranumpy
%files python
%defattr(-, root, root,-)
%{python_sitearch}/vigra
%changelog
* Tue Apr 20 2010 Bruno Postle <bruno@postle.net> 1.7.0-1
- new upstream with cmake replacing autotools.
- patch for x86_64 systems.
- add vigra-python sub-package.
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild