Latest upstream (rhbz#1549354)
This commit is contained in:
parent
d4ea661019
commit
9c0935432a
2
.gitignore
vendored
2
.gitignore
vendored
@ -41,3 +41,5 @@
|
||||
/uwsgi-docs-1610d37.tar.gz
|
||||
/uwsgi-2.0.16.tar.gz
|
||||
/uwsgi-docs-eb4ad98.tar.gz
|
||||
/uwsgi-2.0.17.1.tar.gz
|
||||
/uwsgi-docs-32a8f73.tar.gz
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (uwsgi-2.0.16.tar.gz) = 2f80da366e463971400648fc8dcc9d7a5b51f03cba0b1ce08ff9e8ed75f0955e2014c84892d9991bd7a6f6a4a6b4ac819477f8e4afeded258d3147b5becb2e77
|
||||
SHA512 (uwsgi-docs-eb4ad98.tar.gz) = 3428ed012197bb9bb8b519fa379546783d1ca22795535da46f6b000cb9ead2cad626ceba01b0b6e5998dd498471372d9e12a25fad06c94252ea60c3920c6af50
|
||||
SHA512 (uwsgi-2.0.17.1.tar.gz) = 10d357961fde3a3f5f8e77986cc647313f95a33243e24c2afc482fce21df68a8ae48f90e7b5b76d7edc3cf8fd474d99823d6d60ef7477349abc65a319222f11b
|
||||
SHA512 (uwsgi-docs-32a8f73.tar.gz) = 687240d9c33cb44061b3e43746354a14cfa49162ee25100c97866c0405878b9bc62164b6dbe2acae451edb674d9fd900933062ebd5755b728eeec3f7fe7eda36
|
||||
|
@ -1,48 +0,0 @@
|
||||
diff -up uwsgi-2.0.16/plugins/rack/rack_plugin.c.strict uwsgi-2.0.16/plugins/rack/rack_plugin.c
|
||||
--- uwsgi-2.0.16/plugins/rack/rack_plugin.c.strict 2018-02-10 11:00:57.000000000 +0100
|
||||
+++ uwsgi-2.0.16/plugins/rack/rack_plugin.c 2018-03-29 18:02:35.274649402 +0200
|
||||
@@ -71,7 +71,7 @@ static struct uwsgi_buffer *uwsgi_ruby_e
|
||||
|
||||
static struct uwsgi_buffer *uwsgi_ruby_exception_msg(struct wsgi_request *wsgi_req) {
|
||||
VALUE err = rb_errinfo();
|
||||
- VALUE e = rb_funcall(err, rb_intern("message"), 0, 0);
|
||||
+ VALUE e = rb_funcall(err, rb_intern("message"), 0);
|
||||
struct uwsgi_buffer *ub = uwsgi_buffer_new(RSTRING_LEN(e));
|
||||
if (uwsgi_buffer_append(ub, RSTRING_PTR(e), RSTRING_LEN(e))) {
|
||||
uwsgi_buffer_destroy(ub);
|
||||
@@ -114,7 +114,7 @@ error:
|
||||
static void uwsgi_ruby_exception_log(struct wsgi_request *wsgi_req) {
|
||||
VALUE err = rb_errinfo();
|
||||
VALUE eclass = rb_class_name(rb_class_of(err));
|
||||
- VALUE msg = rb_funcall(err, rb_intern("message"), 0, 0);
|
||||
+ VALUE msg = rb_funcall(err, rb_intern("message"), 0);
|
||||
|
||||
VALUE ary = rb_funcall(err, rb_intern("backtrace"), 0);
|
||||
int i;
|
||||
diff -up uwsgi-2.0.16/plugins/router_basicauth/router_basicauth.c.strict uwsgi-2.0.16/plugins/router_basicauth/router_basicauth.c
|
||||
--- uwsgi-2.0.16/plugins/router_basicauth/router_basicauth.c.strict 2018-02-10 11:00:57.000000000 +0100
|
||||
+++ uwsgi-2.0.16/plugins/router_basicauth/router_basicauth.c 2018-03-29 18:02:57.311779724 +0200
|
||||
@@ -2,7 +2,10 @@
|
||||
|
||||
#ifdef UWSGI_ROUTING
|
||||
|
||||
-#if defined(__linux__) && defined(__GLIBC__)
|
||||
+#if defined(__linux__) && (defined(__GLIBC__) && __GLIBC__ == 2) && \
|
||||
+ (defined(__GLIBC_MINOR__) && __GLIBC_MINOR__ >= 2 && __GLIBC_MINOR__ < 4)
|
||||
+ /* work around glibc-2.2.5 bug,
|
||||
+ * has been fixed at some time in glibc-2.3.X */
|
||||
#include <crypt.h>
|
||||
#elif defined(__CYGWIN__)
|
||||
#include <crypt.h>
|
||||
@@ -66,7 +69,10 @@ static uint16_t htpasswd_check(char *fil
|
||||
|
||||
if (clen > 13) cpwd[13] = 0;
|
||||
|
||||
-#if defined(__linux__) && defined(__GLIBC__)
|
||||
+#if defined(__linux__) && (defined(__GLIBC__) && __GLIBC__ == 2) && \
|
||||
+ (defined(__GLIBC_MINOR__) && __GLIBC_MINOR__ >= 2 && __GLIBC_MINOR__ < 4)
|
||||
+ /* work around glibc-2.2.5 bug,
|
||||
+ * has been fixed at some time in glibc-2.3.X */
|
||||
struct crypt_data cd;
|
||||
cd.initialized = 0;
|
||||
// we do as nginx here
|
22
uwsgi.spec
22
uwsgi.spec
@ -1,12 +1,8 @@
|
||||
# Version
|
||||
%global majornumber 2
|
||||
%global minornumber 0
|
||||
%global releasenumber 16
|
||||
|
||||
# Documentation sources:
|
||||
%global commit eb4ad986cba70ed4acc44699e80965c1175aa323
|
||||
%global commit 32a8f7304d0e705d36dd9644707552939c67f547
|
||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||
%global docrepo uwsgi-docs
|
||||
|
||||
%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_sbindir}/apxs}}
|
||||
%{!?_httpd_moddir: %{expand: %%global _httpd_moddir %%{_libdir}/httpd/modules}}
|
||||
|
||||
@ -89,7 +85,7 @@
|
||||
%bcond_without systemd
|
||||
# el7 does have python3
|
||||
%bcond_without python3
|
||||
# el 7 has another version of python3
|
||||
# el7 has another version of python3
|
||||
%bcond_without python3_other
|
||||
# el7 doesn't have zeromq
|
||||
%bcond_with zeromq
|
||||
@ -122,8 +118,8 @@
|
||||
%endif
|
||||
|
||||
Name: uwsgi
|
||||
Version: %{majornumber}.%{minornumber}.%{releasenumber}
|
||||
Release: 7%{?dist}
|
||||
Version: 2.0.17.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Fast, self-healing, application container server
|
||||
Group: System Environment/Daemons
|
||||
License: GPLv2 with exceptions
|
||||
@ -143,8 +139,6 @@ Patch3: uwsgi_fix_lua.patch
|
||||
Patch5: uwsgi_fix_mongodb.patch
|
||||
Patch6: uwsgi_v8-314_compatibility.patch
|
||||
Patch7: uwsgi_fix_mono.patch
|
||||
# https://github.com/unbit/uwsgi/pull/1768
|
||||
Patch8: uwsgi-2.0.16-strict.patch
|
||||
# https://github.com/unbit/uwsgi/pull/1772
|
||||
Patch9: uwsgi-2.0.16-glfs.patch
|
||||
BuildRequires: curl, python2-devel, libxml2-devel, libuuid-devel, jansson-devel
|
||||
@ -1214,7 +1208,6 @@ cp -p %{SOURCE5} README.Fedora
|
||||
%if %{with mono}
|
||||
%patch7 -p1
|
||||
%endif
|
||||
%patch8 -p1 -b .strict
|
||||
%patch9 -p1 -b .glfs
|
||||
|
||||
#disable plug-ins
|
||||
@ -1312,7 +1305,7 @@ mkdir docs
|
||||
tar -C docs/ --strip-components=1 -xvzf %{SOURCE4}
|
||||
tar -C %{buildroot}%{_usrsrc}/uwsgi/%{version} --strip-components=1 -xvzf %{SOURCE0}
|
||||
cp %{SOURCE1} %{buildroot}%{_usrsrc}/uwsgi/%{version}/buildconf/
|
||||
cp docs/Changelog-%{majornumber}.%{minornumber}.%{releasenumber}.rst CHANGELOG
|
||||
cp docs/Changelog-%{version}.rst CHANGELOG
|
||||
rm -f docs/.gitignore
|
||||
echo "%{commit}, i.e. this:" >> README.Fedora
|
||||
echo "https://github.com/unbit/%{docrepo}/tree/%{commit}" >> README.Fedora
|
||||
@ -1818,6 +1811,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 09 2018 Carl George <carl@george.computer> - 2.0.17.1-1
|
||||
- Latest upstream (rhbz#1549354)
|
||||
|
||||
* Tue Jul 03 2018 Petr Pisar <ppisar@redhat.com> - 2.0.16-7
|
||||
- Perl 5.28 rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user