ced06ff43d
/etc/shadow and /etc/gshadow - fix #159339 - util-linux updates for new audit system (pam_loginuid.so added to util-linux-selinux.pamd) - fix #159418 - sfdisk unusable - crashes immediately on invocation - fix #157674 – sync option on VFAT mount destroys flash drives - fix .spec file /usr/sbin/{hwclock,clock} symlinks
17 lines
364 B
Diff
17 lines
364 B
Diff
--- util-linux-2.12p/login-utils/vipw.c.perm 2005-06-16 10:33:46.387891456 +0200
|
|
+++ util-linux-2.12p/login-utils/vipw.c 2005-06-16 10:34:37.077185512 +0200
|
|
@@ -299,11 +299,11 @@
|
|
}
|
|
if (!is_shadow)
|
|
chmod(tmp_file, 0644);
|
|
-#if 0
|
|
+/*#if 0*/
|
|
/* if shadow file, then mode is 0600 now */
|
|
else
|
|
chmod(tmp_file, 0400);
|
|
-#endif
|
|
+/*#endif*/
|
|
pw_unlock();
|
|
}
|
|
|