- fix #222293 - undocumented partx,addpart, delpart

- Resolves: rhbz#222293
This commit is contained in:
kzak 2007-01-11 15:39:41 +00:00
parent ba0ee667da
commit 07af4295f2
2 changed files with 139 additions and 1 deletions

View File

@ -0,0 +1,129 @@
--- util-linux-2.13-pre7/partx/Makefile.am.kzak 2007-01-11 16:30:39.000000000 +0100
+++ util-linux-2.13-pre7/partx/Makefile.am 2007-01-11 16:30:30.000000000 +0100
@@ -4,5 +4,6 @@
usrsbinexec_PROGRAMS = addpart delpart partx
partx_SOURCES = bsd.c dos.c partx.c solaris.c unixware.c gpt.c crc32.c
+man_MANS = addpart.8 delpart.8 partx.8
endif
--- /dev/null 2007-01-05 11:17:33.335119060 +0100
+++ util-linux-2.13-pre7/partx/delpart.8 2007-01-11 16:28:37.000000000 +0100
@@ -0,0 +1,30 @@
+.\" delpart.8 --
+.\" Copyright 2007 Karel Zak <kzak@redhat.com>
+.\" Copyright 2007 Red Hat, Inc.
+.\" May be distributed under the GNU General Public License
+.TH DELPART 8 "11 Jan 2007"
+.SH NAME
+delpart \-
+simple wrapper around the "del partition" ioctl
+.SH SYNOPSIS
+.B delpart device partition
+.SH DESCRIPTION
+.B delpart
+is a program that asks the Linux kernel to remove a partition.
+
+This command doesn't manipulate with partitions on hard drive.
+
+.SH OPTIONS
+.TP
+.BI device
+Specify the disk device.
+.TP
+.BI partition
+Specify the partition number.
+
+.SH SEE ALSO
+.BR addpart (8),
+.BR fdisk (8),
+.BR parted (8),
+.BR partprobe (8),
+.BR partx (8)
--- /dev/null 2007-01-05 11:17:33.335119060 +0100
+++ util-linux-2.13-pre7/partx/addpart.8 2007-01-11 16:28:37.000000000 +0100
@@ -0,0 +1,36 @@
+.\" addpart.8 --
+.\" Copyright 2007 Karel Zak <kzak@redhat.com>
+.\" Copyright 2007 Red Hat, Inc.
+.\" May be distributed under the GNU General Public License
+.TH ADDPART 8 "11 Jan 2007"
+.SH NAME
+addpart \-
+simple wrapper around the "add partition" ioctl
+.SH SYNOPSIS
+.B addpart device partition start length
+.SH DESCRIPTION
+.B addpart
+is a program that informs the Linux kernel of new partition.
+
+This command doesn't manipulate with partitions on hard drive.
+
+.SH PARAMETERS
+.TP
+.BI device
+Specify the disk device.
+.TP
+.BI partition
+Specify the partition number.
+.TP
+.BI start
+Specify the begin of the partition (in bytes).
+.TP
+.BI length
+Specify the length of the partition (in bytes).
+
+.SH SEE ALSO
+.BR delpart (8),
+.BR fdisk (8),
+.BR parted (8),
+.BR partprobe (8),
+.BR partx (8)
--- /dev/null 2007-01-05 11:17:33.335119060 +0100
+++ util-linux-2.13-pre7/partx/partx.8 2007-01-11 16:28:37.000000000 +0100
@@ -0,0 +1,45 @@
+.\" partx.8 --
+.\" Copyright 2007 Karel Zak <kzak@redhat.com>
+.\" Copyright 2007 Red Hat, Inc.
+.\" May be distributed under the GNU General Public License
+.TH PARTX 8 "11 Jan 2007"
+.SH NAME
+partx \-
+telling the kernel about presence and numbering of on-disk partitions.
+.SH SYNOPSIS
+.B partx [-a|-d|-l] [--type TYPE] [--nr M-N] [partition] disk
+.SH DESCRIPTION
+Given a block device (
+.B disk
+) and a partition table
+.B type
+, try to parse the partition table, and list the
+contents. Optionally add or remove partitions.
+
+This is not an fdisk - adding and removing partitions
+is not a change of the disk, but just telling the kernel
+about presence and numbering of on-disk partitions.
+
+.SH OPTIONS
+.TP
+.B \-a
+add specified partitions or read disk and add all partitions
+.TP
+.B \-d
+delete specified or all partitions
+.TP
+.B \-l
+list partitions
+.TP
+.BI --type " TYPE"
+Specify the partition type -- dos, bsd, solaris, unixware or gpt.
+.TP
+.BI --nr " M-N"
+Specify the range of partitions (e.g --nr 2-4).
+
+.SH SEE ALSO
+.BR addpart (8),
+.BR delpart (8),
+.BR fdisk (8),
+.BR parted (8),
+.BR partprobe (8)

View File

@ -9,7 +9,7 @@
Summary: A collection of basic system utilities.
Name: util-linux
Version: 2.13
Release: 0.48%{?dist}
Release: 0.49%{?dist}
License: distributable
Group: System Environment/Base
@ -240,6 +240,8 @@ Patch260: util-linux-2.13-more-CLOEXEC.patch
# 217240 - namei ignores non-directory components instead of saying "Not a directory"
# 217241 - namei enforces symlink limits inconsistently
Patch261: util-linux-2.13-namei-logic.patch
# 222293 - undocumented partx,addpart, delpart
Patch262: util-linux-2.13-partx-man.patch
# When adding patches, please make sure that it is easy to find out what bug # the
# patch fixes.
@ -340,6 +342,7 @@ cp %{SOURCE8} %{SOURCE9} .
%patch259 -p1
%patch260 -p1
%patch261 -p1
%patch262 -p1
%build
unset LINGUAS || :
@ -593,6 +596,9 @@ exit 0
/sbin/addpart
/sbin/delpart
/sbin/partx
%{_mandir}/man8/partx.8*
%{_mandir}/man8/addpart.8*
%{_mandir}/man8/delpart.8*
/sbin/sfdisk
%{_mandir}/man8/sfdisk.8*
@ -750,6 +756,9 @@ exit 0
/sbin/losetup
%changelog
* Thu Jan 11 2007 Karel Zak <kzak@redhat.com> 2.13-0.49
- fix #222293 - undocumented partx,addpart, delpart
* Sun Dec 17 2006 Karel Zak <kzak@redhat.com> 2.13-0.48
- fix paths in po/Makefile.in.in