clean uneeded files

This commit is contained in:
Lucian Langa 2015-03-23 23:36:01 +01:00
parent ef09191500
commit eaae16b604
3 changed files with 0 additions and 60 deletions

View File

@ -1,27 +0,0 @@
--- unixcw-2.3/Makefile.inc.in.orig 2006-07-13 05:33:33.000000000 +0000
+++ unixcw-2.3/Makefile.inc.in 2007-05-05 20:37:19.000000000 +0000
@@ -18,6 +18,9 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#
+#For Fedora, enables RPMBUILD
+DESTDIR=
+
# Autoconfigure definitions.
AC_CC = @CC@
AC_CFLAGS = @CFLAGS@
@@ -42,9 +45,10 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
+#For Fedora, enables RPMBUILD
prefix = @prefix@
exec_prefix = @exec_prefix@
-includedir = @includedir@
-bindir = @bindir@
-mandir = @mandir@
-libdir = @libdir@
+includedir = $(DESTDIR)@includedir@
+bindir = $(DESTDIR)@bindir@
+mandir = $(DESTDIR)@mandir@
+libdir = $(DESTDIR)@libdir@

View File

@ -1,22 +0,0 @@
--- unixcw-2.3/configure.ac.BAD 2007-05-11 11:17:54.000000000 -0500
+++ unixcw-2.3/configure.ac 2007-05-11 11:18:10.000000000 -0500
@@ -190,7 +190,7 @@ if test -n "$CC" ; then
cat >conftest.c <<-EOF
int so_test() { return 0; }
EOF
- $CC -c conftest.c >/dev/null 2>/dev/null
+ $CC $CFLAG_PIC -c conftest.c >/dev/null 2>/dev/null
$CC -shared -o conftest.so conftest.o >/dev/null 2>/dev/null
rm -f conftest.c conftest.o
if test -f conftest.so ; then
--- unixcw-2.3/configure.BAD 2007-05-11 11:18:26.000000000 -0500
+++ unixcw-2.3/configure 2007-05-11 11:18:43.000000000 -0500
@@ -5704,7 +5704,7 @@ echo $ECHO_N "checking whether cc builds
cat >conftest.c <<-EOF
int so_test() { return 0; }
EOF
- $CC -c conftest.c >/dev/null 2>/dev/null
+ $CC $CFLAG_PIC -c conftest.c >/dev/null 2>/dev/null
$CC -shared -o conftest.so conftest.o >/dev/null 2>/dev/null
rm -f conftest.c conftest.o
if test -f conftest.so ; then

View File

@ -1,11 +0,0 @@
--- unixcw-2.3/src/xcwcp/Makefile.BAD 2007-05-11 11:09:54.000000000 -0500
+++ unixcw-2.3/src/xcwcp/Makefile 2007-05-11 11:09:58.000000000 -0500
@@ -31,7 +31,7 @@ OBJECTS = main.o modeset.o display.o sen
moc_application.o
# Link to the shared libcw.
-LIBS = -L$(QTDIR)/lib -lqt -L../cwlib -lcw
+LIBS = -L$(QTDIR)/lib -lqt-mt -L../cwlib -lcw
default: all