*** empty log message ***

This commit is contained in:
Robert 'Bob' Jensen 2008-02-16 04:04:07 +00:00
parent acb3f066e4
commit becefbf595
6 changed files with 154 additions and 0 deletions

View File

@ -0,0 +1 @@
unixcw-2.3.tgz

View File

@ -0,0 +1 @@
f02e81ab719caa039c85615331c8860b unixcw-2.3.tgz

View File

@ -0,0 +1,27 @@
--- unixcw-2.3/Makefile.inc.in.orig 2006-07-13 05:33:33.000000000 +0000
+++ unixcw-2.3/Makefile.inc.in 2007-05-05 20:37:19.000000000 +0000
@@ -18,6 +18,9 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#
+#For Fedora, enables RPMBUILD
+DESTDIR=
+
# Autoconfigure definitions.
AC_CC = @CC@
AC_CFLAGS = @CFLAGS@
@@ -42,9 +45,10 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
+#For Fedora, enables RPMBUILD
prefix = @prefix@
exec_prefix = @exec_prefix@
-includedir = @includedir@
-bindir = @bindir@
-mandir = @mandir@
-libdir = @libdir@
+includedir = $(DESTDIR)@includedir@
+bindir = $(DESTDIR)@bindir@
+mandir = $(DESTDIR)@mandir@
+libdir = $(DESTDIR)@libdir@

22
unixcw-2.3-picflag.patch Normal file
View File

@ -0,0 +1,22 @@
--- unixcw-2.3/configure.ac.BAD 2007-05-11 11:17:54.000000000 -0500
+++ unixcw-2.3/configure.ac 2007-05-11 11:18:10.000000000 -0500
@@ -190,7 +190,7 @@ if test -n "$CC" ; then
cat >conftest.c <<-EOF
int so_test() { return 0; }
EOF
- $CC -c conftest.c >/dev/null 2>/dev/null
+ $CC $CFLAG_PIC -c conftest.c >/dev/null 2>/dev/null
$CC -shared -o conftest.so conftest.o >/dev/null 2>/dev/null
rm -f conftest.c conftest.o
if test -f conftest.so ; then
--- unixcw-2.3/configure.BAD 2007-05-11 11:18:26.000000000 -0500
+++ unixcw-2.3/configure 2007-05-11 11:18:43.000000000 -0500
@@ -5704,7 +5704,7 @@ echo $ECHO_N "checking whether cc builds
cat >conftest.c <<-EOF
int so_test() { return 0; }
EOF
- $CC -c conftest.c >/dev/null 2>/dev/null
+ $CC $CFLAG_PIC -c conftest.c >/dev/null 2>/dev/null
$CC -shared -o conftest.so conftest.o >/dev/null 2>/dev/null
rm -f conftest.c conftest.o
if test -f conftest.so ; then

11
unixcw-2.3-qtfix.patch Normal file
View File

@ -0,0 +1,11 @@
--- unixcw-2.3/src/xcwcp/Makefile.BAD 2007-05-11 11:09:54.000000000 -0500
+++ unixcw-2.3/src/xcwcp/Makefile 2007-05-11 11:09:58.000000000 -0500
@@ -31,7 +31,7 @@ OBJECTS = main.o modeset.o display.o sen
moc_application.o
# Link to the shared libcw.
-LIBS = -L$(QTDIR)/lib -lqt -L../cwlib -lcw
+LIBS = -L$(QTDIR)/lib -lqt-mt -L../cwlib -lcw
default: all

92
unixcw.spec Normal file
View File

@ -0,0 +1,92 @@
Name: unixcw
Version: 2.3
Release: 2%{?dist}
Summary: Shared library for Morse programs
Group: Applications/Communications
License: GPLv2+
URL: ftp://sunsite.unc.edu/pub/Linux/apps/ham/morse/
Source0: ftp://sunsite.unc.edu/pub/Linux/apps/ham/morse/%{name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# add DESTDIR to makefile
Patch0: unixcw-2.3-makefile.in.patch
# Link against a qt library that actually exists.
Patch1: unixcw-2.3-qtfix.patch
# x86_64 needs -fPIC to make shared libs, fix configure test to use it.
Patch2: unixcw-2.3-picflag.patch
#BuildRequires:
#Requires:
%description
The UnixCW utilities add a general purpose CW library to your system, and
a small set of applications based around this library. These applications
form a Morse code tutor suite, useful for Amateur and Marine radio operators.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
%description devel
UnixCW utility libraries.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
# Fix the encoding on the man pages to be UTF-8
recode()
{
iconv -f "$2" -t utf-8 < "$1" > "${1}_"
mv -f "${1}_" "$1"
}
recode src/cwlib/cw.7 iso-8859-2
recode src/cw/cw.1 iso-8859-2
%build
%configure
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
# Get rid of static lib.
rm -rf $RPM_BUILD_ROOT%{_libdir}/*.a
#Fix permissions for binary files
chmod 0755 $RPM_BUILD_ROOT%{_bindir}/*
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING README
%{_bindir}/*
%{_libdir}/libcw.so.0
%{_libdir}/libcw.so.0.0.0
%{_mandir}/man?/*
%files devel
%defattr(-,root,root,-)
%doc README
%{_libdir}/libcw.so
%{_includedir}/*.h
%{_libdir}/pkgconfig/*.pc
%changelog
* Mon Nov 19 2007 Sindre Pedersen Bjørdal <foolish@guezz.net> 2.3-2
- Update License tag to GPLv2+
- Add missing doc files
- Fix permissions on executable files
* Tue May 15 2007 Robert 'Bob' Jensen <bob@bobjensen.com> 2.3-0
- Initial SPEC