Added workaround for s390x FTBFS

Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com>
This commit is contained in:
Jaroslav Škarvada 2021-02-02 22:15:28 +01:00
parent b8f61d0e94
commit addbe90df6
2 changed files with 15 additions and 1 deletions

View File

@ -0,0 +1,10 @@
diff --git a/host/lib/utils/CMakeLists.txt b/host/lib/utils/CMakeLists.txt
index 7e95d8c..2ad6e40 100644
--- a/host/lib/utils/CMakeLists.txt
+++ b/host/lib/utils/CMakeLists.txt
@@ -229,3 +229,5 @@ if(ENABLE_C_API)
${CMAKE_CURRENT_SOURCE_DIR}/thread_priority_c.cpp
)
endif(ENABLE_C_API)
+
+LIBUHD_APPEND_LIBS(atomic)

View File

@ -36,7 +36,7 @@ BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: boost-devel, libusb1-devel, python3-cheetah, ncurses-devel
BuildRequires: python3-docutils, doxygen, pkgconfig, libpcap-devel
BuildRequires: python3-numpy, vim-common
BuildRequires: python3-numpy, vim-common, libatomic
%if %{with wireshark}
BuildRequires: wireshark-devel, libgcrypt-devel, gnutls-devel
%endif
@ -50,7 +50,10 @@ Summary: Universal Hardware Driver for Ettus Research products
Source0: %{url}/archive/v%{version}/uhd-%{version}.tar.gz
Source1: %{name}-limits.conf
Source2: %{url}/releases/download/v%{version}/uhd-images_%{version}.tar.xz
# Patch provided by upstream
Patch0: uhd-4.0.0.0-gcc-11-fix.patch
# https://github.com/EttusResearch/uhd/issues/410
Patch1: uhd-4.0.0.0-s390x-build-fix.patch
%description
The UHD is the universal hardware driver for Ettus Research products.
@ -99,6 +102,7 @@ Wireshark dissector plugins.
%prep
%setup -q
%patch0 -p1 -b .gcc-11-fix
%patch1 -p1 -b .s390x-build-fix
# firmware
%if %{with binary_firmware}