New version
- Dropped 0001-fix-build patch (upstreamed)
This commit is contained in:
parent
a236defae9
commit
7e3dc52e06
@ -1,34 +0,0 @@
|
||||
From 4827d155bcad9ee39bf850466d4970c18fd1a94a Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Thu, 23 Jul 2015 13:44:14 +0200
|
||||
Subject: [PATCH] fix build
|
||||
|
||||
---
|
||||
host/lib/usrp/b200/b200_io_impl.cpp | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/host/lib/usrp/b200/b200_io_impl.cpp b/host/lib/usrp/b200/b200_io_impl.cpp
|
||||
index 262c95f..c228637 100644
|
||||
--- a/host/lib/usrp/b200/b200_io_impl.cpp
|
||||
+++ b/host/lib/usrp/b200/b200_io_impl.cpp
|
||||
@@ -184,7 +184,7 @@ boost::optional<uhd::msg_task::msg_type_t> b200_impl::handle_async_task(
|
||||
{
|
||||
managed_recv_buffer::sptr buff = xport->get_recv_buff();
|
||||
if (not buff or buff->size() < 8)
|
||||
- return NULL;
|
||||
+ return boost::none;
|
||||
|
||||
const boost::uint32_t sid = uhd::wtohx(buff->cast<const boost::uint32_t *>()[1]);
|
||||
switch (sid) {
|
||||
@@ -248,7 +248,7 @@ boost::optional<uhd::msg_task::msg_type_t> b200_impl::handle_async_task(
|
||||
default:
|
||||
UHD_MSG(error) << "Got a ctrl packet with unknown SID " << sid << std::endl;
|
||||
}
|
||||
- return NULL;
|
||||
+ return boost::none;
|
||||
}
|
||||
|
||||
/***********************************************************************
|
||||
--
|
||||
2.1.0
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
6fa9529904bd134c7eac7e64e9882f34 uhd-images_003.008.002-release.tar.gz
|
||||
9640db62aad5610a49165a688cfe2225 uhd-release_003_008_002.tar.gz
|
||||
e6d2b6b8f4dfc4aca108450f66b0fd4c uhd-images_003.009.004-release.tar.gz
|
||||
0d6451b50afc000d1d13a1f6fb33ba6c uhd-release_003_009_004.tar.gz
|
||||
|
14
uhd.spec
14
uhd.spec
@ -8,8 +8,8 @@
|
||||
%bcond_with neon
|
||||
|
||||
%global ver_major 3
|
||||
%global ver_minor 8
|
||||
%global ver_patch 2
|
||||
%global ver_minor 9
|
||||
%global ver_patch 4
|
||||
|
||||
%global ver %(printf "%03d.%03d.%03d" %{ver_major} %{ver_minor} %{ver_patch})
|
||||
%global ver_ %(printf "%03d_%03d_%03d" %{ver_major} %{ver_minor} %{ver_patch})
|
||||
@ -25,11 +25,12 @@
|
||||
Name: uhd
|
||||
URL: http://code.ettus.com/redmine/ettus/projects/uhd/wiki
|
||||
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
|
||||
Release: 12%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
BuildRequires: cmake
|
||||
BuildRequires: boost-devel, libusb1-devel, python-cheetah, ncurses-devel
|
||||
BuildRequires: docutils, doxygen, pkgconfig, libpcap-devel, wireshark-devel
|
||||
BuildRequires: python-mako
|
||||
%if ! %{with binary_firmware}
|
||||
BuildRequires: sdcc sed
|
||||
%endif
|
||||
@ -42,7 +43,6 @@ Source1: %{name}-limits.conf
|
||||
Source2: http://files.ettus.com/binaries/images/uhd-images_%{ver}-release.tar.gz
|
||||
# Fix firmware build with sdcc-3
|
||||
Patch0: uhd-3.4.2-sdcc-3-fix.patch
|
||||
Patch1: 0001-fix-build.patch
|
||||
|
||||
%description
|
||||
The UHD is the universal hardware driver for Ettus Research products.
|
||||
@ -82,7 +82,6 @@ Tools that are useful for working with and/or debugging USRP device.
|
||||
%prep
|
||||
%setup -q -n uhd-release_%{ver_}
|
||||
%patch0 -p1 -b .sdcc-3-fix
|
||||
%patch1 -p1 -b .fix-build
|
||||
|
||||
# firmware
|
||||
%if %{with binary_firmware}
|
||||
@ -182,7 +181,6 @@ install -Dpm 0755 tools/uhd_dump/chdr_log %{buildroot}%{_bindir}/chdr_log
|
||||
%{_bindir}/usrp2*
|
||||
%{_bindir}/usrp_n2xx_simple_net_burner
|
||||
%{_bindir}/usrp_x3xx_fpga_burner
|
||||
%{_bindir}/nirio_programmer
|
||||
%{_bindir}/octoclock_firmware_burner
|
||||
%{_prefix}/lib/udev/rules.d/10-usrp-uhd.rules
|
||||
%config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
|
||||
@ -210,6 +208,10 @@ install -Dpm 0755 tools/uhd_dump/chdr_log %{buildroot}%{_bindir}/chdr_log
|
||||
%{_bindir}/chdr_log
|
||||
|
||||
%changelog
|
||||
* Tue May 10 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 3.9.4-1
|
||||
- New version
|
||||
- Dropped 0001-fix-build patch (upstreamed)
|
||||
|
||||
* Mon May 9 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 3.8.2-12
|
||||
- Rebuilt to fix Boost ABI problem
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user