New version

- Dropped uhd-dump-libs and wireshark-1.12-fix patches (both upstreamed)
This commit is contained in:
Jaroslav Škarvada 2015-03-06 14:44:38 +01:00
parent 0edbe67c8e
commit 05b035f4b6
3 changed files with 12 additions and 51 deletions

View File

@ -1,22 +0,0 @@
diff --git a/tools/uhd_dump/Makefile b/tools/uhd_dump/Makefile
index b793776..0494767 100644
--- a/tools/uhd_dump/Makefile
+++ b/tools/uhd_dump/Makefile
@@ -20,7 +20,7 @@ OBJECTS = uhd_dump.o
CFLAGS = -g -O0 -Wall
-LDFLAGS = -lpcap -lm
+LIBS = -lpcap -lm
CC = cc
@@ -28,7 +28,7 @@ CC = cc
all: $(BINARIES)
chdr_log: uhd_dump.o chdr_log.o $(INCLUDES)
- $(CC) $(CFLAGS) -o $@ uhd_dump.o chdr_log.o $(LDFLAGS)
+ $(CC) $(CFLAGS) -o $@ uhd_dump.o chdr_log.o $(LIBS) $(LDFLAGS)

View File

@ -1,12 +0,0 @@
diff -up uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake.orig uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake
--- uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake.orig 2014-09-01 16:12:51.884300407 +0200
+++ uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake 2014-09-01 16:10:28.495563673 +0200
@@ -16,7 +16,7 @@
# wireshark does not install its library with pkg-config information,
# so we need to manually find the libraries and headers
-FIND_PATH( WIRESHARK_INCLUDE_DIRS epan/column_info.h PATH_SUFFIXES wireshark )
+FIND_PATH( WIRESHARK_INCLUDE_DIRS epan/column.h PATH_SUFFIXES wireshark )
FIND_LIBRARY( WIRESHARK_LIBRARIES wireshark )
# Report results

View File

@ -8,7 +8,7 @@
%bcond_with neon
%global ver_major 3
%global ver_minor 7
%global ver_minor 8
%global ver_patch 2
%global ver %(printf "%03d.%03d.%03d" %{ver_major} %{ver_minor} %{ver_patch})
@ -25,11 +25,11 @@
Name: uhd
URL: http://code.ettus.com/redmine/ettus/projects/uhd/wiki
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
Release: 2%{?dist}
Release: 1%{?dist}
License: GPLv3+
BuildRequires: cmake
BuildRequires: boost-devel libusb1-devel python-cheetah
BuildRequires: docutils doxygen pkgconfig libpcap-devel wireshark-devel
BuildRequires: boost-devel, libusb1-devel, python-cheetah, ncurses-devel
BuildRequires: docutils, doxygen, pkgconfig, libpcap-devel, wireshark-devel
%if ! %{with binary_firmware}
BuildRequires: sdcc sed
%endif
@ -43,13 +43,9 @@ ExcludeArch: ppc64
%endif
Source0: http://github.com/EttusResearch/uhd/archive/release_%{ver_}.tar.gz#/uhd-release_%{ver_}.tar.gz
Source1: %{name}-limits.conf
Source2: http://files.ettus.com/binaries/uhd_stable/latest_release/uhd-images_%{ver}-release.tar.gz
Source2: http://files.ettus.com/binaries/images/uhd-images_%{ver}-release.tar.gz
# Fix firmware build with sdcc-3
Patch0: uhd-3.4.2-sdcc-3-fix.patch
# Fix not to override distribution LDFLAGS
Patch1: uhd-3.7.2-uhd-dump-libs.patch
# Fix building with wireshark 1.12
Patch2: uhd-3.7.2-wireshark-1.12-fix.patch
%description
The UHD is the universal hardware driver for Ettus Research products.
@ -84,14 +80,11 @@ Requires: %{name} = %{version}-%{release}
#Requires: wireshark = %{wireshark_ver}
%description tools
Tools that are useful for working with and/or debugging USRP device, including
Wireshark plugin to view Compressed HeaDeR (CHDR) formatted-packets.
Tools that are useful for working with and/or debugging USRP device.
%prep
%setup -q -n uhd-release_%{ver_}
%patch0 -p1 -b .sdcc-3-fix
%patch1 -p1 -b .uhd-dump-libs
%patch2 -p1 -b .wireshark-1.12-fix
# firmware
%if %{with binary_firmware}
@ -178,14 +171,12 @@ popd
# tools
install -Dpm 0755 tools/usrp_x3xx_fpga_jtag_programmer.sh %{buildroot}%{_bindir}/usrp_x3xx_fpga_jtag_programmer.sh
install -Dpm 0755 tools/uhd_dump/chdr_log %{buildroot}%{_bindir}/chdr_log
#install -Dpm 0755 tools/chdr-dissector/build/chdr-plugin.so %{buildroot}%{_libdir}/wireshark/plugins/%{wireshark_ver}/chdr-plugin.so
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%exclude %{_docdir}/%{name}/manual
%exclude %{_docdir}/%{name}/doxygen
%exclude %{_datadir}/uhd/images
%doc _tmpdoc/*
@ -194,6 +185,7 @@ install -Dpm 0755 tools/uhd_dump/chdr_log %{buildroot}%{_bindir}/chdr_log
%{_bindir}/usrp_n2xx_simple_net_burner
%{_bindir}/usrp_x3xx_fpga_burner
%{_bindir}/nirio_programmer
%{_bindir}/octoclock_firmware_burner
%{_prefix}/lib/udev/rules.d/10-usrp-uhd.rules
%config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
%{_libdir}/lib*.so.*
@ -208,19 +200,22 @@ install -Dpm 0755 tools/uhd_dump/chdr_log %{buildroot}%{_bindir}/chdr_log
%files devel
%{_includedir}/*
%{_libdir}/lib*.so
%{_libdir}/cmake/uhd/*.cmake
%{_libdir}/pkgconfig/*.pc
%files doc
%doc %{_docdir}/%{name}/manual
%doc %{_docdir}/%{name}/doxygen
%files tools
%doc tools/README.md
%{_bindir}/usrp_x3xx_fpga_jtag_programmer.sh
%{_bindir}/chdr_log
#%{_libdir}/wireshark/plugins/%{wireshark_ver}/chdr-plugin.so
%changelog
* Fri Mar 6 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 3.8.2-1
- New version
- Dropped uhd-dump-libs and wireshark-1.12-fix patches (both upstreamed)
* Tue Jan 27 2015 Petr Machata <pmachata@redhat.com> - 3.7.2-2
- Rebuild for boost 1.57.0