New version

- Added tools subpackage (wireshark plugin disabled due to rhbz#1129419)
- Minor packaging fixes
This commit is contained in:
Jaroslav Škarvada 2014-09-01 17:00:29 +02:00
parent b6f7066e3e
commit 02fea4c7c7
5 changed files with 108 additions and 45 deletions

View File

@ -1,2 +1,2 @@
81be16f9195c553f55fc1f5fc0daaddb uhd-images_003.006.002-release.tar.gz
50a25b95dc08dd3946988c5da98814a9 uhd-release_003_006_002.tar.gz
515387ad594a1ca1e4447e97d4f78aa7 uhd-release_003_007_002.tar.gz
a13f07bf7b908a49ca45bfd036d9f0a9 uhd-images_003.007.002-release.tar.gz

View File

@ -1,29 +0,0 @@
diff --git a/host/lib/convert/CMakeLists.txt b/host/lib/convert/CMakeLists.txt
index 0d9d098..d50b5a1 100644
--- a/host/lib/convert/CMakeLists.txt
+++ b/host/lib/convert/CMakeLists.txt
@@ -97,15 +97,15 @@ IF(CMAKE_COMPILER_IS_GNUCXX)
UNSET(CMAKE_REQUIRED_FLAGS)
ENDIF(CMAKE_COMPILER_IS_GNUCXX)
-IF(HAVE_ARM_NEON_H)
- SET_SOURCE_FILES_PROPERTIES(
- ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
- PROPERTIES COMPILE_FLAGS "${NEON_FLAGS}"
- )
- LIBUHD_APPEND_SOURCES(
- ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
- )
-ENDIF()
+#IF(HAVE_ARM_NEON_H)
+# SET_SOURCE_FILES_PROPERTIES(
+# ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
+# PROPERTIES COMPILE_FLAGS "${NEON_FLAGS}"
+# )
+# LIBUHD_APPEND_SOURCES(
+# ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
+# )
+#ENDIF()
########################################################################
# Convert types generation

View File

@ -0,0 +1,22 @@
diff --git a/tools/uhd_dump/Makefile b/tools/uhd_dump/Makefile
index b793776..0494767 100644
--- a/tools/uhd_dump/Makefile
+++ b/tools/uhd_dump/Makefile
@@ -20,7 +20,7 @@ OBJECTS = uhd_dump.o
CFLAGS = -g -O0 -Wall
-LDFLAGS = -lpcap -lm
+LIBS = -lpcap -lm
CC = cc
@@ -28,7 +28,7 @@ CC = cc
all: $(BINARIES)
chdr_log: uhd_dump.o chdr_log.o $(INCLUDES)
- $(CC) $(CFLAGS) -o $@ uhd_dump.o chdr_log.o $(LDFLAGS)
+ $(CC) $(CFLAGS) -o $@ uhd_dump.o chdr_log.o $(LIBS) $(LDFLAGS)

View File

@ -0,0 +1,12 @@
diff -up uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake.orig uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake
--- uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake.orig 2014-09-01 16:12:51.884300407 +0200
+++ uhd-release_003_007_002/tools/chdr-dissector/cmake/Modules/FindWireshark.cmake 2014-09-01 16:10:28.495563673 +0200
@@ -16,7 +16,7 @@
# wireshark does not install its library with pkg-config information,
# so we need to manually find the libraries and headers
-FIND_PATH( WIRESHARK_INCLUDE_DIRS epan/column_info.h PATH_SUFFIXES wireshark )
+FIND_PATH( WIRESHARK_INCLUDE_DIRS epan/column.h PATH_SUFFIXES wireshark )
FIND_LIBRARY( WIRESHARK_LIBRARIES wireshark )
# Report results

View File

@ -3,13 +3,25 @@
# images you need to install appropriate tools (e.g. Xilinx ISE).
%bcond_without binary_firmware
# NEON support is by default disabled on ARMs
# building with --with=neon will enable auto detection
%bcond_with neon
%global ver_major 3
%global ver_minor 6
%global ver_minor 7
%global ver_patch 2
%global ver %(printf "%03d.%03d.%03d" %{ver_major} %{ver_minor} %{ver_patch})
%global ver_ %(printf "%03d_%03d_%03d" %{ver_major} %{ver_minor} %{ver_patch})
%global wireshark_ver %((%{__awk} '/^#define VERSION[ \t]+/ { print $NF }' /usr/include/wireshark/config.h 2>/dev/null||echo none)|/usr/bin/tr -d '"')
%ifarch %{arm}
%if %{without neon}
%global have_neon -DHAVE_ARM_NEON_H=0
%endif
%endif
Name: uhd
URL: http://code.ettus.com/redmine/ettus/projects/uhd/wiki
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
@ -17,7 +29,7 @@ Release: 6%{?dist}
License: GPLv3+
BuildRequires: cmake
BuildRequires: boost-devel libusb1-devel python-cheetah
BuildRequires: docutils doxygen pkgconfig
BuildRequires: docutils doxygen pkgconfig libpcap-devel wireshark-devel
%if ! %{with binary_firmware}
BuildRequires: sdcc sed
%endif
@ -32,10 +44,12 @@ ExcludeArch: ppc64
Source0: http://github.com/EttusResearch/uhd/archive/release_%{ver_}.tar.gz#/uhd-release_%{ver_}.tar.gz
Source1: %{name}-limits.conf
Source2: http://files.ettus.com/binaries/uhd_stable/latest_release/uhd-images_%{ver}-release.tar.gz
# ARM convert_test fix (rhbz#813393)
Patch0: uhd-3.5.3-no-neon.patch
# Fix firmware build with sdcc-3
Patch1: uhd-3.4.2-sdcc-3-fix.patch
Patch0: uhd-3.4.2-sdcc-3-fix.patch
# Fix not to override distribution LDFLAGS
Patch1: uhd-3.7.2-uhd-dump-libs.patch
# Fix building with wireshark 1.12
Patch2: uhd-3.7.2-wireshark-1.12-fix.patch
%description
The UHD is the universal hardware driver for Ettus Research products.
@ -44,7 +58,6 @@ future Ettus Research products. It can be used standalone without GNU Radio.
%package firmware
Summary: Firmware files for UHD
Group: Applications/Engineering
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
@ -53,7 +66,6 @@ Firmware files for the Universal Hardware driver (UHD).
%package devel
Summary: Development files for UHD
Group: Applications/Engineering
Requires: %{name} = %{version}-%{release}
%description devel
@ -61,16 +73,25 @@ Development files for the Universal Hardware Driver (UHD).
%package doc
Summary: Documentation files for UHD
Group: Applications/Engineering
BuildArch: noarch
%description doc
Documentation for the Universal Hardware Driver (UHD).
%package tools
Summary: Tools for working with / debugging USRP device
Requires: %{name} = %{version}-%{release}
#Requires: wireshark = %{wireshark_ver}
%description tools
Tools that are useful for working with and/or debugging USRP device, including
Wireshark plugin to view Compressed HeaDeR (CHDR) formatted-packets.
%prep
%setup -q -n uhd-release_%{ver_}
%patch0 -p1 -b .no-neon
%patch1 -p1 -b .sdcc-3-fix
%patch0 -p1 -b .sdcc-3-fix
%patch1 -p1 -b .uhd-dump-libs
%patch2 -p1 -b .wireshark-1.12-fix
# firmware
%if %{with binary_firmware}
@ -93,10 +114,24 @@ popd
mkdir -p host/build
pushd host/build
%cmake ../
%cmake %{?have_neon} ../
make %{?_smp_mflags}
popd
# tools
pushd tools/uhd_dump
make %{?_smp_mflags} CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}"
popd
# tools wireshark plugin
# currenty disabled due to rhbz#1129419
#pushd tools/chdr-dissector
#mkdir build
#cd build
#%cmake ../
#make %{?_smp_mflags}
#popd
%check
cd host/build
make test
@ -133,10 +168,18 @@ rm -rf %{buildroot}%{_datadir}/uhd/images/winusb_driver
# convert hardlinks to symlinks (to not package the file twice)
pushd %{buildroot}%{_bindir}
unlink ./usrp_n2xx_simple_net_burner
ln -s ../..%{_libexecdir}/uhd/usrp_n2xx_simple_net_burner
for f in usrp_n2xx_simple_net_burner usrp_x3xx_fpga_burner;
do
unlink $f
ln -s ../..%{_libexecdir}/uhd/$f
done
popd
# tools
install -Dpm 0755 tools/usrp_x3xx_fpga_jtag_programmer.sh %{buildroot}%{_bindir}/usrp_x3xx_fpga_jtag_programmer.sh
install -Dpm 0755 tools/uhd_dump/chdr_log %{buildroot}%{_bindir}/chdr_log
#install -Dpm 0755 tools/chdr-dissector/build/chdr-plugin.so %{buildroot}%{_libdir}/wireshark/plugins/%{wireshark_ver}/chdr-plugin.so
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
@ -146,7 +189,11 @@ popd
%exclude %{_docdir}/%{name}/doxygen
%exclude %{_datadir}/uhd/images
%doc _tmpdoc/*
%{_bindir}/*
%{_bindir}/uhd_*
%{_bindir}/usrp2*
%{_bindir}/usrp_n2xx_simple_net_burner
%{_bindir}/usrp_x3xx_fpga_burner
%{_bindir}/nirio_programmer
%{_prefix}/lib/udev/rules.d/10-usrp-uhd.rules
%config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
%{_libdir}/lib*.so.*
@ -167,7 +214,18 @@ popd
%doc %{_docdir}/%{name}/manual
%doc %{_docdir}/%{name}/doxygen
%files tools
%doc tools/README.md
%{_bindir}/usrp_x3xx_fpga_jtag_programmer.sh
%{_bindir}/chdr_log
#%{_libdir}/wireshark/plugins/%{wireshark_ver}/chdr-plugin.so
%changelog
* Mon Sep 1 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 3.7.2-1
- New version
- Added tools subpackage (wireshark plugin disabled due to rhbz#1129419)
- Minor packaging fixes
* Fri Aug 29 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 3.6.2-6
- Migrated udev rule to dynamic ACL management
- Fixed udev rule location