Update to 2.1.1
This commit is contained in:
parent
88b450bd40
commit
dd8f055c63
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@
|
||||
/udisks-2.0.90.tar.bz2
|
||||
/udisks-2.0.91.tar.bz2
|
||||
/udisks-2.1.0.tar.bz2
|
||||
/udisks-2.1.1.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
a8c806034f096a8b10dfae1c4a917d0c udisks-2.1.0.tar.bz2
|
||||
80e03f312542b800cf3162254b202725 udisks-2.1.1.tar.bz2
|
||||
|
@ -1,26 +0,0 @@
|
||||
From b841e30a98459816dfc49a735d3db4355a88edcd Mon Sep 17 00:00:00 2001
|
||||
From: David Zeuthen <zeuthen@gmail.com>
|
||||
Date: Tue, 19 Mar 2013 04:31:40 +0000
|
||||
Subject: Properly identify firewire devices as non-system devices
|
||||
|
||||
This was reported in bug 62077.
|
||||
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=62077
|
||||
|
||||
Signed-off-by: David Zeuthen <zeuthen@gmail.com>
|
||||
---
|
||||
diff --git a/src/udiskslinuxblock.c b/src/udiskslinuxblock.c
|
||||
index a1781cf..d619850 100644
|
||||
--- a/src/udiskslinuxblock.c
|
||||
+++ b/src/udiskslinuxblock.c
|
||||
@@ -354,7 +354,7 @@ update_hints (UDisksLinuxBlock *block,
|
||||
connection_bus = udisks_drive_get_connection_bus (drive);
|
||||
removable = udisks_drive_get_media_removable (drive);
|
||||
if (removable ||
|
||||
- (g_strcmp0 (connection_bus, "usb") == 0 || g_strcmp0 (connection_bus, "firewire") == 0) ||
|
||||
+ (g_strcmp0 (connection_bus, "usb") == 0 || g_strcmp0 (connection_bus, "ieee1394") == 0) ||
|
||||
(g_str_has_prefix (device_file, "/dev/mmcblk") || g_str_has_prefix (device_file, "/dev/mspblk")))
|
||||
{
|
||||
hint_system = FALSE;
|
||||
--
|
||||
cgit v0.9.0.2-2-gbebe
|
13
udisks2.spec
13
udisks2.spec
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: Disk Manager
|
||||
Name: udisks2
|
||||
Version: 2.1.0
|
||||
Release: 3%{?dist}
|
||||
Version: 2.1.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.freedesktop.org/wiki/Software/udisks
|
||||
@ -64,11 +64,6 @@ Requires: ntfsprogs
|
||||
Conflicts: kernel < 2.6.26
|
||||
|
||||
|
||||
# Cannot mount external firewire hard drive or usb thumb drive as normal user, root required
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=909010
|
||||
Patch0: udisks-2.1.1-firewire-ident.patch
|
||||
|
||||
|
||||
%description
|
||||
udisks provides a daemon, D-Bus API and command line tools for
|
||||
managing disks and storage devices. This package is for the udisks 2.x
|
||||
@ -98,7 +93,6 @@ daemon. This package is for the udisks 2.x series.
|
||||
|
||||
%prep
|
||||
%setup -q -n udisks-%{version}
|
||||
%patch0 -p1 -b .firewire-ident
|
||||
|
||||
%build
|
||||
# we can't use _hardened_build here, see
|
||||
@ -162,6 +156,9 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
|
||||
|
||||
# Note: please don't forget the %{?dist} in the changelog. Thanks
|
||||
%changelog
|
||||
* Wed Aug 21 2013 Tomas Bzatek <tbzatek@redhat.com> - 2.1.1-1%{?dist}
|
||||
- Update to 2.1.1
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user