Raspberry Pi and Allwinner fixes, Enable some new devices

This commit is contained in:
Peter Robinson 2017-08-25 17:11:36 +01:00
parent 3a1a44b396
commit fbf8311945
6 changed files with 202 additions and 10 deletions

View File

@ -16,6 +16,7 @@ orangepi_win
orangepi_zero_plus2
p2371-2180
pine64_plus
poplar
puma-rk3399
rpi_3
sheep-rk3368

View File

@ -34,6 +34,7 @@ Cubietruck_plus
db-mv784mp-gp
difrnce_dit4350
dserve_dsrv9703c
evb-rk3229
fennec-rk3288
firefly-rk3288
highbank
@ -109,6 +110,7 @@ stih410-b2260
sunxi_Gemei_G9
tinker-rk3288
trimslice
turris_omnia
udoo
udoo_neo
UTOO_P66

View File

@ -0,0 +1,74 @@
From patchwork Fri Aug 25 01:45:31 2017
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Subject: [U-Boot] rpi: Enable USB keyboard support
From: Simon Glass <sjg@chromium.org>
X-Patchwork-Id: 805721
Message-Id: <20170825014531.192640-1-sjg@chromium.org>
To: U-Boot Mailing List <u-boot@lists.denx.de>
Cc: Fabian Vogt <fvogt@suse.com>, Stephen Warren <swarren@nvidia.com>
Date: Thu, 24 Aug 2017 19:45:31 -0600
This is currently disabled, so USB keyboards are not detected in U_Boot.
Enable this option to fix that.
Signed-off-by: Simon Glass <sjg@chromium.org>
Tested-by: Jonathan Gray <jsg@jsg.id.au>
Reviewed-by: Bin Meng <bmeng.cn@gmail.com>
---
configs/rpi_2_defconfig | 1 +
configs/rpi_3_32b_defconfig | 1 +
configs/rpi_3_defconfig | 1 +
configs/rpi_defconfig | 1 +
4 files changed, 4 insertions(+)
diff --git a/configs/rpi_2_defconfig b/configs/rpi_2_defconfig
index 63d1e4042d..5150eed79c 100644
--- a/configs/rpi_2_defconfig
+++ b/configs/rpi_2_defconfig
@@ -15,6 +15,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
CONFIG_CMD_GPIO=y
CONFIG_CMD_MMC=y
CONFIG_CMD_USB=y
+CONFIG_DM_KEYBOARD=y
CONFIG_DM_MMC=y
CONFIG_MMC_SDHCI=y
CONFIG_MMC_SDHCI_BCM2835=y
diff --git a/configs/rpi_3_32b_defconfig b/configs/rpi_3_32b_defconfig
index 343cb197a1..caceb85b07 100644
--- a/configs/rpi_3_32b_defconfig
+++ b/configs/rpi_3_32b_defconfig
@@ -16,6 +16,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
CONFIG_CMD_GPIO=y
CONFIG_CMD_MMC=y
CONFIG_CMD_USB=y
+CONFIG_DM_KEYBOARD=y
CONFIG_DM_MMC=y
CONFIG_MMC_SDHCI=y
CONFIG_MMC_SDHCI_BCM2835=y
diff --git a/configs/rpi_3_defconfig b/configs/rpi_3_defconfig
index 6c9f2e32b5..e3dd1b9124 100644
--- a/configs/rpi_3_defconfig
+++ b/configs/rpi_3_defconfig
@@ -16,6 +16,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
CONFIG_CMD_GPIO=y
CONFIG_CMD_MMC=y
CONFIG_CMD_USB=y
+CONFIG_DM_KEYBOARD=y
CONFIG_DM_MMC=y
CONFIG_MMC_SDHCI=y
CONFIG_MMC_SDHCI_BCM2835=y
diff --git a/configs/rpi_defconfig b/configs/rpi_defconfig
index 6b3cec5ce0..eaf9bb9189 100644
--- a/configs/rpi_defconfig
+++ b/configs/rpi_defconfig
@@ -15,6 +15,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
CONFIG_CMD_GPIO=y
CONFIG_CMD_MMC=y
CONFIG_CMD_USB=y
+CONFIG_DM_KEYBOARD=y
CONFIG_DM_MMC=y
CONFIG_MMC_SDHCI=y
CONFIG_MMC_SDHCI_BCM2835=y

View File

@ -0,0 +1,81 @@
From aeac5d911f15e3d17ca857b6e0830e770b4e6db1 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Tue, 22 Aug 2017 15:52:50 +0100
Subject: [PATCH] sun7i: fix gmac rename
---
arch/arm/include/asm/arch-sunxi/sys_proto.h | 2 +-
board/sunxi/Makefile | 2 +-
include/configs/sunxi-common.h | 2 +-
scripts/build-whitelist.sh | 2 +-
scripts/config_whitelist.txt | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/arch/arm/include/asm/arch-sunxi/sys_proto.h b/arch/arm/include/asm/arch-sunxi/sys_proto.h
index a373319a2b..096510b787 100644
--- a/arch/arm/include/asm/arch-sunxi/sys_proto.h
+++ b/arch/arm/include/asm/arch-sunxi/sys_proto.h
@@ -24,7 +24,7 @@ void sdelay(unsigned long);
void return_to_fel(uint32_t lr, uint32_t sp);
/* Board / SoC level designware gmac init */
-#if !defined CONFIG_SPL_BUILD && defined CONFIG_SUNXI_GMAC
+#if !defined CONFIG_SPL_BUILD && defined CONFIG_SUN7I_GMAC
void eth_init_board(void);
#else
static inline void eth_init_board(void) {}
diff --git a/board/sunxi/Makefile b/board/sunxi/Makefile
index f4411f01c3..526cb72a51 100644
--- a/board/sunxi/Makefile
+++ b/board/sunxi/Makefile
@@ -9,7 +9,7 @@
# SPDX-License-Identifier: GPL-2.0+
#
obj-y += board.o
-obj-$(CONFIG_SUNXI_GMAC) += gmac.o
+obj-$(CONFIG_SUN7I_GMAC) += gmac.o
ifndef CONFIG_SPL_BUILD
obj-$(CONFIG_SUNXI_AHCI) += ahci.o
endif
diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
index 212862acd1..1373b1f037 100644
--- a/include/configs/sunxi-common.h
+++ b/include/configs/sunxi-common.h
@@ -294,7 +294,7 @@ extern int soft_i2c_gpio_scl;
#define CONFIG_MII /* MII PHY management */
#endif
-#ifdef CONFIG_SUNXI_GMAC
+#ifdef CONFIG_SUN7I_GMAC
#define CONFIG_PHY_ADDR 1
#define CONFIG_MII /* MII PHY management */
#define CONFIG_PHY_REALTEK
diff --git a/scripts/build-whitelist.sh b/scripts/build-whitelist.sh
index 7d8160d5f2..0f102a0585 100755
--- a/scripts/build-whitelist.sh
+++ b/scripts/build-whitelist.sh
@@ -16,7 +16,7 @@ export LC_ALL=C LC_COLLATE=C
# SUNXI_GMAC,AHCI,SATAPWR=SUNXI_GPB(8)
#
# We want this to produce:
-# CONFIG_SUNXI_GMAC
+# CONFIG_SUN7I_GMAC
# CONFIG_AHCI
# CONFIG_SATAPWR
#
diff --git a/scripts/config_whitelist.txt b/scripts/config_whitelist.txt
index 6c628c878c..024dcd6a1e 100644
--- a/scripts/config_whitelist.txt
+++ b/scripts/config_whitelist.txt
@@ -2308,7 +2308,7 @@ CONFIG_STV0991_HZ_CLOCK
CONFIG_ST_SMI
CONFIG_SUNXI_AHCI
CONFIG_SUNXI_EMAC
-CONFIG_SUNXI_GMAC
+CONFIG_SUN7I_GMAC
CONFIG_SUNXI_GPIO
CONFIG_SUNXI_MAX_FB_SIZE
CONFIG_SUNXI_USB_PHYS
--
2.13.5

View File

@ -1,17 +1,18 @@
From e0010e2633c473b36b8b04c94dd29978d38919d3 Mon Sep 17 00:00:00 2001
From d667f43d25d9c7fe48bc9d163dc9c9e062361acb Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Thu, 3 Aug 2017 17:28:15 +0100
Subject: [PATCH] sunxi pine64 dm mmc support
Date: Thu, 17 Aug 2017 11:55:55 +0100
Subject: [PATCH] pine64 use DM mmc
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
---
configs/pine64_plus_defconfig | 4 ++++
1 file changed, 4 insertions(+)
configs/pine64_plus_defconfig | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/configs/pine64_plus_defconfig b/configs/pine64_plus_defconfig
index a509ca92b2..5c4a688bdd 100644
index a509ca92b2..da3663fbb1 100644
--- a/configs/pine64_plus_defconfig
+++ b/configs/pine64_plus_defconfig
@@ -14,3 +14,7 @@ CONFIG_SPL=y
@@ -14,3 +14,9 @@ CONFIG_SPL=y
CONFIG_OF_LIST="sun50i-a64-pine64 sun50i-a64-pine64-plus"
CONFIG_SUN8I_EMAC=y
CONFIG_USB_EHCI_HCD=y
@ -19,6 +20,32 @@ index a509ca92b2..5c4a688bdd 100644
+CONFIG_DM_MMC=y
+# CONFIG_SPL_DM_MMC is not set
+# CONFIG_SPL_DM_MMC_OPS is not set
+CONFIG_SCSI=y
+CONFIG_DM_SCSI=y
--
2.13.3
2.13.5
From d1569782c6fe336577d801ea8c9300e63eb3e9c1 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Thu, 17 Aug 2017 12:01:59 +0100
Subject: [PATCH] add mmc
---
configs/pine64_plus_defconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/configs/pine64_plus_defconfig b/configs/pine64_plus_defconfig
index da3663fbb1..78f9cfe21d 100644
--- a/configs/pine64_plus_defconfig
+++ b/configs/pine64_plus_defconfig
@@ -15,6 +15,7 @@ CONFIG_OF_LIST="sun50i-a64-pine64 sun50i-a64-pine64-plus"
CONFIG_SUN8I_EMAC=y
CONFIG_USB_EHCI_HCD=y
# CONFIG_SPL_BLK is not set
+CONFIG_MMC=y
CONFIG_DM_MMC=y
# CONFIG_SPL_DM_MMC is not set
# CONFIG_SPL_DM_MMC_OPS is not set
--
2.13.5

View File

@ -2,7 +2,7 @@
Name: uboot-tools
Version: 2017.09
Release: 0.3%{?candidate:.%{candidate}}%{?dist}
Release: 0.4%{?candidate:.%{candidate}}%{?dist}
Summary: U-Boot utilities
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
URL: http://www.denx.de/wiki/U-Boot
@ -22,8 +22,11 @@ Patch10: dragonboard-fixes.patch
Patch11: mx6-Initial-Hummingboard-2-support.patch
Patch12: sti-STiH410-B2260-support.patch
Patch13: rpi-Revert-dm-Drop-CONFIG_OF_EMBED.patch
#Patch14: sunxi-dm-pine64.patch
Patch14: rpi-Enable-USB-keyboard-support.patch
Patch15: sunxi-Fix-CONFIG_SUNXI_GMAC-references.patch
Patch16: sunxi-mmc-fixes.patch
# Patch17: sunxi-dm-pine64.patch
# Patch14: mvebu-enable-generic-distro-boot-config.patch
BuildRequires: bc
@ -275,6 +278,10 @@ cp -p board/warp7/README builds/docs/README.warp7
%endif
%changelog
* Fri Aug 25 2017 Peter Robinson <pbrobinson@fedoraproject.org> 2017.09-0.4.rc2
- Raspberry Pi and Allwinner fixes
- Enable some new devices
* Tue Aug 15 2017 Peter Robinson <pbrobinson@fedoraproject.org> 2017.09-0.3.rc2
- 2017.09 RC2