2017.05 RC2
This commit is contained in:
parent
80ae5ab87e
commit
e965f7ea51
@ -1,58 +0,0 @@
|
||||
From patchwork Fri Dec 16 04:53:30 2016
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 8bit
|
||||
Subject: [U-Boot,v2] Makefile: Fix linking with modern binutils
|
||||
From: Joel Stanley <joel@jms.id.au>
|
||||
X-Patchwork-Id: 706336
|
||||
X-Patchwork-Delegate: trini@ti.com
|
||||
Message-Id: <20161216045330.31257-1-joel@jms.id.au>
|
||||
To: u-boot@lists.denx.de
|
||||
Cc: npiggin@gmail.com, amodra@gmail.com
|
||||
Date: Fri, 16 Dec 2016 15:23:30 +1030
|
||||
|
||||
Since Binutils 1a9ccd70f9a7[1] u-boot will not link targets that set
|
||||
CONFIG_SYS_TEXT_BASE=0 with the following error:
|
||||
|
||||
LD u-boot
|
||||
arm-linux-gnueabi-ld.bfd: u-boot: Not enough room for program headers, try
|
||||
linking with -N
|
||||
arm-linux-gnueabi-ld.bfd: final link failed: Bad value
|
||||
|
||||
The issue can reproduced the bad binutils and the rock2_defconfig target.
|
||||
|
||||
This issue was also encountered by the powerpc kernel[2], with the fix
|
||||
being to pass --no-dynamic-linker for linkers newer than 2.26 when this
|
||||
flag was introduced. The option tells ld that the PIE or shared lib does
|
||||
not need loaded program headers.
|
||||
|
||||
Ubuntu Zesty's Binutils 2.27.51.20161202 hits this error.
|
||||
|
||||
[1] https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commit;h=1a9ccd70f9a7
|
||||
[2] https://git.kernel.org/cgit/linux/kernel/git/powerpc/linux.git/commit/?h=next&id=ff45000fcb56b5b0f1a14a865d3541746d838a0a
|
||||
|
||||
Signed-off-by: Joel Stanley <joel@jms.id.au>
|
||||
Tested-by: Sjoerd Simons <sjoerd.simons@collabora.co.uk>
|
||||
---
|
||||
v2:
|
||||
- use ld-option to test for the flag instead of the version, as suggested by Måns
|
||||
- update commit message with clarification from Alan
|
||||
|
||||
Makefile | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index dfed58bec661..c98a8361654a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -793,6 +793,10 @@ ALL-y += $(CONFIG_BUILD_TARGET:"%"=%)
|
||||
endif
|
||||
|
||||
LDFLAGS_u-boot += $(LDFLAGS_FINAL)
|
||||
+
|
||||
+# Avoid 'Not enough room for program headers' error on binutils 2.28 onwards.
|
||||
+LDFLAGS_u-boot += $(call ld-option, --no-dynamic-linker)
|
||||
+
|
||||
ifneq ($(CONFIG_SYS_TEXT_BASE),)
|
||||
LDFLAGS_u-boot += -Ttext $(CONFIG_SYS_TEXT_BASE)
|
||||
endif
|
@ -1,197 +0,0 @@
|
||||
From patchwork Thu Mar 30 19:29:52 2017
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [U-Boot,1/3] config: am335x_evm: detect Black Wireless using BWA
|
||||
From: robertcnelson@gmail.com
|
||||
X-Patchwork-Id: 745389
|
||||
Message-Id: <20170330192954.22673-1-robertcnelson@gmail.com>
|
||||
To: u-boot@lists.denx.de
|
||||
Cc: Tom Rini <trini@konsulko.com>, Jason Kridner <jkridner@beagleboard.org>,
|
||||
Will Newton <willn@resin.io>
|
||||
Date: Thu, 30 Mar 2017 14:29:52 -0500
|
||||
|
||||
BeagleBone Black Wireless is clone of the BeagleBone Black (BBB) with
|
||||
the Ethernet replaced by a TI wl1835 wireless module.
|
||||
|
||||
This board can be indentified by the BWAx value after A335BNLT (BBB)
|
||||
in the at24 eeprom:
|
||||
BWAx [aa 55 33 ee 41 33 33 35 42 4e 4c 54 42 57 41 35 |.U3.A335BNLTBWA5|]
|
||||
|
||||
http://beagleboard.org/black-wireless
|
||||
https://github.com/beagleboard/beaglebone-black-wireless
|
||||
|
||||
firmware: https://github.com/beagleboard/beaglebone-black-wireless/tree/master/firmware
|
||||
wl18xx mac address: /proc/device-tree/ocp/ethernet@4a100000/slave@4a100200/mac-address
|
||||
|
||||
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
||||
CC: Tom Rini <trini@konsulko.com>
|
||||
CC: Jason Kridner <jkridner@beagleboard.org>
|
||||
CC: Will Newton <willn@resin.io>
|
||||
Reviewed-by: Tom Rini <trini@konsulko.com>
|
||||
---
|
||||
board/ti/am335x/board.c | 7 +++++++
|
||||
include/configs/am335x_evm.h | 2 ++
|
||||
2 files changed, 9 insertions(+)
|
||||
|
||||
diff --git a/board/ti/am335x/board.c b/board/ti/am335x/board.c
|
||||
index 8eaf3e9a5c..304ae34fb7 100644
|
||||
--- a/board/ti/am335x/board.c
|
||||
+++ b/board/ti/am335x/board.c
|
||||
@@ -651,6 +651,13 @@ int board_late_init(void)
|
||||
#ifdef CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
|
||||
char *name = NULL;
|
||||
|
||||
+ if (board_is_bone_lt()) {
|
||||
+ /* BeagleBoard.org BeagleBone Black Wireless: */
|
||||
+ if (!strncmp(board_ti_get_rev(), "BWA", 3)) {
|
||||
+ name = "BBBW";
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
if (board_is_bbg1())
|
||||
name = "BBG1";
|
||||
set_board_info_env(name);
|
||||
diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
|
||||
index 27126871f7..dcac2f5816 100644
|
||||
--- a/include/configs/am335x_evm.h
|
||||
+++ b/include/configs/am335x_evm.h
|
||||
@@ -138,6 +138,8 @@
|
||||
"setenv fdtfile am335x-bone.dtb; fi; " \
|
||||
"if test $board_name = A335BNLT; then " \
|
||||
"setenv fdtfile am335x-boneblack.dtb; fi; " \
|
||||
+ "if test $board_name = BBBW; then " \
|
||||
+ "setenv fdtfile am335x-boneblack-wireless.dtb; fi; " \
|
||||
"if test $board_name = BBG1; then " \
|
||||
"setenv fdtfile am335x-bonegreen.dtb; fi; " \
|
||||
"if test $board_name = A33515BB; then " \
|
||||
From patchwork Thu Mar 30 19:29:53 2017
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [U-Boot,2/3] config: am335x_evm: detect Green Wireless using GW1
|
||||
From: robertcnelson@gmail.com
|
||||
X-Patchwork-Id: 745390
|
||||
Message-Id: <20170330192954.22673-2-robertcnelson@gmail.com>
|
||||
To: u-boot@lists.denx.de
|
||||
Cc: Tom Rini <trini@konsulko.com>, Jason Kridner <jkridner@beagleboard.org>,
|
||||
Will Newton <willn@resin.io>
|
||||
Date: Thu, 30 Mar 2017 14:29:53 -0500
|
||||
|
||||
SeeedStudio BeagleBone Green Wireless (BBGW) is an expansion of the
|
||||
SeeedStudio Green (BBG) with the Ethernet replaced by a TI wl1835
|
||||
wireless module.
|
||||
|
||||
This board can be indentified by the GW1x value after A335BNLT (BBB)
|
||||
in the at24 eeprom:
|
||||
GW1x [aa 55 33 ee 41 33 33 35 42 4e 4c 54 47 57 31 41 |.U3.A335BNLTGW1A|]
|
||||
|
||||
http://beagleboard.org/green-wireless
|
||||
http://wiki.seeed.cc/BeagleBone_Green_Wireless/
|
||||
|
||||
firmware: https://github.com/beagleboard/beaglebone-black-wireless/tree/master/firmware
|
||||
wl18xx mac address: Stored in at24 eeprom at address 5-16:
|
||||
hexdump -e '8/1 "%c"' /sys/bus/i2c/devices/0-0050/eeprom | cut -b 5-16
|
||||
|
||||
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
||||
CC: Tom Rini <trini@konsulko.com>
|
||||
CC: Jason Kridner <jkridner@beagleboard.org>
|
||||
CC: Will Newton <willn@resin.io>
|
||||
Reviewed-by: Tom Rini <trini@konsulko.com>
|
||||
---
|
||||
board/ti/am335x/board.c | 4 ++++
|
||||
include/configs/am335x_evm.h | 2 ++
|
||||
2 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/board/ti/am335x/board.c b/board/ti/am335x/board.c
|
||||
index 304ae34fb7..54589638b3 100644
|
||||
--- a/board/ti/am335x/board.c
|
||||
+++ b/board/ti/am335x/board.c
|
||||
@@ -656,6 +656,10 @@ int board_late_init(void)
|
||||
if (!strncmp(board_ti_get_rev(), "BWA", 3)) {
|
||||
name = "BBBW";
|
||||
}
|
||||
+ /* SeeedStudio BeagleBone Green Wireless */
|
||||
+ if (!strncmp(board_ti_get_rev(), "GW1", 3)) {
|
||||
+ name = "BBGW";
|
||||
+ }
|
||||
}
|
||||
|
||||
if (board_is_bbg1())
|
||||
diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
|
||||
index dcac2f5816..d90c5156d3 100644
|
||||
--- a/include/configs/am335x_evm.h
|
||||
+++ b/include/configs/am335x_evm.h
|
||||
@@ -142,6 +142,8 @@
|
||||
"setenv fdtfile am335x-boneblack-wireless.dtb; fi; " \
|
||||
"if test $board_name = BBG1; then " \
|
||||
"setenv fdtfile am335x-bonegreen.dtb; fi; " \
|
||||
+ "if test $board_name = BBGW; then " \
|
||||
+ "setenv fdtfile am335x-bonegreen-wireless.dtb; fi; " \
|
||||
"if test $board_name = A33515BB; then " \
|
||||
"setenv fdtfile am335x-evm.dtb; fi; " \
|
||||
"if test $board_name = A335X_SK; then " \
|
||||
From patchwork Thu Mar 30 19:29:54 2017
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [U-Boot,3/3] config: am335x_evm: detect BeagleBone Blue using BLA
|
||||
From: robertcnelson@gmail.com
|
||||
X-Patchwork-Id: 745391
|
||||
Message-Id: <20170330192954.22673-3-robertcnelson@gmail.com>
|
||||
To: u-boot@lists.denx.de
|
||||
Cc: Tom Rini <trini@konsulko.com>, Jason Kridner <jkridner@beagleboard.org>,
|
||||
Will Newton <willn@resin.io>
|
||||
Date: Thu, 30 Mar 2017 14:29:54 -0500
|
||||
|
||||
BeagleBone Blue is next grenation of boards from BeagleBoard.org, focusing
|
||||
on robotics with a TI wl1835 wireless module for connectivity.
|
||||
|
||||
This board can be indentified by the BLAx value after A335BNLT (BBB)
|
||||
in the at24 eeprom:
|
||||
BLAx: [aa 55 33 ee 41 33 33 35 42 4e 4c 54 42 4c 41 30 |.U3.A335BNLTBLA2|]
|
||||
|
||||
http://beagleboard.org/blue
|
||||
https://github.com/beagleboard/beaglebone-blue
|
||||
|
||||
firmware: https://github.com/beagleboard/beaglebone-black-wireless/tree/master/firmware
|
||||
wl18xx mac address: /proc/device-tree/ocp/ethernet@4a100000/slave@4a100200/mac-address
|
||||
|
||||
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
||||
CC: Tom Rini <trini@konsulko.com>
|
||||
CC: Jason Kridner <jkridner@beagleboard.org>
|
||||
CC: Will Newton <willn@resin.io>
|
||||
Reviewed-by: Tom Rini <trini@konsulko.com>
|
||||
---
|
||||
board/ti/am335x/board.c | 4 ++++
|
||||
include/configs/am335x_evm.h | 2 ++
|
||||
2 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/board/ti/am335x/board.c b/board/ti/am335x/board.c
|
||||
index 54589638b3..3e842d3187 100644
|
||||
--- a/board/ti/am335x/board.c
|
||||
+++ b/board/ti/am335x/board.c
|
||||
@@ -660,6 +660,10 @@ int board_late_init(void)
|
||||
if (!strncmp(board_ti_get_rev(), "GW1", 3)) {
|
||||
name = "BBGW";
|
||||
}
|
||||
+ /* BeagleBoard.org BeagleBone Blue */
|
||||
+ if (!strncmp(board_ti_get_rev(), "BLA", 3)) {
|
||||
+ name = "BBBL";
|
||||
+ }
|
||||
}
|
||||
|
||||
if (board_is_bbg1())
|
||||
diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
|
||||
index d90c5156d3..5fbc1e3ff9 100644
|
||||
--- a/include/configs/am335x_evm.h
|
||||
+++ b/include/configs/am335x_evm.h
|
||||
@@ -144,6 +144,8 @@
|
||||
"setenv fdtfile am335x-bonegreen.dtb; fi; " \
|
||||
"if test $board_name = BBGW; then " \
|
||||
"setenv fdtfile am335x-bonegreen-wireless.dtb; fi; " \
|
||||
+ "if test $board_name = BBBL; then " \
|
||||
+ "setenv fdtfile am335x-boneblue.dtb; fi; " \
|
||||
"if test $board_name = A33515BB; then " \
|
||||
"setenv fdtfile am335x-evm.dtb; fi; " \
|
||||
"if test $board_name = A335X_SK; then " \
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (u-boot-2017.05-rc1.tar.bz2) = 06295e6e56a28566f8c65ab370a087740f017390f0f2917dacb0a45d0793b0c50d37dfe7da36eee3704bb538834bfb3e99c75a641d7388372139030ff9becc89
|
||||
SHA512 (u-boot-2017.05-rc2.tar.bz2) = 306f200258e2a07107667fc2485c617b6a2f0facf68b02026d5d33640546804db3968d7e4e7121450e2e32ba2fc1682d4e8087be566eed4164ea38aca4956cba
|
||||
|
@ -1,8 +1,8 @@
|
||||
%global candidate rc1
|
||||
%global candidate rc2
|
||||
|
||||
Name: uboot-tools
|
||||
Version: 2017.05
|
||||
Release: 0.3%{?candidate:.%{candidate}}%{?dist}
|
||||
Release: 0.4%{?candidate:.%{candidate}}%{?dist}
|
||||
Summary: U-Boot utilities
|
||||
|
||||
Group: Development/Tools
|
||||
@ -18,8 +18,6 @@ Patch3: U-Boot-2-2-rsa-Fix-deprecated-warnings-for-OpenSSL-1.1.x.patch
|
||||
Patch4: tools-kwbimage-fix-build-with-OpenSSL-1.1.x.patch
|
||||
Patch5: mx6cuboxi-Add-support-for-sata.patch
|
||||
Patch6: mx6-Initial-Hummingboard-2-support.patch
|
||||
Patch7: bbone-new-devices.patch
|
||||
Patch8: U-Boot-v2-Makefile-Fix-linking-with-modern-binutils.patch
|
||||
Patch9: sti-STiH410-B2260-support.patch
|
||||
|
||||
# Patch9: 0001-arm-mvebu-enable-generic-distro-boot-config.patch
|
||||
@ -258,6 +256,9 @@ cp -p board/rockchip/evb_rk3399/README doc/README.evb_rk3399
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 17 2017 Peter Robinson <pbrobinson@fedoraproject.org> 2017.05-0.4.rc2
|
||||
- 2017.05 RC2
|
||||
|
||||
* Tue Apr 11 2017 Peter Robinson <pbrobinson@fedoraproject.org> 2017.05-0.3.rc1
|
||||
- Add support for STi STiH410
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user