fix CHIP patches to apply cleanly
This commit is contained in:
parent
c196516e65
commit
db70ea6ed1
@ -1,14 +1,8 @@
|
||||
From 44c798799f667310ce29ce264be5c4bff7a21cf2 Mon Sep 17 00:00:00 2001
|
||||
From: Maxime Ripard <maxime.ripard@free-electrons.com>
|
||||
Date: Thu, 15 Oct 2015 22:04:07 +0200
|
||||
Subject: [PATCH 005/600] sunxi: Use Kconfig CONFIG_MMC
|
||||
From c8a8fe4701ba559f843a3af7ac7df44d967cdb0f Mon Sep 17 00:00:00 2001
|
||||
From: no one <noone@example.com>
|
||||
Date: Tue, 17 Nov 2015 11:58:14 +0000
|
||||
Subject: [PATCH 1/2] sunxi: Use Kconfig CONFIG_MMC
|
||||
|
||||
Not all sunxi boards have an MMC embedded. Switching to the Kconfig option
|
||||
will allow to enable or disable the support in each boards' defconfig.
|
||||
|
||||
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
|
||||
Reviewed-by: Hans de Goede <hdegoede@redhat.com>
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
---
|
||||
board/sunxi/Kconfig | 4 ++++
|
||||
drivers/mmc/Kconfig | 2 +-
|
||||
@ -16,7 +10,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
3 files changed, 10 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig
|
||||
index b336777..f6f2a60 100644
|
||||
index 55906b5..8a727d6 100644
|
||||
--- a/board/sunxi/Kconfig
|
||||
+++ b/board/sunxi/Kconfig
|
||||
@@ -227,6 +227,10 @@ config OLD_SUNXI_KERNEL_COMPAT
|
||||
@ -44,10 +38,10 @@ index d3d7d91..ceae7bc 100644
|
||||
TODO: Move all architectures to use this option
|
||||
|
||||
diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
|
||||
index 072934d..ddcfe94 100644
|
||||
index e1ba791..607fda2 100644
|
||||
--- a/include/configs/sunxi-common.h
|
||||
+++ b/include/configs/sunxi-common.h
|
||||
@@ -140,8 +140,7 @@
|
||||
@@ -135,8 +135,7 @@
|
||||
#endif
|
||||
|
||||
/* mmc config */
|
||||
@ -57,7 +51,7 @@ index 072934d..ddcfe94 100644
|
||||
#define CONFIG_GENERIC_MMC
|
||||
#define CONFIG_CMD_MMC
|
||||
#define CONFIG_MMC_SUNXI
|
||||
@@ -197,7 +196,7 @@
|
||||
@@ -192,7 +191,7 @@
|
||||
|
||||
#define CONFIG_SPL_LIBDISK_SUPPORT
|
||||
|
||||
@ -66,8 +60,8 @@ index 072934d..ddcfe94 100644
|
||||
#define CONFIG_SPL_MMC_SUPPORT
|
||||
#endif
|
||||
|
||||
@@ -355,9 +354,12 @@ extern int soft_i2c_gpio_scl;
|
||||
#define CONFIG_ANDROID_BOOT_IMAGE
|
||||
@@ -349,9 +348,12 @@ extern int soft_i2c_gpio_scl;
|
||||
#define CONFIG_FASTBOOT_BUF_SIZE 0x2000000
|
||||
|
||||
#define CONFIG_FASTBOOT_FLASH
|
||||
+
|
||||
|
@ -1,18 +1,8 @@
|
||||
From fd8133b725198978865ead730ff20d3991e05f20 Mon Sep 17 00:00:00 2001
|
||||
From: Maxime Ripard <maxime.ripard@free-electrons.com>
|
||||
Date: Thu, 15 Oct 2015 22:04:10 +0200
|
||||
Subject: [PATCH 008/600] sunxi: Add CHIP support
|
||||
From 41a02f2dc4b10c0e1cf80b20d730f4c3e29c2b6f Mon Sep 17 00:00:00 2001
|
||||
From: no one <noone@example.com>
|
||||
Date: Tue, 17 Nov 2015 12:07:25 +0000
|
||||
Subject: [PATCH] sunxi: Add CHIP support
|
||||
|
||||
The C.H.I.P. is a small SBC with an Allwinner R8, 8GB of NAND, 512MB of
|
||||
RAM, USB host and OTG, a wifi / bluetooth combo chip, an audio/video jack
|
||||
and two connectors to plug additional boards on top of it.
|
||||
|
||||
The DT is identical to the DT submitted to the upstream kernel.
|
||||
|
||||
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
|
||||
Reviewed-by: Tom Rini <trini@konsulko.com>
|
||||
Reviewed-by: Hans de Goede <hdegoede@redhat.com>
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
---
|
||||
arch/arm/dts/Makefile | 3 +-
|
||||
arch/arm/dts/sun5i-r8-chip.dts | 214 +++++++++++++++++++++++++++++++++++++++++
|
||||
@ -23,13 +13,13 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
create mode 100644 configs/CHIP_defconfig
|
||||
|
||||
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
||||
index 8cd282b..8b656e9 100644
|
||||
index 65b4230..6a053cc 100644
|
||||
--- a/arch/arm/dts/Makefile
|
||||
+++ b/arch/arm/dts/Makefile
|
||||
@@ -113,7 +113,8 @@ dtb-$(CONFIG_MACH_SUN5I) += \
|
||||
sun5i-a13-olinuxino.dtb \
|
||||
@@ -115,7 +115,8 @@ dtb-$(CONFIG_MACH_SUN5I) += \
|
||||
sun5i-a13-olinuxino-micro.dtb \
|
||||
sun5i-a13-q8-tablet.dtb \
|
||||
sun5i-a13-tzx-q8-713b7.dtb \
|
||||
- sun5i-a13-utoo-p66.dtb
|
||||
+ sun5i-a13-utoo-p66.dtb \
|
||||
+ sun5i-r8-chip.dtb
|
||||
@ -257,7 +247,7 @@ index 0000000..abf3ccb
|
||||
+ usb1_vbus-supply = <®_vcc5v0>;
|
||||
+};
|
||||
diff --git a/board/sunxi/MAINTAINERS b/board/sunxi/MAINTAINERS
|
||||
index 99f29d3..96c4f3a 100644
|
||||
index 67a9d29..7ccd7e1 100644
|
||||
--- a/board/sunxi/MAINTAINERS
|
||||
+++ b/board/sunxi/MAINTAINERS
|
||||
@@ -24,6 +24,7 @@ F: configs/A13-OLinuXino_defconfig
|
||||
|
@ -23,11 +23,10 @@ Patch8: U-Boot-board-ti-am335x-add-support-for-BeagleBone-Green.patch
|
||||
Patch10: 0002-fastboot-Implement-OEM-format-only-when-we-have-MMC-.patch
|
||||
Patch11: 0003-mmc-Add-generic-Kconfig-option.patch
|
||||
Patch12: 0004-sunxi-board-Only-try-to-use-the-MMC-related-function.patch
|
||||
Patch13: 0005-sunxi-Use-Kconfig-CONFIG_MMC.patch
|
||||
Patch14: 0006-sun5i-Sync-the-DTSI-with-the-kernel.patch
|
||||
Patch15: 0007-axp209-Sync-the-DTSI-with-the-kernel.patch
|
||||
Patch16: 0008-sunxi-Add-CHIP-support.patch
|
||||
|
||||
Patch13: 0005-sunxi-Use-Kconfig-CONFIG_MMC.patch
|
||||
Patch18: 0008-sunxi-Add-CHIP-support.patch
|
||||
|
||||
BuildRequires: bc
|
||||
BuildRequires: dtc
|
||||
|
Loading…
Reference in New Issue
Block a user