update Pine64 LTS patch

This commit is contained in:
Peter Robinson 2018-09-05 17:01:21 +01:00
parent 2489007525
commit ce842aae38
1 changed files with 26 additions and 5 deletions

View File

@ -1,6 +1,6 @@
From 89b9b412ccc5beb7ab72139d43efeaaa46f2d7e4 Mon Sep 17 00:00:00 2001
From 82cc7aca5fb7c7103256229a3ead0b8075da5813 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Wed, 5 Sep 2018 14:01:50 +0100
Date: Wed, 5 Sep 2018 17:00:25 +0100
Subject: [PATCH] sunxi: DT: A64: add Pine64-LTS support
The Pine64-LTS board is a new board version of the Pine64, though
@ -13,9 +13,11 @@ software point of view they are really not different.
Signed-off-by: Andre Przywara <andre.przywara@arm.com>
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
---
arch/arm/dts/Makefile | 1 +
configs/sopine_baseboard_defconfig | 1 +
2 files changed, 2 insertions(+)
arch/arm/dts/Makefile | 1 +
arch/arm/dts/sun50i-a64-pine64-lts.dts | 13 +++++++++++++
configs/sopine_baseboard_defconfig | 1 +
3 files changed, 15 insertions(+)
create mode 100644 arch/arm/dts/sun50i-a64-pine64-lts.dts
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
index ebfa227262..6cd440d6af 100644
@ -29,6 +31,25 @@ index ebfa227262..6cd440d6af 100644
sun50i-a64-pine64-plus.dtb \
sun50i-a64-pine64.dtb \
sun50i-a64-sopine-baseboard.dtb
diff --git a/arch/arm/dts/sun50i-a64-pine64-lts.dts b/arch/arm/dts/sun50i-a64-pine64-lts.dts
new file mode 100644
index 0000000000..72d6961dc3
--- /dev/null
+++ b/arch/arm/dts/sun50i-a64-pine64-lts.dts
@@ -0,0 +1,13 @@
+/*
+ * SPDX-License-Identifier: (GPL-2.0+ OR MIT)
+ *
+ * Copyright (c) 2018 ARM Ltd.
+ */
+
+#include "sun50i-a64-sopine-baseboard.dts"
+
+/ {
+ model = "Pine64 LTS";
+ compatible = "pine64,pine64-lts", "allwinner,sun50i-r18",
+ "allwinner,sun50i-a64";
+};
diff --git a/configs/sopine_baseboard_defconfig b/configs/sopine_baseboard_defconfig
index 9ede081c08..eead38a1e3 100644
--- a/configs/sopine_baseboard_defconfig