2021.01 RC3, latest proposed RPi-400 patch, UEFI boot fixes
This commit is contained in:
parent
5fa2e9250c
commit
ce18c50c5d
File diff suppressed because it is too large
Load Diff
@ -1,496 +1,3 @@
|
|||||||
From 9b10863bc8b14ca5463a95dd2c77555cfc68f326 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
Date: Wed, 9 Sep 2020 10:59:31 +0100
|
|
||||||
Subject: [PATCH] Initial PineTab dts from linux 5.7-rc1
|
|
||||||
|
|
||||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
---
|
|
||||||
arch/arm/dts/Makefile | 1 +
|
|
||||||
arch/arm/dts/sun50i-a64-pinetab.dts | 460 ++++++++++++++++++++++++++++
|
|
||||||
2 files changed, 461 insertions(+)
|
|
||||||
create mode 100644 arch/arm/dts/sun50i-a64-pinetab.dts
|
|
||||||
|
|
||||||
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
|
||||||
index 193f5c6138..57ef94450a 100644
|
|
||||||
--- a/arch/arm/dts/Makefile
|
|
||||||
+++ b/arch/arm/dts/Makefile
|
|
||||||
@@ -611,6 +611,7 @@ dtb-$(CONFIG_MACH_SUN50I) += \
|
|
||||||
sun50i-a64-pinephone-1.0.dtb \
|
|
||||||
sun50i-a64-pinephone-1.1.dtb \
|
|
||||||
sun50i-a64-pinephone-1.2.dtb \
|
|
||||||
+ sun50i-a64-pinetab.dtb \
|
|
||||||
sun50i-a64-sopine-baseboard.dtb \
|
|
||||||
sun50i-a64-teres-i.dtb
|
|
||||||
dtb-$(CONFIG_MACH_SUN9I) += \
|
|
||||||
diff --git a/arch/arm/dts/sun50i-a64-pinetab.dts b/arch/arm/dts/sun50i-a64-pinetab.dts
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000000..316e8a4439
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/arch/arm/dts/sun50i-a64-pinetab.dts
|
|
||||||
@@ -0,0 +1,460 @@
|
|
||||||
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
||||||
+/*
|
|
||||||
+ * Copyright (C) 2019 Icenowy Zheng <icenowy@aosc.xyz>
|
|
||||||
+ *
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+/dts-v1/;
|
|
||||||
+
|
|
||||||
+#include "sun50i-a64.dtsi"
|
|
||||||
+#include "sun50i-a64-cpu-opp.dtsi"
|
|
||||||
+
|
|
||||||
+#include <dt-bindings/gpio/gpio.h>
|
|
||||||
+#include <dt-bindings/input/input.h>
|
|
||||||
+#include <dt-bindings/pwm/pwm.h>
|
|
||||||
+
|
|
||||||
+/ {
|
|
||||||
+ model = "PineTab";
|
|
||||||
+ compatible = "pine64,pinetab", "allwinner,sun50i-a64";
|
|
||||||
+
|
|
||||||
+ aliases {
|
|
||||||
+ serial0 = &uart0;
|
|
||||||
+ ethernet0 = &rtl8723cs;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ backlight: backlight {
|
|
||||||
+ compatible = "pwm-backlight";
|
|
||||||
+ pwms = <&pwm 0 50000 PWM_POLARITY_INVERTED>;
|
|
||||||
+ brightness-levels = <0 16 18 20 22 24 26 29 32 35 38 42 46 51 56 62 68 75 83 91 100>;
|
|
||||||
+ default-brightness-level = <15>;
|
|
||||||
+ enable-gpios = <&pio 3 23 GPIO_ACTIVE_HIGH>; /* PD23 */
|
|
||||||
+ power-supply = <&vdd_bl>;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ chosen {
|
|
||||||
+ stdout-path = "serial0:115200n8";
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ i2c-csi {
|
|
||||||
+ compatible = "i2c-gpio";
|
|
||||||
+ sda-gpios = <&pio 4 13 GPIO_ACTIVE_HIGH>; /* PE13 */
|
|
||||||
+ scl-gpios = <&pio 4 12 GPIO_ACTIVE_HIGH>; /* PE12 */
|
|
||||||
+ i2c-gpio,delay-us = <5>;
|
|
||||||
+ #address-cells = <1>;
|
|
||||||
+ #size-cells = <0>;
|
|
||||||
+
|
|
||||||
+ /* Rear camera */
|
|
||||||
+ ov5640: camera@3c {
|
|
||||||
+ compatible = "ovti,ov5640";
|
|
||||||
+ reg = <0x3c>;
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&csi_mclk_pin>;
|
|
||||||
+ clocks = <&ccu CLK_CSI_MCLK>;
|
|
||||||
+ clock-names = "xclk";
|
|
||||||
+
|
|
||||||
+ AVDD-supply = <®_dldo3>;
|
|
||||||
+ DOVDD-supply = <®_aldo1>;
|
|
||||||
+ DVDD-supply = <®_eldo3>;
|
|
||||||
+ reset-gpios = <&pio 4 14 GPIO_ACTIVE_LOW>; /* PE14 */
|
|
||||||
+ powerdown-gpios = <&pio 4 15 GPIO_ACTIVE_HIGH>; /* PE15 */
|
|
||||||
+
|
|
||||||
+ port {
|
|
||||||
+ ov5640_ep: endpoint {
|
|
||||||
+ remote-endpoint = <&csi_ep>;
|
|
||||||
+ bus-width = <8>;
|
|
||||||
+ hsync-active = <1>; /* Active high */
|
|
||||||
+ vsync-active = <0>; /* Active low */
|
|
||||||
+ data-active = <1>; /* Active high */
|
|
||||||
+ pclk-sample = <1>; /* Rising */
|
|
||||||
+ };
|
|
||||||
+ };
|
|
||||||
+ };
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ speaker_amp: audio-amplifier {
|
|
||||||
+ compatible = "simple-audio-amplifier";
|
|
||||||
+ enable-gpios = <&pio 7 7 GPIO_ACTIVE_HIGH>; /* PH7 */
|
|
||||||
+ sound-name-prefix = "Speaker Amp";
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ vdd_bl: regulator@0 {
|
|
||||||
+ compatible = "regulator-fixed";
|
|
||||||
+ regulator-name = "bl-3v3";
|
|
||||||
+ regulator-min-microvolt = <3300000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ gpio = <&pio 7 6 GPIO_ACTIVE_HIGH>; /* PH6 */
|
|
||||||
+ enable-active-high;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ wifi_pwrseq: wifi_pwrseq {
|
|
||||||
+ compatible = "mmc-pwrseq-simple";
|
|
||||||
+ reset-gpios = <&r_pio 0 2 GPIO_ACTIVE_LOW>; /* PL2 */
|
|
||||||
+ post-power-on-delay-ms = <200>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&codec {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&codec_analog {
|
|
||||||
+ hpvcc-supply = <®_eldo1>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&cpu0 {
|
|
||||||
+ cpu-supply = <®_dcdc2>;
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&cpu1 {
|
|
||||||
+ cpu-supply = <®_dcdc2>;
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&cpu2 {
|
|
||||||
+ cpu-supply = <®_dcdc2>;
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&cpu3 {
|
|
||||||
+ cpu-supply = <®_dcdc2>;
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&csi {
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ port {
|
|
||||||
+ #address-cells = <1>;
|
|
||||||
+ #size-cells = <0>;
|
|
||||||
+
|
|
||||||
+ csi_ep: endpoint {
|
|
||||||
+ remote-endpoint = <&ov5640_ep>;
|
|
||||||
+ bus-width = <8>;
|
|
||||||
+ hsync-active = <1>; /* Active high */
|
|
||||||
+ vsync-active = <0>; /* Active low */
|
|
||||||
+ data-active = <1>; /* Active high */
|
|
||||||
+ pclk-sample = <1>; /* Rising */
|
|
||||||
+ };
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&dai {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&de {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&dphy {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&dsi {
|
|
||||||
+ vcc-dsi-supply = <®_dldo1>;
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ panel@0 {
|
|
||||||
+ compatible = "feixin,k101-im2ba02";
|
|
||||||
+ reg = <0>;
|
|
||||||
+ avdd-supply = <®_dc1sw>;
|
|
||||||
+ dvdd-supply = <®_dc1sw>;
|
|
||||||
+ cvdd-supply = <®_ldo_io1>;
|
|
||||||
+ reset-gpios = <&pio 3 24 GPIO_ACTIVE_HIGH>; /* PD24 */
|
|
||||||
+ backlight = <&backlight>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&ehci0 {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&ehci1 {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&i2c0 {
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ touchscreen@5d {
|
|
||||||
+ compatible = "goodix,gt9271";
|
|
||||||
+ reg = <0x5d>;
|
|
||||||
+ interrupt-parent = <&pio>;
|
|
||||||
+ interrupts = <7 4 IRQ_TYPE_LEVEL_HIGH>; /* PH4 */
|
|
||||||
+ irq-gpios = <&pio 7 4 GPIO_ACTIVE_HIGH>; /* PH4 */
|
|
||||||
+ reset-gpios = <&pio 7 8 GPIO_ACTIVE_HIGH>; /* PH8 */
|
|
||||||
+ AVDD28-supply = <®_ldo_io1>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&i2c0_pins {
|
|
||||||
+ bias-pull-up;
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&i2c1 {
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ /* TODO: add Bochs BMA223 accelerometer here */
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&lradc {
|
|
||||||
+ vref-supply = <®_aldo3>;
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ button-200 {
|
|
||||||
+ label = "Volume Up";
|
|
||||||
+ linux,code = <KEY_VOLUMEUP>;
|
|
||||||
+ channel = <0>;
|
|
||||||
+ voltage = <200000>;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ button-400 {
|
|
||||||
+ label = "Volume Down";
|
|
||||||
+ linux,code = <KEY_VOLUMEDOWN>;
|
|
||||||
+ channel = <0>;
|
|
||||||
+ voltage = <400000>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&mixer1 {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&mmc0 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&mmc0_pins>;
|
|
||||||
+ vmmc-supply = <®_dcdc1>;
|
|
||||||
+ cd-gpios = <&pio 5 6 GPIO_ACTIVE_LOW>;
|
|
||||||
+ disable-wp;
|
|
||||||
+ bus-width = <4>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&mmc1 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&mmc1_pins>;
|
|
||||||
+ vmmc-supply = <®_dldo4>;
|
|
||||||
+ vqmmc-supply = <®_eldo1>;
|
|
||||||
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
||||||
+ bus-width = <4>;
|
|
||||||
+ non-removable;
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ rtl8723cs: wifi@1 {
|
|
||||||
+ reg = <1>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&mmc2 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&mmc2_pins>;
|
|
||||||
+ vmmc-supply = <®_dcdc1>;
|
|
||||||
+ vqmmc-supply = <®_dcdc1>;
|
|
||||||
+ bus-width = <8>;
|
|
||||||
+ non-removable;
|
|
||||||
+ cap-mmc-hw-reset;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&ohci0 {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&pwm {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&r_rsb {
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ axp803: pmic@3a3 {
|
|
||||||
+ compatible = "x-powers,axp803";
|
|
||||||
+ reg = <0x3a3>;
|
|
||||||
+ interrupt-parent = <&r_intc>;
|
|
||||||
+ interrupts = <0 IRQ_TYPE_LEVEL_LOW>;
|
|
||||||
+ x-powers,drive-vbus-en;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+#include "axp803.dtsi"
|
|
||||||
+
|
|
||||||
+&ac_power_supply {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&battery_power_supply {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_aldo1 {
|
|
||||||
+ regulator-min-microvolt = <2800000>;
|
|
||||||
+ regulator-max-microvolt = <2800000>;
|
|
||||||
+ regulator-name = "dovdd-csi";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_aldo2 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <1800000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-name = "vcc-pl";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_aldo3 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <2700000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-name = "vcc-pll-avcc";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_dc1sw {
|
|
||||||
+ regulator-name = "vcc-lcd";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_dcdc1 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <3300000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-name = "vcc-3v3";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_dcdc2 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <1000000>;
|
|
||||||
+ regulator-max-microvolt = <1300000>;
|
|
||||||
+ regulator-name = "vdd-cpux";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+/* DCDC3 is polyphased with DCDC2 */
|
|
||||||
+
|
|
||||||
+®_dcdc5 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <1200000>;
|
|
||||||
+ regulator-max-microvolt = <1200000>;
|
|
||||||
+ regulator-name = "vcc-dram";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_dcdc6 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <1100000>;
|
|
||||||
+ regulator-max-microvolt = <1100000>;
|
|
||||||
+ regulator-name = "vdd-sys";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_dldo1 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <3300000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-name = "vcc-hdmi-dsi-sensor";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_dldo3 {
|
|
||||||
+ regulator-min-microvolt = <2800000>;
|
|
||||||
+ regulator-max-microvolt = <2800000>;
|
|
||||||
+ regulator-name = "avdd-csi";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_dldo4 {
|
|
||||||
+ regulator-min-microvolt = <3300000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-name = "vcc-wifi";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_drivevbus {
|
|
||||||
+ regulator-name = "usb0-vbus";
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_eldo1 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <1800000>;
|
|
||||||
+ regulator-max-microvolt = <1800000>;
|
|
||||||
+ regulator-name = "cpvdd";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_eldo2 {
|
|
||||||
+ regulator-min-microvolt = <1800000>;
|
|
||||||
+ regulator-max-microvolt = <1800000>;
|
|
||||||
+ regulator-name = "vcca-1v8";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_eldo3 {
|
|
||||||
+ regulator-min-microvolt = <1800000>;
|
|
||||||
+ regulator-max-microvolt = <1800000>;
|
|
||||||
+ regulator-name = "dvdd-1v8-csi";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_fldo1 {
|
|
||||||
+ regulator-min-microvolt = <1200000>;
|
|
||||||
+ regulator-max-microvolt = <1200000>;
|
|
||||||
+ regulator-name = "vcc-1v2-hsic";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_fldo2 {
|
|
||||||
+ regulator-always-on;
|
|
||||||
+ regulator-min-microvolt = <1100000>;
|
|
||||||
+ regulator-max-microvolt = <1100000>;
|
|
||||||
+ regulator-name = "vdd-cpus";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_ldo_io0 {
|
|
||||||
+ regulator-min-microvolt = <3300000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-name = "vcc-usb";
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_ldo_io1 {
|
|
||||||
+ regulator-min-microvolt = <3300000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-enable-ramp-delay = <3500000>;
|
|
||||||
+ regulator-name = "vcc-touchscreen";
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+®_rtc_ldo {
|
|
||||||
+ regulator-name = "vcc-rtc";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&sound {
|
|
||||||
+ status = "okay";
|
|
||||||
+ simple-audio-card,aux-devs = <&codec_analog>, <&speaker_amp>;
|
|
||||||
+ simple-audio-card,widgets = "Microphone", "Internal Microphone Left",
|
|
||||||
+ "Microphone", "Internal Microphone Right",
|
|
||||||
+ "Headphone", "Headphone Jack",
|
|
||||||
+ "Speaker", "Internal Speaker";
|
|
||||||
+ simple-audio-card,routing =
|
|
||||||
+ "Left DAC", "AIF1 Slot 0 Left",
|
|
||||||
+ "Right DAC", "AIF1 Slot 0 Right",
|
|
||||||
+ "Speaker Amp INL", "LINEOUT",
|
|
||||||
+ "Speaker Amp INR", "LINEOUT",
|
|
||||||
+ "Internal Speaker", "Speaker Amp OUTL",
|
|
||||||
+ "Internal Speaker", "Speaker Amp OUTR",
|
|
||||||
+ "Headphone Jack", "HP",
|
|
||||||
+ "AIF1 Slot 0 Left ADC", "Left ADC",
|
|
||||||
+ "AIF1 Slot 0 Right ADC", "Right ADC",
|
|
||||||
+ "Internal Microphone Left", "MBIAS",
|
|
||||||
+ "MIC1", "Internal Microphone Left",
|
|
||||||
+ "Internal Microphone Right", "HBIAS",
|
|
||||||
+ "MIC2", "Internal Microphone Right";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&uart0 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&uart0_pb_pins>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&usb_otg {
|
|
||||||
+ dr_mode = "otg";
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&usb_power_supply {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&usbphy {
|
|
||||||
+ usb0_id_det-gpios = <&pio 7 9 GPIO_ACTIVE_HIGH>; /* PH9 */
|
|
||||||
+ usb0_vbus_power-supply = <&usb_power_supply>;
|
|
||||||
+ usb0_vbus-supply = <®_drivevbus>;
|
|
||||||
+ usb1_vbus-supply = <®_ldo_io0>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
||||||
From 6bf15552c2b6becb48ce7732120e0ddb2078cb1a Mon Sep 17 00:00:00 2001
|
From 6bf15552c2b6becb48ce7732120e0ddb2078cb1a Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
From: Peter Robinson <pbrobinson@gmail.com>
|
||||||
Date: Tue, 14 Apr 2020 09:53:07 +0100
|
Date: Tue, 14 Apr 2020 09:53:07 +0100
|
||||||
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -43,6 +43,9 @@ orangepi_win
|
|||||||
orangepi_zero_plus
|
orangepi_zero_plus
|
||||||
orangepi_zero_plus2
|
orangepi_zero_plus2
|
||||||
p212
|
p212
|
||||||
|
p2371-2180
|
||||||
|
p2771-0000-500
|
||||||
|
p3450-0000
|
||||||
pine64-lts
|
pine64-lts
|
||||||
pine64_plus
|
pine64_plus
|
||||||
pinebook
|
pinebook
|
||||||
@ -51,6 +54,7 @@ pinephone
|
|||||||
pinetab
|
pinetab
|
||||||
pine_h64
|
pine_h64
|
||||||
poplar
|
poplar
|
||||||
|
puma-rk3399
|
||||||
rock64-rk3328
|
rock64-rk3328
|
||||||
rock960-rk3399
|
rock960-rk3399
|
||||||
rock-pi-4-rk3399
|
rock-pi-4-rk3399
|
||||||
|
@ -56,6 +56,7 @@ inet9f_rev03
|
|||||||
inet_q972
|
inet_q972
|
||||||
Itead_Ibox_A20
|
Itead_Ibox_A20
|
||||||
jesurun_q5
|
jesurun_q5
|
||||||
|
jetson-tk1
|
||||||
kc1
|
kc1
|
||||||
Lamobo_R1
|
Lamobo_R1
|
||||||
libretech_all_h3_cc_h2_plus
|
libretech_all_h3_cc_h2_plus
|
||||||
@ -63,6 +64,7 @@ Linksprite_pcDuino
|
|||||||
Linksprite_pcDuino3
|
Linksprite_pcDuino3
|
||||||
Linksprite_pcDuino3_Nano
|
Linksprite_pcDuino3_Nano
|
||||||
liteboard
|
liteboard
|
||||||
|
marsboard
|
||||||
Marsboard_A10
|
Marsboard_A10
|
||||||
Mele_A1000
|
Mele_A1000
|
||||||
Mele_A1000G_quad
|
Mele_A1000G_quad
|
||||||
@ -99,6 +101,8 @@ orangepi_plus2e
|
|||||||
orangepi_r1
|
orangepi_r1
|
||||||
orangepi_zero
|
orangepi_zero
|
||||||
origen
|
origen
|
||||||
|
paz00
|
||||||
|
pinecube
|
||||||
polaroid_mid2809pxe04
|
polaroid_mid2809pxe04
|
||||||
pov_protab2_ips9
|
pov_protab2_ips9
|
||||||
q8_a13_tablet
|
q8_a13_tablet
|
||||||
@ -107,8 +111,10 @@ q8_a33_tablet_1024x600
|
|||||||
q8_a33_tablet_800x480
|
q8_a33_tablet_800x480
|
||||||
qemu_arm
|
qemu_arm
|
||||||
r7-tv-dongle
|
r7-tv-dongle
|
||||||
|
riotboard
|
||||||
rock
|
rock
|
||||||
rock-pi-n8-rk3288
|
rock-pi-n8-rk3288
|
||||||
|
rock2
|
||||||
rpi_2
|
rpi_2
|
||||||
rpi_3_32b
|
rpi_3_32b
|
||||||
rpi_4_32b
|
rpi_4_32b
|
||||||
@ -121,6 +127,9 @@ sunxi_Gemei_G9
|
|||||||
tbs_a711
|
tbs_a711
|
||||||
tinker-rk3288
|
tinker-rk3288
|
||||||
tinker-s-rk3288
|
tinker-s-rk3288
|
||||||
|
trimslice
|
||||||
|
udoo
|
||||||
|
udoo_neo
|
||||||
usbarmory
|
usbarmory
|
||||||
UTOO_P66
|
UTOO_P66
|
||||||
vexpress_ca15_tc2
|
vexpress_ca15_tc2
|
||||||
|
@ -1,104 +0,0 @@
|
|||||||
From 71f86c48580642a8d6a7d1049427bb72cb93b480 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
Date: Sun, 8 Nov 2020 19:57:50 +0000
|
|
||||||
Subject: [PATCH] rockchip: Move Bob specific bits to it's specific u-boot.dtsi
|
|
||||||
|
|
||||||
Move the bits that are device specific to the -u-boot.dtsi as the
|
|
||||||
bits may be different on other devices and hence breaks SPI on
|
|
||||||
those devices such as the Pinebook Pro.
|
|
||||||
|
|
||||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
Fixes: c4cea2bbf995 ("rockchip: Enable building a SPI ROM image on bob")
|
|
||||||
Cc: Simon Glass <sjg@chromium.org>
|
|
||||||
---
|
|
||||||
arch/arm/dts/rk3399-gru-u-boot.dtsi | 30 +++++++++++++++++++++++++++++
|
|
||||||
arch/arm/dts/rk3399-u-boot.dtsi | 25 ------------------------
|
|
||||||
2 files changed, 30 insertions(+), 25 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/arch/arm/dts/rk3399-gru-u-boot.dtsi b/arch/arm/dts/rk3399-gru-u-boot.dtsi
|
|
||||||
index 390ac2bb5a..5e95cacfea 100644
|
|
||||||
--- a/arch/arm/dts/rk3399-gru-u-boot.dtsi
|
|
||||||
+++ b/arch/arm/dts/rk3399-gru-u-boot.dtsi
|
|
||||||
@@ -5,6 +5,36 @@
|
|
||||||
|
|
||||||
#include "rk3399-u-boot.dtsi"
|
|
||||||
|
|
||||||
+/ {
|
|
||||||
+ aliases {
|
|
||||||
+ spi1 = &spi1;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+#ifdef CONFIG_ROCKCHIP_SPI_IMAGE
|
|
||||||
+&binman {
|
|
||||||
+ rom {
|
|
||||||
+ filename = "u-boot.rom";
|
|
||||||
+ size = <0x400000>;
|
|
||||||
+ pad-byte = <0xff>;
|
|
||||||
+
|
|
||||||
+ mkimage {
|
|
||||||
+ args = "-n rk3399 -T rkspi";
|
|
||||||
+ u-boot-spl {
|
|
||||||
+ };
|
|
||||||
+ };
|
|
||||||
+ u-boot-img {
|
|
||||||
+ offset = <0x40000>;
|
|
||||||
+ };
|
|
||||||
+ u-boot {
|
|
||||||
+ offset = <0x300000>;
|
|
||||||
+ };
|
|
||||||
+ fdtmap {
|
|
||||||
+ };
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
&spi_flash {
|
|
||||||
u-boot,dm-pre-reloc;
|
|
||||||
};
|
|
||||||
diff --git a/arch/arm/dts/rk3399-u-boot.dtsi b/arch/arm/dts/rk3399-u-boot.dtsi
|
|
||||||
index ecd230c720..26b0a34e64 100644
|
|
||||||
--- a/arch/arm/dts/rk3399-u-boot.dtsi
|
|
||||||
+++ b/arch/arm/dts/rk3399-u-boot.dtsi
|
|
||||||
@@ -11,7 +11,6 @@
|
|
||||||
mmc0 = &sdhci;
|
|
||||||
mmc1 = &sdmmc;
|
|
||||||
pci0 = &pcie0;
|
|
||||||
- spi1 = &spi1;
|
|
||||||
};
|
|
||||||
|
|
||||||
cic: syscon@ff620000 {
|
|
||||||
@@ -60,30 +59,6 @@
|
|
||||||
|
|
||||||
};
|
|
||||||
|
|
||||||
-#ifdef CONFIG_ROCKCHIP_SPI_IMAGE
|
|
||||||
-&binman {
|
|
||||||
- rom {
|
|
||||||
- filename = "u-boot.rom";
|
|
||||||
- size = <0x400000>;
|
|
||||||
- pad-byte = <0xff>;
|
|
||||||
-
|
|
||||||
- mkimage {
|
|
||||||
- args = "-n rk3399 -T rkspi";
|
|
||||||
- u-boot-spl {
|
|
||||||
- };
|
|
||||||
- };
|
|
||||||
- u-boot-img {
|
|
||||||
- offset = <0x40000>;
|
|
||||||
- };
|
|
||||||
- u-boot {
|
|
||||||
- offset = <0x300000>;
|
|
||||||
- };
|
|
||||||
- fdtmap {
|
|
||||||
- };
|
|
||||||
- };
|
|
||||||
-};
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
&cru {
|
|
||||||
u-boot,dm-pre-reloc;
|
|
||||||
};
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
@ -1,39 +0,0 @@
|
|||||||
From 12bc3e2c7c805f989629d1a546276491a7d28922 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
Date: Mon, 9 Nov 2020 23:01:19 +0000
|
|
||||||
Subject: [PATCH] rockchip: Pinebook Pro: Fix USB
|
|
||||||
|
|
||||||
Improve USB config so keyboard and USB-A ports work.
|
|
||||||
|
|
||||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
---
|
|
||||||
configs/pinebook-pro-rk3399_defconfig | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/configs/pinebook-pro-rk3399_defconfig b/configs/pinebook-pro-rk3399_defconfig
|
|
||||||
index 1ed54ad0ed..8fbd7280ac 100644
|
|
||||||
--- a/configs/pinebook-pro-rk3399_defconfig
|
|
||||||
+++ b/configs/pinebook-pro-rk3399_defconfig
|
|
||||||
@@ -55,6 +55,8 @@ CONFIG_SPI_FLASH_WINBOND=y
|
|
||||||
CONFIG_DM_ETH=y
|
|
||||||
CONFIG_NVME=y
|
|
||||||
CONFIG_PCI=y
|
|
||||||
+CONFIG_PHY_ROCKCHIP_INNO_USB2=y
|
|
||||||
+CONFIG_PHY_ROCKCHIP_TYPEC=y
|
|
||||||
CONFIG_DM_PMIC_FAN53555=y
|
|
||||||
CONFIG_PMIC_RK8XX=y
|
|
||||||
CONFIG_REGULATOR_PWM=y
|
|
||||||
@@ -76,8 +78,9 @@ CONFIG_USB_EHCI_GENERIC=y
|
|
||||||
CONFIG_USB_OHCI_HCD=y
|
|
||||||
CONFIG_USB_OHCI_GENERIC=y
|
|
||||||
CONFIG_USB_DWC3=y
|
|
||||||
-CONFIG_ROCKCHIP_USB2_PHY=y
|
|
||||||
+CONFIG_USB_DWC3_GENERIC=y
|
|
||||||
CONFIG_USB_KEYBOARD=y
|
|
||||||
+CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y
|
|
||||||
CONFIG_USB_HOST_ETHER=y
|
|
||||||
CONFIG_USB_ETHER_ASIX=y
|
|
||||||
CONFIG_USB_ETHER_RTL8152=y
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (u-boot-2021.01-rc2.tar.bz2) = ac21ed6ce160de377a8ea5750cd617f1c6d6e2b9508c8999fafb641e210e3bd030dcd26cea38259639c45ae0d0b9fda6d1007c547fdee002d8d946d6fb1952bb
|
SHA512 (u-boot-2021.01-rc3.tar.bz2) = 4c88bbdeb1e39e52bb069c4bf65c9829290a51da9a21de8e60d50b62c74ae98a35d22a235fdc0a86467aedc34f85dff5d63b874af247323d0d5bdcb2e82cd4a3
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
%global candidate rc2
|
%global candidate rc3
|
||||||
|
|
||||||
Name: uboot-tools
|
Name: uboot-tools
|
||||||
Version: 2021.01
|
Version: 2021.01
|
||||||
Release: 0.2%{?candidate:.%{candidate}}%{?dist}
|
Release: 0.3%{?candidate:.%{candidate}}%{?dist}
|
||||||
Summary: U-Boot utilities
|
Summary: U-Boot utilities
|
||||||
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
|
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
|
||||||
URL: http://www.denx.de/wiki/U-Boot
|
URL: http://www.denx.de/wiki/U-Boot
|
||||||
@ -23,22 +23,19 @@ Patch2: uefi-use-Fedora-specific-path-name.patch
|
|||||||
# Board fixes and enablement
|
# Board fixes and enablement
|
||||||
# RPi - uses RPI firmware device tree for HAT support
|
# RPi - uses RPI firmware device tree for HAT support
|
||||||
Patch4: rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
|
Patch4: rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
|
||||||
Patch5: rpi-Add-identifier-for-the-new-RPi400.patch
|
Patch5: Raspberry-Pi-400-Compute-Module-4-support.patch
|
||||||
# Tegra improvements
|
# Tegra improvements
|
||||||
Patch6: arm-tegra-define-fdtfile-option-for-distro-boot.patch
|
Patch6: arm-tegra-define-fdtfile-option-for-distro-boot.patch
|
||||||
Patch7: arm-add-BOOTENV_EFI_SET_FDTFILE_FALLBACK-for-tegra186-be.patch
|
Patch7: arm-add-BOOTENV_EFI_SET_FDTFILE_FALLBACK-for-tegra186-be.patch
|
||||||
# AllWinner improvements
|
# AllWinner improvements
|
||||||
Patch8: AllWinner-UpstreamSync.patch
|
|
||||||
Patch9: AllWinner-PinePhone.patch
|
|
||||||
Patch10: AllWinner-PineTab.patch
|
Patch10: AllWinner-PineTab.patch
|
||||||
Patch11: 0001-Fixes-for-AllWinner-ethernet-network-interfaces.patch
|
Patch11: 0001-Fixes-for-AllWinner-ethernet-network-interfaces.patch
|
||||||
|
Patch12: sunxi-add-PineCube-board.patch
|
||||||
# TI fixes
|
# TI fixes
|
||||||
Patch12: 0001-Fix-BeagleAI-detection.patch
|
Patch13: 0001-Fix-BeagleAI-detection.patch
|
||||||
# Rockchips improvements
|
# Rockchips improvements
|
||||||
Patch13: arm-rk3399-enable-rng-on-rock960-and-firefly3399.patch
|
#Patch14: arm-rk3399-enable-rng-on-rock960-and-firefly3399.patch
|
||||||
Patch14: rockchip-Move-Bob-specific-bits-to-it-s-specific-u-b.patch
|
|
||||||
Patch15: rk3399-Pinebook-pro-EDP-support.patch
|
Patch15: rk3399-Pinebook-pro-EDP-support.patch
|
||||||
Patch16: rockchip-Pinebook-Pro-Fix-USB.patch
|
|
||||||
|
|
||||||
BuildRequires: bc
|
BuildRequires: bc
|
||||||
BuildRequires: dtc
|
BuildRequires: dtc
|
||||||
@ -239,6 +236,11 @@ cp -p board/warp7/README builds/docs/README.warp7
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 15 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 2021.01-0.3.rc3
|
||||||
|
- Update to 2021.01 RC3
|
||||||
|
- Latest RPi-400/CM4 support patch
|
||||||
|
- Re-enable previously disabled device support
|
||||||
|
|
||||||
* Mon Dec 14 2020 Javier Martinez Canillas <javierm@redhat.com> - 2021.01-0.2.rc2
|
* Mon Dec 14 2020 Javier Martinez Canillas <javierm@redhat.com> - 2021.01-0.2.rc2
|
||||||
- Fix a "scan_dev_for_efi" not defined error
|
- Fix a "scan_dev_for_efi" not defined error
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user