Merge remote-tracking branch 'up/master' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2019-12-14 16:36:40 +02:00
commit c05c9a2db0
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
5 changed files with 199 additions and 74 deletions

View File

@ -12,8 +12,12 @@ ficus-rk3399
firefly-rk3399 firefly-rk3399
geekbox geekbox
hikey hikey
khadas-edge-captain-rk3399
khadas-edge-v-rk3399
khadas-edge-rk3399
khadas-vim khadas-vim
khadas-vim2 khadas-vim2
khadas-vim3
libretech-ac libretech-ac
libretech_all_h3_cc_h5 libretech_all_h3_cc_h5
libretech-cc libretech-cc

118
raspberry-pi-4-fixes.patch Normal file
View File

@ -0,0 +1,118 @@
From e19cfcc07ac5da8b3a04e21875ec542d994865d4 Mon Sep 17 00:00:00 2001
From: Matthias Brugger <mbrugger@suse.com>
Date: Thu, 5 Dec 2019 18:53:13 +0100
Subject: [PATCH 08/10] rpi: fix dram bank initialization
To update the dram bank information from device-tree we use
fdtdec_decode_ram_size() which expectes the the size-cells and
address-cells to be defined in the memory node. For normal system RAM
these values are defined in the root node. When the values differ from
the default values defined in the spec, we can end up with wrong RAM
bank information.
Switch to the "standard" way to update the RAM bank information to
avoid this.
Fixes: 9de5b89e4c ("rpi4: enable dram bank initialization")
Signed-off-by: Matthias Brugger <mbrugger@suse.com>
---
board/raspberrypi/rpi/rpi.c | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/board/raspberrypi/rpi/rpi.c b/board/raspberrypi/rpi/rpi.c
index 5f120ea9c2..e19610f40f 100644
--- a/board/raspberrypi/rpi/rpi.c
+++ b/board/raspberrypi/rpi/rpi.c
@@ -275,8 +275,13 @@ int dram_init(void)
#ifdef CONFIG_BCM2711
int dram_init_banksize(void)
{
- return fdtdec_decode_ram_size(gd->fdt_blob, NULL, 0, NULL,
- (phys_size_t *)&gd->ram_size, gd->bd);
+ int ret;
+
+ ret = fdtdec_setup_memory_banksize();
+ if (ret)
+ return ret;
+
+ return fdtdec_setup_mem_size_base();
}
#endif
#endif
--
2.24.1
From a63f81c242090682ea4907fa6475d8057208cb05 Mon Sep 17 00:00:00 2001
From: Matthias Brugger <mbrugger@suse.com>
Date: Thu, 5 Dec 2019 18:53:14 +0100
Subject: [PATCH 09/10] rpi: Enable DRAM bank initialization on arm64
Up to now we only update the DRAM banks when we are define
CONFIG_BCM2711. But our one binary approach uses a config that supports
BCM2837 and BCM2711. As a result we only see one gibibyte of RAM on
Raspberry Pi 4, even if it has more RAM.
Fix this by calling dram_init_banksize.
Fixes: 5694090670 ("ARM: defconfig: add unified config for RPi3 and RPi4")
Signed-off-by: Matthias Brugger <mbrugger@suse.com>
---
board/raspberrypi/rpi/rpi.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/board/raspberrypi/rpi/rpi.c b/board/raspberrypi/rpi/rpi.c
index e19610f40f..e367ba3092 100644
--- a/board/raspberrypi/rpi/rpi.c
+++ b/board/raspberrypi/rpi/rpi.c
@@ -272,7 +272,6 @@ int dram_init(void)
}
#ifdef CONFIG_OF_BOARD
-#ifdef CONFIG_BCM2711
int dram_init_banksize(void)
{
int ret;
@@ -284,7 +283,6 @@ int dram_init_banksize(void)
return fdtdec_setup_mem_size_base();
}
#endif
-#endif
static void set_fdtfile(void)
{
--
2.24.1
From e5167465a1740f0cac05be44f3e2a4e334eb527a Mon Sep 17 00:00:00 2001
From: Matthias Brugger <mbrugger@suse.com>
Date: Thu, 5 Dec 2019 18:53:15 +0100
Subject: [PATCH 10/10] ARM: defconfig: Fix 32bit config for RPi4
The rpi_4_32b_defconfig states that only one DRAM bank is present. This
leads to a wrong configuration of the available DRAM. Fix this by
setting the DRAM bank config accordingly.
Fixes: 193279d784 ("RPI: Add defconfigs for rpi4 (32/64)")
Signed-off-by: Matthias Brugger <mbrugger@suse.com>
---
configs/rpi_4_32b_defconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configs/rpi_4_32b_defconfig b/configs/rpi_4_32b_defconfig
index e7d8f29060..80cf930032 100644
--- a/configs/rpi_4_32b_defconfig
+++ b/configs/rpi_4_32b_defconfig
@@ -4,7 +4,7 @@ CONFIG_SYS_TEXT_BASE=0x00008000
CONFIG_TARGET_RPI_4_32B=y
CONFIG_SYS_MALLOC_F_LEN=0x2000
CONFIG_ENV_SIZE=0x4000
-CONFIG_NR_DRAM_BANKS=1
+CONFIG_NR_DRAM_BANKS=2
CONFIG_DISTRO_DEFAULTS=y
CONFIG_OF_BOARD_SETUP=y
# CONFIG_ARCH_FIXUP_FDT_MEMORY is not set
--
2.24.1

View File

@ -1,35 +1,24 @@
From 097ce774b6739aa6a52e4d79e2920e3ef5af41d3 Mon Sep 17 00:00:00 2001 From 961918a6fcbab383c92135f5cad5ea758bdaef79 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com> From: Peter Robinson <pbrobinson@gmail.com>
Date: Thu, 31 Oct 2019 09:19:23 +0000 Date: Wed, 4 Dec 2019 23:27:10 +0000
Subject: [PATCH] tools: fix version.h Subject: [PATCH] tools fix
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
--- ---
Makefile | 6 +++--- Makefile | 1 +
1 file changed, 3 insertions(+), 3 deletions(-) 1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index 58a5721b3d..7b40069d9f 100644 index 556cebdfc4..4bcf4d677f 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -1848,14 +1848,14 @@ checkarmreloc: u-boot @@ -1894,6 +1894,7 @@ checkarmreloc: u-boot
false; \
fi fi
-tools/version.h: include/version.h tools/version.h: include/version.h
+version.h: include/version.h + $(Q)mkdir -p $(dir $@)
$(call if_changed,copy) $(call if_changed,copy)
-envtools: scripts_basic $(version_h) $(timestamp_h) tools/version.h envtools: scripts_basic $(version_h) $(timestamp_h) tools/version.h
+envtools: scripts_basic $(version_h) $(timestamp_h) version.h
$(Q)$(MAKE) $(build)=tools/env
tools-only: export TOOLS_ONLY=y
-tools-only: scripts_basic $(version_h) $(timestamp_h) tools/version.h
+tools-only: scripts_basic $(version_h) $(timestamp_h) version.h
$(Q)$(MAKE) $(build)=tools
tools-all: export HOST_TOOLS_ALL=y
-- --
2.23.0 2.23.0

View File

@ -2,7 +2,7 @@
Name: uboot-tools Name: uboot-tools
Version: 2020.01 Version: 2020.01
Release: 0.6%{?candidate:.%{candidate}}.1.riscv64%{?dist} Release: 0.8%{?candidate:.%{candidate}}.0.riscv64%{?dist}
Summary: U-Boot utilities Summary: U-Boot utilities
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+ License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
URL: http://www.denx.de/wiki/U-Boot URL: http://www.denx.de/wiki/U-Boot
@ -31,6 +31,7 @@ Patch9: tools-fix-version.h.patch
Patch10: zynqmp-Add-support-for-u-boot.itb-generation-with-ATF.patch Patch10: zynqmp-Add-support-for-u-boot.itb-generation-with-ATF.patch
Patch11: zynqmp-Do-not-assing-MIO34-that-early-on-zcu100.patch Patch11: zynqmp-Do-not-assing-MIO34-that-early-on-zcu100.patch
Patch12: bcm283x-dts-Rename-U-Boot-file.patch Patch12: bcm283x-dts-Rename-U-Boot-file.patch
Patch13: raspberry-pi-4-fixes.patch
# PXE depends on fdt_addr (mandatory) # PXE depends on fdt_addr (mandatory)
# fdt_addr is an address to DTB in HW (e.g. ROM) # fdt_addr is an address to DTB in HW (e.g. ROM)
@ -298,7 +299,7 @@ cp -p board/warp/README builds/docs/README.warp
cp -p board/warp7/README builds/docs/README.warp7 cp -p board/warp7/README builds/docs/README.warp7
%files %files
%doc README doc/imx doc/README.kwbimage doc/README.distro doc/README.gpt %doc README doc/README.kwbimage doc/README.distro doc/README.gpt
%doc doc/README.odroid doc/README.rockchip doc/uefi doc/uImage.FIT doc/arch/arm64.rst %doc doc/README.odroid doc/README.rockchip doc/uefi doc/uImage.FIT doc/arch/arm64.rst
%doc doc/README.chromium builds/docs/* %doc doc/README.chromium builds/docs/*
%{_bindir}/* %{_bindir}/*
@ -323,14 +324,19 @@ cp -p board/warp7/README builds/docs/README.warp7
%endif %endif
%changelog %changelog
* Thu Dec 5 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2020.01-0.6-rc4.1.riscv64 * Sat Dec 14 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2020.01-0.8-rc4.0.riscv64
- Match CONFIG_NR_CPUS to Linux configuration (32)
* Thu Dec 5 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2020.01-0.6-rc4.0.riscv64
- Add support for RISC-V (riscv64) - Add support for RISC-V (riscv64)
- Define filesize and kernel_comp_addr_r for QEMU virt and SiFive FU540 boards - Define filesize and kernel_comp_addr_r for QEMU virt and SiFive FU540 boards
to support Image.gz with booti to support Image.gz with booti
- Add 'addappend' label to PXE/EXTLINUX configuration - Add 'addappend' label to PXE/EXTLINUX configuration
- Match CONFIG_NR_CPUS to Linux configuration (32)
* Thu Dec 12 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2020.01-0.8-rc4
- Fixes for Raspberry Pi
* Thu Dec 5 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2020.01-0.7-rc4
- Enable the Khadas Edge and VIM series of devices
- Minor other fixes
* Tue Dec 3 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2020.01-0.6-rc4 * Tue Dec 3 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2020.01-0.6-rc4
- Fixes for AllWinner, Raspberry Pi, Rockchip, Xilinx ZynqMP - Fixes for AllWinner, Raspberry Pi, Rockchip, Xilinx ZynqMP

View File

@ -1,9 +1,9 @@
From patchwork Tue Dec 3 13:34:58 2019 From patchwork Thu Dec 5 08:46:57 2019
Content-Type: text/plain; charset="utf-8" Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0 MIME-Version: 1.0
Content-Transfer-Encoding: 7bit Content-Transfer-Encoding: 7bit
X-Patchwork-Submitter: Michal Simek <michal.simek@xilinx.com> X-Patchwork-Submitter: Michal Simek <michal.simek@xilinx.com>
X-Patchwork-Id: 1203703 X-Patchwork-Id: 1204536
Return-Path: <u-boot-bounces@lists.denx.de> Return-Path: <u-boot-bounces@lists.denx.de>
X-Original-To: incoming@patchwork.ozlabs.org X-Original-To: incoming@patchwork.ozlabs.org
Delivered-To: patchwork-incoming@bilbo.ozlabs.org Delivered-To: patchwork-incoming@bilbo.ozlabs.org
@ -18,24 +18,24 @@ Authentication-Results: ozlabs.org;
dkim=fail reason="signature verification failed" (2048-bit key; dkim=fail reason="signature verification failed" (2048-bit key;
unprotected) header.d=monstr-eu.20150623.gappssmtp.com unprotected) header.d=monstr-eu.20150623.gappssmtp.com
header.i=@monstr-eu.20150623.gappssmtp.com header.i=@monstr-eu.20150623.gappssmtp.com
header.b="jRbgIEeD"; dkim-atps=neutral header.b="F7yFmrcr"; dkim-atps=neutral
Received: from phobos.denx.de (phobos.denx.de [85.214.62.61]) Received: from phobos.denx.de (phobos.denx.de [85.214.62.61])
(using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits)
key-exchange X25519 server-signature RSA-PSS (4096 bits)) key-exchange X25519 server-signature RSA-PSS (4096 bits))
(No client certificate requested) (No client certificate requested)
by ozlabs.org (Postfix) with ESMTPS id 47S3BR4jKtz9sR7 by ozlabs.org (Postfix) with ESMTPS id 47T8mj1rxFz9sPT
for <incoming@patchwork.ozlabs.org>; for <incoming@patchwork.ozlabs.org>;
Wed, 4 Dec 2019 00:44:47 +1100 (AEDT) Thu, 5 Dec 2019 19:59:49 +1100 (AEDT)
Received: by phobos.denx.de (Postfix, from userid 109) Received: by phobos.denx.de (Postfix, from userid 109)
id CC7BF81624; Tue, 3 Dec 2019 14:44:44 +0100 (CET) id DC15F81730; Thu, 5 Dec 2019 09:59:15 +0100 (CET)
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on mail.denx.de X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on mail.denx.de
X-Spam-Level: X-Spam-Level:
X-Spam-Status: No, score=-0.9 required=5.0 tests=DKIM_INVALID,DKIM_SIGNED, X-Spam-Status: No, score=-0.8 required=5.0 tests=DKIM_INVALID,DKIM_SIGNED,
MAILING_LIST_MULTI,RCVD_IN_MSPIKE_H2,SPF_HELO_NONE,SPF_PASS, MAILING_LIST_MULTI,RCVD_IN_MSPIKE_H2,SPF_HELO_NONE,SPF_PASS,
URIBL_BLOCKED autolearn=unavailable autolearn_force=no version=3.4.2 URIBL_BLOCKED autolearn=unavailable autolearn_force=no version=3.4.2
Received: from phobos.denx.de (localhost [IPv6:::1]) Received: from phobos.denx.de (localhost [IPv6:::1])
by phobos.denx.de (Postfix) with ESMTP id B50BD80901; by phobos.denx.de (Postfix) with ESMTP id AD3C281702;
Tue, 3 Dec 2019 14:44:12 +0100 (CET) Thu, 5 Dec 2019 09:47:37 +0100 (CET)
Authentication-Results: mail.denx.de; Authentication-Results: mail.denx.de;
dmarc=none (p=none dis=none) header.from=xilinx.com dmarc=none (p=none dis=none) header.from=xilinx.com
Authentication-Results: mail.denx.de; Authentication-Results: mail.denx.de;
@ -44,59 +44,60 @@ Authentication-Results: mail.denx.de;
dkim=fail reason="signature verification failed" (2048-bit key; dkim=fail reason="signature verification failed" (2048-bit key;
unprotected) header.d=monstr-eu.20150623.gappssmtp.com unprotected) header.d=monstr-eu.20150623.gappssmtp.com
header.i=@monstr-eu.20150623.gappssmtp.com header.i=@monstr-eu.20150623.gappssmtp.com
header.b="jRbgIEeD"; dkim-atps=neutral header.b="F7yFmrcr"; dkim-atps=neutral
Received: by phobos.denx.de (Postfix, from userid 109) Received: by phobos.denx.de (Postfix, from userid 109)
id C809980901; Tue, 3 Dec 2019 14:44:09 +0100 (CET) id EFEE0816D6; Thu, 5 Dec 2019 09:47:35 +0100 (CET)
Received: from mail-wr1-f68.google.com (mail-wr1-f68.google.com Received: from mail-wm1-f68.google.com (mail-wm1-f68.google.com
[209.85.221.68]) [209.85.128.68])
(using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits)) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits))
(No client certificate requested) (No client certificate requested)
by phobos.denx.de (Postfix) with ESMTPS id 32C4081828 by phobos.denx.de (Postfix) with ESMTPS id 13F3481702
for <u-boot@lists.denx.de>; Tue, 3 Dec 2019 14:35:05 +0100 (CET) for <u-boot@lists.denx.de>; Thu, 5 Dec 2019 09:47:05 +0100 (CET)
Authentication-Results: mail.denx.de; Authentication-Results: mail.denx.de;
dmarc=none (p=none dis=none) header.from=xilinx.com dmarc=none (p=none dis=none) header.from=xilinx.com
Authentication-Results: mail.denx.de; spf=none smtp.mailfrom=monstr@monstr.eu Authentication-Results: mail.denx.de; spf=none smtp.mailfrom=monstr@monstr.eu
Received: by mail-wr1-f68.google.com with SMTP id c14so3678946wrn.7 Received: by mail-wm1-f68.google.com with SMTP id p9so2672948wmc.2
for <u-boot@lists.denx.de>; Tue, 03 Dec 2019 05:35:05 -0800 (PST) for <u-boot@lists.denx.de>; Thu, 05 Dec 2019 00:47:05 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
d=monstr-eu.20150623.gappssmtp.com; s=20150623; d=monstr-eu.20150623.gappssmtp.com; s=20150623;
h=sender:from:to:cc:subject:date:message-id:mime-version h=sender:from:to:cc:subject:date:message-id:mime-version
:content-transfer-encoding; :content-transfer-encoding;
bh=Cm6gQWLkk/+5jek3dvRRAOkfCxAi+n+YRN+ZTQR2FHo=; bh=zKC9njDJvxTe218gXlGDt/iSWcQwlzyEn/MHFrB1GUk=;
b=jRbgIEeDUORknOe9qVPm4LptQigs2tytbss1dEwuK+OXROAETXd9oUKQ4lUG+1iOvX b=F7yFmrcrJYGseyeuyhzqQujaDM8FvSqw3O1Pfmlh+SK6+tZ7BLQ6+XIDpi5DQAIzHs
Tid7F+uJZ3urEn2pwCtU89SWYZAYA5XdKZgrQfk6Fs8jgoojVbHdWLCdLFDi8N6WE0TB 9Oe0co+RlaN+ypuEKw69o+zmaAHwbQoupL2LBoVJkAcVDseWpjatJtapzpyfUVqhfUaw
TefM3xfA7QwJeV9QQEJS+IqDNItUcrFBKzw09ABBVRqXsUHB2luZuaw1w72PXdcCP65o XRFXuVzSyRx64eELCzcR7Hl5ioK9Q7Y/tjvV07IHac4Uc8N0N/LS66Rj/49Reo4DGIhT
TWHYXVjIo5BGAn4XTNDuK9LyLaSVCld5zRHZvAYfDDGReHAtXGfkpcIohgmicVPjoDZd ThR6PDhriY0ANIDa8KnxQpQBiMuSuC4lTz3BuDMM/7LbS4r7Yy89EC+4wwXE4ZzXYAsO
qpUbc+6jK7aFnXNzxxJ1eqpjvnmX+7md9aS+e96pdPJ+Q3yRKgeSXcLbiIYBhBPEuu7S Kykj/rvg7d+BW8O1g3bxbDQVy/5IVDqslArlUH6xZpNOKDxwfLAvkAIvQiV/YJlNC1hQ
nuDg== f+OQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
d=1e100.net; s=20161025; d=1e100.net; s=20161025;
h=x-gm-message-state:sender:from:to:cc:subject:date:message-id h=x-gm-message-state:sender:from:to:cc:subject:date:message-id
:mime-version:content-transfer-encoding; :mime-version:content-transfer-encoding;
bh=Cm6gQWLkk/+5jek3dvRRAOkfCxAi+n+YRN+ZTQR2FHo=; bh=zKC9njDJvxTe218gXlGDt/iSWcQwlzyEn/MHFrB1GUk=;
b=XXEYwNGUqeSbWgn8YgWbka943yZCnj3ZkdNK846QU3Ft8AplFDniryxOkYlyLB91kY b=W2HsrghOni524RBbGxTnERtM2TNSUjmMhNi98cPFIy39d+LzzF1vxLBvF16jtovKsF
+Mn5z0e4xWL1MEaZT+2EQh53CApzWORoYeYryGsaql+hDD5zlQdm/0UkJSoLZ99slhrS DVYBg8lVrIEeaD1/XjcNmN7mk4LdWuwBnhUpAEVSQ3ccrxqMGSAud4vaduMo2czlBNWq
FNcNW40dU4iLXvCx7f8+/YDcF+7sYS4X1zxVxef0Sh1qPyB6ykXzbHgspO+uyBxRCZOJ m85KtYJctifHGMThcX9fwwr3+VmZIZ46ZUyXVuGSEqr7lZK/Nrnn7dH+v5hfYR60KhtI
2Xa08s7ry6p0N8mwBsUwRxaCc23wAa4L8HhdenIAw9wY7nnkhO7pW+byLeQ+NCJ4UfSH 1yxf6vkuoC+Z89WfQGiM2JMCnlmVy7ety6+s6b1PYRyf1FQbt4MmZ4ywRAfSuAtY4NUD
7pkxVk21TXyy0TC/J4TdNKHS8Gc6/8i2ajCsvCoMZ1mqt/5ZVqLUWZMfhj6Jurh42gPq XmDp+8lDrpa08LjlJxBbKqeKS+Eeh2pKDkOwInuxWiLDOgZ7fAT3LG5Uq+1GDGbNfKs9
dtgQ== xtlA==
X-Gm-Message-State: APjAAAU6J4Y0f3lLB9Z6GsZEAlImhG85wi6UhlX3hg1mTxyh6DyjAcvR X-Gm-Message-State: APjAAAUFPoTdro6+fDkKW4xky4+l2r/NtdDEuEaU72qNICk1Wlu+706B
pI0Js+5A+34PRuDW/kk+TVvWWBu1Z04p1w== tYlmosjzcX01d6VDfvz1eDIGZy20ca8=
X-Google-Smtp-Source: APXvYqxP0G+EP2youCblhWcjCu3FQ03Ed7G6Tlo0+mBMiEFAJvA1rgNQFC5gVk3s6GNdnRX3YIX1kw== X-Google-Smtp-Source: APXvYqzdmCVgU6CmN6exvPPKe9MZLPRPrinxyPtHvAnw7yyB3wd7uJyGYyFkZXVKepilUtZDhUtjHg==
X-Received: by 2002:adf:fe12:: with SMTP id n18mr5128119wrr.158.1575380104990; X-Received: by 2002:a7b:cc0c:: with SMTP id f12mr3835348wmh.5.1575535624294;
Tue, 03 Dec 2019 05:35:04 -0800 (PST) Thu, 05 Dec 2019 00:47:04 -0800 (PST)
Received: from localhost (nat-35.starnet.cz. [178.255.168.35]) Received: from localhost (nat-35.starnet.cz. [178.255.168.35])
by smtp.gmail.com with ESMTPSA id by smtp.gmail.com with ESMTPSA id
72sm3710284wrl.73.2019.12.03.05.35.03 a7sm11805025wrr.50.2019.12.05.00.47.03
(version=TLS1_2 cipher=ECDHE-RSA-CHACHA20-POLY1305 bits=256/256); (version=TLS1_2 cipher=ECDHE-RSA-CHACHA20-POLY1305 bits=256/256);
Tue, 03 Dec 2019 05:35:04 -0800 (PST) Thu, 05 Dec 2019 00:47:03 -0800 (PST)
From: Michal Simek <michal.simek@xilinx.com> From: Michal Simek <michal.simek@xilinx.com>
To: u-boot@lists.denx.de, To: u-boot@lists.denx.de,
git@xilinx.com, git@xilinx.com,
pbrobinson@gmail.com pbrobinson@gmail.com
Subject: [PATCH] arm64: zynqmp: Add support for u-boot.itb generation with ATF. Subject: [PATCH v2] arm64: zynqmp: Add support for u-boot.itb generation with
Date: Tue, 3 Dec 2019 14:34:58 +0100 ATF
Message-Id: <5568e78d8e06c2ce6a86c88ee42509a0c80fc4ef.1575380094.git.michal.simek@xilinx.com> Date: Thu, 5 Dec 2019 09:46:57 +0100
Message-Id: <311b20ae349e6a93714c227df5907667d1cb9463.1575535613.git.michal.simek@xilinx.com>
X-Mailer: git-send-email 2.24.0 X-Mailer: git-send-email 2.24.0
MIME-Version: 1.0 MIME-Version: 1.0
X-BeenThere: u-boot@lists.denx.de X-BeenThere: u-boot@lists.denx.de
@ -110,8 +111,7 @@ List-Post: <mailto:u-boot@lists.denx.de>
List-Help: <mailto:u-boot-request@lists.denx.de?subject=help> List-Help: <mailto:u-boot-request@lists.denx.de?subject=help>
List-Subscribe: <https://lists.denx.de/listinfo/u-boot>, List-Subscribe: <https://lists.denx.de/listinfo/u-boot>,
<mailto:u-boot-request@lists.denx.de?subject=subscribe> <mailto:u-boot-request@lists.denx.de?subject=subscribe>
Cc: Marek Vasut <marex@denx.de>, Stefan Roese <sr@denx.de>, Cc: Marek Vasut <marex@denx.de>, Stefan Roese <sr@denx.de>
Chris Packham <judge.packham@gmail.com>
Errors-To: u-boot-bounces@lists.denx.de Errors-To: u-boot-bounces@lists.denx.de
Sender: "U-Boot" <u-boot-bounces@lists.denx.de> Sender: "U-Boot" <u-boot-bounces@lists.denx.de>
X-Virus-Scanned: clamav-milter 0.101.4 at mail.denx.de X-Virus-Scanned: clamav-milter 0.101.4 at mail.denx.de
@ -124,9 +124,17 @@ this gap.
Tested on zcu102, zcu104 and zcu100/Ultra96. Tested on zcu102, zcu104 and zcu100/Ultra96.
zcu100/Ultra96 v2.2 ATF build by:
make DEBUG=0 ZYNQMP_CONSOLE=cadence1 RESET_TO_BL31=1 PLAT=zynqmp bl31
Signed-off-by: Michal Simek <michal.simek@xilinx.com> Signed-off-by: Michal Simek <michal.simek@xilinx.com>
--- ---
Changes in v2:
- Exchange u-boot/atf in config section
- Use default ATF baseaddr from mainline
- Update commit message
Kconfig | 3 +- Kconfig | 3 +-
arch/arm/mach-zynqmp/mkimage_fit_atf.sh | 99 +++++++++++++++++++++++++ arch/arm/mach-zynqmp/mkimage_fit_atf.sh | 99 +++++++++++++++++++++++++
include/configs/xilinx_zynqmp.h | 6 +- include/configs/xilinx_zynqmp.h | 6 +-
@ -156,7 +164,7 @@ index e22417ec4471..7efafffec0a4 100644
Specifies a (platform specific) script file to generate the FIT Specifies a (platform specific) script file to generate the FIT
diff --git a/arch/arm/mach-zynqmp/mkimage_fit_atf.sh b/arch/arm/mach-zynqmp/mkimage_fit_atf.sh diff --git a/arch/arm/mach-zynqmp/mkimage_fit_atf.sh b/arch/arm/mach-zynqmp/mkimage_fit_atf.sh
new file mode 100755 new file mode 100755
index 000000000000..1a4f396d1c3a index 000000000000..c50aba45ca5c
--- /dev/null --- /dev/null
+++ b/arch/arm/mach-zynqmp/mkimage_fit_atf.sh +++ b/arch/arm/mach-zynqmp/mkimage_fit_atf.sh
@@ -0,0 +1,99 @@ @@ -0,0 +1,99 @@
@ -170,7 +178,7 @@ index 000000000000..1a4f396d1c3a
+ +
+BL33="u-boot-nodtb.bin" +BL33="u-boot-nodtb.bin"
+[ -z "$BL31" ] && BL31="bl31.bin" +[ -z "$BL31" ] && BL31="bl31.bin"
+[ -z "$ATF_LOAD_ADDR" ] && ATF_LOAD_ADDR="0xfffe0000" +[ -z "$ATF_LOAD_ADDR" ] && ATF_LOAD_ADDR="0xfffea000"
+[ -z "$BL33_LOAD_ADDR" ] && BL33_LOAD_ADDR="0x8000000" +[ -z "$BL33_LOAD_ADDR" ] && BL33_LOAD_ADDR="0x8000000"
+ +
+if [ ! -f $BL31 ]; then +if [ ! -f $BL31 ]; then
@ -247,8 +255,8 @@ index 000000000000..1a4f396d1c3a
+cat << __CONF_SECTION1_EOF +cat << __CONF_SECTION1_EOF
+ config_$cnt { + config_$cnt {
+ description = "$(basename $dtname .dtb)"; + description = "$(basename $dtname .dtb)";
+ firmware = "uboot"; + firmware = "atf";
+ loadables = "atf"; + loadables = "uboot";
+ fdt = "fdt_$cnt"; + fdt = "fdt_$cnt";
+ }; + };
+__CONF_SECTION1_EOF +__CONF_SECTION1_EOF