Update genet NIC driver

This commit is contained in:
Peter Robinson 2020-02-02 11:19:15 +00:00
parent fbb777748c
commit b16faa89e5
2 changed files with 71 additions and 58 deletions

View File

@ -1,9 +1,10 @@
From patchwork Fri Jan 17 01:20:45 2020
From patchwork Mon Jan 27 01:14:42 2020
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
X-Patchwork-Submitter: Andre Przywara <andre.przywara@arm.com>
X-Patchwork-Id: 1224574
X-Patchwork-Id: 1229487
X-Patchwork-Delegate: matthias.bgg@gmail.com
Return-Path: <u-boot-bounces@lists.denx.de>
X-Original-To: incoming@patchwork.ozlabs.org
Delivered-To: patchwork-incoming@bilbo.ozlabs.org
@ -18,45 +19,45 @@ Received: from phobos.denx.de (phobos.denx.de [85.214.62.61])
(using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits)
key-exchange X25519 server-signature RSA-PSS (4096 bits)
server-digest SHA256) (No client certificate requested)
by ozlabs.org (Postfix) with ESMTPS id 47zNYx20D9z9s1x
by ozlabs.org (Postfix) with ESMTPS id 485WyY3RgHz9sNx
for <incoming@patchwork.ozlabs.org>;
Fri, 17 Jan 2020 12:21:21 +1100 (AEDT)
Mon, 27 Jan 2020 12:15:33 +1100 (AEDT)
Received: from h2850616.stratoserver.net (localhost [IPv6:::1])
by phobos.denx.de (Postfix) with ESMTP id 06756819DE;
Fri, 17 Jan 2020 02:21:12 +0100 (CET)
by phobos.denx.de (Postfix) with ESMTP id 032668149B;
Mon, 27 Jan 2020 02:15:24 +0100 (CET)
Authentication-Results: phobos.denx.de;
dmarc=none (p=none dis=none) header.from=arm.com
Authentication-Results: phobos.denx.de;
spf=pass smtp.mailfrom=u-boot-bounces@lists.denx.de
Received: by phobos.denx.de (Postfix, from userid 109)
id B04A3819F3; Fri, 17 Jan 2020 02:21:09 +0100 (CET)
id EEE77814D8; Mon, 27 Jan 2020 02:15:19 +0100 (CET)
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on phobos.denx.de
X-Spam-Level:
X-Spam-Status: No, score=0.0 required=5.0 tests=SPF_HELO_NONE, URIBL_BLOCKED
autolearn=ham autolearn_force=no version=3.4.2
Received: from foss.arm.com (foss.arm.com [217.140.110.172])
by phobos.denx.de (Postfix) with ESMTP id C7E3E819C4
for <u-boot@lists.denx.de>; Fri, 17 Jan 2020 02:21:04 +0100 (CET)
by phobos.denx.de (Postfix) with ESMTP id 6BB718050D
for <u-boot@lists.denx.de>; Mon, 27 Jan 2020 02:15:13 +0100 (CET)
Authentication-Results: phobos.denx.de;
dmarc=none (p=none dis=none) header.from=arm.com
Authentication-Results: phobos.denx.de;
spf=pass smtp.mailfrom=andre.przywara@arm.com
Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14])
by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id AC38D11FB;
Thu, 16 Jan 2020 17:21:03 -0800 (PST)
by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 2859A31B;
Sun, 26 Jan 2020 17:15:12 -0800 (PST)
Received: from localhost.localdomain (unknown [172.31.20.19])
by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id
28AF53F534; Thu, 16 Jan 2020 17:21:02 -0800 (PST)
8F3D83F52E; Sun, 26 Jan 2020 17:15:09 -0800 (PST)
From: Andre Przywara <andre.przywara@arm.com>
To: Joe Hershberger <joe.hershberger@ni.com>,
Matthias Brugger <mbrugger@suse.com>
Subject: [PATCH v2 1/3] net: Add support for Broadcom GENETv5 Ethernet
Subject: [PATCH v3 1/3] net: Add support for Broadcom GENETv5 Ethernet
controller
Date: Fri, 17 Jan 2020 01:20:45 +0000
Message-Id: <20200117012047.31096-2-andre.przywara@arm.com>
Date: Mon, 27 Jan 2020 01:14:42 +0000
Message-Id: <20200127011444.8114-2-andre.przywara@arm.com>
X-Mailer: git-send-email 2.14.1
In-Reply-To: <20200117012047.31096-1-andre.przywara@arm.com>
References: <20200117012047.31096-1-andre.przywara@arm.com>
In-Reply-To: <20200127011444.8114-1-andre.przywara@arm.com>
References: <20200127011444.8114-1-andre.przywara@arm.com>
X-BeenThere: u-boot@lists.denx.de
X-Mailman-Version: 2.1.26
Precedence: list
@ -91,8 +92,8 @@ Signed-off-by: Andre Przywara <andre.przywara@arm.com>
---
drivers/net/Kconfig | 7 +
drivers/net/Makefile | 1 +
drivers/net/bcmgenet.c | 722 +++++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 730 insertions(+)
drivers/net/bcmgenet.c | 729 +++++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 737 insertions(+)
create mode 100644 drivers/net/bcmgenet.c
diff --git a/drivers/net/Kconfig b/drivers/net/Kconfig
@ -127,10 +128,10 @@ index 30991834ec..6e0a68834d 100644
obj-$(CONFIG_BCM_SF2_ETH) += bcm-sf2-eth.o
diff --git a/drivers/net/bcmgenet.c b/drivers/net/bcmgenet.c
new file mode 100644
index 0000000000..4f8f190071
index 0000000000..8f4848aec6
--- /dev/null
+++ b/drivers/net/bcmgenet.c
@@ -0,0 +1,722 @@
@@ -0,0 +1,729 @@
+// SPDX-License-Identifier: GPL-2.0+
+/*
+ * Copyright (C) 2019 Amit Singh Tomar <amittomer25@gmail.com>
@ -772,6 +773,13 @@ index 0000000000..4f8f190071
+ if (ret)
+ return ret;
+
+ writel(0, priv->mac_reg + SYS_RBUF_FLUSH_CTRL);
+ udelay(10);
+ /* disable MAC while updating its registers */
+ writel(0, priv->mac_reg + UMAC_CMD);
+ /* issue soft reset with (rg)mii loopback to ensure a stable rxclk */
+ writel(CMD_SW_RESET | CMD_LCL_LOOP_EN, priv->mac_reg + UMAC_CMD);
+
+ mdio_node = dev_read_first_subnode(dev);
+ name = ofnode_get_name(mdio_node);
+
@ -789,8 +797,8 @@ index 0000000000..4f8f190071
+ struct bcmgenet_eth_priv *priv = dev_get_priv(dev);
+
+ clrbits_32(priv->mac_reg + UMAC_CMD, CMD_TX_EN | CMD_RX_EN);
+ clrbits_32(priv->mac_reg + TDMA_REG_BASE + DMA_CTRL,
+ 1 << (DEFAULT_Q + DMA_RING_BUF_EN_SHIFT) | DMA_EN);
+
+ bcmgenet_disable_dma(priv);
+}
+
+static const struct eth_ops bcmgenet_gmac_eth_ops = {
@ -854,12 +862,13 @@ index 0000000000..4f8f190071
+ .flags = DM_FLAG_ALLOC_PRIV_DMA,
+};
From patchwork Fri Jan 17 01:20:46 2020
From patchwork Mon Jan 27 01:14:43 2020
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
X-Patchwork-Submitter: Andre Przywara <andre.przywara@arm.com>
X-Patchwork-Id: 1224577
X-Patchwork-Id: 1229488
X-Patchwork-Delegate: matthias.bgg@gmail.com
Return-Path: <u-boot-bounces@lists.denx.de>
X-Original-To: incoming@patchwork.ozlabs.org
Delivered-To: patchwork-incoming@bilbo.ozlabs.org
@ -874,44 +883,44 @@ Received: from phobos.denx.de (phobos.denx.de [85.214.62.61])
(using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits)
key-exchange X25519 server-signature RSA-PSS (4096 bits))
(No client certificate requested)
by ozlabs.org (Postfix) with ESMTPS id 47zNZQ66yWz9s1x
by ozlabs.org (Postfix) with ESMTPS id 485Wyk1KSXz9sNx
for <incoming@patchwork.ozlabs.org>;
Fri, 17 Jan 2020 12:21:50 +1100 (AEDT)
Mon, 27 Jan 2020 12:15:42 +1100 (AEDT)
Received: from h2850616.stratoserver.net (localhost [IPv6:::1])
by phobos.denx.de (Postfix) with ESMTP id CC16E81A1E;
Fri, 17 Jan 2020 02:21:18 +0100 (CET)
by phobos.denx.de (Postfix) with ESMTP id 459628050D;
Mon, 27 Jan 2020 02:15:27 +0100 (CET)
Authentication-Results: phobos.denx.de;
dmarc=none (p=none dis=none) header.from=arm.com
Authentication-Results: phobos.denx.de;
spf=pass smtp.mailfrom=u-boot-bounces@lists.denx.de
Received: by phobos.denx.de (Postfix, from userid 109)
id 1F1A7819EB; Fri, 17 Jan 2020 02:21:13 +0100 (CET)
id BA6FB8149B; Mon, 27 Jan 2020 02:15:20 +0100 (CET)
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on phobos.denx.de
X-Spam-Level:
X-Spam-Status: No, score=0.0 required=5.0 tests=SPF_HELO_NONE, URIBL_BLOCKED
autolearn=ham autolearn_force=no version=3.4.2
Received: from foss.arm.com (foss.arm.com [217.140.110.172])
by phobos.denx.de (Postfix) with ESMTP id 7315B819D9
for <u-boot@lists.denx.de>; Fri, 17 Jan 2020 02:21:06 +0100 (CET)
by phobos.denx.de (Postfix) with ESMTP id 26F8D80199
for <u-boot@lists.denx.de>; Mon, 27 Jan 2020 02:15:16 +0100 (CET)
Authentication-Results: phobos.denx.de;
dmarc=none (p=none dis=none) header.from=arm.com
Authentication-Results: phobos.denx.de;
spf=pass smtp.mailfrom=andre.przywara@arm.com
Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14])
by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 52F10113E;
Thu, 16 Jan 2020 17:21:05 -0800 (PST)
by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 06EA1328;
Sun, 26 Jan 2020 17:15:15 -0800 (PST)
Received: from localhost.localdomain (unknown [172.31.20.19])
by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id
E28533F534; Thu, 16 Jan 2020 17:21:03 -0800 (PST)
87D203F52E; Sun, 26 Jan 2020 17:15:12 -0800 (PST)
From: Andre Przywara <andre.przywara@arm.com>
To: Joe Hershberger <joe.hershberger@ni.com>,
Matthias Brugger <mbrugger@suse.com>
Subject: [PATCH v2 2/3] rpi4: Update memory map to accommodate scb devices
Date: Fri, 17 Jan 2020 01:20:46 +0000
Message-Id: <20200117012047.31096-3-andre.przywara@arm.com>
Subject: [PATCH v3 2/3] rpi4: Update memory map to accommodate scb devices
Date: Mon, 27 Jan 2020 01:14:43 +0000
Message-Id: <20200127011444.8114-3-andre.przywara@arm.com>
X-Mailer: git-send-email 2.14.1
In-Reply-To: <20200117012047.31096-1-andre.przywara@arm.com>
References: <20200117012047.31096-1-andre.przywara@arm.com>
In-Reply-To: <20200127011444.8114-1-andre.przywara@arm.com>
References: <20200127011444.8114-1-andre.przywara@arm.com>
X-BeenThere: u-boot@lists.denx.de
X-Mailman-Version: 2.1.26
Precedence: list
@ -962,12 +971,13 @@ index 3b5f45b431..9966d6c833 100644
PTE_BLOCK_NON_SHARE |
PTE_BLOCK_PXN | PTE_BLOCK_UXN
From patchwork Fri Jan 17 01:20:47 2020
From patchwork Mon Jan 27 01:14:44 2020
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
X-Patchwork-Submitter: Andre Przywara <andre.przywara@arm.com>
X-Patchwork-Id: 1224576
X-Patchwork-Id: 1229489
X-Patchwork-Delegate: matthias.bgg@gmail.com
Return-Path: <u-boot-bounces@lists.denx.de>
X-Original-To: incoming@patchwork.ozlabs.org
Delivered-To: patchwork-incoming@bilbo.ozlabs.org
@ -984,44 +994,44 @@ Received: from phobos.denx.de (phobos.denx.de
(using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits)
key-exchange X25519 server-signature RSA-PSS (4096 bits))
(No client certificate requested)
by ozlabs.org (Postfix) with ESMTPS id 47zNZD44jHz9s1x
by ozlabs.org (Postfix) with ESMTPS id 485Wyv2Lcwz9sNx
for <incoming@patchwork.ozlabs.org>;
Fri, 17 Jan 2020 12:21:40 +1100 (AEDT)
Mon, 27 Jan 2020 12:15:51 +1100 (AEDT)
Received: from h2850616.stratoserver.net (localhost [IPv6:::1])
by phobos.denx.de (Postfix) with ESMTP id 4B69B81A0E;
Fri, 17 Jan 2020 02:21:16 +0100 (CET)
by phobos.denx.de (Postfix) with ESMTP id A6BBC816BB;
Mon, 27 Jan 2020 02:15:29 +0100 (CET)
Authentication-Results: phobos.denx.de;
dmarc=none (p=none dis=none) header.from=arm.com
Authentication-Results: phobos.denx.de;
spf=pass smtp.mailfrom=u-boot-bounces@lists.denx.de
Received: by phobos.denx.de (Postfix, from userid 109)
id 8833A819EB; Fri, 17 Jan 2020 02:21:12 +0100 (CET)
id D46C6814F5; Mon, 27 Jan 2020 02:15:23 +0100 (CET)
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on phobos.denx.de
X-Spam-Level:
X-Spam-Status: No, score=0.0 required=5.0 tests=SPF_HELO_NONE, URIBL_BLOCKED
autolearn=ham autolearn_force=no version=3.4.2
Received: from foss.arm.com (foss.arm.com [217.140.110.172])
by phobos.denx.de (Postfix) with ESMTP id 4813C819EB
for <u-boot@lists.denx.de>; Fri, 17 Jan 2020 02:21:07 +0100 (CET)
by phobos.denx.de (Postfix) with ESMTP id D04C2814DE
for <u-boot@lists.denx.de>; Mon, 27 Jan 2020 02:15:18 +0100 (CET)
Authentication-Results: phobos.denx.de;
dmarc=none (p=none dis=none) header.from=arm.com
Authentication-Results: phobos.denx.de;
spf=pass smtp.mailfrom=andre.przywara@arm.com
Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14])
by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id EE23A11FB;
Thu, 16 Jan 2020 17:21:06 -0800 (PST)
by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id DA93B31B;
Sun, 26 Jan 2020 17:15:17 -0800 (PST)
Received: from localhost.localdomain (unknown [172.31.20.19])
by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id
88DE23F534; Thu, 16 Jan 2020 17:21:05 -0800 (PST)
677703F52E; Sun, 26 Jan 2020 17:15:15 -0800 (PST)
From: Andre Przywara <andre.przywara@arm.com>
To: Joe Hershberger <joe.hershberger@ni.com>,
Matthias Brugger <mbrugger@suse.com>
Subject: [PATCH v2 3/3] rpi4: Enable GENET Ethernet controller
Date: Fri, 17 Jan 2020 01:20:47 +0000
Message-Id: <20200117012047.31096-4-andre.przywara@arm.com>
Subject: [PATCH v3 3/3] rpi4: Enable GENET Ethernet controller
Date: Mon, 27 Jan 2020 01:14:44 +0000
Message-Id: <20200127011444.8114-4-andre.przywara@arm.com>
X-Mailer: git-send-email 2.14.1
In-Reply-To: <20200117012047.31096-1-andre.przywara@arm.com>
References: <20200117012047.31096-1-andre.przywara@arm.com>
In-Reply-To: <20200127011444.8114-1-andre.przywara@arm.com>
References: <20200127011444.8114-1-andre.przywara@arm.com>
X-BeenThere: u-boot@lists.denx.de
X-Mailman-Version: 2.1.26
Precedence: list

View File

@ -2,7 +2,7 @@
Name: uboot-tools
Version: 2020.04
Release: 0.1%{?candidate:.%{candidate}}%{?dist}
Release: 0.2%{?candidate:.%{candidate}}%{?dist}
Summary: U-Boot utilities
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
URL: http://www.denx.de/wiki/U-Boot
@ -249,6 +249,9 @@ cp -p board/warp7/README builds/docs/README.warp7
%endif
%changelog
* Sun Feb 2 2020 Peter Robinson <pbrobinson@fedoraproject.org> 2020.04-0.2-rc1
- Update genet NIC driver
* Wed Jan 29 2020 Peter Robinson <pbrobinson@fedoraproject.org> 2020.04-0.1-rc1
- 2020.04 RC1