Merge remote-tracking branch 'up/master' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2019-12-28 20:08:05 +02:00
commit 8f589f71e3
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
4 changed files with 10 additions and 151 deletions

View File

@ -1,118 +0,0 @@
From e19cfcc07ac5da8b3a04e21875ec542d994865d4 Mon Sep 17 00:00:00 2001
From: Matthias Brugger <mbrugger@suse.com>
Date: Thu, 5 Dec 2019 18:53:13 +0100
Subject: [PATCH 08/10] rpi: fix dram bank initialization
To update the dram bank information from device-tree we use
fdtdec_decode_ram_size() which expectes the the size-cells and
address-cells to be defined in the memory node. For normal system RAM
these values are defined in the root node. When the values differ from
the default values defined in the spec, we can end up with wrong RAM
bank information.
Switch to the "standard" way to update the RAM bank information to
avoid this.
Fixes: 9de5b89e4c ("rpi4: enable dram bank initialization")
Signed-off-by: Matthias Brugger <mbrugger@suse.com>
---
board/raspberrypi/rpi/rpi.c | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/board/raspberrypi/rpi/rpi.c b/board/raspberrypi/rpi/rpi.c
index 5f120ea9c2..e19610f40f 100644
--- a/board/raspberrypi/rpi/rpi.c
+++ b/board/raspberrypi/rpi/rpi.c
@@ -275,8 +275,13 @@ int dram_init(void)
#ifdef CONFIG_BCM2711
int dram_init_banksize(void)
{
- return fdtdec_decode_ram_size(gd->fdt_blob, NULL, 0, NULL,
- (phys_size_t *)&gd->ram_size, gd->bd);
+ int ret;
+
+ ret = fdtdec_setup_memory_banksize();
+ if (ret)
+ return ret;
+
+ return fdtdec_setup_mem_size_base();
}
#endif
#endif
--
2.24.1
From a63f81c242090682ea4907fa6475d8057208cb05 Mon Sep 17 00:00:00 2001
From: Matthias Brugger <mbrugger@suse.com>
Date: Thu, 5 Dec 2019 18:53:14 +0100
Subject: [PATCH 09/10] rpi: Enable DRAM bank initialization on arm64
Up to now we only update the DRAM banks when we are define
CONFIG_BCM2711. But our one binary approach uses a config that supports
BCM2837 and BCM2711. As a result we only see one gibibyte of RAM on
Raspberry Pi 4, even if it has more RAM.
Fix this by calling dram_init_banksize.
Fixes: 5694090670 ("ARM: defconfig: add unified config for RPi3 and RPi4")
Signed-off-by: Matthias Brugger <mbrugger@suse.com>
---
board/raspberrypi/rpi/rpi.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/board/raspberrypi/rpi/rpi.c b/board/raspberrypi/rpi/rpi.c
index e19610f40f..e367ba3092 100644
--- a/board/raspberrypi/rpi/rpi.c
+++ b/board/raspberrypi/rpi/rpi.c
@@ -272,7 +272,6 @@ int dram_init(void)
}
#ifdef CONFIG_OF_BOARD
-#ifdef CONFIG_BCM2711
int dram_init_banksize(void)
{
int ret;
@@ -284,7 +283,6 @@ int dram_init_banksize(void)
return fdtdec_setup_mem_size_base();
}
#endif
-#endif
static void set_fdtfile(void)
{
--
2.24.1
From e5167465a1740f0cac05be44f3e2a4e334eb527a Mon Sep 17 00:00:00 2001
From: Matthias Brugger <mbrugger@suse.com>
Date: Thu, 5 Dec 2019 18:53:15 +0100
Subject: [PATCH 10/10] ARM: defconfig: Fix 32bit config for RPi4
The rpi_4_32b_defconfig states that only one DRAM bank is present. This
leads to a wrong configuration of the available DRAM. Fix this by
setting the DRAM bank config accordingly.
Fixes: 193279d784 ("RPI: Add defconfigs for rpi4 (32/64)")
Signed-off-by: Matthias Brugger <mbrugger@suse.com>
---
configs/rpi_4_32b_defconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configs/rpi_4_32b_defconfig b/configs/rpi_4_32b_defconfig
index e7d8f29060..80cf930032 100644
--- a/configs/rpi_4_32b_defconfig
+++ b/configs/rpi_4_32b_defconfig
@@ -4,7 +4,7 @@ CONFIG_SYS_TEXT_BASE=0x00008000
CONFIG_TARGET_RPI_4_32B=y
CONFIG_SYS_MALLOC_F_LEN=0x2000
CONFIG_ENV_SIZE=0x4000
-CONFIG_NR_DRAM_BANKS=1
+CONFIG_NR_DRAM_BANKS=2
CONFIG_DISTRO_DEFAULTS=y
CONFIG_OF_BOARD_SETUP=y
# CONFIG_ARCH_FIXUP_FDT_MEMORY is not set
--
2.24.1

View File

@ -1 +1 @@
SHA512 (u-boot-2020.01-rc4.tar.bz2) = 8ea8cfa9db2eed29e306b10924fa769f900fa4f92ddf69ea538948ffee561fda81900232a807afce1884812b7bf3d44086e67ce6df29277be41ccbad42f2d315
SHA512 (u-boot-2020.01-rc5.tar.bz2) = f39ef40e4a8a030a779d1732bb588fba808140c91d4d92b6228f752b58ecbbdb90a4b8feae1646a42c64ba044d6c503228f877b33e221330b3f96f3c9006d60a

View File

@ -1,24 +0,0 @@
From 961918a6fcbab383c92135f5cad5ea758bdaef79 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Wed, 4 Dec 2019 23:27:10 +0000
Subject: [PATCH] tools fix
---
Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile
index 556cebdfc4..4bcf4d677f 100644
--- a/Makefile
+++ b/Makefile
@@ -1894,6 +1894,7 @@ checkarmreloc: u-boot
fi
tools/version.h: include/version.h
+ $(Q)mkdir -p $(dir $@)
$(call if_changed,copy)
envtools: scripts_basic $(version_h) $(timestamp_h) tools/version.h
--
2.23.0

View File

@ -1,8 +1,8 @@
%global candidate rc4
%global candidate rc5
Name: uboot-tools
Version: 2020.01
Release: 0.8%{?candidate:.%{candidate}}.0.riscv64%{?dist}
Release: 0.9%{?candidate:.%{candidate}}.0.riscv64%{?dist}
Summary: U-Boot utilities
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
URL: http://www.denx.de/wiki/U-Boot
@ -27,11 +27,9 @@ Patch5: rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
Patch6: dragonboard-fixes.patch
Patch7: ARM-tegra-Add-NVIDIA-Jetson-Nano.patch
Patch8: arm-tegra-defaine-fdtfile-for-all-devices.patch
Patch9: tools-fix-version.h.patch
Patch10: zynqmp-Add-support-for-u-boot.itb-generation-with-ATF.patch
Patch11: zynqmp-Do-not-assing-MIO34-that-early-on-zcu100.patch
Patch12: bcm283x-dts-Rename-U-Boot-file.patch
Patch13: raspberry-pi-4-fixes.patch
Patch9: zynqmp-Add-support-for-u-boot.itb-generation-with-ATF.patch
Patch10: zynqmp-Do-not-assing-MIO34-that-early-on-zcu100.patch
Patch11: bcm283x-dts-Rename-U-Boot-file.patch
# PXE depends on fdt_addr (mandatory)
# fdt_addr is an address to DTB in HW (e.g. ROM)
@ -324,13 +322,16 @@ cp -p board/warp7/README builds/docs/README.warp7
%endif
%changelog
* Sat Dec 14 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2020.01-0.8-rc4.0.riscv64
* Sat Dec 28 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2020.01-0.9-rc5.0.riscv64
- Add support for RISC-V (riscv64)
- Define filesize and kernel_comp_addr_r for QEMU virt and SiFive FU540 boards
to support Image.gz with booti
- Add 'addappend' label to PXE/EXTLINUX configuration
- Match CONFIG_NR_CPUS to Linux configuration (32)
* Tue Dec 17 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2020.01-0.9-rc5
- 2020.01 RC5
* Thu Dec 12 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2020.01-0.8-rc4
- Fixes for Raspberry Pi