2019.01 RC2

This commit is contained in:
Peter Robinson 2018-12-18 13:56:46 +00:00
parent 0af9e0dfb6
commit 8b18f846e5
4 changed files with 9 additions and 3045 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1 +1 @@
SHA512 (u-boot-2019.01-rc1.tar.bz2) = 415581e8aadd37210f5ccdaf4fb64f81b348d553f1b8732931a10aef89f55c0647f7d45fb759aa2ca0c4c624485269c15ee18b55a1cad73a48116af2d4634e40
SHA512 (u-boot-2019.01-rc2.tar.bz2) = d1c76fba9935c3bb7bee67219106af3a05f020cbad6ea2bf4865877d2c67d5ef76ba2d5d49ac623fe8db72fd5adfa5f13894ca80a22d1b0bdbc2549ffdab0815

View File

@ -1,63 +0,0 @@
From patchwork Tue Dec 4 11:24:51 2018
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Subject: [U-Boot] tools: add a generic config for native tools building
X-Patchwork-Submitter: Otavio Salvador <otavio@ossystems.com.br>
X-Patchwork-Id: 1007581
Message-Id: <20181204112452.10544-1-otavio@ossystems.com.br>
To: U-Boot Mailing List <u-boot@lists.denx.de>
Cc: Alexander Graf <agraf@suse.de>, Ryder Lee <ryder.lee@mediatek.com>,
Otavio Salvador <otavio@ossystems.com.br>,
Vagrant Cascadian <vagrant@debian.org>,
Heinrich Schuchardt <xypron.glpk@gmx.de>,
Alexey Brodkin <alexey.brodkin@synopsys.com>,
Michal Simek <michal.simek@xilinx.com>
Date: Tue, 4 Dec 2018 09:24:51 -0200
From: Otavio Salvador <otavio@ossystems.com.br>
List-Id: U-Boot discussion <u-boot.lists.denx.de>
The motivation for this is to allow distributions to distribute all
possible tools in a generic way, avoiding the need of specific tools
building for each machine.
Especially on OpenEmbedded / Yocto Project ecosystem, it is very
common each BSP to end providing their specific tools when they need
to generate images for some SoC (e.g MX23 / MX28 in meta-freescale
case).
Using this, we can package the tools doing:
$: make tools-all_defconfig
$: make tools-all
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
configs/tools-all_defconfig | 3 +++
tools/Makefile | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)
create mode 100644 configs/tools-all_defconfig
diff --git a/configs/tools-all_defconfig b/configs/tools-all_defconfig
new file mode 100644
index 0000000000..be69bdf43a
--- /dev/null
+++ b/configs/tools-all_defconfig
@@ -0,0 +1,3 @@
+CONFIG_SYS_TEXT_BASE=0
+CONFIG_FIT=y
+CONFIG_FIT_SIGNATURE=y
diff --git a/tools/Makefile b/tools/Makefile
index c93d17a42f..29ff6ed221 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -125,7 +125,7 @@ fit_info-objs := $(dumpimage-mkimage-objs) fit_info.o
fit_check_sign-objs := $(dumpimage-mkimage-objs) fit_check_sign.o
file2include-objs := file2include.o
-ifneq ($(CONFIG_MX23)$(CONFIG_MX28),)
+ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
# Add CONFIG_MXS into host CFLAGS, so we can check whether or not register
# the mxsimage support within tools/mxsimage.c .
HOSTCFLAGS_mxsimage.o += -DCONFIG_MXS

View File

@ -1,8 +1,8 @@
%global candidate rc1
%global candidate rc2
Name: uboot-tools
Version: 2019.01
Release: 0.2%{?candidate:.%{candidate}}%{?dist}
Release: 0.3%{?candidate:.%{candidate}}%{?dist}
Summary: U-Boot utilities
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
URL: http://www.denx.de/wiki/U-Boot
@ -20,11 +20,10 @@ Patch1: uefi-use-Fedora-specific-path-name.patch
# general fixes
Patch2: uefi-distro-load-FDT-from-any-partition-on-boot-device.patch
Patch3: usb-kbd-fixes.patch
Patch4: tools-add-a-generic-config-for-native-tools-building.patch
Patch4: efi_loader-Make-RTS-relocation-more-robust.patch
# Board fixes and enablement
Patch10: rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
Patch11: rk3399-Rock960-Ficus-board-support.patch
Patch12: dragonboard-fixes.patch
Patch13: tegra186-jetson-tx2-disable-onboard-emmc.patch
Patch14: tegra-TXx-Add-CONFIG_EFI_LOADER_BOUNCE_BUFFER.patch
@ -162,8 +161,8 @@ done
%endif
make HOSTCC="gcc $RPM_OPT_FLAGS" %{?_smp_mflags} CROSS_COMPILE="" tools-all_defconfig V=1 O=builds/
make HOSTCC="gcc $RPM_OPT_FLAGS" %{?_smp_mflags} CROSS_COMPILE="" tools-all V=1 O=builds/
make HOSTCC="gcc $RPM_OPT_FLAGS" %{?_smp_mflags} CROSS_COMPILE="" tools-only_defconfig V=1 O=builds/
make HOSTCC="gcc $RPM_OPT_FLAGS" %{?_smp_mflags} CROSS_COMPILE="" tools-only V=1 O=builds/
%install
mkdir -p $RPM_BUILD_ROOT%{_bindir}
@ -316,6 +315,9 @@ cp -p board/warp7/README builds/docs/README.warp7
%endif
%changelog
* Tue Dec 18 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2019.01-0.3-rc2
- 2019.01 RC2
* Wed Dec 12 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2019.01-0.2-rc1
- ATF tweaks and fixes
- Enable amarula_a64_relic, nanopi_a64, puma-rk3399