updated to to 2011.03

build the tool for manipulation with environment only on arm
This commit is contained in:
Dan Horák 2011-04-14 15:23:39 +02:00
parent a9253e33e9
commit 5e75bee0ae
4 changed files with 29 additions and 34 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
u-boot-2010.03.tar.bz2
/u-boot-2011.03.tar.bz2

View File

@ -1 +1 @@
2bf5ebf497dddc52440b1ea386cc1332 u-boot-2010.03.tar.bz2
91d02124c94368557d0e9ac05fb8c33f u-boot-2011.03.tar.bz2

View File

@ -1,26 +0,0 @@
From 3b3524cd9878e356f88075e570fa029b0790eca2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Fri, 28 May 2010 23:09:43 +0200
Subject: [PATCH] switch to CC variable for compiler
Don't use a hardcoded cross-gcc, switch to using CC variable instead.
---
tools/env/Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/tools/env/Makefile b/tools/env/Makefile
index 2df631e..570a956 100644
--- a/tools/env/Makefile
+++ b/tools/env/Makefile
@@ -35,7 +35,7 @@ endif
all: $(obj)fw_printenv
$(obj)fw_printenv: $(SRCS) $(HEADERS)
- $(CROSS_COMPILE)gcc $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
+ $(CC) $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
clean:
rm -f $(obj)fw_printenv $(obj)crc32.c
--
1.6.6.1

View File

@ -1,15 +1,19 @@
Name: uboot-tools
Version: 2010.03
Release: 2%{?dist}
Version: 2011.03
Release: 1%{?dist}
Summary: U-Boot utilities
Group: Development/Tools
License: GPLv2+
URL: http://www.denx.de/wiki/U-Boot
Source0: ftp://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
Patch0: u-boot-2010.03-env-makefile.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# build the tool for manipulation with environment only on arm
%ifarch %{arm}
%global with_env 1
%endif
%description
This package contains a few U-Boot utilities - mkimage for creating boot images
@ -18,7 +22,6 @@ and fw_printenv/fw_setenv for manipulating the boot environment variables.
%prep
%setup -q -n u-boot-%{version}
%patch0 -p1
%build
@ -27,10 +30,15 @@ make sheevaplug_config
# create files normally created by cross-compiler
touch include/autoconf.mk
touch include/autoconf.mk.dep
touch {cpu/arm926ejs,examples/standalone,tools,tools/env}/.depend
mkdir include/generated
touch include/generated/generic-asm-offsets.h
touch lib/asm-offsets.s
touch {arch/arm/cpu/arm926ejs,examples/standalone,tools,tools/env}/.depend
make tools HOSTCC="gcc $RPM_OPT_FLAGS" HOSTSTRIP=/bin/true CROSS_COMPILE=""
make env CC="gcc $RPM_OPT_FLAGS"
%if 0%{?with_env}
make env HOSTCC="gcc $RPM_OPT_FLAGS" CROSS_COMPILE=""
%endif
%install
@ -38,12 +46,17 @@ rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_bindir}
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
install -p -m 0755 tools/mkimage $RPM_BUILD_ROOT%{_bindir}
install -p -m 0644 doc/mkimage.1 $RPM_BUILD_ROOT%{_mandir}/man1
%if 0%{?with_env}
install -p -m 0755 tools/env/fw_printenv $RPM_BUILD_ROOT%{_bindir}
( cd $RPM_BUILD_ROOT%{_bindir}; ln -sf fw_printenv fw_setenv )
install -p -m 0644 tools/env/fw_env.config $RPM_BUILD_ROOT%{_sysconfdir}
%endif
%clean
@ -52,14 +65,21 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc COPYING README doc/uImage.FIT
%doc COPYING README doc/README.imximage doc/README.kwbimage doc/uImage.FIT
%{_bindir}/mkimage
%{_mandir}/man1/mkimage.1*
%if 0%{?with_env}
%{_bindir}/fw_printenv
%{_bindir}/fw_setenv
%config(noreplace) %{_sysconfdir}/fw_env.config
%endif
%changelog
* Thu Apr 14 2011 Dan Horák <dan[at]danny.cz> - 2011.03-1
- updated to to 2011.03
- build the tool for manipulation with environment only on arm
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2010.03-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild