initial import
This commit is contained in:
parent
f92ea64a08
commit
5c9ad74116
@ -0,0 +1 @@
|
||||
u-boot-2010.03.tar.bz2
|
26
u-boot-2010.03-env-makefile.patch
Normal file
26
u-boot-2010.03-env-makefile.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 3b3524cd9878e356f88075e570fa029b0790eca2 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Fri, 28 May 2010 23:09:43 +0200
|
||||
Subject: [PATCH] switch to CC variable for compiler
|
||||
|
||||
Don't use a hardcoded cross-gcc, switch to using CC variable instead.
|
||||
---
|
||||
tools/env/Makefile | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/tools/env/Makefile b/tools/env/Makefile
|
||||
index 2df631e..570a956 100644
|
||||
--- a/tools/env/Makefile
|
||||
+++ b/tools/env/Makefile
|
||||
@@ -35,7 +35,7 @@ endif
|
||||
all: $(obj)fw_printenv
|
||||
|
||||
$(obj)fw_printenv: $(SRCS) $(HEADERS)
|
||||
- $(CROSS_COMPILE)gcc $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
|
||||
+ $(CC) $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
|
||||
|
||||
clean:
|
||||
rm -f $(obj)fw_printenv $(obj)crc32.c
|
||||
--
|
||||
1.6.6.1
|
||||
|
69
uboot-tools.spec
Normal file
69
uboot-tools.spec
Normal file
@ -0,0 +1,69 @@
|
||||
Name: uboot-tools
|
||||
Version: 2010.03
|
||||
Release: 1%{?dist}
|
||||
Summary: U-Boot utilities
|
||||
|
||||
Group: Development/Tools
|
||||
License: GPLv2+
|
||||
URL: http://www.denx.de/wiki/U-Boot
|
||||
Source0: ftp://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
|
||||
Patch0: u-boot-2010.03-env-makefile.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
|
||||
%description
|
||||
This package contains a few U-Boot utilities - mkimage for creating boot images
|
||||
and fw_printenv/fw_setenv for manipulating the boot environment variables.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n u-boot-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
make sheevaplug_config
|
||||
|
||||
# create files normally created by cross-compiler
|
||||
touch include/autoconf.mk
|
||||
touch include/autoconf.mk.dep
|
||||
touch {cpu/arm926ejs,examples/standalone,tools,tools/env}/.depend
|
||||
|
||||
make tools HOSTCC="gcc $RPM_OPT_FLAGS" HOSTSTRIP=/bin/true CROSS_COMPILE=""
|
||||
make env CC="gcc $RPM_OPT_FLAGS"
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
|
||||
|
||||
install -p -m 0755 tools/mkimage $RPM_BUILD_ROOT%{_bindir}
|
||||
install -p -m 0755 tools/env/fw_printenv $RPM_BUILD_ROOT%{_bindir}
|
||||
( cd $RPM_BUILD_ROOT%{_bindir}; ln -sf fw_printenv fw_setenv )
|
||||
|
||||
install -p -m 0644 tools/env/fw_env.config $RPM_BUILD_ROOT%{_sysconfdir}
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README doc/uImage.FIT
|
||||
%{_bindir}/mkimage
|
||||
%{_bindir}/fw_printenv
|
||||
%{_bindir}/fw_setenv
|
||||
%config(noreplace) %{_sysconfdir}/fw_env.config
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 27 2010 Dan Horák <dan[at]danny.cz> 2010.03-1
|
||||
- updated to to 2010.03
|
||||
- applied review feedback - added docs and expanded description
|
||||
- pass proper CFLAGS to the compiler
|
||||
|
||||
* Sat Nov 14 2009 Dan Horák <dan[at]danny.cz> 2009.08-1
|
||||
- initial Fedora version
|
Loading…
Reference in New Issue
Block a user