Add patch to fix detection of Panda ES/A4

This commit is contained in:
Peter Robinson 2015-09-12 11:11:31 +01:00
parent 784d5b1e8a
commit 5611803cce
10 changed files with 90 additions and 56 deletions

View File

@ -1,7 +1,7 @@
From ee628ad871f52c14be04116280457fb0990cd143 Mon Sep 17 00:00:00 2001
From f0b1a1a1a41a74ee64f2a68fc7348d9d9e33c84c Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Wed, 15 Jul 2015 11:30:24 +0100
Subject: [PATCH 1/5] wandboard: add support for generic distro boot
Subject: [PATCH 1/9] wandboard: add support for generic distro boot
---
include/configs/wandboard.h | 33 ++++++++++++++++++++++++---------
@ -97,5 +97,5 @@ index f05b55a..b3ad82a 100644
#define CONFIG_NR_DRAM_BANKS 1
#define PHYS_SDRAM MMDC0_ARB_BASE_ADDR
--
2.4.5
2.5.0

View File

@ -1,7 +1,7 @@
From 7ab7e76c7813e7d9db16eeb2bd2cf15e98da1726 Mon Sep 17 00:00:00 2001
From c47ac887df62e802776f0d666e3626c852640a2d Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Tue, 23 Jun 2015 00:53:25 +0100
Subject: [PATCH 2/5] am33xx: add support for generic distro boot
Subject: [PATCH 2/9] am33xx: add support for generic distro boot
---
include/configs/am335x_evm.h | 28 ++++++++++++++++++----------
@ -76,5 +76,5 @@ index 0aea7d1..d6073b2 100644
"fdt_addr_r=0x88000000\0" \
"rdaddr=0x88080000\0" \
--
2.4.5
2.5.0

View File

@ -1,7 +1,7 @@
From 99afbef73d291faf6ba069d36eef7d7b1eef6514 Mon Sep 17 00:00:00 2001
From 304a082f0ac1cb2f1ad70c3be76568e2496d94af Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Thu, 2 Jul 2015 23:26:44 +0100
Subject: [PATCH 3/5] Switch omap4 boards to use config_distro_defaults and
Subject: [PATCH 3/9] Switch omap4 boards to use config_distro_defaults and
config_distro_bootcmd.
Add pxefile_addr_r to DEFAULT_LINUX_BOOT_ENV, as pxefile_addr_r is used
@ -94,5 +94,5 @@ index e966134..51b7265 100644
/*
* Defines for SPL
--
2.4.5
2.5.0

View File

@ -1,7 +1,7 @@
From 63e521287c2ebbce0a1830dd66cdb5d29a5e9ae6 Mon Sep 17 00:00:00 2001
From d61dda6e7dff4ae510699e72eca523d453efb082 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Thu, 2 Jul 2015 23:28:56 +0100
Subject: [PATCH 4/5] Add BOOTENV_INIT_COMMAND for commands that may be needed
Subject: [PATCH 4/9] Add BOOTENV_INIT_COMMAND for commands that may be needed
to run before bootcmd, such as setting the fdt file variables for platfroms
that detect on boot.
@ -10,7 +10,7 @@ Subject: [PATCH 4/5] Add BOOTENV_INIT_COMMAND for commands that may be needed
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/include/config_distro_bootcmd.h b/include/config_distro_bootcmd.h
index 3a360ca4..dcad4c8 100644
index 3a360ca..dcad4c8 100644
--- a/include/config_distro_bootcmd.h
+++ b/include/config_distro_bootcmd.h
@@ -176,6 +176,10 @@
@ -34,5 +34,5 @@ index 3a360ca4..dcad4c8 100644
"run bootcmd_${target}; " \
"done\0"
--
2.4.5
2.5.0

View File

@ -1,7 +1,7 @@
From 6084de3105dedfe50d8456cb4b6f3eaee362fa35 Mon Sep 17 00:00:00 2001
From f09b9edc5269edfdf803b5cd10eb01a3ad3b779f Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Fri, 3 Jul 2015 00:08:05 +0100
Subject: [PATCH 5/5] port utilite to distro generic boot commands
Subject: [PATCH 5/9] port utilite to distro generic boot commands
---
include/configs/cm_fx6.h | 107 ++++++++++++-----------------------------------
@ -144,5 +144,5 @@ index 231f4ba..8a2e46c 100644
#define CONFIG_PREBOOT "usb start"
--
2.4.5
2.5.0

View File

@ -1,7 +1,7 @@
From afc8e9b8023aa2f7073c8a7fa7592be1debffa6c Mon Sep 17 00:00:00 2001
From 0a50f653c44cef7685d8300ddccb2c7476cbed71 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Wed, 15 Jul 2015 12:37:44 +0100
Subject: [PATCH 6/6] mx6: utilite: disable logos
Subject: [PATCH 6/9] mx6: utilite: disable logos
---
include/configs/cm_fx6.h | 8 --------
@ -25,5 +25,5 @@ index 8a2e46c..713d90a 100644
-
#endif /* __CONFIG_CM_FX6_H */
--
2.4.5
2.5.0

View File

@ -1,15 +1,7 @@
From patchwork Thu Jul 9 07:33:00 2015
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Subject: [U-Boot,1/2] ARM: tegra: move VPR configuration to a later stage
From e20acc67fd6ddd5c359e2d93ca0894222fedd30b Mon Sep 17 00:00:00 2001
From: Alexandre Courbot <acourbot@nvidia.com>
X-Patchwork-Id: 493287
Message-Id: <1436427181-23904-2-git-send-email-acourbot@nvidia.com>
To: Stephen Warren <swarren@nvidia.com>, Tom Warren <twarren@nvidia.com>,
u-boot@lists.denx.de
Cc: linux-tegra@vger.kernel.org, gnurou@gmail.com
Date: Thu, 9 Jul 2015 16:33:00 +0900
Subject: [PATCH 7/9] ARM: tegra: move VPR configuration to a later stage
U-boot is responsible for enabling the GPU DT node after all necessary
configuration (VPR setup for T124) is performed. In order to be able to
@ -38,7 +30,7 @@ Cc: Tom Warren <twarren@nvidia.com>
delete mode 100644 arch/arm/mach-tegra/vpr.c
diff --git a/arch/arm/include/asm/arch-tegra/ap.h b/arch/arm/include/asm/arch-tegra/ap.h
index ca40e4e0bce6..2d58271e39f9 100644
index ca40e4e..2d58271 100644
--- a/arch/arm/include/asm/arch-tegra/ap.h
+++ b/arch/arm/include/asm/arch-tegra/ap.h
@@ -66,15 +66,6 @@ int tegra_get_sku_info(void);
@ -59,7 +51,7 @@ index ca40e4e0bce6..2d58271e39f9 100644
#endif
diff --git a/arch/arm/include/asm/arch-tegra/gpu.h b/arch/arm/include/asm/arch-tegra/gpu.h
new file mode 100644
index 000000000000..b347a21835f5
index 0000000..b347a21
--- /dev/null
+++ b/arch/arm/include/asm/arch-tegra/gpu.h
@@ -0,0 +1,27 @@
@ -91,7 +83,7 @@ index 000000000000..b347a21835f5
+
+#endif /* CONFIG_TEGRA_GPU */
diff --git a/arch/arm/mach-tegra/Makefile b/arch/arm/mach-tegra/Makefile
index fefc180b130e..f6f5583d6dd1 100644
index fefc180..f6f5583 100644
--- a/arch/arm/mach-tegra/Makefile
+++ b/arch/arm/mach-tegra/Makefile
@@ -24,7 +24,7 @@ obj-y += pinmux-common.o
@ -104,7 +96,7 @@ index fefc180b130e..f6f5583d6dd1 100644
ifndef CONFIG_SPL_BUILD
diff --git a/arch/arm/mach-tegra/ap.c b/arch/arm/mach-tegra/ap.c
index 0b94e8aaf9c3..70613f9c3649 100644
index 0b94e8a..70613f9 100644
--- a/arch/arm/mach-tegra/ap.c
+++ b/arch/arm/mach-tegra/ap.c
@@ -218,7 +218,4 @@ void s_init(void)
@ -116,7 +108,7 @@ index 0b94e8aaf9c3..70613f9c3649 100644
- config_vpr();
}
diff --git a/arch/arm/mach-tegra/board2.c b/arch/arm/mach-tegra/board2.c
index ce9b6959efb1..1d7c5eff5587 100644
index ce9b695..1d7c5ef 100644
--- a/arch/arm/mach-tegra/board2.c
+++ b/arch/arm/mach-tegra/board2.c
@@ -29,6 +29,7 @@
@ -138,7 +130,7 @@ index ce9b6959efb1..1d7c5eff5587 100644
#endif
diff --git a/arch/arm/mach-tegra/gpu.c b/arch/arm/mach-tegra/gpu.c
new file mode 100644
index 000000000000..b2fa50b5400e
index 0000000..b2fa50b
--- /dev/null
+++ b/arch/arm/mach-tegra/gpu.c
@@ -0,0 +1,47 @@
@ -191,7 +183,7 @@ index 000000000000..b2fa50b5400e
+}
diff --git a/arch/arm/mach-tegra/vpr.c b/arch/arm/mach-tegra/vpr.c
deleted file mode 100644
index f695811c9b6d..000000000000
index f695811..0000000
--- a/arch/arm/mach-tegra/vpr.c
+++ /dev/null
@@ -1,35 +0,0 @@
@ -231,7 +223,7 @@ index f695811c9b6d..000000000000
- readl(&mc->mc_video_protect_reg_ctrl);
-}
diff --git a/include/configs/tegra124-common.h b/include/configs/tegra124-common.h
index 1aee5c89f4c4..a05d2b53c8bf 100644
index 1aee5c8..a05d2b5 100644
--- a/include/configs/tegra124-common.h
+++ b/include/configs/tegra124-common.h
@@ -70,4 +70,7 @@
@ -242,3 +234,6 @@ index 1aee5c89f4c4..a05d2b53c8bf 100644
+#define CONFIG_TEGRA_GPU
+
#endif /* _TEGRA124_COMMON_H_ */
--
2.5.0

View File

@ -1,15 +1,7 @@
From patchwork Thu Jul 9 07:33:01 2015
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Subject: [U-Boot,2/2] ARM: tegra: enable GPU DT node when appropriate
From e512e16b155d9eba97764cb64cdcaa4e5b1953fc Mon Sep 17 00:00:00 2001
From: Alexandre Courbot <acourbot@nvidia.com>
X-Patchwork-Id: 493288
Message-Id: <1436427181-23904-3-git-send-email-acourbot@nvidia.com>
To: Stephen Warren <swarren@nvidia.com>, Tom Warren <twarren@nvidia.com>,
u-boot@lists.denx.de
Cc: linux-tegra@vger.kernel.org, gnurou@gmail.com
Date: Thu, 9 Jul 2015 16:33:01 +0900
Subject: [PATCH 8/9] ARM: tegra: enable GPU DT node when appropriate
T124 requires some specific configuration (VPR setup) to be performed by
the bootloader before the GPU can be used. For this reason, the GPU node
@ -31,7 +23,7 @@ Cc: Tom Warren <twarren@nvidia.com>
6 files changed, 55 insertions(+)
diff --git a/arch/arm/include/asm/arch-tegra/gpu.h b/arch/arm/include/asm/arch-tegra/gpu.h
index b347a21835f5..eac73ed5fddf 100644
index b347a21..eac73ed 100644
--- a/arch/arm/include/asm/arch-tegra/gpu.h
+++ b/arch/arm/include/asm/arch-tegra/gpu.h
@@ -25,3 +25,19 @@ static inline bool gpu_configured(void)
@ -55,7 +47,7 @@ index b347a21835f5..eac73ed5fddf 100644
+
+#endif
diff --git a/arch/arm/mach-tegra/gpu.c b/arch/arm/mach-tegra/gpu.c
index b2fa50b5400e..4ea046d3e5b6 100644
index b2fa50b..4ea046d 100644
--- a/arch/arm/mach-tegra/gpu.c
+++ b/arch/arm/mach-tegra/gpu.c
@@ -45,3 +45,22 @@ bool vpr_configured(void)
@ -82,7 +74,7 @@ index b2fa50b5400e..4ea046d3e5b6 100644
+
+#endif
diff --git a/board/nvidia/jetson-tk1/jetson-tk1.c b/board/nvidia/jetson-tk1/jetson-tk1.c
index 52425a8f6dea..3c21767ce4da 100644
index 52425a8..3c21767 100644
--- a/board/nvidia/jetson-tk1/jetson-tk1.c
+++ b/board/nvidia/jetson-tk1/jetson-tk1.c
@@ -11,6 +11,7 @@
@ -105,7 +97,7 @@ index 52425a8f6dea..3c21767ce4da 100644
+ return 0;
+}
diff --git a/board/nvidia/venice2/venice2.c b/board/nvidia/venice2/venice2.c
index c56ef129d6c7..3e2b9a7745e9 100644
index c56ef12..3e2b9a7 100644
--- a/board/nvidia/venice2/venice2.c
+++ b/board/nvidia/venice2/venice2.c
@@ -8,6 +8,7 @@
@ -128,7 +120,7 @@ index c56ef129d6c7..3e2b9a7745e9 100644
+ return 0;
+}
diff --git a/include/configs/jetson-tk1.h b/include/configs/jetson-tk1.h
index 3bbff282df27..b3e649664508 100644
index 3bbff28..b3e6496 100644
--- a/include/configs/jetson-tk1.h
+++ b/include/configs/jetson-tk1.h
@@ -82,4 +82,6 @@
@ -139,7 +131,7 @@ index 3bbff282df27..b3e649664508 100644
+
#endif /* __CONFIG_H */
diff --git a/include/configs/venice2.h b/include/configs/venice2.h
index 1d9d053b3566..bc5080aa27f0 100644
index 1d9d053..bc5080a 100644
--- a/include/configs/venice2.h
+++ b/include/configs/venice2.h
@@ -64,4 +64,6 @@
@ -149,3 +141,6 @@ index 1d9d053b3566..bc5080aa27f0 100644
+#define CONFIG_OF_BOARD_SETUP
+
#endif /* __CONFIG_H */
--
2.5.0

View File

@ -0,0 +1,40 @@
From 52c90ebd27e0a30e8a225e42499522aeb52510d0 Mon Sep 17 00:00:00 2001
From: "dbatzle@dcbcyber.com" <dbatzle@dcbcyber.com>
Date: Wed, 26 Aug 2015 00:45:58 +0100
Subject: [PATCH 9/9] ARM fix pandaboard es and a4 revision ID
board_name environment variable was not getting set correctly for
Pandaboard A4 and ES
Signed-off-by: David Batzle <dbatzle@dcbcyber.com>
CC:Albert Aribaud <albert.u.boot@aribaud.net>
CC: Tom Rini <trini@ti.com>
---
board/ti/panda/panda.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/board/ti/panda/panda.c b/board/ti/panda/panda.c
index 783ba35..92e1b63 100644
--- a/board/ti/panda/panda.c
+++ b/board/ti/panda/panda.c
@@ -101,7 +101,7 @@ int get_board_revision(void)
board_id4 = gpio_get_value(PANDA_ES_BOARD_ID_4_GPIO);
#ifdef CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
- setenv("board_name", strcat(CONFIG_SYS_BOARD, "-es"));
+ setenv("board_name", "panda-es");
#endif
board_id = ((board_id4 << 4) | (board_id3 << 3) |
(board_id2 << 2) | (board_id1 << 1) | (board_id0));
@@ -115,7 +115,7 @@ int get_board_revision(void)
#ifdef CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
if ((board_id >= 0x3) && (processor_rev == OMAP4430_ES2_3))
- setenv("board_name", strcat(CONFIG_SYS_BOARD, "-a4"));
+ setenv("board_name", "panda-a4");
#endif
}
--
2.5.0

View File

@ -2,7 +2,7 @@
Name: uboot-tools
Version: 2015.07
Release: 4%{?candidate:.%{candidate}}%{?dist}
Release: 5%{?candidate:.%{candidate}}%{?dist}
Summary: U-Boot utilities
Group: Development/Tools
@ -18,9 +18,10 @@ Patch4: 0004-Add-BOOTENV_INIT_COMMAND-for-commands-that-may-be-ne.patch
Patch5: 0005-port-utilite-to-distro-generic-boot-commands.patch
Patch6: 0006-mx6-utilite-disable-logos.patch
# http://patchwork.ozlabs.org/patch/493287/
Patch7: ARM-tegra-move-VPR-configuration-to-a-later-stage.patch
Patch7: 0007-ARM-tegra-move-VPR-configuration-to-a-later-stage.patch
# http://patchwork.ozlabs.org/patch/493288/
Patch8: ARM-tegra-enable-GPU-DT-node-when-appropriate.patch
Patch8: 0008-ARM-tegra-enable-GPU-DT-node-when-appropriate.patch
Patch9: 0009-ARM-fix-pandaboard-es-and-a4-revision-ID.patch
BuildRequires: bc
BuildRequires: dtc
@ -170,6 +171,9 @@ install -p -m 0644 tools/env/fw_env.config $RPM_BUILD_ROOT%{_sysconfdir}
%endif
%changelog
* Sat Sep 12 2015 Peter Robinson <pbrobinson@fedoraproject.org> 2015.07-5
- Add patch to fix detection of Panda ES/A4
* Fri Aug 7 2015 Peter Robinson <pbrobinson@fedoraproject.org> 2015.07-4
- Add tegra patches to enable GPU