add Pine64 LTS patch
This commit is contained in:
parent
93c0afec39
commit
2489007525
46
sunxi-DT-A64-add-Pine64-LTS-support.patch
Normal file
46
sunxi-DT-A64-add-Pine64-LTS-support.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From 89b9b412ccc5beb7ab72139d43efeaaa46f2d7e4 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Wed, 5 Sep 2018 14:01:50 +0100
|
||||
Subject: [PATCH] sunxi: DT: A64: add Pine64-LTS support
|
||||
|
||||
The Pine64-LTS board is a new board version of the Pine64, though
|
||||
actually it's a non-SoM version of the SoPine and its baseboard.
|
||||
In contrast to the original Pine64 it features LPDDR3 DRAM, an eMMC
|
||||
socket and a SPI flash chip for storing firmware (like U-Boot).
|
||||
Add it as a variant to the existing SoPine defconfig, since from a
|
||||
software point of view they are really not different.
|
||||
|
||||
Signed-off-by: Andre Przywara <andre.przywara@arm.com>
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
arch/arm/dts/Makefile | 1 +
|
||||
configs/sopine_baseboard_defconfig | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
||||
index ebfa227262..6cd440d6af 100644
|
||||
--- a/arch/arm/dts/Makefile
|
||||
+++ b/arch/arm/dts/Makefile
|
||||
@@ -401,6 +401,7 @@ dtb-$(CONFIG_MACH_SUN50I) += \
|
||||
sun50i-a64-nanopi-a64.dtb \
|
||||
sun50i-a64-olinuxino.dtb \
|
||||
sun50i-a64-orangepi-win.dtb \
|
||||
+ sun50i-a64-pine64-lts.dtb \
|
||||
sun50i-a64-pine64-plus.dtb \
|
||||
sun50i-a64-pine64.dtb \
|
||||
sun50i-a64-sopine-baseboard.dtb
|
||||
diff --git a/configs/sopine_baseboard_defconfig b/configs/sopine_baseboard_defconfig
|
||||
index 9ede081c08..eead38a1e3 100644
|
||||
--- a/configs/sopine_baseboard_defconfig
|
||||
+++ b/configs/sopine_baseboard_defconfig
|
||||
@@ -15,6 +15,7 @@ CONFIG_NR_DRAM_BANKS=1
|
||||
# CONFIG_SPL_DOS_PARTITION is not set
|
||||
# CONFIG_SPL_EFI_PARTITION is not set
|
||||
CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-sopine-baseboard"
|
||||
+CONFIG_OF_LIST="sun50i-a64-sopine-baseboard sun50i-a64-pine64-lts"
|
||||
CONFIG_SUN8I_EMAC=y
|
||||
CONFIG_USB_EHCI_HCD=y
|
||||
CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y
|
||||
--
|
||||
2.19.0.rc0
|
||||
|
@ -31,6 +31,7 @@ Patch15: tegra186-jetson-tx2-disable-onboard-emmc.patch
|
||||
Patch16: tegra-efi_loader-simplify-ifdefs.patch
|
||||
Patch17: tegra-TXx-Add-CONFIG_EFI_LOADER_BOUNCE_BUFFER.patch
|
||||
Patch18: tegra-fix-tx1.patch
|
||||
Patch19: sunxi-DT-A64-add-Pine64-LTS-support.patch
|
||||
|
||||
BuildRequires: bc
|
||||
BuildRequires: dtc
|
||||
@ -303,6 +304,7 @@ cp -p board/warp7/README builds/docs/README.warp7
|
||||
- Enable nanopi_neo_plus2, pine_h64, rock960-rk3399, a64-olinuxino
|
||||
- Build against new upstream AllWinner ATF support
|
||||
- Use firmware provided DT on Raspberry Pi
|
||||
- Support for Pine64-LTS
|
||||
|
||||
* Tue Aug 14 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2018.09-0.2.rc2
|
||||
- 2018.09 RC2
|
||||
|
Loading…
Reference in New Issue
Block a user