2019.01 RC1, new devices
This commit is contained in:
parent
5856918f28
commit
1ecd9b94d2
@ -20,6 +20,7 @@ nanopi-k2
|
||||
nanopi_neo2
|
||||
nanopi_neo_plus2
|
||||
odroid-c2
|
||||
orangepi_lite2
|
||||
orangepi_one_plus
|
||||
orangepi_pc2
|
||||
orangepi_prime
|
||||
@ -30,7 +31,9 @@ p212
|
||||
p2371-2180
|
||||
p2771-0000-500
|
||||
pine_h64
|
||||
pine64-lts
|
||||
pine64_plus
|
||||
pinebook
|
||||
poplar
|
||||
rock960-rk3399
|
||||
rpi_3
|
||||
|
@ -17,6 +17,7 @@ Auxtek-T004
|
||||
ba10_tv_box
|
||||
Bananapi
|
||||
bananapi_m2_berry
|
||||
bananapi_m2_zero
|
||||
Bananapi_M2_Ultra
|
||||
Bananapro
|
||||
chiliboard
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 0775d5df2f7d076e7fdf15f517ca464623cce0fb Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Tue, 4 Dec 2018 10:27:54 +0000
|
||||
Subject: [PATCH] make tools-all defconfig a thing
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
configs/tools-all_defconfig | 3 +++
|
||||
tools/Makefile | 2 +-
|
||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
||||
create mode 100644 configs/tools-all_defconfig
|
||||
|
||||
diff --git a/configs/tools-all_defconfig b/configs/tools-all_defconfig
|
||||
new file mode 100644
|
||||
index 00000000000..be69bdf43ad
|
||||
--- /dev/null
|
||||
+++ b/configs/tools-all_defconfig
|
||||
@@ -0,0 +1,3 @@
|
||||
+CONFIG_SYS_TEXT_BASE=0
|
||||
+CONFIG_FIT=y
|
||||
+CONFIG_FIT_SIGNATURE=y
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index c93d17a42fd..29ff6ed221b 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -125,7 +125,7 @@ fit_info-objs := $(dumpimage-mkimage-objs) fit_info.o
|
||||
fit_check_sign-objs := $(dumpimage-mkimage-objs) fit_check_sign.o
|
||||
file2include-objs := file2include.o
|
||||
|
||||
-ifneq ($(CONFIG_MX23)$(CONFIG_MX28),)
|
||||
+ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
|
||||
# Add CONFIG_MXS into host CFLAGS, so we can check whether or not register
|
||||
# the mxsimage support within tools/mxsimage.c .
|
||||
HOSTCFLAGS_mxsimage.o += -DCONFIG_MXS
|
||||
--
|
||||
2.19.2
|
||||
|
@ -1,6 +1,6 @@
|
||||
From 44dd1455f924aa99e6bff0b124a9be0a85dcfa89 Mon Sep 17 00:00:00 2001
|
||||
From 7bf054b1b2e1e4105e94642e18fc74a63eccce97 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Tue, 4 Sep 2018 11:59:18 +0100
|
||||
Date: Tue, 4 Dec 2018 15:26:59 +0000
|
||||
Subject: [PATCH] rpi: Use firmware provided device tree
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
@ -13,70 +13,70 @@ Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
5 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/configs/rpi_0_w_defconfig b/configs/rpi_0_w_defconfig
|
||||
index d5bf01b76e..08f177f34a 100644
|
||||
index 66b0de31b60..9446465fdf7 100644
|
||||
--- a/configs/rpi_0_w_defconfig
|
||||
+++ b/configs/rpi_0_w_defconfig
|
||||
@@ -13,7 +13,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
|
||||
CONFIG_CMD_GPIO=y
|
||||
@@ -14,7 +14,7 @@ CONFIG_CMD_GPIO=y
|
||||
CONFIG_CMD_MMC=y
|
||||
CONFIG_CMD_USB=y
|
||||
CONFIG_CMD_FS_UUID=y
|
||||
-CONFIG_OF_EMBED=y
|
||||
+CONFIG_OF_BOARD=y
|
||||
CONFIG_DEFAULT_DEVICE_TREE="bcm2835-rpi-zero-w"
|
||||
CONFIG_ENV_FAT_INTERFACE="mmc"
|
||||
CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
|
||||
diff --git a/configs/rpi_2_defconfig b/configs/rpi_2_defconfig
|
||||
index a50a815759..0918c6c9ff 100644
|
||||
index ba75e52dda0..d324e2bdd33 100644
|
||||
--- a/configs/rpi_2_defconfig
|
||||
+++ b/configs/rpi_2_defconfig
|
||||
@@ -13,7 +13,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
|
||||
CONFIG_CMD_GPIO=y
|
||||
@@ -14,7 +14,7 @@ CONFIG_CMD_GPIO=y
|
||||
CONFIG_CMD_MMC=y
|
||||
CONFIG_CMD_USB=y
|
||||
CONFIG_CMD_FS_UUID=y
|
||||
-CONFIG_OF_EMBED=y
|
||||
+CONFIG_OF_BOARD=y
|
||||
CONFIG_DEFAULT_DEVICE_TREE="bcm2836-rpi-2-b"
|
||||
CONFIG_ENV_FAT_INTERFACE="mmc"
|
||||
CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
|
||||
diff --git a/configs/rpi_3_32b_defconfig b/configs/rpi_3_32b_defconfig
|
||||
index ec395d29ed..22165bde53 100644
|
||||
index bbcdd91e909..46816cd1da7 100644
|
||||
--- a/configs/rpi_3_32b_defconfig
|
||||
+++ b/configs/rpi_3_32b_defconfig
|
||||
@@ -14,7 +14,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
|
||||
CONFIG_CMD_GPIO=y
|
||||
@@ -15,7 +15,7 @@ CONFIG_CMD_GPIO=y
|
||||
CONFIG_CMD_MMC=y
|
||||
CONFIG_CMD_USB=y
|
||||
CONFIG_CMD_FS_UUID=y
|
||||
-CONFIG_OF_EMBED=y
|
||||
+CONFIG_OF_BOARD=y
|
||||
CONFIG_DEFAULT_DEVICE_TREE="bcm2837-rpi-3-b"
|
||||
CONFIG_ENV_FAT_INTERFACE="mmc"
|
||||
CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
|
||||
diff --git a/configs/rpi_3_defconfig b/configs/rpi_3_defconfig
|
||||
index ac99f2000a..0ca298cd54 100644
|
||||
index 54b6303c2d8..f05ddf8f61f 100644
|
||||
--- a/configs/rpi_3_defconfig
|
||||
+++ b/configs/rpi_3_defconfig
|
||||
@@ -14,7 +14,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
|
||||
CONFIG_CMD_GPIO=y
|
||||
@@ -15,7 +15,7 @@ CONFIG_CMD_GPIO=y
|
||||
CONFIG_CMD_MMC=y
|
||||
CONFIG_CMD_USB=y
|
||||
CONFIG_CMD_FS_UUID=y
|
||||
-CONFIG_OF_EMBED=y
|
||||
+CONFIG_OF_BOARD=y
|
||||
CONFIG_DEFAULT_DEVICE_TREE="bcm2837-rpi-3-b"
|
||||
CONFIG_ENV_FAT_INTERFACE="mmc"
|
||||
CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
|
||||
diff --git a/configs/rpi_defconfig b/configs/rpi_defconfig
|
||||
index db42ffd135..0ec1365b1b 100644
|
||||
index e7820cb147b..d248873174d 100644
|
||||
--- a/configs/rpi_defconfig
|
||||
+++ b/configs/rpi_defconfig
|
||||
@@ -13,7 +13,7 @@ CONFIG_SYS_PROMPT="U-Boot> "
|
||||
CONFIG_CMD_GPIO=y
|
||||
@@ -14,7 +14,7 @@ CONFIG_CMD_GPIO=y
|
||||
CONFIG_CMD_MMC=y
|
||||
CONFIG_CMD_USB=y
|
||||
CONFIG_CMD_FS_UUID=y
|
||||
-CONFIG_OF_EMBED=y
|
||||
+CONFIG_OF_BOARD=y
|
||||
CONFIG_DEFAULT_DEVICE_TREE="bcm2835-rpi-b"
|
||||
CONFIG_ENV_FAT_INTERFACE="mmc"
|
||||
CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
|
||||
--
|
||||
2.19.0.rc0
|
||||
2.19.2
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (u-boot-2018.11.tar.bz2) = 1ea0bbb5f5e6d4c60b3a6bd345d1fa6e9da025daf36f47e8392bab34cb432c2e3633d903efb260f71fff87dffd6f2bf09ac900e96b3d4247073958d83b89ceff
|
||||
SHA512 (u-boot-2019.01-rc1.tar.bz2) = 415581e8aadd37210f5ccdaf4fb64f81b348d553f1b8732931a10aef89f55c0647f7d45fb759aa2ca0c4c624485269c15ee18b55a1cad73a48116af2d4634e40
|
||||
|
@ -1,67 +0,0 @@
|
||||
From 82cc7aca5fb7c7103256229a3ead0b8075da5813 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Wed, 5 Sep 2018 17:00:25 +0100
|
||||
Subject: [PATCH] sunxi: DT: A64: add Pine64-LTS support
|
||||
|
||||
The Pine64-LTS board is a new board version of the Pine64, though
|
||||
actually it's a non-SoM version of the SoPine and its baseboard.
|
||||
In contrast to the original Pine64 it features LPDDR3 DRAM, an eMMC
|
||||
socket and a SPI flash chip for storing firmware (like U-Boot).
|
||||
Add it as a variant to the existing SoPine defconfig, since from a
|
||||
software point of view they are really not different.
|
||||
|
||||
Signed-off-by: Andre Przywara <andre.przywara@arm.com>
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
arch/arm/dts/Makefile | 1 +
|
||||
arch/arm/dts/sun50i-a64-pine64-lts.dts | 13 +++++++++++++
|
||||
configs/sopine_baseboard_defconfig | 1 +
|
||||
3 files changed, 15 insertions(+)
|
||||
create mode 100644 arch/arm/dts/sun50i-a64-pine64-lts.dts
|
||||
|
||||
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
||||
index ebfa227262..6cd440d6af 100644
|
||||
--- a/arch/arm/dts/Makefile
|
||||
+++ b/arch/arm/dts/Makefile
|
||||
@@ -401,6 +401,7 @@ dtb-$(CONFIG_MACH_SUN50I) += \
|
||||
sun50i-a64-nanopi-a64.dtb \
|
||||
sun50i-a64-olinuxino.dtb \
|
||||
sun50i-a64-orangepi-win.dtb \
|
||||
+ sun50i-a64-pine64-lts.dtb \
|
||||
sun50i-a64-pine64-plus.dtb \
|
||||
sun50i-a64-pine64.dtb \
|
||||
sun50i-a64-sopine-baseboard.dtb
|
||||
diff --git a/arch/arm/dts/sun50i-a64-pine64-lts.dts b/arch/arm/dts/sun50i-a64-pine64-lts.dts
|
||||
new file mode 100644
|
||||
index 0000000000..72d6961dc3
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/dts/sun50i-a64-pine64-lts.dts
|
||||
@@ -0,0 +1,13 @@
|
||||
+/*
|
||||
+ * SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
||||
+ *
|
||||
+ * Copyright (c) 2018 ARM Ltd.
|
||||
+ */
|
||||
+
|
||||
+#include "sun50i-a64-sopine-baseboard.dts"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Pine64 LTS";
|
||||
+ compatible = "pine64,pine64-lts", "allwinner,sun50i-r18",
|
||||
+ "allwinner,sun50i-a64";
|
||||
+};
|
||||
diff --git a/configs/sopine_baseboard_defconfig b/configs/sopine_baseboard_defconfig
|
||||
index 9ede081c08..eead38a1e3 100644
|
||||
--- a/configs/sopine_baseboard_defconfig
|
||||
+++ b/configs/sopine_baseboard_defconfig
|
||||
@@ -15,6 +15,7 @@ CONFIG_NR_DRAM_BANKS=1
|
||||
# CONFIG_SPL_DOS_PARTITION is not set
|
||||
# CONFIG_SPL_EFI_PARTITION is not set
|
||||
CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-sopine-baseboard"
|
||||
+CONFIG_OF_LIST="sun50i-a64-sopine-baseboard sun50i-a64-pine64-lts"
|
||||
CONFIG_SUN8I_EMAC=y
|
||||
CONFIG_USB_EHCI_HCD=y
|
||||
CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y
|
||||
--
|
||||
2.19.0.rc0
|
||||
|
63
tools-add-a-generic-config-for-native-tools-building.patch
Normal file
63
tools-add-a-generic-config-for-native-tools-building.patch
Normal file
@ -0,0 +1,63 @@
|
||||
From patchwork Tue Dec 4 11:24:51 2018
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [U-Boot] tools: add a generic config for native tools building
|
||||
X-Patchwork-Submitter: Otavio Salvador <otavio@ossystems.com.br>
|
||||
X-Patchwork-Id: 1007581
|
||||
Message-Id: <20181204112452.10544-1-otavio@ossystems.com.br>
|
||||
To: U-Boot Mailing List <u-boot@lists.denx.de>
|
||||
Cc: Alexander Graf <agraf@suse.de>, Ryder Lee <ryder.lee@mediatek.com>,
|
||||
Otavio Salvador <otavio@ossystems.com.br>,
|
||||
Vagrant Cascadian <vagrant@debian.org>,
|
||||
Heinrich Schuchardt <xypron.glpk@gmx.de>,
|
||||
Alexey Brodkin <alexey.brodkin@synopsys.com>,
|
||||
Michal Simek <michal.simek@xilinx.com>
|
||||
Date: Tue, 4 Dec 2018 09:24:51 -0200
|
||||
From: Otavio Salvador <otavio@ossystems.com.br>
|
||||
List-Id: U-Boot discussion <u-boot.lists.denx.de>
|
||||
|
||||
The motivation for this is to allow distributions to distribute all
|
||||
possible tools in a generic way, avoiding the need of specific tools
|
||||
building for each machine.
|
||||
|
||||
Especially on OpenEmbedded / Yocto Project ecosystem, it is very
|
||||
common each BSP to end providing their specific tools when they need
|
||||
to generate images for some SoC (e.g MX23 / MX28 in meta-freescale
|
||||
case).
|
||||
|
||||
Using this, we can package the tools doing:
|
||||
|
||||
$: make tools-all_defconfig
|
||||
$: make tools-all
|
||||
|
||||
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
|
||||
---
|
||||
|
||||
configs/tools-all_defconfig | 3 +++
|
||||
tools/Makefile | 2 +-
|
||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
||||
create mode 100644 configs/tools-all_defconfig
|
||||
|
||||
diff --git a/configs/tools-all_defconfig b/configs/tools-all_defconfig
|
||||
new file mode 100644
|
||||
index 0000000000..be69bdf43a
|
||||
--- /dev/null
|
||||
+++ b/configs/tools-all_defconfig
|
||||
@@ -0,0 +1,3 @@
|
||||
+CONFIG_SYS_TEXT_BASE=0
|
||||
+CONFIG_FIT=y
|
||||
+CONFIG_FIT_SIGNATURE=y
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index c93d17a42f..29ff6ed221 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -125,7 +125,7 @@ fit_info-objs := $(dumpimage-mkimage-objs) fit_info.o
|
||||
fit_check_sign-objs := $(dumpimage-mkimage-objs) fit_check_sign.o
|
||||
file2include-objs := file2include.o
|
||||
|
||||
-ifneq ($(CONFIG_MX23)$(CONFIG_MX28),)
|
||||
+ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
|
||||
# Add CONFIG_MXS into host CFLAGS, so we can check whether or not register
|
||||
# the mxsimage support within tools/mxsimage.c .
|
||||
HOSTCFLAGS_mxsimage.o += -DCONFIG_MXS
|
@ -1,8 +1,8 @@
|
||||
#global candidate rc3
|
||||
%global candidate rc1
|
||||
|
||||
Name: uboot-tools
|
||||
Version: 2018.11
|
||||
Release: 1%{?candidate:.%{candidate}}%{?dist}
|
||||
Version: 2019.01
|
||||
Release: 0.1%{?candidate:.%{candidate}}%{?dist}
|
||||
Summary: U-Boot utilities
|
||||
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
|
||||
URL: http://www.denx.de/wiki/U-Boot
|
||||
@ -20,7 +20,7 @@ Patch1: uefi-use-Fedora-specific-path-name.patch
|
||||
# general fixes
|
||||
Patch2: uefi-distro-load-FDT-from-any-partition-on-boot-device.patch
|
||||
Patch3: usb-kbd-fixes.patch
|
||||
Patch4: make-tools-all-defconfig-a-thing.patch
|
||||
Patch4: tools-add-a-generic-config-for-native-tools-building.patch
|
||||
|
||||
# Board fixes and enablement
|
||||
Patch10: rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
|
||||
@ -29,8 +29,7 @@ Patch12: dragonboard-fixes.patch
|
||||
Patch13: tegra186-jetson-tx2-disable-onboard-emmc.patch
|
||||
Patch14: tegra-TXx-Add-CONFIG_EFI_LOADER_BOUNCE_BUFFER.patch
|
||||
Patch15: tegra-fix-tx1.patch
|
||||
Patch16: sunxi-DT-A64-add-Pine64-LTS-support.patch
|
||||
Patch17: mmc-fsl_esdhc-Avoid-infinite-loop-in-esdhc_send_cmd_common.patch
|
||||
Patch16: mmc-fsl_esdhc-Avoid-infinite-loop-in-esdhc_send_cmd_common.patch
|
||||
|
||||
BuildRequires: bc
|
||||
BuildRequires: dtc
|
||||
@ -317,6 +316,10 @@ cp -p board/warp7/README builds/docs/README.warp7
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Dec 4 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2019.01-0.1-rc1
|
||||
- 2019.01 RC1
|
||||
- Enable new devices
|
||||
|
||||
* Tue Dec 4 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2018.11-1
|
||||
- 2018.11
|
||||
- Build with ATF 2.0
|
||||
|
@ -1,19 +1,19 @@
|
||||
From 1a8fa60aedff8a2368ac357a51dc15357065fabe Mon Sep 17 00:00:00 2001
|
||||
From a49845f198af088c4e5e0019edbf519344d78c97 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Tue, 5 Dec 2017 00:11:54 +0000
|
||||
Subject: [PATCH 3/5] usb kbd fixes
|
||||
Date: Tue, 4 Dec 2018 15:29:14 +0000
|
||||
Subject: [PATCH] usb kbd fixes
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
common/usb_kbd.c | 66 +++++++++++++++++++++++++++++++++++++++++--------------
|
||||
common/usb_kbd.c | 66 +++++++++++++++++++++++++++++++++++------------
|
||||
include/console.h | 2 --
|
||||
2 files changed, 50 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/common/usb_kbd.c b/common/usb_kbd.c
|
||||
index 8cbdba6ac2..82ad93f6ca 100644
|
||||
index 020f0d4117f..47674ce4458 100644
|
||||
--- a/common/usb_kbd.c
|
||||
+++ b/common/usb_kbd.c
|
||||
@@ -516,25 +516,59 @@ static int probe_usb_keyboard(struct usb_device *dev)
|
||||
@@ -518,25 +518,59 @@ static int probe_usb_keyboard(struct usb_device *dev)
|
||||
return error;
|
||||
|
||||
stdinname = env_get("stdin");
|
||||
@ -87,8 +87,8 @@ index 8cbdba6ac2..82ad93f6ca 100644
|
||||
+#endif
|
||||
}
|
||||
|
||||
#ifndef CONFIG_DM_USB
|
||||
@@ -640,7 +674,7 @@ static int usb_kbd_remove(struct udevice *dev)
|
||||
#if !CONFIG_IS_ENABLED(DM_USB)
|
||||
@@ -642,7 +676,7 @@ static int usb_kbd_remove(struct udevice *dev)
|
||||
|
||||
return 0;
|
||||
err:
|
||||
@ -98,10 +98,10 @@ index 8cbdba6ac2..82ad93f6ca 100644
|
||||
}
|
||||
|
||||
diff --git a/include/console.h b/include/console.h
|
||||
index cea29ed6dc..7dfd36d7d1 100644
|
||||
index e935c601f12..6382ec8e0d6 100644
|
||||
--- a/include/console.h
|
||||
+++ b/include/console.h
|
||||
@@ -57,8 +57,6 @@ int console_announce_r(void);
|
||||
@@ -56,8 +56,6 @@ int console_announce_r(void);
|
||||
/*
|
||||
* CONSOLE multiplexing.
|
||||
*/
|
||||
@ -111,5 +111,5 @@ index cea29ed6dc..7dfd36d7d1 100644
|
||||
|
||||
#endif
|
||||
--
|
||||
2.14.3
|
||||
2.19.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user