Merge remote-tracking branch 'up/master' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2019-11-01 05:45:44 +02:00
commit 12e45d3b64
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
7 changed files with 7786 additions and 172 deletions

View File

@ -1,106 +0,0 @@
From patchwork Tue Sep 24 15:10:24 2019
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
X-Patchwork-Submitter: Mian Yousaf Kaukab <ykaukab@suse.de>
X-Patchwork-Id: 1166676
X-Patchwork-Delegate: xypron.glpk@gmx.de
Return-Path: <u-boot-bounces@lists.denx.de>
X-Original-To: incoming@patchwork.ozlabs.org
Delivered-To: patchwork-incoming@bilbo.ozlabs.org
Authentication-Results: ozlabs.org;
spf=none (mailfrom) smtp.mailfrom=lists.denx.de
(client-ip=81.169.180.215; helo=lists.denx.de;
envelope-from=u-boot-bounces@lists.denx.de;
receiver=<UNKNOWN>)
Authentication-Results: ozlabs.org;
dmarc=none (p=none dis=none) header.from=suse.de
Received: from lists.denx.de (dione.denx.de [81.169.180.215])
by ozlabs.org (Postfix) with ESMTP id 46d4Ps4qsmz9sP3
for <incoming@patchwork.ozlabs.org>;
Wed, 25 Sep 2019 01:10:41 +1000 (AEST)
Received: by lists.denx.de (Postfix, from userid 105)
id 23898C21E2F; Tue, 24 Sep 2019 15:10:34 +0000 (UTC)
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on lists.denx.de
X-Spam-Level:
X-Spam-Status: No, score=0.0 required=5.0 tests=none autolearn=unavailable
autolearn_force=no version=3.4.0
Received: from lists.denx.de (localhost [IPv6:::1])
by lists.denx.de (Postfix) with ESMTP id A6013C21C4A;
Tue, 24 Sep 2019 15:10:32 +0000 (UTC)
Received: by lists.denx.de (Postfix, from userid 105)
id CEBD7C21C4A; Tue, 24 Sep 2019 15:10:30 +0000 (UTC)
Received: from mx1.suse.de (mx2.suse.de [195.135.220.15])
by lists.denx.de (Postfix) with ESMTPS id EC062C21C38
for <u-boot@lists.denx.de>; Tue, 24 Sep 2019 15:10:26 +0000 (UTC)
X-Virus-Scanned: by amavisd-new at test-mx.suse.de
Received: from relay2.suse.de (unknown [195.135.220.254])
by mx1.suse.de (Postfix) with ESMTP id 6EC7DABF4;
Tue, 24 Sep 2019 15:10:26 +0000 (UTC)
From: Mian Yousaf Kaukab <ykaukab@suse.de>
To: u-boot@lists.denx.de
Date: Tue, 24 Sep 2019 17:10:24 +0200
Message-Id: <20190924151024.13297-1-ykaukab@suse.de>
X-Mailer: git-send-email 2.16.4
Cc: xypron.glpk@gmx.de, swarren@nvidia.com
Subject: [U-Boot] [PATCH] Revert "ARM: tegra: reserve unmapped RAM so EFI
doesn't use it"
X-BeenThere: u-boot@lists.denx.de
X-Mailman-Version: 2.1.18
Precedence: list
List-Id: U-Boot discussion <u-boot.lists.denx.de>
List-Unsubscribe: <https://lists.denx.de/options/u-boot>,
<mailto:u-boot-request@lists.denx.de?subject=unsubscribe>
List-Archive: <http://lists.denx.de/pipermail/u-boot/>
List-Post: <mailto:u-boot@lists.denx.de>
List-Help: <mailto:u-boot-request@lists.denx.de?subject=help>
List-Subscribe: <https://lists.denx.de/listinfo/u-boot>,
<mailto:u-boot-request@lists.denx.de?subject=subscribe>
MIME-Version: 1.0
Errors-To: u-boot-bounces@lists.denx.de
Sender: "U-Boot" <u-boot-bounces@lists.denx.de>
This reverts commit 0797f7f0b7e1d7853e2842ddc235ffef139fa792.
Tegra specific solution is not required any more as efi core has been
made aware of ram_top with the following commit:
7b78d6438a efi_loader: Reserve unaccessible memory
Signed-off-by: Mian Yousaf Kaukab <ykaukab@suse.de>
Tested-by: Stephen Warren <swarren@nvidia.com>
---
arch/arm/mach-tegra/board2.c | 14 --------------
1 file changed, 14 deletions(-)
diff --git a/arch/arm/mach-tegra/board2.c b/arch/arm/mach-tegra/board2.c
index f13bd256cc..07f54f0684 100644
--- a/arch/arm/mach-tegra/board2.c
+++ b/arch/arm/mach-tegra/board2.c
@@ -6,7 +6,6 @@
#include <common.h>
#include <dm.h>
-#include <efi_loader.h>
#include <env.h>
#include <errno.h>
#include <ns16550.h>
@@ -224,19 +223,6 @@ int board_early_init_f(void)
int board_late_init(void)
{
-#if CONFIG_IS_ENABLED(EFI_LOADER)
- if (gd->bd->bi_dram[1].start) {
- /*
- * Only bank 0 is below board_get_usable_ram_top(), so all of
- * bank 1 is not mapped by the U-Boot MMU configuration, and so
- * we must prevent EFI from using it.
- */
- efi_add_memory_map(gd->bd->bi_dram[1].start,
- gd->bd->bi_dram[1].size >> EFI_PAGE_SHIFT,
- EFI_BOOT_SERVICES_DATA, false);
- }
-#endif
-
#if defined(CONFIG_TEGRA_SUPPORT_NON_SECURE)
if (tegra_cpu_is_non_secure()) {
printf("CPU is in NS mode\n");

View File

@ -1,42 +0,0 @@
From f6bfab7799821fbb7289b5cd0b932220dec81a00 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Tue, 8 Oct 2019 10:52:07 +0100
Subject: [PATCH] Revert "spl: imx6: Let spl_boot_device return USDHC1 or
USDHC2"
This reverts commit 14d319b1856b86e593e01abd0a1e3c2d63b52a8a.
---
arch/arm/mach-imx/spl.c | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/arch/arm/mach-imx/spl.c b/arch/arm/mach-imx/spl.c
index 1f230aca33..9f1e0f6a72 100644
--- a/arch/arm/mach-imx/spl.c
+++ b/arch/arm/mach-imx/spl.c
@@ -24,7 +24,6 @@ u32 spl_boot_device(void)
{
unsigned int bmode = readl(&src_base->sbmr2);
u32 reg = imx6_src_get_boot_mode();
- u32 mmc_index = ((reg >> 11) & 0x03);
/*
* Check for BMODE if serial downloader is enabled
@@ -85,12 +84,11 @@ u32 spl_boot_device(void)
/* SD/eSD: 8.5.3, Table 8-15 */
case IMX6_BMODE_SD:
case IMX6_BMODE_ESD:
+ return BOOT_DEVICE_MMC1;
+ /* MMC/eMMC: 8.5.3 */
case IMX6_BMODE_MMC:
case IMX6_BMODE_EMMC:
- if (mmc_index == 1)
- return BOOT_DEVICE_MMC2;
- else
- return BOOT_DEVICE_MMC1;
+ return BOOT_DEVICE_MMC1;
/* NAND Flash: 8.5.2, Table 8-10 */
case IMX6_BMODE_NAND_MIN ... IMX6_BMODE_NAND_MAX:
return BOOT_DEVICE_NAND;
--
2.21.0

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -1 +1 @@
SHA512 (u-boot-2019.10.tar.bz2) = d8e98fca4b6af8d49d20ec09beab16b77863fcee88cda3605cc14435de21030bf3ca5e7cf7d06e42d4c0f75279c7295ecd628d2b77666eff7b7fd50374e051fd
SHA512 (u-boot-2020.01-rc1.tar.bz2) = f376101af005423bbfdb20b1563662ef208fb2c2cac000a2796e67e90e17acd1f422f5e60ccaee8d7a4723faf306e254571dcc3222c32821ace3b379f83b6f09

35
tools-fix-version.h.patch Normal file
View File

@ -0,0 +1,35 @@
From 097ce774b6739aa6a52e4d79e2920e3ef5af41d3 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Thu, 31 Oct 2019 09:19:23 +0000
Subject: [PATCH] tools: fix version.h
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
---
Makefile | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
index 58a5721b3d..7b40069d9f 100644
--- a/Makefile
+++ b/Makefile
@@ -1848,14 +1848,14 @@ checkarmreloc: u-boot
false; \
fi
-tools/version.h: include/version.h
+version.h: include/version.h
$(call if_changed,copy)
-envtools: scripts_basic $(version_h) $(timestamp_h) tools/version.h
+envtools: scripts_basic $(version_h) $(timestamp_h) version.h
$(Q)$(MAKE) $(build)=tools/env
tools-only: export TOOLS_ONLY=y
-tools-only: scripts_basic $(version_h) $(timestamp_h) tools/version.h
+tools-only: scripts_basic $(version_h) $(timestamp_h) version.h
$(Q)$(MAKE) $(build)=tools
tools-all: export HOST_TOOLS_ALL=y
--
2.23.0

View File

@ -1,8 +1,8 @@
#global candidate rc1
%global candidate rc1
Name: uboot-tools
Version: 2019.10
Release: 2%{?candidate:.%{candidate}}.4.riscv64%{?dist}
Version: 2020.01
Release: 0.1%{?candidate:.%{candidate}}.0.riscv64%{?dist}
Summary: U-Boot utilities
License: GPLv2+ BSD LGPL-2.1+ LGPL-2.0+
URL: http://www.denx.de/wiki/U-Boot
@ -22,16 +22,17 @@ Patch1: uefi-distro-load-FDT-from-any-partition-on-boot-device.patch
Patch2: uefi-use-Fedora-specific-path-name.patch
# Board fixes and enablement
Patch5: usb-kbd-fixes.patch
Patch6: rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
Patch7: dragonboard-fixes.patch
Patch8: ARM-tegra-Add-NVIDIA-Jetson-Nano.patch
Patch9: arm-tegra-defaine-fdtfile-for-all-devices.patch
Patch10: Revert-spl-imx6-Let-spl_boot_device-return-USDHC1-or.patch
Patch11: Revert-ARM-tegra-reserve-unmapped-RAM-so-EFI-doesn-t-use-it.patch
Patch12: rockchip-rk3399-rock960-Update-config-for-TPL.patch
Patch13: rockchip-dts-rk3328-rock64-Add-same-as-spl-order.patch
Patch14: rockchip-rk3328-Fix-memory-instability-on-ROCK64.patch
Patch4: usb-kbd-fixes.patch
Patch5: rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
Patch6: dragonboard-fixes.patch
Patch7: ARM-tegra-Add-NVIDIA-Jetson-Nano.patch
Patch8: arm-tegra-defaine-fdtfile-for-all-devices.patch
Patch9: rockchip-rk3399-rock960-Update-config-for-TPL.patch
Patch10: rockchip-dts-rk3328-rock64-Add-same-as-spl-order.patch
Patch11: rockchip-rk3328-Fix-memory-instability-on-ROCK64.patch
Patch12: fdt-Switch-to-the-latest-libfdt-sort-of.patch
Patch13: scripts-Convert-to-Python-3.patch
Patch14: tools-fix-version.h.patch
# PXE depends on fdt_addr (mandatory)
# fdt_addr is an address to DTB in HW (e.g. ROM)
@ -74,19 +75,22 @@ Patch26: uboot-riscv-def-kernel_gz_addr_r-kernel_gz_size.patch
BuildRequires: bc
BuildRequires: dtc
BuildRequires: make
# Added for .el7 rebuild, so newer gcc is used
# Requirements for building on el7
%if 0%{?rhel} == 7
BuildRequires: devtoolset-7-build
BuildRequires: devtoolset-7-binutils
BuildRequires: devtoolset-7-gcc
BuildRequires: python2-devel
BuildRequires: python3-setuptools
BuildRequires: python2-libfdt
%else
BuildRequires: gcc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-libfdt
%endif
BuildRequires: flex bison
BuildRequires: openssl-devel
BuildRequires: python2-devel
BuildRequires: python2-setuptools
#BuildRequires: python2-libfdt
BuildRequires: SDL-devel
BuildRequires: swig
%ifarch %{arm} aarch64
@ -142,7 +146,7 @@ u-boot bootloader binaries for riscv64 boards
cp %SOURCE1 %SOURCE2 %SOURCE3 %SOURCE4 %SOURCE6 .
sed -i 's/python/python2/' arch/arm/mach-rockchip/make_fit_atf.py
sed -i 's/python/python3/' arch/arm/mach-rockchip/make_fit_atf.py
%build
mkdir builds
@ -331,15 +335,15 @@ cp -p board/warp7/README builds/docs/README.warp7
%endif
%changelog
* Wed Oct 30 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2019.10-2.4.riscv64
* Thu Nov 1 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2020.01-0.1.0.riscv64
- Add support for RISC-V (riscv64)
- Define kernel_gz_size and kernel_gz_addr_r for QEMU virt and SiFive FU540 boards
to support Image.gz with booti
* Mon Oct 28 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2019.10-2.1.riscv64
- Add 'addappend' label to PXE/EXTLINUX configuration
* Thu Oct 17 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> 2019.10-2.0.riscv64
- Add support for RISC-V (riscv64)
* Wed Oct 30 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2020.01-0.1
- 2020.01 RC1
- Initial migration to python3
* Wed Oct 9 2019 Peter Robinson <pbrobinson@fedoraproject.org> 2019.10-2
- Fixes for Rockchips rk3328 and rk3399 platforms