Update to latest release for Java 10 support

Drop upstreamed patch
This commit is contained in:
Mat Booth 2018-06-05 16:36:25 +01:00
parent 5463eb9bfc
commit afff5fa0b6
4 changed files with 13 additions and 76 deletions

View File

@ -1,60 +0,0 @@
diff --git a/tycho-core/src/main/java/org/eclipse/tycho/core/locking/FileLockServiceImpl.java b/tycho-core/src/main/java/org/eclipse/tycho/core/locking/FileLockServiceImpl.java
index ae8d6c88..197e104d 100644
--- a/tycho-core/src/main/java/org/eclipse/tycho/core/locking/FileLockServiceImpl.java
+++ b/tycho-core/src/main/java/org/eclipse/tycho/core/locking/FileLockServiceImpl.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 2011 SAP AG and others.
+ * Copyright (c) 2011, 2018 SAP AG and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -29,7 +29,7 @@ public class FileLockServiceImpl implements FileLockService {
private Location anyLocation;
public FileLockServiceImpl() {
- anyLocation = new BasicLocation(null, null, false, null, new ConfigValues(new HashMap<String, String>()),
+ anyLocation = new BasicLocation(null, null, false, null, new ConfigValues(new HashMap<String, String>(), new HashMap<Throwable, Integer>()),
new EquinoxContainer(null), new AtomicBoolean(false));
}
diff --git a/tycho-core/src/main/java/org/eclipse/tycho/core/osgitools/EquinoxResolver.java b/tycho-core/src/main/java/org/eclipse/tycho/core/osgitools/EquinoxResolver.java
index 941a84b9..b072823c 100644
--- a/tycho-core/src/main/java/org/eclipse/tycho/core/osgitools/EquinoxResolver.java
+++ b/tycho-core/src/main/java/org/eclipse/tycho/core/osgitools/EquinoxResolver.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 2008, 2013 Sonatype Inc. and others.
+ * Copyright (c) 2008, 2018 Sonatype Inc. and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -276,6 +276,7 @@ public class EquinoxResolver {
systemBundleManifest.put(Constants.BUNDLE_SYMBOLICNAME, SYSTEM_BUNDLE_SYMBOLIC_NAME);
systemBundleManifest.put(Constants.BUNDLE_VERSION, "0.0.0");
systemBundleManifest.put(Constants.BUNDLE_MANIFESTVERSION, "2");
+ systemBundleManifest.put(StateImpl.Eclipse_JREBUNDLE, "true");
if (systemPackages != null && systemPackages.trim().length() > 0) {
systemBundleManifest.put(Constants.EXPORT_PACKAGE, systemPackages);
} else {
diff --git a/tycho-core/src/test/java/org/eclipse/tycho/core/osgitools/EquinoxResolverTest.java b/tycho-core/src/test/java/org/eclipse/tycho/core/osgitools/EquinoxResolverTest.java
index e062e0b7..56462e8c 100644
--- a/tycho-core/src/test/java/org/eclipse/tycho/core/osgitools/EquinoxResolverTest.java
+++ b/tycho-core/src/test/java/org/eclipse/tycho/core/osgitools/EquinoxResolverTest.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 2012 Sonatype Inc. and others.
+ * Copyright (c) 2012, 2018 Sonatype Inc. and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -68,6 +68,8 @@ public class EquinoxResolverTest extends AbstractTychoMojoTestCase {
.getFullSpecification();
assertEquals("CDC-1.0/Foundation-1.0", ee.getProfileName());
Properties platformProperties = subject.getPlatformProperties(projects.get(2), ee);
- assertEquals("javax.microedition.io", platformProperties.get(Constants.FRAMEWORK_SYSTEMPACKAGES));
+ assertEquals(
+ "java.io,java.lang,java.lang.ref,java.lang.reflect,java.math,java.net,java.security,java.security.acl,java.security.cert,java.security.interfaces,java.security.spec,java.text,java.text.resources,java.util,java.util.jar,java.util.zip,javax.microedition.io",
+ platformProperties.get(Constants.FRAMEWORK_SYSTEMPACKAGES));
}
}

View File

@ -41,7 +41,7 @@ index c43cc8d..6e5fde4 100644
+ <surefire-version>2.21.0</surefire-version>
<!-- dependencies to Eclipse artifacts deployed by tycho-releng/ -->
<equinoxVersion>3.12.100</equinoxVersion>
<equinoxVersion>3.13.0.v20180226-1711</equinoxVersion>
diff --git a/tycho-surefire/org.eclipse.tycho.surefire.junit/pom.xml b/tycho-surefire/org.eclipse.tycho.surefire.junit/pom.xml
index f99c319..0224cc6 100644
--- a/tycho-surefire/org.eclipse.tycho.surefire.junit/pom.xml
@ -106,7 +106,7 @@ index 991edc1..83732d5 100644
+++ b/tycho-surefire/org.eclipse.tycho.surefire.osgibooter/META-INF/MANIFEST.MF
@@ -5,9 +5,11 @@ Require-Bundle: org.eclipse.osgi;bundle-version="3.2.2",
Eclipse-AutoStart: true
Bundle-Version: 1.2.0.qualifier
Bundle-Version: 1.2.0
Bundle-ClassPath: .,
- jars/surefire-booter-2.19.1.jar,
- jars/surefire-api-2.19.1.jar,

View File

@ -1,3 +1,3 @@
SHA512 (fedoraproject-p2-290f67a4c717599b2f5166ea89aa5365571314b1.tar.gz) = 5ddfa3e7c1dc3d64335d836d74d7325904f294e0ab1782de41a8815b09ddf42f0c47a263c3a6217626aaf293a17788d01174c327e17b192a0f451d07d5655c49
SHA512 (tycho-5d018bb7d0c2d09275a00b4863e8ac6d5fa04541.tar.gz) = c307d13d8edbe7aafc8ee489d76ef1fc9c60db668fba1ca99a9970e1aceb18154071256f24ebdeba47dd707795ba4a797b10f4c45b9c95228eb77b1afee981c4
SHA512 (org.eclipse.tycho-tycho-1.2.0.tar.xz) = 1d08e3c7865ed7c4fc9097146fb8f4aaca39e5a82d1bc9f830a1c8d1661339de2e652195c9aad273738c3a221c19255acfa0533e910ce2e4cf2a85d880d7f51e
SHA512 (eclipse-bootstrap-photon.tar.xz) = c18687eecd7d79bbd0722e8effc89d32a8fe31f2c9fe978cc73cfe9679d5a7fd01d8e12483404e3257d86817b7a12b4dcdfbd88316855a06d8f43da71a3c49a8

View File

@ -12,7 +12,7 @@
%bcond_with bootstrap
# Release tags or git SHAs
%global git_tag 5d018bb7d0c2d09275a00b4863e8ac6d5fa04541
%global git_tag tycho-%{version}
%global fp_p2_git_tag 290f67a4c717599b2f5166ea89aa5365571314b1
%global fp_p2_version 0.0.1
@ -22,7 +22,7 @@
Name: tycho
Version: 1.2.0
Release: 0.5.git5d018bb%{?dist}
Release: 1%{?dist}
Summary: Plugins and extensions for building Eclipse plugins and OSGI bundles with Maven
# license file is missing but all files having some licensing information are ASL 2.0
@ -30,7 +30,7 @@ License: ASL 2.0 and EPL
URL: http://eclipse.org/tycho
# Tycho project source
Source0: https://github.com/eclipse/tycho/archive/%{git_tag}/tycho-%{git_tag}.tar.gz
Source0: http://git.eclipse.org/c/tycho/org.eclipse.tycho.git/snapshot/org.eclipse.tycho-%{git_tag}.tar.xz
# Eclipse Plugin Project supporting filesystem as p2 repository
Source1: https://github.com/rgrunber/fedoraproject-p2/archive/%{fp_p2_git_tag}/fedoraproject-p2-%{fp_p2_git_tag}.tar.gz
@ -52,14 +52,12 @@ Source10: eclipse-bootstrap-photon.tar.xz
%endif
Patch0: tycho-fix-build.patch
# Submitted upstream: https://bugs.eclipse.org/bugs/show_bug.cgi?id=535564
Patch1: tycho-maven-archiver-3.0.1.patch
Patch2: %{name}-use-custom-resolver.patch
Patch3: %{name}-maven-delegation.patch
# Changes needed for building against photon
# Submitted upstream in https://bugs.eclipse.org/bugs/show_bug.cgi?id=534255
Patch4: build-against-photon-equinox.patch
# Changes needed for building against latest surefire
Patch5: build-against-surefire-2.21.patch
Patch4: build-against-surefire-2.21.patch
BuildArch: noarch
@ -167,7 +165,7 @@ Summary: Javadocs for %{name}
This package contains the API documentation for %{name}.
%prep
%setup -q -n tycho-%{git_tag} -a 1
%setup -q -n org.eclipse.tycho-%{git_tag} -a 1
mv fedoraproject-p2-%{fp_p2_git_tag} fedoraproject-p2
%patch0 -p1
@ -175,18 +173,13 @@ mv fedoraproject-p2-%{fp_p2_git_tag} fedoraproject-p2
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
# Unneeded for RPM builds
%pom_remove_plugin :maven-site-plugin
# Switch for "tycho" platform deps
%pom_change_dep org.eclipse.platform: org.eclipse.tycho: . tycho-core sisu-equinox/sisu-equinox-embedder
%pom_change_dep org.eclipse.jdt: org.eclipse.tycho: . tycho-compiler-jdt
sed -i -e 's/>%{version}-SNAPSHOT</>%{version}</' $(grep -rl '>%{version}-SNAPSHOT<' --include=pom.xml)
sed -i -e 's/\.qualifier//' $(find tycho-{surefire,bundles} -maxdepth 3 -name MANIFEST.MF)
# Move from org.sonatype.aether to org.eclipse.aether
find . -name "*.java" | xargs sed -i 's/org.sonatype.aether/org.eclipse.aether/g'
find . -name "*.java" | xargs sed -i 's/org.eclipse.aether.util.DefaultRepositorySystemSession/org.eclipse.aether.DefaultRepositorySystemSession/g'
@ -366,6 +359,10 @@ ln -s %{_javadir}/tycho/org.fedoraproject.p2.jar %{buildroot}${xmvn_libdir}/inst
%files javadoc -f .mfiles-javadoc
%changelog
* Tue Jun 05 2018 Mat Booth <mat.booth@redhat.com> - 1.2.0-1
- Update to latest release for Java 10 support
- Drop upstreamed patch
* Wed May 09 2018 Mat Booth <mat.booth@redhat.com> - 1.2.0-0.5.git5d018bb
- Surefure now used maven-shared-utils instead of plexus-utils, fixes test runs
in other packages