Update to 0.23.0 release
- Allow tycho-bootstrap.sh to work with "set -e" to fail faster and see errors more easily
This commit is contained in:
parent
3e8366cfcd
commit
236cba38ad
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
2cfc11196f68212dbaf9e6eb364c4a98 fedoraproject-p2-7a5a01.tar.xz
|
||||
d7ee912e8da240c8d87892ed876960ae org.eclipse.tycho-tycho-0.22.0.tar.bz2
|
||||
0a14e091316e0a467f94c7821b9e21e6 org.eclipse.tycho-tycho-0.23.0.tar.xz
|
||||
c600a5115f29962c974b75b4b25e74f1 eclipse-bootstrap.tar.xz
|
||||
|
@ -1,10 +1,10 @@
|
||||
#! /bin/bash
|
||||
#! /bin/bash -e
|
||||
|
||||
. $(pwd)/tycho-scripts.sh
|
||||
|
||||
eclipse_bootstrap=$1
|
||||
preV='0.22.0'
|
||||
v='0.22.0-SNAPSHOT'
|
||||
preV='0.23.0'
|
||||
v='0.23.0-SNAPSHOT'
|
||||
osgiV='3.10.0.v20140328-1811'
|
||||
fp2V='0.0.1-SNAPSHOT'
|
||||
bundles=()
|
||||
@ -30,7 +30,7 @@ xtraDeps[0]=""
|
||||
|
||||
externalDeps[4]="org.eclipse.equinox.common,org.eclipse.equinox.p2.repository,org.eclipse.equinox.p2.metadata,org.eclipse.equinox.p2.core,org.eclipse.equinox.p2.metadata.repository,org.eclipse.equinox.p2.artifact.repository,org.eclipse.osgi"
|
||||
externalDeps[5]="org.eclipse.core.runtime,org.eclipse.equinox.security,org.eclipse.equinox.frameworkadmin.equinox,org.eclipse.equinox.frameworkadmin,org.eclipse.equinox.p2.core,org.eclipse.equinox.p2.metadata,org.eclipse.equinox.p2.publisher,org.eclipse.equinox.p2.publisher.eclipse,org.eclipse.equinox.p2.artifact.repository,org.eclipse.equinox.p2.metadata.repository,org.eclipse.equinox.p2.director,org.eclipse.equinox.p2.repository,org.eclipse.equinox.p2.updatesite,org.eclipse.core.net,org.eclipse.equinox.common,org.eclipse.osgi,org.eclipse.equinox.preferences"
|
||||
externalDeps[6]="org.eclipse.equinox.p2.director.app,org.eclipse.equinox.p2.core,org.eclipse.equinox.p2.publisher,org.eclipse.equinox.p2.updatesite,org.eclipse.core.runtime,org.eclipse.equinox.p2.metadata,org.eclipse.equinox.p2.repository,org.eclipse.equinox.p2.repository.tools,org.eclipse.equinox.p2.metadata.repository,org.eclipse.equinox.p2.artifact.repository,org.eclipse.equinox.p2.publisher.eclipse,org.eclipse.equinox.p2.engine,org.eclipse.equinox.p2.director,org.eclipse.osgi,org.eclipse.equinox.common,org.eclipse.equinox.app,org.eclipse.equinox.registry"
|
||||
externalDeps[6]="org.eclipse.equinox.p2.director.app,org.eclipse.equinox.frameworkadmin.equinox,org.eclipse.equinox.frameworkadmin,org.eclipse.equinox.p2.core,org.eclipse.equinox.p2.publisher,org.eclipse.equinox.p2.updatesite,org.eclipse.core.runtime,org.eclipse.equinox.p2.metadata,org.eclipse.equinox.p2.repository,org.eclipse.equinox.p2.repository.tools,org.eclipse.equinox.p2.metadata.repository,org.eclipse.equinox.p2.artifact.repository,org.eclipse.equinox.p2.publisher.eclipse,org.eclipse.equinox.p2.engine,org.eclipse.equinox.p2.director,org.eclipse.osgi,org.eclipse.equinox.common,org.eclipse.equinox.app,org.eclipse.equinox.registry"
|
||||
|
||||
xtraExternalDeps[0]="org.eclipse.osgi,org.eclipse.core.runtime,org.eclipse.equinox.common,org.eclipse.equinox.p2.metadata,org.eclipse.equinox.p2.repository,org.eclipse.equinox.p2.core,org.eclipse.equinox.p2.publisher.eclipse,org.eclipse.equinox.p2.publisher,org.eclipse.equinox.p2.touchpoint.eclipse,org.eclipse.equinox.p2.updatesite,org.eclipse.equinox.p2.repository.tools,org.eclipse.equinox.app,slf4j.api"
|
||||
|
||||
|
@ -169,7 +169,7 @@ diff --git a/tycho-p2/tycho-p2-publisher-plugin/pom.xml b/tycho-p2/tycho-p2-publ
|
||||
index e52cf18..bcd8c91 100644
|
||||
--- a/tycho-p2/tycho-p2-publisher-plugin/pom.xml
|
||||
+++ b/tycho-p2/tycho-p2-publisher-plugin/pom.xml
|
||||
@@ -48,12 +48,6 @@
|
||||
@@ -52,17 +52,6 @@
|
||||
<artifactId>tycho-packaging-plugin</artifactId>
|
||||
<version>${project.version}</version>
|
||||
</dependency>
|
||||
@ -178,6 +178,11 @@ index e52cf18..bcd8c91 100644
|
||||
- <artifactId>tycho-testing-harness</artifactId>
|
||||
- <version>${project.version}</version>
|
||||
- <scope>test</scope>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.mockito</groupId>
|
||||
- <artifactId>mockito-core</artifactId>
|
||||
- <scope>test</scope>
|
||||
- </dependency>
|
||||
</dependencies>
|
||||
|
||||
@ -203,10 +208,10 @@ index 0990b2d..7dd1d68 100644
|
||||
- <classifier>tests</classifier>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
<groupId>org.apache.maven</groupId>
|
||||
<artifactId>maven-compat</artifactId>
|
||||
<groupId>org.mockito</groupId>
|
||||
<artifactId>mockito-core</artifactId>
|
||||
<scope>test</scope>
|
||||
@@ -78,10 +65,19 @@
|
||||
@@ -83,10 +70,19 @@
|
||||
|
||||
<build>
|
||||
<plugins>
|
||||
|
@ -123,34 +123,6 @@ index b71b858..1160f6c 100644
|
||||
validateUniqueBaseDirs(projects);
|
||||
}
|
||||
|
||||
diff --git a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java
|
||||
index e30aae3..0102465 100644
|
||||
--- a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java
|
||||
+++ b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java
|
||||
@@ -27,6 +27,7 @@ import org.apache.maven.project.MavenProjectHelper;
|
||||
import org.codehaus.plexus.archiver.Archiver;
|
||||
import org.codehaus.plexus.archiver.ArchiverException;
|
||||
import org.codehaus.plexus.archiver.tar.TarArchiver;
|
||||
+import org.codehaus.plexus.archiver.tar.TarArchiver.TarCompressionMethod;
|
||||
import org.codehaus.plexus.archiver.tar.TarLongFileMode;
|
||||
import org.eclipse.tycho.core.shared.TargetEnvironment;
|
||||
import org.eclipse.tycho.plugins.tar.TarGzArchiver;
|
||||
@@ -98,13 +99,9 @@ public final class ProductArchiverMojo extends AbstractProductMojo {
|
||||
productArchivers.put(TAR_GZ_ARCHIVE_FORMAT, new ProductArchiver() {
|
||||
@Override
|
||||
Archiver getArchiver() throws ArchiverException {
|
||||
- TarArchiver.TarCompressionMethod tarCompressionMethod = new TarArchiver.TarCompressionMethod();
|
||||
- tarCompressionMethod.setValue("gzip"); // surprisingly, compression names are private in plexus
|
||||
- tarArchiver.setCompression(tarCompressionMethod);
|
||||
+ tarArchiver.setCompression(TarCompressionMethod.gzip);
|
||||
// avoid lots of long file path (> 100 chars) warnings
|
||||
- TarLongFileMode gnuMode = new TarLongFileMode();
|
||||
- gnuMode.setValue(TarLongFileMode.GNU);
|
||||
- tarArchiver.setLongfile(gnuMode);
|
||||
+ tarArchiver.setLongfile(TarLongFileMode.gnu);
|
||||
return tarArchiver;
|
||||
}
|
||||
});
|
||||
diff --git a/tycho-testing-harness/src/main/java/org/eclipse/tycho/test/AbstractTychoIntegrationTest.java b/tycho-testing-harness/src/main/java/org/eclipse/tycho/test/AbstractTychoIntegrationTest.java
|
||||
index a8173df..cf2cf57 100644
|
||||
--- a/tycho-testing-harness/src/main/java/org/eclipse/tycho/test/AbstractTychoIntegrationTest.java
|
||||
|
@ -48,7 +48,7 @@ index 9658fbc..efd0a2c 100644
|
||||
--- a/tycho-bundles/org.eclipse.tycho.core.shared.tests/META-INF/MANIFEST.MF
|
||||
+++ b/tycho-bundles/org.eclipse.tycho.core.shared.tests/META-INF/MANIFEST.MF
|
||||
@@ -7,3 +7,4 @@ Fragment-Host: org.eclipse.tycho.core.shared
|
||||
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
|
||||
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
|
||||
Require-Bundle: org.junit;bundle-version="4.8.2"
|
||||
Bundle-Vendor: %providerName
|
||||
+Import-Package: org.eclipse.tycho.p2.repository
|
||||
@ -89,8 +89,8 @@ index 7b39d58..a15354f 100644
|
||||
+ this(localRepositoryRoot, false, mavenLogger, new Properties(), null);
|
||||
}
|
||||
|
||||
public File getLocalRepositoryRoot() {
|
||||
@@ -49,4 +51,8 @@ public class MavenContextImpl implements MavenContext {
|
||||
@Override
|
||||
@@ -53,4 +55,8 @@ public class MavenContextImpl implements MavenContext {
|
||||
return mergedProperties;
|
||||
}
|
||||
|
||||
@ -224,31 +224,31 @@ diff --git a/tycho-bundles/org.eclipse.tycho.p2.maven.repository/src/main/java/o
|
||||
index 2a746f2..7b9983a 100644
|
||||
--- a/tycho-bundles/org.eclipse.tycho.p2.maven.repository/src/main/java/org/eclipse/tycho/repository/local/index/LocalRepositoryP2IndicesImpl.java
|
||||
+++ b/tycho-bundles/org.eclipse.tycho.p2.maven.repository/src/main/java/org/eclipse/tycho/repository/local/index/LocalRepositoryP2IndicesImpl.java
|
||||
@@ -14,6 +14,7 @@ package org.eclipse.tycho.repository.local.index;
|
||||
import java.io.File;
|
||||
@@ -15,6 +15,7 @@ package org.eclipse.tycho.repository.local.index;
|
||||
|
||||
import org.eclipse.tycho.core.shared.MavenContext;
|
||||
import org.eclipse.tycho.core.shared.MavenLogger;
|
||||
+import org.eclipse.tycho.core.shared.MavenRepositorySystem;
|
||||
import org.eclipse.tycho.locking.facade.FileLockService;
|
||||
import org.eclipse.tycho.p2.repository.LocalRepositoryP2Indices;
|
||||
import org.eclipse.tycho.p2.repository.TychoRepositoryIndex;
|
||||
@@ -23,6 +24,7 @@ public class LocalRepositoryP2IndicesImpl implements LocalRepositoryP2Indices {
|
||||
// injected members
|
||||
@@ -25,6 +26,7 @@ public class LocalRepositoryP2IndicesImpl implements LocalRepositoryP2Indices {
|
||||
private FileLockService fileLockService;
|
||||
private File localRepositoryRoot;
|
||||
private MavenLogger logger;
|
||||
+ private MavenRepositorySystem repoSystem;
|
||||
|
||||
// derived members
|
||||
private boolean initialized = false;
|
||||
@@ -36,6 +38,7 @@ public class LocalRepositoryP2IndicesImpl implements LocalRepositoryP2Indices {
|
||||
// injected by DS runtime
|
||||
@@ -39,6 +41,7 @@ public class LocalRepositoryP2IndicesImpl implements LocalRepositoryP2Indices {
|
||||
public void setMavenContext(MavenContext mavenContext) {
|
||||
this.localRepositoryRoot = mavenContext.getLocalRepositoryRoot();
|
||||
this.logger = mavenContext.getLogger();
|
||||
+ this.repoSystem = mavenContext.getRepositorySystem();
|
||||
}
|
||||
|
||||
// injected by DS runtime
|
||||
@@ -72,4 +75,8 @@ public class LocalRepositoryP2IndicesImpl implements LocalRepositoryP2Indices {
|
||||
@@ -80,4 +83,8 @@ public class LocalRepositoryP2IndicesImpl implements LocalRepositoryP2Indices {
|
||||
return localRepositoryRoot;
|
||||
}
|
||||
|
||||
@ -401,7 +401,7 @@ index 8bee7ba..f2b07a5 100644
|
||||
+ this.bundlesPublisher = new TargetPlatformBundlePublisher(localRepositoryRoot, mavenContext.getLogger(), mavenContext.getRepositorySystem());
|
||||
}
|
||||
|
||||
public void setProjectLocation(File projectLocation) {
|
||||
@Override
|
||||
diff --git a/tycho-bundles/org.eclipse.tycho.p2.resolver.impl/src/main/java/org/eclipse/tycho/p2/target/TargetPlatformBundlePublisher.java b/tycho-bundles/org.eclipse.tycho.p2.resolver.impl/src/main/java/org/eclipse/tycho/p2/target/TargetPlatformBundlePublisher.java
|
||||
index 0195871..44a0f30 100644
|
||||
--- a/tycho-bundles/org.eclipse.tycho.p2.resolver.impl/src/main/java/org/eclipse/tycho/p2/target/TargetPlatformBundlePublisher.java
|
||||
@ -472,7 +472,7 @@ diff --git a/tycho-bundles/org.eclipse.tycho.p2.resolver.shared/src/main/java/or
|
||||
index b5c8c55..8842af3 100644
|
||||
--- a/tycho-bundles/org.eclipse.tycho.p2.resolver.shared/src/main/java/org/eclipse/tycho/p2/repository/LocalRepositoryReader.java
|
||||
+++ b/tycho-bundles/org.eclipse.tycho.p2.resolver.shared/src/main/java/org/eclipse/tycho/p2/repository/LocalRepositoryReader.java
|
||||
@@ -14,54 +14,27 @@ import java.io.File;
|
||||
@@ -14,55 +14,28 @@ import java.io.File;
|
||||
import java.lang.reflect.Constructor;
|
||||
import java.lang.reflect.Method;
|
||||
|
||||
@ -489,6 +489,7 @@ index b5c8c55..8842af3 100644
|
||||
+ this.repositorySystem = repositorySystem;
|
||||
}
|
||||
|
||||
@Override
|
||||
@SuppressWarnings({ "unchecked", "rawtypes" })
|
||||
public File getLocalArtifactLocation(GAV gav, String classifier, String extension) {
|
||||
- File file = new File(localMavenRepositoryRoot, RepositoryLayoutHelper.getRelativePath(gav, classifier,
|
||||
|
@ -1,77 +0,0 @@
|
||||
From 068c927f7e56f216bc8bce674e849fae9ffceb1d Mon Sep 17 00:00:00 2001
|
||||
From: Mat Booth <mat.booth@redhat.com>
|
||||
Date: Thu, 10 Jul 2014 15:26:50 +0100
|
||||
Subject: [PATCH] Add "running env only" option to the p2-director-plugin.
|
||||
|
||||
This options allows you to restrict assembling and archiving products
|
||||
to only the current running target environment.
|
||||
---
|
||||
.../tycho/plugins/p2/director/AbstractProductMojo.java | 17 +++++++++++++++++
|
||||
.../eclipse/tycho/plugins/p2/director/DirectorMojo.java | 3 +++
|
||||
.../tycho/plugins/p2/director/ProductArchiverMojo.java | 3 +++
|
||||
3 files changed, 23 insertions(+)
|
||||
|
||||
diff --git a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/AbstractProductMojo.java b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/AbstractProductMojo.java
|
||||
index 7879a79..59eaf7a 100644
|
||||
--- a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/AbstractProductMojo.java
|
||||
+++ b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/AbstractProductMojo.java
|
||||
@@ -106,6 +106,16 @@ abstract class AbstractProductMojo extends AbstractMojo {
|
||||
private List<Product> products;
|
||||
|
||||
/**
|
||||
+ * <p>
|
||||
+ * Assemble and archive product installations for the running environment only. Setting this to
|
||||
+ * true will omit all target environments that do not exactly match the running environment.
|
||||
+ * </p>
|
||||
+ *
|
||||
+ * @parameter expression="${director.running.env.only}"
|
||||
+ */
|
||||
+ private boolean runningEnvOnly;
|
||||
+
|
||||
+ /**
|
||||
* Kill the forked process after a certain number of seconds. If set to 0, wait forever for the
|
||||
* process, never timing out.
|
||||
*/
|
||||
@@ -148,4 +158,11 @@ abstract class AbstractProductMojo extends AbstractMojo {
|
||||
static String getOsWsArch(TargetEnvironment env, char separator) {
|
||||
return env.getOs() + separator + env.getWs() + separator + env.getArch();
|
||||
}
|
||||
+
|
||||
+ /**
|
||||
+ * @return true if the product should be built for the given target environment, false otherwise
|
||||
+ */
|
||||
+ boolean buildForEnv(TargetEnvironment env) {
|
||||
+ return !runningEnvOnly || TargetEnvironment.getRunningEnvironment().equals(env);
|
||||
+ }
|
||||
}
|
||||
diff --git a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/DirectorMojo.java b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/DirectorMojo.java
|
||||
index 9f90ff1..fc8b342 100644
|
||||
--- a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/DirectorMojo.java
|
||||
+++ b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/DirectorMojo.java
|
||||
@@ -114,6 +114,9 @@ public final class DirectorMojo extends AbstractProductMojo {
|
||||
RepositoryReferences sources = getSourceRepositories();
|
||||
for (Product product : products) {
|
||||
for (TargetEnvironment env : getEnvironments()) {
|
||||
+ if (!buildForEnv(env)) {
|
||||
+ continue;
|
||||
+ }
|
||||
DirectorRuntime.Command command = director.newInstallCommand();
|
||||
|
||||
File destination = getProductMaterializeDirectory(product, env);
|
||||
diff --git a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java
|
||||
index 0102465..ffa84b0 100644
|
||||
--- a/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java
|
||||
+++ b/tycho-p2/tycho-p2-director-plugin/src/main/java/org/eclipse/tycho/plugins/p2/director/ProductArchiverMojo.java
|
||||
@@ -122,6 +122,9 @@ public final class ProductArchiverMojo extends AbstractProductMojo {
|
||||
|
||||
for (Product product : config.getProducts()) {
|
||||
for (TargetEnvironment env : getEnvironments()) {
|
||||
+ if (!buildForEnv(env)) {
|
||||
+ continue;
|
||||
+ }
|
||||
String format = getArchiveFormat(env);
|
||||
ProductArchiver productArchiver = productArchivers.get(format);
|
||||
if (productArchiver == null) {
|
||||
--
|
||||
1.9.3
|
||||
|
@ -37,7 +37,12 @@ pushd ${basedir}
|
||||
pushd ${output}
|
||||
classfiles=`for file in $(find . -name "*.class"); do echo -n ' -C '${output} ${file} ; done;`
|
||||
popd
|
||||
jar -cfmv "target/${bName}-${version}.jar" 'META-INF/MANIFEST.MF' 'OSGI-INF' 'plugin.xml' 'about.html' 'plugin.properties' ${classfiles}
|
||||
packagefiles="${classfiles}"
|
||||
[ -e about.html ] && packagefiles="about.html $packagefiles"
|
||||
[ -e plugin.properties ] && packagefiles="plugin.properties $packagefiles"
|
||||
[ -e plugin.xml ] && packagefiles="plugin.xml $packagefiles"
|
||||
[ -e OSGI-INF ] && packagefiles="OSGI-INF $packagefiles"
|
||||
jar -cfmv "target/${bName}-${version}.jar" 'META-INF/MANIFEST.MF' ${classfiles}
|
||||
popd
|
||||
|
||||
# Install
|
||||
@ -71,11 +76,10 @@ destDir=$2
|
||||
for loc in ${osgiLocations[@]} ; do
|
||||
for jar in `find ${loc} -name "*.jar" 2>/dev/null`; do
|
||||
bsn=`readBSN ${jar}`
|
||||
versionline=`unzip -p ${jar} 'META-INF/MANIFEST.MF' | grep 'Bundle-Version:'`
|
||||
if [ -n "${bsn}" ]; then
|
||||
versionline=`unzip -p ${jar} 'META-INF/MANIFEST.MF' | grep 'Bundle-Version:'`
|
||||
vers=`echo "${versionline}" | sed 's/Bundle-Version: \([a-zA-Z0-9_.-]*\).*/\1/'`
|
||||
echo ${wantedBundles} | grep -q "${bsn}"
|
||||
if [ $? -eq 0 ]; then
|
||||
if echo ${wantedBundles} | grep "${bsn}" ; then
|
||||
cp ${jar} "${destDir}/${bsn}_${vers}.jar"
|
||||
wantedBundles=`removeFromList "${wantedBundles}" "${bsn}"`
|
||||
fi
|
||||
|
@ -281,10 +281,10 @@ index 8d36462..b5c8c55 100644
|
||||
|
||||
public class LocalRepositoryReader implements RepositoryReader {
|
||||
|
||||
@@ -20,8 +22,46 @@ public class LocalRepositoryReader implements RepositoryReader {
|
||||
this.localMavenRepositoryRoot = localMavenRepositoryRoot;
|
||||
@@ -21,8 +23,46 @@
|
||||
}
|
||||
|
||||
@Override
|
||||
+ @SuppressWarnings({ "unchecked", "rawtypes" })
|
||||
public File getLocalArtifactLocation(GAV gav, String classifier, String extension) {
|
||||
- return new File(localMavenRepositoryRoot, RepositoryLayoutHelper.getRelativePath(gav, classifier, extension));
|
||||
@ -307,7 +307,7 @@ index 8d36462..b5c8c55 100644
|
||||
+ // Retrieve the workspace reader from the plexus container
|
||||
+ Method mLookup = pclazz.getMethod("lookup", String.class, String.class);
|
||||
+ Object reader = mLookup.invoke(plexus, "org.eclipse.aether.repository.WorkspaceReader", "ide");
|
||||
|
||||
+
|
||||
+ // Create an Aether Artifact based on GAV, classifier, and extension
|
||||
+ Class iartclazz = Class.forName("org.eclipse.aether.artifact.Artifact");
|
||||
+ Class artclazz = Class.forName("org.eclipse.aether.artifact.DefaultArtifact");
|
||||
@ -327,7 +327,7 @@ index 8d36462..b5c8c55 100644
|
||||
+ }
|
||||
+ }
|
||||
+ return file;
|
||||
+
|
||||
|
||||
+ }
|
||||
}
|
||||
diff --git a/tycho-bundles/org.eclipse.tycho.p2.resolver.shared/src/main/java/org/eclipse/tycho/p2/target/facade/TargetPlatformConfigurationStub.java b/tycho-bundles/org.eclipse.tycho.p2.resolver.shared/src/main/java/org/eclipse/tycho/p2/target/facade/TargetPlatformConfigurationStub.java
|
||||
@ -351,11 +351,10 @@ diff --git a/tycho-bundles/tycho-bundles-external/tycho-bundles-external.product
|
||||
index 7c99168..28ad59f 100644
|
||||
--- a/tycho-bundles/tycho-bundles-external/tycho-bundles-external.product
|
||||
+++ b/tycho-bundles/tycho-bundles-external/tycho-bundles-external.product
|
||||
@@ -76,6 +76,8 @@
|
||||
@@ -77,6 +77,7 @@
|
||||
<plugin id="org.eclipse.tycho.noopsecurity"/>
|
||||
<plugin id="org.sat4j.core"/>
|
||||
<plugin id="org.sat4j.pb"/>
|
||||
+ <plugin id="org.tukaani.xz"/>
|
||||
+ <plugin id="org.fedoraproject.p2"/>
|
||||
</plugins>
|
||||
|
||||
@ -411,16 +410,16 @@ diff --git a/tycho-core/src/main/java/org/eclipse/tycho/core/maven/TychoMavenLif
|
||||
index 1160f6c..acb2a1d 100644
|
||||
--- a/tycho-core/src/main/java/org/eclipse/tycho/core/maven/TychoMavenLifecycleParticipant.java
|
||||
+++ b/tycho-core/src/main/java/org/eclipse/tycho/core/maven/TychoMavenLifecycleParticipant.java
|
||||
@@ -29,6 +29,7 @@ import org.apache.maven.project.MavenProject;
|
||||
@@ -30,6 +30,7 @@ import org.apache.maven.project.MavenProject;
|
||||
import org.codehaus.plexus.PlexusContainer;
|
||||
import org.codehaus.plexus.component.annotations.Component;
|
||||
import org.codehaus.plexus.component.annotations.Requirement;
|
||||
+import org.codehaus.plexus.component.repository.exception.ComponentLookupException;
|
||||
import org.codehaus.plexus.logging.Logger;
|
||||
import org.eclipse.tycho.ReactorProject;
|
||||
import org.eclipse.tycho.core.ee.shared.BuildFailureException;
|
||||
@@ -68,6 +69,18 @@ public class TychoMavenLifecycleParticipant extends AbstractMavenLifecyclePartic
|
||||
validate(projects);
|
||||
import org.eclipse.tycho.core.osgitools.BundleReader;
|
||||
@@ -86,6 +87,18 @@ public class TychoMavenLifecycleParticipant extends AbstractMavenLifecyclePartic
|
||||
|
||||
configureComponents(session);
|
||||
|
||||
+ try {
|
||||
@ -646,4 +645,3 @@ index ae2dc38..a0c9969 100644
|
||||
}
|
||||
--
|
||||
2.1.0
|
||||
|
||||
|
39
tycho.spec
39
tycho.spec
@ -17,6 +17,8 @@
|
||||
# %%global snap -SNAPSHOT
|
||||
%global snap %{nil}
|
||||
|
||||
%global git_tag tycho-0.23.0
|
||||
|
||||
%global fp_p2_sha 7a5a01
|
||||
%global fp_p2_version 0.0.1
|
||||
%global fp_p2_snap -SNAPSHOT
|
||||
@ -24,15 +26,14 @@
|
||||
%define __requires_exclude osgi*
|
||||
|
||||
Name: %{?scl_prefix}tycho
|
||||
Version: 0.22.0
|
||||
Release: 18%{?dist}
|
||||
Version: 0.23.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Plugins and extensions for building Eclipse plugins and OSGI bundles with Maven
|
||||
|
||||
Group: Development/Libraries
|
||||
# license file is missing but all files having some licensing information are ASL 2.0
|
||||
License: ASL 2.0 and EPL
|
||||
URL: http://eclipse.org/tycho
|
||||
Source0: http://git.eclipse.org/c/tycho/org.eclipse.tycho.git/snapshot/org.eclipse.tycho-tycho-0.22.0.tar.bz2
|
||||
Source0: http://git.eclipse.org/c/tycho/org.eclipse.tycho.git/snapshot/org.eclipse.tycho-%{git_tag}.tar.xz
|
||||
|
||||
# this is a workaround for maven-plugin-plugin changes that happened after
|
||||
# version 2.4.3 (impossible to have empty mojo created as aggregate). This
|
||||
@ -59,9 +60,7 @@ Patch3: %{pkg_name}-use-custom-resolver.patch
|
||||
Patch4: %{pkg_name}-maven-delegation.patch
|
||||
# Additional changes needed just for bootstrap build
|
||||
Patch5: %{pkg_name}-fix-bootstrap-build.patch
|
||||
# Patch director plugin to only assemble products for the current arch
|
||||
Patch6: %{pkg_name}-running-env-only.patch
|
||||
Patch7: %{pkg_name}-port-to-jetty-9.3.0.patch
|
||||
Patch6: %{pkg_name}-port-to-jetty-9.3.0.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -161,7 +160,7 @@ Requires: jpackage-utils
|
||||
This package contains the API documentation for %{pkg_name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n org.eclipse.tycho-tycho-0.22.0
|
||||
%setup -q -n org.eclipse.tycho-%{git_tag}
|
||||
|
||||
# Prepare fedoraproject-p2
|
||||
tar -xf %{SOURCE6}
|
||||
@ -173,8 +172,7 @@ tar -xf %{SOURCE6}
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p0
|
||||
%patch6 -p0
|
||||
|
||||
find tycho-core -iname '*html' -delete
|
||||
|
||||
@ -201,19 +199,6 @@ sed -i '/^<unit id=.*$/d' tycho-bundles/tycho-bundles-target/tycho-bundles-targe
|
||||
# org.ow2.asm:asm-debug-all -> org.ow2.asm:asm-all
|
||||
%pom_xpath_set "pom:dependency[pom:artifactId='asm-debug-all']/pom:artifactId" "asm-all" tycho-artifactcomparator
|
||||
|
||||
# org.hamcrest -> org.hamcrest.core
|
||||
%pom_xpath_set "pom:requirement[pom:id='org.hamcrest']/pom:id" "org.hamcrest.core" tycho-bundles/org.eclipse.tycho.p2.maven.repository.tests
|
||||
|
||||
# Build against plexus-archiver 2.6
|
||||
pushd tycho-its/src/test/java/org/eclipse/tycho/test/
|
||||
for f in TYCHO0439repositoryCategories/RepositoryCategoriesTest.java \
|
||||
product/Util.java; do
|
||||
sed -i 's/org.codehaus.plexus.archiver.zip.ZipEntry/org.apache.commons.compress.archivers.zip.ZipArchiveEntry/g
|
||||
s/org.codehaus.plexus.archiver.zip.ZipFile/org.apache.commons.compress.archivers.zip.ZipFile/g
|
||||
s/ZipEntry/ZipArchiveEntry/g' $f
|
||||
done
|
||||
popd
|
||||
|
||||
# we don't have org.apache.commons:commons-compress:jar:sources
|
||||
%pom_xpath_remove "pom:dependency[pom:classifier='sources' and pom:artifactId='commons-compress']" tycho-p2/tycho-p2-director-plugin
|
||||
|
||||
@ -225,6 +210,9 @@ for mod in tycho-bundles/org.eclipse.tycho.{p2.{maven.repository.tests,resolver.
|
||||
$mod/META-INF/MANIFEST.MF
|
||||
done
|
||||
|
||||
# Fix bundle names
|
||||
sed -i -e 's/org\.hamcrest/org.hamcrest.core/' tycho-bundles/pom.xml
|
||||
sed -i -e 's/org\.mockito/org.mockito.mockito-core/' tycho-bundles/org.eclipse.tycho.p2.tools.tests/META-INF/MANIFEST.MF
|
||||
|
||||
# Bootstrap Build
|
||||
%if %{eclipse_bootstrap}
|
||||
@ -431,6 +419,11 @@ ln -s %{_javadir}/tycho/org.fedoraproject.p2.jar %{buildroot}%{_datadir}/xmvn/li
|
||||
%{_javadocdir}/tycho
|
||||
|
||||
%changelog
|
||||
* Fri Jun 05 2015 Mat Booth <mat.booth@redhat.com> - 0.23.0-1
|
||||
- Update to 0.23.0 release
|
||||
- Allow tycho-bootstrap.sh to work with "set -e" to fail faster
|
||||
and see errors more easily
|
||||
|
||||
* Sat May 30 2015 Alexander Kurtakov <akurtako@redhat.com> 0.22.0-18
|
||||
- Fix build with no tomcat servlet.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user