Backport THRIFT-2214 fix to get package built on aarch64.

Signed-off-by: Marcin Juszkiewicz <mjuszkiewicz@redhat.com>
This commit is contained in:
Marcin Juszkiewicz 2015-10-21 12:41:16 +02:00
parent 36c8431993
commit 781b311da5
2 changed files with 46 additions and 1 deletions

View File

@ -0,0 +1,39 @@
From f4e6e62ea091b94322ecc99756269dbee1c06380 Mon Sep 17 00:00:00 2001
From: Ben Craig <bencraig@apache.org>
Date: Tue, 5 Nov 2013 19:49:12 -0600
Subject: [PATCH 081/223] THRIFT-2214: System header sys/param.h is included
inside the Thrift namespace Client: cpp Patch: Vladimir Strisovsky
---
lib/cpp/src/thrift/protocol/TProtocol.h | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/lib/cpp/src/thrift/protocol/TProtocol.h b/lib/cpp/src/thrift/protocol/TProtocol.h
index d6ecc0f..e72033a 100644
--- a/lib/cpp/src/thrift/protocol/TProtocol.h
+++ b/lib/cpp/src/thrift/protocol/TProtocol.h
@@ -75,10 +75,6 @@ static inline To bitwise_cast(From from) {
}
-namespace apache { namespace thrift { namespace protocol {
-
-using apache::thrift::transport::TTransport;
-
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
#endif
@@ -140,6 +136,10 @@ using apache::thrift::transport::TTransport;
# error "Can't define htonll or ntohll!"
#endif
+namespace apache { namespace thrift { namespace protocol {
+
+using apache::thrift::transport::TTransport;
+
/**
* Enumerated definition of the types that the Thrift protocol supports.
* Take special note of the T_END type which is used specifically to mark
--
2.6.1

View File

@ -60,7 +60,7 @@
Name: thrift
Version: %{pkg_version}
Release: %{pkg_rel}%{?dist}.5
Release: %{pkg_rel}%{?dist}.6
Summary: Software framework for cross-language services development
# Parts of the source are used under the BSD and zlib licenses, but
@ -94,6 +94,8 @@ Patch0: thrift-0.9.1-buildxml.patch
Patch1: thrift-0.9.1-rebar.patch
# for fb303, excise maven ant tasks; build against system libraries; etc.
Patch2: fb303-0.9.1-buildxml.patch
# required to get it build on aarch64
Patch3: thrift-0.9.1-THRIFT-2214-System-header-sys-param.h-is-included-in.patch
Group: Development/Libraries
@ -321,6 +323,7 @@ The fb303-java package contains Java bindings for fb303.
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%{?!el5:sed -i -e 's/^AC_PROG_LIBTOOL/LT_INIT/g' configure.ac}
@ -545,6 +548,9 @@ find %{buildroot} -name \*.py -exec grep -q /usr/bin/env {} \; -print | xargs -r
%doc LICENSE NOTICE
%changelog
* Wed Oct 21 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 0.9.1-16.6
- Backport THRIFT-2214 fix to get package built on aarch64.
* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.9.1-16.5
- Rebuilt for Boost 1.59