Update to 3.0.3
This commit is contained in:
parent
a60bbb4174
commit
ae31234270
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@
|
||||
/texstudio-2.12.22.tar.gz
|
||||
/texstudio-3.0.0.tar.gz
|
||||
/texstudio-3.0.1.tar.gz
|
||||
/texstudio-3.0.3.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (texstudio-3.0.1.tar.gz) = aba57d9f45af259131d3ab47463a30bec24d8fa5b30a9c574308b8a7d6c1117acb1553df20ebe5855281510f82c4d55700a0db0dffeee1b69f2afec234e18b93
|
||||
SHA512 (texstudio-3.0.3.tar.gz) = dac50645cbf5baaecd2bc96b2362da75dceb07d88086de83f920b09c317d9ba10c8488f9d4d33fcb76d4ae260d369201c2704e423543fa87f8a729abe6d9614a
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 6647a0026bb16993707350d4829920e78918fb9e Mon Sep 17 00:00:00 2001
|
||||
From 3d277f1e446343511177893102704da36582158f Mon Sep 17 00:00:00 2001
|
||||
From: hannes <hannes@fedoraproject.org>
|
||||
Date: Sun, 11 Feb 2018 07:45:11 +0100
|
||||
Subject: [PATCH 3/3] update fix
|
||||
Date: Sat, 2 Jan 2021 10:23:12 +0100
|
||||
Subject: [PATCH] Update fix
|
||||
|
||||
---
|
||||
src/configdialog.ui | 6 ++++++
|
||||
@ -9,37 +9,34 @@ Subject: [PATCH 3/3] update fix
|
||||
2 files changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/configdialog.ui b/src/configdialog.ui
|
||||
index 0f3cbe6..1b11b92 100644
|
||||
index 88710e9..12b38b0 100644
|
||||
--- a/src/configdialog.ui
|
||||
+++ b/src/configdialog.ui
|
||||
@@ -584,14 +584,20 @@
|
||||
</property>
|
||||
@@ -590,6 +590,9 @@
|
||||
<property name="value">
|
||||
<number>7</number>
|
||||
- </property>
|
||||
+ </property>
|
||||
+ <property name="readOnly">
|
||||
+ <bool>true</bool>
|
||||
+ </property>
|
||||
</property>
|
||||
+ <property name="readOnly">
|
||||
+ <bool>true</bool>
|
||||
+ </property>
|
||||
</widget>
|
||||
</item>
|
||||
<item row="0" column="0">
|
||||
<widget class="QCheckBox" name="checkBoxAutoUpdateCheck">
|
||||
@@ -597,6 +600,9 @@
|
||||
<property name="text">
|
||||
<string>Automatically check every</string>
|
||||
- </property>
|
||||
+ </property>
|
||||
+ <property name="checkable">
|
||||
+ <bool>false</bool>
|
||||
+ </property>
|
||||
</property>
|
||||
+ <property name="checkable">
|
||||
+ <bool>false</bool>
|
||||
+ </property>
|
||||
</widget>
|
||||
</item>
|
||||
<item row="0" column="5">
|
||||
diff --git a/src/configmanager.cpp b/src/configmanager.cpp
|
||||
index afd54b7..e2e9629 100644
|
||||
index 7e6effc..0193acc 100644
|
||||
--- a/src/configmanager.cpp
|
||||
+++ b/src/configmanager.cpp
|
||||
@@ -485,7 +485,7 @@ ConfigManager::ConfigManager(QObject *parent): QObject (parent),
|
||||
@@ -489,7 +489,7 @@ ConfigManager::ConfigManager(QObject *parent): QObject (parent),
|
||||
registerOption("Macros/RepositoryURL", &URLmacroRepository, "https://api.github.com/repos/texstudio-org/texstudio-macro/contents/", nullptr);
|
||||
|
||||
//updates
|
||||
@ -48,4 +45,6 @@ index afd54b7..e2e9629 100644
|
||||
registerOption("Update/UpdateLevel", &updateLevel, 0, &pseudoDialog->comboBoxUpdateLevel);
|
||||
registerOption("Update/AutoCheckInvervalDays", &autoUpdateCheckIntervalDays, 7, &pseudoDialog->spinBoxAutoUpdateCheckIntervalDays);
|
||||
registerOption("Update/LastCheck", &lastUpdateCheck, QDateTime());
|
||||
--
|
||||
2.29.2
|
||||
|
||||
|
@ -1,17 +1,17 @@
|
||||
From bdd7b1385d47af230bc3bdd788d37527f3a8cf35 Mon Sep 17 00:00:00 2001
|
||||
From 56b0ae1e6cd6457cd19501911b06ae731bdcc53c Mon Sep 17 00:00:00 2001
|
||||
From: hannes <hannes@fedoraproject.org>
|
||||
Date: Tue, 25 Aug 2020 20:31:22 +0200
|
||||
Subject: [PATCH 1/2] qtsingle
|
||||
Date: Sat, 2 Jan 2021 09:27:47 +0100
|
||||
Subject: [PATCH] qtsingle patch
|
||||
|
||||
---
|
||||
texstudio.pro | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/texstudio.pro b/texstudio.pro
|
||||
index 05eb87f..b23f7e6 100644
|
||||
index 72a51bf..a353278 100644
|
||||
--- a/texstudio.pro
|
||||
+++ b/texstudio.pro
|
||||
@@ -100,7 +100,11 @@ isEmpty(INTERNAL_TERMINAL):pkgAtLeastVersion("qtermwidget5", "0.9.0") {
|
||||
@@ -101,7 +101,11 @@ isEmpty(INTERNAL_TERMINAL):pkgAtLeastVersion("qtermwidget5", "0.9.0") {
|
||||
message(Use experimental JS engine)
|
||||
}
|
||||
|
||||
@ -25,5 +25,5 @@ index 05eb87f..b23f7e6 100644
|
||||
# ##############################
|
||||
# precompile_header: PRECOMPILED_HEADER = mostQtHeaders.h
|
||||
--
|
||||
2.26.2
|
||||
2.29.2
|
||||
|
||||
|
@ -1,24 +1,25 @@
|
||||
From 49be56617e3a720a0c93d1c8ff13f3c4dbd89471 Mon Sep 17 00:00:00 2001
|
||||
From 6860e474606f324e39bbf32422305cbed71c07ec Mon Sep 17 00:00:00 2001
|
||||
From: hannes <hannes@fedoraproject.org>
|
||||
Date: Thu, 26 Dec 2019 11:46:48 +0100
|
||||
Subject: [PATCH 2/2] debughelper
|
||||
Date: Sat, 2 Jan 2021 09:35:36 +0100
|
||||
Subject: [PATCH 3/3] wtf_flags
|
||||
|
||||
---
|
||||
texstudio.pro | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
texstudio.pro | 15 +++++++--------
|
||||
1 file changed, 7 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/texstudio.pro b/texstudio.pro
|
||||
index b23f7e6..77b0397 100644
|
||||
index a353278..766660a 100644
|
||||
--- a/texstudio.pro
|
||||
+++ b/texstudio.pro
|
||||
@@ -414,15 +414,14 @@ exists(./.git) {
|
||||
@@ -428,16 +428,15 @@ exists(./.git) {
|
||||
}
|
||||
|
||||
!win32-msvc*: {
|
||||
- QMAKE_CXXFLAGS_DEBUG -= -O -O1 -O2 -O3
|
||||
- QMAKE_CXXFLAGS_DEBUG += -Wall -Wextra -Wmissing-include-dirs -Wunknown-pragmas -Wundef -Wpointer-arith -Winline -O0
|
||||
+# QMAKE_CXXFLAGS_DEBUG += -Wall -Wextra -Wmissing-include-dirs -Wunknown-pragmas -Wundef -Wpointer-arith -Winline -O0
|
||||
+ # QMAKE_CXXFLAGS_DEBUG += -Wall -Wextra -Wmissing-include-dirs -Wunknown-pragmas -Wundef -Wpointer-arith -Winline -O0
|
||||
QMAKE_CXXFLAGS += -std=c++11
|
||||
!isEmpty(MXE): QMAKE_CXXFLAGS += -fpermissive
|
||||
- !win32:!haiku: QMAKE_LFLAGS += -rdynamic # option not supported by mingw and haiku
|
||||
- else {
|
||||
- QMAKE_CXXFLAGS += -gstabs -g
|
||||
@ -35,5 +36,5 @@ index b23f7e6..77b0397 100644
|
||||
DEFINES += _CRT_SECURE_NO_WARNINGS
|
||||
}
|
||||
--
|
||||
2.24.1
|
||||
2.29.2
|
||||
|
||||
|
108
texstudio.spec
108
texstudio.spec
@ -1,6 +1,6 @@
|
||||
Name: texstudio
|
||||
Version: 3.0.1
|
||||
Release: 2%{?dist}
|
||||
Version: 3.0.3
|
||||
Release: 1%{?dist}
|
||||
|
||||
Summary: A feature-rich editor for LaTeX documents
|
||||
# texstudio binary: GPLv3 due to static linkage of bundled qcodeedit
|
||||
@ -121,6 +121,9 @@ desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE1}
|
||||
%doc utilities/AUTHORS utilities/COPYING utilities/manual/CHANGELOG.txt
|
||||
|
||||
%changelog
|
||||
* Sat Jan 02 2021 Johannes Lips <hannes@fedoraproject.org> 3.0.3-1
|
||||
- Update to latest upstream release 3.0.3
|
||||
|
||||
* Sun Sep 06 2020 Johannes Lips <hannes@fedoraproject.org> 3.0.1-2
|
||||
- enabled internal terminal
|
||||
|
||||
@ -234,104 +237,3 @@ desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE1}
|
||||
* Wed Oct 12 2016 Johannes Lips <hannes@fedoraproject.org> 2.11.2-1
|
||||
- Update to latest upstream bugfix release 2.11.2
|
||||
|
||||
* Mon May 30 2016 Johannes Lips <hannes@fedoraproject.org> 2.11.0-1
|
||||
- Update to latest upstream bugfix release 2.11.0
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Feb 01 2016 Rex Dieter <rdieter@fedoraproject.org> 2.10.8-2
|
||||
- use %%qmake_qt5 to ensure proper build flags
|
||||
|
||||
* Sun Jan 24 2016 Johannes Lips <hannes@fedoraproject.org> 2.10.8-1
|
||||
- Update to latest upstream bugfix release 2.10.8
|
||||
|
||||
* Tue Jan 12 2016 Johannes Lips <hannes@fedoraproject.org> 2.10.6-1
|
||||
- Update to latest upstream bugfix release 2.10.6
|
||||
|
||||
* Wed Dec 16 2015 Johannes Lips <hannes@fedoraproject.org> 2.10.4-2
|
||||
- added patch to disable update check
|
||||
|
||||
* Tue Oct 27 2015 Johannes Lips <hannes@fedoraproject.org> 2.10.4-1
|
||||
- Update to latest upstream bugfix release 2.10.4
|
||||
|
||||
* Thu Sep 17 2015 Johannes Lips <hannes@fedoraproject.org> 2.10.2-1
|
||||
- Update to latest upstream bugfix release 2.10.2
|
||||
|
||||
* Fri Sep 11 2015 Johannes Lips <hannes@fedoraproject.org> 2.10.0-1
|
||||
- Update to latest upstream version 2.10.0
|
||||
- added patch to fix arm build #1262987
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun May 24 2015 Johannes Lips <hannes@fedoraproject.org> 2.9.4-3
|
||||
- add qtsingleapplication patch - using fedora version
|
||||
|
||||
* Sat Apr 25 2015 Johannes Lips <hannes@fedoraproject.org> 2.9.4-2
|
||||
- switch to building with Qt5
|
||||
- removed qtsingleapplication patch - using bundled one
|
||||
|
||||
* Tue Mar 24 2015 Johannes Lips <hannes@fedoraproject.org> 2.9.4-1
|
||||
- Update to latest upstream version 2.9.4
|
||||
|
||||
* Mon Mar 23 2015 Johannes Lips <hannes@fedoraproject.org> 2.9.2-1
|
||||
- Update to latest upstream version 2.9.2
|
||||
|
||||
* Mon Mar 09 2015 Johannes Lips <hannes@fedoraproject.org> 2.9.0-1
|
||||
- Update to latest upstream version 2.9.0
|
||||
- changelog cleaned up
|
||||
|
||||
* Sun Dec 07 2014 Johannes Lips <hannes@fedoraproject.org> 2.8.8-1
|
||||
- Update to latest upstream version 2.8.8
|
||||
|
||||
* Tue Nov 04 2014 Johannes Lips <hannes@fedoraproject.org> 2.8.6-1
|
||||
- Update to latest upstream version 2.8.6
|
||||
|
||||
* Tue Sep 09 2014 Johannes Lips <hannes@fedoraproject.org> 2.8.4-1
|
||||
- Update to latest upstream version 2.8.4
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jul 26 2014 Johannes Lips <hannes@fedoraproject.org> 2.8.2-1
|
||||
- Update to latest upstream version 2.8.2
|
||||
|
||||
* Fri Jun 20 2014 Johannes Lips <hannes@fedoraproject.org> 2.8.0-1
|
||||
- Update to latest upstream version 2.8.0
|
||||
|
||||
* Wed Mar 19 2014 Johannes Lips <hannes@fedoraproject.org> 2.7.0-1
|
||||
- Update to latest upstream version 2.7.0
|
||||
|
||||
* Sun Nov 03 2013 Johannes Lips <hannes@fedoraproject.org> 2.6.6-1
|
||||
- Update to latest upstream version 2.6.6
|
||||
|
||||
* Sat Nov 02 2013 Johannes Lips <hannes@fedoraproject.org> 2.6.4-1
|
||||
- Update to latest upstream version 2.6.4
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Jul 16 2013 Johannes Lips <hannes@fedoraproject.org> 2.6.2-1
|
||||
- Update to latest upstream version 2.6.2
|
||||
|
||||
* Sun Jun 16 2013 Johannes Lips <hannes@fedoraproject.org> 2.6.0-1
|
||||
- Update to latest upstream version 2.6.0
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Jan 11 2013 Johannes Lips <hannes@fedoraproject.org> 2.5.2-1
|
||||
- update to recent upstream version
|
||||
|
||||
* Thu Nov 22 2012 Johannes Lips <hannes@fedoraproject.org> 2.5.1-1
|
||||
- update to recent upstream version
|
||||
|
||||
* Mon Oct 29 2012 Dan Horák <dan[at]danny.cz> 2.5-2
|
||||
- disable internal crash handler on not supported arches
|
||||
|
||||
* Sat Oct 27 2012 Johannes Lips <hannes@fedoraproject.org> 2.5-1
|
||||
- update to recent upstream version
|
||||
|
||||
* Sat Feb 18 2012 Johannes Lips <Johannes.Lips googlemail com> 2.3-2
|
||||
- disabled the build of debug files
|
||||
|
Loading…
Reference in New Issue
Block a user