texlive/texlive-checklib_fixes.patch

63 lines
2.8 KiB
Diff

#! /bin/sh /usr/share/dpatch/dpatch-run
## 54_checklib_fixes.dpatch by Norbert Preining
##
## DP: fix unnecessary libraries in the ELF header, ie libs which were
## DP: added to teh bin at linking stage
@DPATCH@
build/source/texk/web2c/Makefile.in | 4 ++--
build/source/texk/xdvik/Makefile.in | 4 ++--
build/source/utils/pdfopen/Makefile.in | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
Index: texlive-bin-2006.svn3816/build/source/texk/web2c/Makefile.in
===================================================================
--- texlive-bin-2006.svn3816.orig/build/source/texk/web2c/Makefile.in 2007-01-10 18:39:42.000000000 +0100
+++ texlive-bin-2006.svn3816/build/source/texk/web2c/Makefile.in 2007-01-26 04:03:16.000000000 +0100
@@ -55,10 +55,10 @@
# All the x_... variables will be empty if we aren't supporting X.
x_cppflags = @X_CFLAGS@
x_ldflags = @X_LIBS@
-x_pre_libs = @X_PRE_LIBS@
+x_pre_libs = # disabled since it created unnecessary deps @X_PRE_LIBS@
x_extra_libs = @X_EXTRA_LIBS@
x_tool_libs = @x_tool_libs@
-x_ext_lib = @x_ext_lib@
+x_ext_lib = # disabled since it created unnecessary deps @x_ext_lib@
wlibs = @wlibs@
# Follow the library order used in X11R6 itself:
# -lXaw -lXmu -lXt -lSM -lICE -lXext -lX11 (some may not be present).
Index: texlive-bin-2006.svn3816/build/source/texk/xdvik/Makefile.in
===================================================================
--- texlive-bin-2006.svn3816.orig/build/source/texk/xdvik/Makefile.in 2006-01-17 22:41:51.000000000 +0100
+++ texlive-bin-2006.svn3816/build/source/texk/xdvik/Makefile.in 2007-01-26 04:03:16.000000000 +0100
@@ -17,13 +17,13 @@
# This matches web2c (needed only for Metafont).
x_cppflags=@X_CFLAGS@ @iconv_includes@
x_ldflags=@X_LIBS@ @x_linker_options@ @iconv_libpath@
-x_pre_libs=@X_PRE_LIBS@
+x_pre_libs= # disabled as it generates unnecessary deps @X_PRE_LIBS@
x_extra_libs=@X_EXTRA_LIBS@ @iconv_libs@
x_tool_libs=@x_tool_libs@
x_xmu_lib=@x_xmu_lib@
x_xpm_libs=@x_xpm_libs@
# -lXp and -lXext
-x_ext_lib=@x_ext_lib@
+x_ext_lib= # disabled as it generates unnecessary deps @x_ext_lib@
# Follow the library order used in X11R6 itself.
# It seems that on Cygwin, libXaw needs _XpmReadFileToPixmap, so we put
Index: texlive-bin-2006.svn3816/build/source/utils/pdfopen/Makefile.in
===================================================================
--- texlive-bin-2006.svn3816.orig/build/source/utils/pdfopen/Makefile.in 2006-06-15 15:28:00.000000000 +0200
+++ texlive-bin-2006.svn3816/build/source/utils/pdfopen/Makefile.in 2007-01-26 04:03:16.000000000 +0100
@@ -158,7 +158,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
AM_CFLAGS = $(X_CFLAGS)
-LDADD = $(X_LIBS) -lX11 -lXmu $(X_EXTRA_LIBS)
+LDADD = $(X_LIBS) -lX11 $(X_EXTRA_LIBS)
pdfopen_SOURCES = pdfopen.c sendx.c
pdfclose_SOURCES = pdfclose.c sendx.c
all: all-am