- unify texlive and texlive-fonts packages and obsolete texlive-fonts

(related: #426388)
- move subpackages versions to the top of spec file
- changes from Patruce Dumas:
remove BuildRequires on texmf packages
don't create .fmt files during the build
ship the ptex.pool file
This commit is contained in:
Jindrich Novy 2008-01-02 14:02:40 +00:00
parent 34f6ff55ec
commit fe9dcc477f
2 changed files with 179 additions and 177 deletions

View File

@ -1,57 +1,78 @@
--- ptex-src-3.1.8/Makefile.in.orig 2004-12-03 17:33:13.000000000 +0900 diff -up ptex-src-3.1.10/Makefile.in.fmts ptex-src-3.1.10/Makefile.in
+++ ptex-src-3.1.8/Makefile.in 2004-12-16 15:54:25.407886051 +0900 --- ptex-src-3.1.10/Makefile.in.fmts 2006-06-05 03:50:47.000000000 +0200
@@ -6,8 +6,8 @@ +++ ptex-src-3.1.10/Makefile.in 2008-01-01 23:28:57.000000000 +0100
default: programs formats @@ -3,11 +3,9 @@ version = @WEB2CVERSION@
configopt = @configopt@
configkcode = @configkcode@
-default: programs formats
+default: programs texmf.cnf
programs=ptex tftopl pltotf pdvitype jbibtex programs=ptex tftopl pltotf pdvitype jbibtex
-euc-formats=ptex-euc.fmt platex-euc.fmt -euc-formats=ptex-euc.fmt platex-euc.fmt
-sjis-formats=ptex-sjis.fmt platex-sjis.fmt -sjis-formats=ptex-sjis.fmt platex-sjis.fmt
+euc-formats=ptex-euc.fmt platex-euc.fmt platex209-euc.fmt
+sjis-formats=ptex-sjis.fmt platex-sjis.fmt platex209-sjis.fmt
ac_include ../../make/paths.mk ac_include ../../make/paths.mk
@@ -186,6 +186,14 @@ @@ -162,30 +160,12 @@ $(kpathsea):
$(dumpenv) $(MAKE) progname=platex files="platex.ltx" prereq-check
$(dumpenv) ./ptex --ini --kanji=sjis --progname=platex --jobname=platex-sjis \\input platex.ltx </dev/null
+platex209-euc.fmt: ptex texmf.cnf #
+ $(dumpenv) $(MAKE) progname=platex files="plplain.ini" prereq-check # Making formats and bases.
+ $(dumpenv) ./ptex --ini --kanji=euc --progname=platex --jobname=platex209-euc \\input platex.ltx </dev/null -formats=$(euc-formats) $(sjis-formats)
+ -formats: $(formats)
+platex209-sjis.fmt: ptex texmf.cnf
+ $(dumpenv) $(MAKE) progname=platex files="plplain.ini" prereq-check texmf.cnf: $(kpathsea_dir)/texmf.cnf
+ $(dumpenv) ./ptex --ini --kanji=sjis --progname=platex --jobname=platex209-sjis \\input platex.ltx </dev/null $(SHELL) $(thisdir)/mkconf $(kpathsea_dir)/texmf.cnf > texmf.cnf
+
dumpenv = TEXMFCNF=$(thisdir)
-ptex-euc.fmt: ptex texmf.cnf
- $(dumpenv) $(MAKE) progname=ptex files="ptex.tex min10.tfm" prereq-check
- $(dumpenv) ./ptex --ini --kanji=euc --progname=ptex --jobname=ptex-euc \\input ptex.tex \\dump </dev/null
-
-ptex-sjis.fmt: ptex texmf.cnf
- $(dumpenv) $(MAKE) progname=ptex files="ptex.tex min10.tfm" prereq-check
- $(dumpenv) ./ptex --ini --kanji=sjis --progname=ptex --jobname=ptex-sjis \\input ptex.tex \\dump </dev/null
-
-platex-euc.fmt: ptex texmf.cnf
- $(dumpenv) $(MAKE) progname=platex files="platex.ltx" prereq-check
- $(dumpenv) ./ptex --ini --kanji=euc --progname=platex --jobname=platex-euc \\input platex.ltx </dev/null
-
-platex-sjis.fmt: ptex texmf.cnf
- $(dumpenv) $(MAKE) progname=platex files="platex.ltx" prereq-check
- $(dumpenv) ./ptex --ini --kanji=sjis --progname=platex --jobname=platex-sjis \\input platex.ltx </dev/null
-
# This is meant to be called recursively, with $(files) set. # This is meant to be called recursively, with $(files) set.
prereq-check: $(kpathsea_dir)/kpsewhich prereq-check: $(kpathsea_dir)/kpsewhich
$(dumpenv) $(kpathsea_dir)/kpsewhich --progname=$(progname) $(files) >/dev/null || $(MAKE) prereq-lose >/dev/null $(dumpenv) $(kpathsea_dir)/kpsewhich --progname=$(progname) $(files) >/dev/null || $(MAKE) prereq-lose >/dev/null
@@ -222,17 +230,19 @@ @@ -209,7 +189,6 @@ $(kpathsea_dir)/kpsewhich: $(kpathsea)
install: install-exec install-data
$(top_srcdir)/kpathsea/mktexlsr
install-exec:: install-links
-install-data:: install-formats
# Installation directories.
$(bindir)::
@@ -223,17 +202,7 @@ install-programs: $(programs) $(bindir)
# The links to ptex for each format. # The links to ptex for each format.
install-links: install-programs $(bindir) install-links: install-programs $(bindir)
- cd $(bindir) && (rm -f iniptex virptex platex; $(LN) ptex platex) - cd $(bindir) && (rm -f iniptex virptex platex; $(LN) ptex platex)
+ cd $(bindir) && (rm -f iniptex virptex platex platex209; $(LN) ptex platex ; $(LN) ptex platex209) -
-# Always do plain.*, so examples from the TeXbook (etc.) will work.
# Always do plain.*, so examples from the TeXbook (etc.) will work. -install-formats: $(formats) $(web2cdir)
install-formats: $(formats) $(web2cdir) - for f in $(formats); do $(INSTALL_DATA) $$f $(web2cdir)/$$f; done
for f in $(formats); do $(INSTALL_DATA) $$f $(web2cdir)/$$f; done
- cd $(web2cdir) && (rm -f ptex-jis.fmt platex-jis.fmt ;\ - cd $(web2cdir) && (rm -f ptex-jis.fmt platex-jis.fmt ;\
+ cd $(web2cdir) && (rm -f ptex-jis.fmt platex-jis.fmt platex209-jis.fmt ;\ - $(LN) ptex-euc.fmt ptex-jis.fmt ;\
$(LN) ptex-euc.fmt ptex-jis.fmt ;\
- $(LN) platex-euc.fmt platex-jis.fmt) - $(LN) platex-euc.fmt platex-jis.fmt)
- cd $(web2cdir) && (rm -f ptex.fmt platex.fmt ;\ - cd $(web2cdir) && (rm -f ptex.fmt platex.fmt ;\
+ $(LN) platex-euc.fmt platex-jis.fmt ;\ - $(LN) ptex-$(configkcode).fmt ptex.fmt ;\
+ $(LN) platex209-euc.fmt platex209-jis.fmt)
+ cd $(web2cdir) && (rm -f ptex.fmt platex.fmt platex209.fmt ;\
$(LN) ptex-$(configkcode).fmt ptex.fmt ;\
- $(LN) platex-$(configkcode).fmt platex.fmt ) - $(LN) platex-$(configkcode).fmt platex.fmt )
+ $(LN) platex-$(configkcode).fmt platex.fmt ;\ + cd $(bindir) && (rm -f iniptex virptex platex platex209; $(LN) ptex platex ; $(LN) ptex platex209)
+ $(LN) platex209-$(configkcode).fmt platex209.fmt)
# Auxiliary files. # Auxiliary files.
install-data:: install-data::
@@ -321,6 +331,7 @@ @@ -323,6 +292,7 @@ distclean:: clean
rm -fr failure rm -fr failure
rm -f ptex.web ptex.ch ptex.p ptex.pool ptex.log ptex-euc.fmt ptex-sjis.fmt rm -f ptex.web ptex.ch ptex.p ptex.pool ptex.log ptex-euc.fmt ptex-sjis.fmt
rm -f platex.log platex-euc.fmt platex-sjis.fmt texsys.aux platex rm -f platex.log platex-euc.fmt platex-sjis.fmt texsys.aux platex

View File

@ -1,12 +1,16 @@
# This spec file is based on texjive project created by Michael A. Peters. # This spec file is based on texjive project created by Michael A. Peters.
# Adopted and modified for Fedora by Jindrich Novy. # Adopted and modified for Fedora by Jindrich Novy.
%define texlive_ver 2007 %define texlive_ver 2007
%define ptex_src_ver 3.1.10
%define pdvipsk_ver p1.7a
%define mendexk_ver 2.6e
%define dvipdfm_ver 0.13.2d
%define dvipdfmx_ver 0
%define dvipng_ver 1.9
%define xdvi_ver 22.84.12
%define enable_japanese 1 %define enable_japanese 1
%define ptex_src_ver 3.1.10
%define pdvipsk_ver p1.7a
%define mendexk_ver 2.6e
%define desktop_file_utils_version 0.9 %define desktop_file_utils_version 0.9
%define default_letter_paper 0 %define default_letter_paper 0
@ -51,7 +55,6 @@ Source1001: ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/dvips/dvipsk-jpatch-%{pdvip
Source1002: ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/mendex/mendexk%{mendexk_ver}.tar.gz Source1002: ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/mendex/mendexk%{mendexk_ver}.tar.gz
Source1003: vfontmap Source1003: vfontmap
# Don't run brp-python-bytecompile # Don't run brp-python-bytecompile
%define __os_install_post /usr/lib/rpm/redhat/brp-compress /usr/lib/rpm/redhat/brp-strip %{__strip} /usr/lib/rpm/redhat/brp-strip-static-archive %{__strip} /usr/lib/rpm/redhat/brp-strip-comment-note %{__strip} %{__objdump} %{nil} %define __os_install_post /usr/lib/rpm/redhat/brp-compress /usr/lib/rpm/redhat/brp-strip %{__strip} /usr/lib/rpm/redhat/brp-strip-static-archive %{__strip} /usr/lib/rpm/redhat/brp-strip-comment-note %{__strip} %{__objdump} %{nil}
@ -139,6 +142,7 @@ Patch1003: texlive-2007-pxdvi.patch
Patch1004: texlive-2007-jp-platex209.patch Patch1004: texlive-2007-jp-platex209.patch
Patch1005: texlive-2007-pdvips.patch Patch1005: texlive-2007-pdvips.patch
Patch1006: texlive-2007-ptex-3.1.10.patch Patch1006: texlive-2007-ptex-3.1.10.patch
Patch1007: texlive-2007-fmtutil-ptex.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -150,16 +154,12 @@ BuildRequires: libSM-devel libICE-devel
BuildRequires: Xaw3d-devel BuildRequires: Xaw3d-devel
BuildRequires: poppler-devel >= 0.6.2-2 BuildRequires: poppler-devel >= 0.6.2-2
BuildRequires: teckit-devel BuildRequires: teckit-devel
# buildrequire texlive-texmf-fonts and texlive-texmf-latex for ptex
BuildRequires: texlive-texmf-fonts = %{version}
BuildRequires: texlive-texmf-latex = %{version}
# pxdvi buildrequires freetype >= 2.1.10 # pxdvi buildrequires freetype >= 2.1.10
%if %{enable_japanese} %if %{enable_japanese}
BuildRequires: freetype-devel >= 2.1.10 BuildRequires: freetype-devel >= 2.1.10
%endif %endif
Requires: xdg-utils ruby Requires: xdg-utils ruby
Requires: texlive-texmf = %{version} Requires: texlive-texmf = %{version}
Requires: texlive-fonts = %{version}-%{release}
Requires: texlive-texmf-errata = %{version} Requires: texlive-texmf-errata = %{version}
# for a2ping # for a2ping
Requires: ghostscript Requires: ghostscript
@ -177,6 +177,8 @@ Requires(post): %{_bindir}/fmtutil
Obsoletes: tetex < 3.0-99 Obsoletes: tetex < 3.0-99
Provides: tetex = 3.0-99 Provides: tetex = 3.0-99
Provides: tex Provides: tex
Obsoletes: texlive-fonts < 2007-6
Provides: texlive-fonts = 2007-6
%description %description
TeXLive is an implementation of TeX for Linux or UNIX systems. TeX takes TeXLive is an implementation of TeX for Linux or UNIX systems. TeX takes
@ -218,7 +220,7 @@ The TeX documentation is located in the texlive-doc package.
%package dvips %package dvips
Summary: A DVI to PostScript converter for the TeX text formatting system Summary: A DVI to PostScript converter for the TeX text formatting system
Group: Applications/Publishing Group: Applications/Publishing
Requires: texlive-fonts = %{version}-%{release} Requires: texlive = %{version}-%{release}
Requires: psutils Requires: psutils
Obsoletes: tetex-dvips < 3.0-99 Obsoletes: tetex-dvips < 3.0-99
Provides: tetex-dvips = 3.0-99 Provides: tetex-dvips = 3.0-99
@ -240,9 +242,9 @@ interface for TeX), and xdvi (for previewing .dvi files in X).
Summary: A collection of utilities for working with dvi files Summary: A collection of utilities for working with dvi files
Group: Applications/Publishing Group: Applications/Publishing
# not positive about this requires, pretty sure though # not positive about this requires, pretty sure though
Requires: texlive-fonts = %{version}-%{release} Requires: texlive = %{version}-%{release}
# used to be in tetex, but has a separate upstream # used to be in tetex, but has a separate upstream
Requires: dvipng, dvipdfm Requires: dvipng dvipdfm
# some dvi utilities used to be in tetex # some dvi utilities used to be in tetex
Obsoletes: tetex < 3.0-99 Obsoletes: tetex < 3.0-99
@ -250,25 +252,6 @@ Obsoletes: tetex < 3.0-99
The texlive-dviutils package includes a set of tools for working with dvi The texlive-dviutils package includes a set of tools for working with dvi
files. You only need this package if you plan to manipulate existing dvi files. files. You only need this package if you plan to manipulate existing dvi files.
%package fonts
Summary: The font files for the TeX text formatting system
Group: Applications/Publishing
Obsoletes: tetex-fonts < 3.0-99
Provides: tetex-fonts = 3.0-99
# needed by allcm, allec, allneeded
Requires: texlive-dvips = %{version}-%{release}
Requires: texlive-texmf-fonts >= %{version}
Requires: texlive-texmf-errata = %{version}
%description fonts
The texlive-fonts package contains programs required to generate font files
for the TeX text formatting system.
The kpathsea related programs are also in this package, they are needed
in order to find out a file in the TeX file tree.
%package latex %package latex
Summary: The LaTeX front end for the TeX text formatting system Summary: The LaTeX front end for the TeX text formatting system
Group: Applications/Publishing Group: Applications/Publishing
@ -293,6 +276,8 @@ The TeX documentation is located in the texlive-doc package.
%package -n kpathsea %package -n kpathsea
Summary: Shared library needed by kpathsea and info files Summary: Shared library needed by kpathsea and info files
Group: Development/Libraries Group: Development/Libraries
Obsoletes: tetex-fonts < 3.0-99
Requires: texlive = %{version}-%{release}
%description -n kpathsea %description -n kpathsea
Shared library needed by kpathsea and info files. Shared library needed by kpathsea and info files.
@ -314,14 +299,11 @@ Summary: An X viewer for DVI files
Group: Applications/Publishing Group: Applications/Publishing
Requires: texlive-dvips = %{version}-%{release} Requires: texlive-dvips = %{version}-%{release}
Requires(post): desktop-file-utils >= %{desktop_file_utils_version} Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
Version: 22.84.12 Version: %{xdvi_ver}
#Url: http://xdvi.sourceforge.net/ #Url: http://xdvi.sourceforge.net/
#Source0: http://downloads.sourceforge.net/xdvi/xdvik-%{version}.tar.gz #Source0: http://downloads.sourceforge.net/xdvi/xdvik-%{xdvi_ver}.tar.gz
Obsoletes: tetex-xdvi < 3.0-99 Obsoletes: tetex-xdvi < 3.0-99
Provides: tetex-xdvi = 3.0-99 Provides: tetex-xdvi = 3.0-99
#Provides: texlive-xdvi = %{version}-%{release}
#Requires: texlive-texmf-errata = %{version}
%description -n xdvi %description -n xdvi
Xdvik, the kpathsea version of xdvi, is a previewer for DVI files Xdvik, the kpathsea version of xdvi, is a previewer for DVI files
@ -335,10 +317,10 @@ formatting package which provides an easier-to-use interface for TeX).
%package -n dvipng %package -n dvipng
Summary: DVI-to-PNG converter Summary: DVI-to-PNG converter
Version: 1.9 Version: %{dvipng_ver}
Group: Applications/Publishing Group: Applications/Publishing
#Url: http://savannah.nongnu.org/projects/dvipng/ #Url: http://savannah.nongnu.org/projects/dvipng/
#Source0: http://download.savannah.gnu.org/releases/dvipng/dvipng-%{version}.tar.gz #Source0: http://download.savannah.gnu.org/releases/dvipng/dvipng-%{dvipng_ver}.tar.gz
%description -n dvipng %description -n dvipng
This program makes PNG and/or GIF graphics from DVI files as obtained This program makes PNG and/or GIF graphics from DVI files as obtained
@ -356,10 +338,10 @@ Replacement for makeindex with many enhancements.
%package -n dvipdfm %package -n dvipdfm
Summary: DVI to PDF translator Summary: DVI to PDF translator
Version: 0.13.2d Version: %{dvipdfm_ver}
Group: Applications/Publishing Group: Applications/Publishing
#Url: http://gaspra.kettering.edu/dvipdfm/ #Url: http://gaspra.kettering.edu/dvipdfm/
#Source0: http://gaspra.kettering.edu/dvipdfm/dvipdfm-%{version}.tar.gz #Source0: http://gaspra.kettering.edu/dvipdfm/dvipdfm-%{dvipdfm_ver}.tar.gz
# for dvipdft # for dvipdft
Requires: ghostscript Requires: ghostscript
# for .enc files # for .enc files
@ -370,11 +352,10 @@ DVI to PDF translator.
%package -n dvipdfmx %package -n dvipdfmx
Summary: Extended version of the dvipdfm DVI to PDF translator Summary: Extended version of the dvipdfm DVI to PDF translator
Version: %{dvipdfmx_ver}
Group: Applications/Publishing Group: Applications/Publishing
Version: 0
#Url: http://project.ktug.or.kr/dvipdfmx/ #Url: http://project.ktug.or.kr/dvipdfmx/
# %define ver_date 20070518 #Source0: http://project.ktug.or.kr/dvipdfmx/snapshot/release/dvipdfmx-%{dvipdfmx_ver}.tar.gz
#Source0: http://project.ktug.or.kr/dvipdfmx/snapshot/release/dvipdfmx-%{ver_date}.tar.gz
# for cmap files # for cmap files
Requires: texlive-texmf-fonts = %{texlive_ver} Requires: texlive-texmf-fonts = %{texlive_ver}
Provides: texlive-dvipdfmx Provides: texlive-dvipdfmx
@ -475,6 +456,8 @@ chmod -x texk/dvipdfm/encodings.c
%patch305 -p0 %patch305 -p0
%patch306 -p0 %patch306 -p0
%patch1007 -p1 -b .ptex
#pushd texk/kpathsea #pushd texk/kpathsea
#%{__sed} -i 's?^TEXMF =.*?TEXMF = {\$TEXMFCONFIG,\$TEXMFVAR,\$TEXMFHOME,\$TEXMFSYSCONFIG,\!\!\$TEXMFSYSVAR,\!\!\$TEXMFLOCAL,\!\!\$TEXMFMAIN,\!\!\$TEXMFDIST}?' texmf.in #%{__sed} -i 's?^TEXMF =.*?TEXMF = {\$TEXMFCONFIG,\$TEXMFVAR,\$TEXMFHOME,\$TEXMFSYSCONFIG,\!\!\$TEXMFSYSVAR,\!\!\$TEXMFLOCAL,\!\!\$TEXMFMAIN,\!\!\$TEXMFDIST}?' texmf.in
@ -519,7 +502,7 @@ sed -e s/^platex/platex-pl/g \
tar xfz %{SOURCE1000} -C texk/web2c/ tar xfz %{SOURCE1000} -C texk/web2c/
cd texk/web2c/ptex-src-%{ptex_src_ver} cd texk/web2c/ptex-src-%{ptex_src_ver}
sed -i -e 's|/{ptex/{platex,generic,},tex/{latex,generic,}}|/{ptex/platex,{p,}tex/latex,{p,}tex/generic,{p,}tex}|g' -e 's/| uniq//g' mkconf sed -i -e 's|/{ptex/{platex,generic,},tex/{latex,generic,}}|/{ptex/platex,{p,}tex/latex,{p,}tex/generic,{p,}tex}|g' -e 's/| uniq//g' mkconf
%patch1004 -p1 %patch1004 -p1 -b .fmts
%patch1006 -p1 %patch1006 -p1
cd - cd -
@ -714,6 +697,10 @@ desktop-file-install --vendor tetex --delete-original \
--add-category Graphics \ --add-category Graphics \
xdvi.desktop xdvi.desktop
# remove pool files, they belong to texlive-texmf
rm -rf %{buildroot}%{_texmf_main}/web2c/*.pool
# ptex pool file is added later, and therefore kept
# Japanese pTeX # Japanese pTeX
%if %{enable_japanese} %if %{enable_japanese}
# remove %{buildroot}%{_bindir}/platex # remove %{buildroot}%{_bindir}/platex
@ -769,9 +756,6 @@ cd -
# remove useless files in texconfig # remove useless files in texconfig
rm -rf %{buildroot}%{_texmf_main}/texconfig/{g,v,x,README,generic} rm -rf %{buildroot}%{_texmf_main}/texconfig/{g,v,x,README,generic}
# remove pool files, they belong to texlive-texmf
rm -rf %{buildroot}%{_texmf_main}/web2c/*.pool
# move the configuration files that should be under user control # move the configuration files that should be under user control
mkdir -p %{buildroot}%{_texmf_conf}/{web2c/,dvipdfm/} mkdir -p %{buildroot}%{_texmf_conf}/{web2c/,dvipdfm/}
mv %{buildroot}%{_texmf_main}/web2c/mktexdir.opt %{buildroot}%{_texmf_conf}/web2c/ mv %{buildroot}%{_texmf_main}/web2c/mktexdir.opt %{buildroot}%{_texmf_conf}/web2c/
@ -786,7 +770,9 @@ rm -rf %{buildroot}
%post %post
%{_bindir}/texconfig-sys rehash 2> /dev/null || : %{_bindir}/texconfig-sys rehash 2> /dev/null || :
[ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/web2c.info.gz %{_infodir}/dir || :
%{_bindir}/fmtutil-sys --all > /dev/null 2>&1 || : %{_bindir}/fmtutil-sys --all > /dev/null 2>&1 || :
%{_bindir}/updmap-sys --syncwithtrees > /dev/null 2>&1 || :
%post afm %post afm
%{_bindir}/texconfig-sys rehash 2> /dev/null || : %{_bindir}/texconfig-sys rehash 2> /dev/null || :
@ -798,11 +784,6 @@ rm -rf %{buildroot}
%post dviutils %post dviutils
%{_bindir}/texconfig-sys rehash 2> /dev/null || : %{_bindir}/texconfig-sys rehash 2> /dev/null || :
%post fonts
%{_bindir}/texconfig-sys rehash 2> /dev/null || :
[ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/web2c.info.gz %{_infodir}/dir || :
%{_bindir}/updmap-sys --syncwithtrees > /dev/null 2>&1 || :
%post latex %post latex
[ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/latex.info.gz %{_infodir}/dir || : [ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/latex.info.gz %{_infodir}/dir || :
%{_bindir}/texconfig-sys init >/dev/null 2>&1 || : %{_bindir}/texconfig-sys init >/dev/null 2>&1 || :
@ -825,6 +806,11 @@ fi
[ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/dvipng.info.gz %{_infodir}/dir || : [ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/dvipng.info.gz %{_infodir}/dir || :
%preun
if [ "$1" = 0 ]; then
[ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/web2c.info.gz %{_infodir}/dir || :
fi
%preun dvips %preun dvips
if [ "$1" = 0 ]; then if [ "$1" = 0 ]; then
[ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/dvips.info.gz %{_infodir}/dir || : [ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/dvips.info.gz %{_infodir}/dir || :
@ -840,11 +826,6 @@ if [ "$1" = 0 ]; then
[ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/latex.info.gz %{_infodir}/dir || : [ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/latex.info.gz %{_infodir}/dir || :
fi fi
%preun fonts
if [ "$1" = 0 ]; then
[ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/web2c.info.gz %{_infodir}/dir || :
fi
%preun -n kpathsea %preun -n kpathsea
/sbin/ldconfig /sbin/ldconfig
if [ "$1" = 0 ]; then if [ "$1" = 0 ]; then
@ -860,9 +841,6 @@ fi
%postun dvips %postun dvips
%{_bindir}/texconfig-sys rehash 2> /dev/null || : %{_bindir}/texconfig-sys rehash 2> /dev/null || :
%postun fonts
%{_bindir}/texconfig-sys rehash 2> /dev/null || :
%postun latex %postun latex
%{_bindir}/texconfig-sys rehash 2> /dev/null || : %{_bindir}/texconfig-sys rehash 2> /dev/null || :
@ -1054,7 +1032,7 @@ fi
%{_texmf_main}/bibtex/ %{_texmf_main}/bibtex/
# Japanese pTeX # Japanese pTeX
%if %{enable_japanese} %if %{enable_japanese}
%{_texmf_main}/web2c/*.fmt %{_texmf_main}/web2c/ptex.pool
%endif %endif
%dir %{_texmf_main}/doc %dir %{_texmf_main}/doc
%doc %{_texmf_main}/doc/bibtex8/ %doc %{_texmf_main}/doc/bibtex8/
@ -1064,88 +1042,6 @@ fi
%endif %endif
%dir %{_texmf_var}/web2c/ %dir %{_texmf_var}/web2c/
%doc __fedora_kpathsea/fmtutil.cnf-init %doc __fedora_kpathsea/fmtutil.cnf-init
%files afm
%defattr(-,root,root,-)
%{_bindir}/afm2tfm
%{_bindir}/ttf2afm
%{_mandir}/man1/afm2tfm.1*
%{_mandir}/man1/ttf2afm.1*
# not in fedora tetex, but a separate project
#%{_bindir}/afm2pl
#%{_mandir}/man1/afm2pl.1*
%files dvips
%defattr(-,root,root,-)
%{_bindir}/dvi2fax
%{_bindir}/dvips
%{_bindir}/dvired
%{_bindir}/odvips
%{_texmf_main}/dvips/
%{_mandir}/man1/dvi2fax.1*
%{_mandir}/man1/dvips.1*
%{_mandir}/man1/dvired.1*
%{_mandir}/man1/odvips.1*
%{_infodir}/dvips.info.*
# Japanese pTeX
%if %{enable_japanese}
%{_bindir}/pdvips
%{_bindir}/opdvips
%{_bindir}/pdvitype
%{_texmf_main}/pdvips/
%{_texmf_main}/fonts/map/pdvips/
%{_mandir}/man1/pdvips.1*
%{_mandir}/man1/opdvips.1*
%doc %{_texmf_main}/doc/pdvipsk/
%endif
%files dviutils
%defattr(-,root,root,-)
# separated project (dvi2tty)
#%{_bindir}/disdvi
%{_bindir}/dt2dv
%{_bindir}/dv2dt
# separated project (dvi2tty)
#%{_bindir}/dvi2tty
%{_bindir}/dvicopy
%{_bindir}/dvihp
%{_bindir}/dvitype
%{_bindir}/dvibook
%{_bindir}/dviconcat
%{_bindir}/dvidvi
%{_bindir}/dvilj
%{_bindir}/dvilj2p
%{_bindir}/dvilj4
%{_bindir}/dvilj4l
%{_bindir}/dvilj6
%{_bindir}/dvipos
%{_bindir}/dviselect
%{_bindir}/dvitodvi
%{_bindir}/odvicopy
%{_bindir}/odvitype
%{_mandir}/man1/dvicopy.1*
%{_mandir}/man1/dvihp.1*
%{_mandir}/man1/dvitype.1*
%{_mandir}/man1/dt2dv.1*
%{_mandir}/man1/dv2dt.1*
# separated project (dvi2tty)
#%{_mandir}/man1/dvi2tty.1*
%{_mandir}/man1/dvibook.1*
%{_mandir}/man1/dviconcat.1*
%{_mandir}/man1/dvidvi.1*
%{_mandir}/man1/dvilj.1*
%{_mandir}/man1/dvilj2p.1*
%{_mandir}/man1/dvilj4.1*
%{_mandir}/man1/dvilj4l.1*
%{_mandir}/man1/dvilj6.1*
%{_mandir}/man1/dvipos.1*
%{_mandir}/man1/dviselect.1*
%{_mandir}/man1/dvitodvi.1*
%{_mandir}/man1/odvicopy.1*
%{_mandir}/man1/odvitype.1*
%files fonts
%defattr(-,root,root,-)
%{_bindir}/allcm %{_bindir}/allcm
%{_bindir}/allec %{_bindir}/allec
%{_bindir}/allneeded %{_bindir}/allneeded
@ -1237,6 +1133,85 @@ fi
%{_texmf_main}/web2c/mktexnam %{_texmf_main}/web2c/mktexnam
%{_texmf_main}/web2c/mktexupd %{_texmf_main}/web2c/mktexupd
%files afm
%defattr(-,root,root,-)
%{_bindir}/afm2tfm
%{_bindir}/ttf2afm
%{_mandir}/man1/afm2tfm.1*
%{_mandir}/man1/ttf2afm.1*
# not in fedora tetex, but a separate project
#%{_bindir}/afm2pl
#%{_mandir}/man1/afm2pl.1*
%files dvips
%defattr(-,root,root,-)
%{_bindir}/dvi2fax
%{_bindir}/dvips
%{_bindir}/dvired
%{_bindir}/odvips
%{_texmf_main}/dvips/
%{_mandir}/man1/dvi2fax.1*
%{_mandir}/man1/dvips.1*
%{_mandir}/man1/dvired.1*
%{_mandir}/man1/odvips.1*
%{_infodir}/dvips.info.*
# Japanese pTeX
%if %{enable_japanese}
%{_bindir}/pdvips
%{_bindir}/opdvips
%{_bindir}/pdvitype
%{_texmf_main}/pdvips/
%{_texmf_main}/fonts/map/pdvips/
%{_mandir}/man1/pdvips.1*
%{_mandir}/man1/opdvips.1*
%doc %{_texmf_main}/doc/pdvipsk/
%endif
%files dviutils
%defattr(-,root,root,-)
# separated project (dvi2tty)
#%{_bindir}/disdvi
%{_bindir}/dt2dv
%{_bindir}/dv2dt
# separated project (dvi2tty)
#%{_bindir}/dvi2tty
%{_bindir}/dvicopy
%{_bindir}/dvihp
%{_bindir}/dvitype
%{_bindir}/dvibook
%{_bindir}/dviconcat
%{_bindir}/dvidvi
%{_bindir}/dvilj
%{_bindir}/dvilj2p
%{_bindir}/dvilj4
%{_bindir}/dvilj4l
%{_bindir}/dvilj6
%{_bindir}/dvipos
%{_bindir}/dviselect
%{_bindir}/dvitodvi
%{_bindir}/odvicopy
%{_bindir}/odvitype
%{_mandir}/man1/dvicopy.1*
%{_mandir}/man1/dvihp.1*
%{_mandir}/man1/dvitype.1*
%{_mandir}/man1/dt2dv.1*
%{_mandir}/man1/dv2dt.1*
# separated project (dvi2tty)
#%{_mandir}/man1/dvi2tty.1*
%{_mandir}/man1/dvibook.1*
%{_mandir}/man1/dviconcat.1*
%{_mandir}/man1/dvidvi.1*
%{_mandir}/man1/dvilj.1*
%{_mandir}/man1/dvilj2p.1*
%{_mandir}/man1/dvilj4.1*
%{_mandir}/man1/dvilj4l.1*
%{_mandir}/man1/dvilj6.1*
%{_mandir}/man1/dvipos.1*
%{_mandir}/man1/dviselect.1*
%{_mandir}/man1/dvitodvi.1*
%{_mandir}/man1/odvicopy.1*
%{_mandir}/man1/odvitype.1*
%files latex %files latex
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{_bindir}/latex %{_bindir}/latex
@ -1352,8 +1327,14 @@ fi
%{_texmf_main}/dvipdfm/ %{_texmf_main}/dvipdfm/
%changelog %changelog
* Mon Dec 31 2007 Jindrich Novy <jnovy@redhat.com> - 2007-6 * Wed Jan 02 2008 Jindrich Novy <jnovy@redhat.com> - 2007-6
- kpathsea doesn't depend on texlive-fonts any more (#426388) - unify texlive and texlive-fonts packages and obsolete
texlive-fonts (related: #426388)
- move subpackages versions to the top of spec file
- changes from Patruce Dumas:
* remove BuildRequires on texmf packages
* don't create .fmt files during the build
* ship the ptex.pool file
* Mon Dec 17 2007 Jindrich Novy <jnovy@redhat.com> - 2007-5 * Mon Dec 17 2007 Jindrich Novy <jnovy@redhat.com> - 2007-5
- add tex virtual provide - add tex virtual provide