package texdoc and texdoctk to a separate subpackage texlive-doc, because
of the Perl-Tk dependencies and logic
This commit is contained in:
parent
0e5aad6c01
commit
c8d3ea229b
@ -1,15 +0,0 @@
|
||||
--- tetex-src-3.0/texk/tetex/texdoctk.tkdep 2004-11-06 00:12:14.000000000 +0100
|
||||
+++ tetex-src-3.0/texk/tetex/texdoctk 2005-07-18 14:57:54.132164864 +0200
|
||||
@@ -9,7 +9,11 @@
|
||||
# and the full disclaimer.
|
||||
###############################################################################
|
||||
use strict;
|
||||
-use Tk;
|
||||
+BEGIN {
|
||||
+ eval {require Tk;};
|
||||
+ die "This program requires perl-Tk. Try to look in fedora-extras.\n" if $@;
|
||||
+ import Tk;
|
||||
+}
|
||||
use Getopt::Long;
|
||||
Getopt::Long::config('bundling');
|
||||
use File::Basename;
|
@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
/usr/lib/rpm/perl.req "$@" | grep -v 'perl(\(Tk\|Win32\|only\|path_tre\|just\|Htex\|Pts\)'
|
||||
/usr/lib/rpm/perl.req "$@" | grep -v 'perl(\(Win32\|only\|path_tre\|just\|Htex\|Pts\)'
|
||||
|
35
texlive.spec
35
texlive.spec
@ -64,7 +64,6 @@ Source1003: vfontmap
|
||||
|
||||
# and sane defaults to build against can be inserted via sed
|
||||
Patch5: texlive-2007-browser.patch
|
||||
Patch6: texlive-2007-tkdep.patch
|
||||
Patch8: texlive-2007-xprint.patch
|
||||
Patch9: texlive-teckit.patch
|
||||
|
||||
@ -219,6 +218,23 @@ texlive-xdvi (for previewing .dvi files in X).
|
||||
|
||||
The TeX documentation is located in the texlive-doc package.
|
||||
|
||||
%package doc
|
||||
Summary: Applications to browse documentation for TeXLive
|
||||
Group: Applications/Publishing
|
||||
Requires: texlive = %{version}-%{release}
|
||||
Obsoletes: tetex-doc < 3.0-99
|
||||
Provides: tetex-doc = 3.0-99
|
||||
Obsoletes: texlive-doc < 2007-7
|
||||
Provides: texlive-doc = %{version}-%{release}
|
||||
Requires: texlive-texmf-doc = %{version}
|
||||
Requires: texlive-texmf-doc-errata = %{version}
|
||||
|
||||
%description doc
|
||||
If you are installing texlive and need a documentation to describe
|
||||
styles or you are a TeX beginner and need tutorials, you may install
|
||||
this package to obtain applications allowing you to user-friendly browse
|
||||
documentation of the TeX formatting system.
|
||||
|
||||
%package dvips
|
||||
Summary: A DVI to PostScript converter for the TeX text formatting system
|
||||
Group: Applications/Publishing
|
||||
@ -397,7 +413,6 @@ chmod -x texk/dvipdfm/encodings.c
|
||||
######
|
||||
# Use htmlview first
|
||||
%patch5 -p1 -b .browser
|
||||
%patch6 -p1 -b .tkdep
|
||||
%patch8 -p1 -b .xprint
|
||||
%patch9 -p1 -b .teckit
|
||||
%patch22 -p1 -b .fedora_paths
|
||||
@ -945,8 +960,6 @@ fi
|
||||
%{_bindir}/texconfig
|
||||
%{_bindir}/texconfig-dialog
|
||||
%{_bindir}/texconfig-sys
|
||||
%{_bindir}/texdoc
|
||||
%{_bindir}/texdoctk
|
||||
%{_bindir}/texexec
|
||||
%{_bindir}/texfont
|
||||
%{_bindir}/texhash
|
||||
@ -1077,8 +1090,6 @@ fi
|
||||
%{_mandir}/man1/tex.1*
|
||||
%{_mandir}/man1/texconfig.1*
|
||||
%{_mandir}/man1/texconfig-sys.1*
|
||||
%{_mandir}/man1/texdoc.1*
|
||||
%{_mandir}/man1/texdoctk.1*
|
||||
%{_mandir}/man1/texexec.1*
|
||||
%{_mandir}/man1/texfind.1*
|
||||
%{_mandir}/man1/texfont.1*
|
||||
@ -1163,6 +1174,14 @@ fi
|
||||
%doc %{_texmf_main}/doc/pdvipsk/
|
||||
%endif
|
||||
|
||||
%files doc
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/texdoc
|
||||
%{_bindir}/texdoctk
|
||||
# man pages
|
||||
%{_mandir}/man1/texdoc.1*
|
||||
%{_mandir}/man1/texdoctk.1*
|
||||
|
||||
%files dviutils
|
||||
%defattr(-,root,root,-)
|
||||
# separated project (dvi2tty)
|
||||
@ -1323,8 +1342,10 @@ fi
|
||||
%{_texmf_main}/dvipdfm/
|
||||
|
||||
%changelog
|
||||
* Fri Jan 11 2008 Jindrich Novy <jnovy@redhat.com> - 2007-9
|
||||
* Mon Jan 14 2008 Jindrich Novy <jnovy@redhat.com> - 2007-9
|
||||
- unify texlive and texlive-fonts filelists
|
||||
- package texdoc and texdoctk to a separate subpackage
|
||||
texlive-doc, because of the Perl-Tk dependencies and logic
|
||||
|
||||
* Mon Jan 07 2008 Jindrich Novy <jnovy@redhat.com> - 2007-8
|
||||
- add tex-latex and tex-dvips virtual provides
|
||||
|
Loading…
x
Reference in New Issue
Block a user