- don't build/package xdvik/pxdvik, it's now separated

- fix texlive-doc requires, description
- use virtual provides with parentheses to avoid clashes with real packages
    (#410401)
This commit is contained in:
Jindrich Novy 2008-01-15 13:37:53 +00:00
parent c8d3ea229b
commit b33261128d
11 changed files with 17 additions and 11265 deletions

View File

@ -1,149 +0,0 @@
--- texlive-2007/texk/configure.in.pxdvi 2007-02-22 11:12:57.000000000 +0900
+++ texlive-2007/texk/configure.in 2007-02-22 11:16:07.000000000 +0900
@@ -76,6 +76,7 @@
tth
xdv2pdf
xdvik
+ pxdvik
xdvipdfmx
'
--- texlive-2007/texk/pxdvik/vfontmap.c.pxdvi 2007-02-22 11:12:58.000000000 +0900
+++ texlive-2007/texk/pxdvik/vfontmap.c 2007-02-22 11:12:58.000000000 +0900
@@ -8,7 +8,7 @@
#include "vfontmap.h"
#include "kpathsea/tex-file.h"
#ifndef DEFAULT_FONTMAP
-#define DEFAULT_FONTMAP "/usr/local/share/texmf/xdvi/vfontmap"
+#define DEFAULT_FONTMAP "/usr/share/texmf/pxdvi/vfontmap"
#endif
#ifdef KANJI
#if defined(USE_ZEIT) && defined(USE_VFONTMAP)
--- texlive-2007/texk/pxdvik/withenable.ac.pxdvi 2007-02-22 11:12:58.000000000 +0900
+++ texlive-2007/texk/pxdvik/withenable.ac 2007-02-22 11:12:58.000000000 +0900
@@ -83,9 +83,9 @@
fi],
AC_DEFINE(A4))
-VFONTMAP='$(texmf)/xdvi/vfontmap'
+VFONTMAP='$(texmf)/pxdvi/vfontmap'
AC_ARG_WITH(vfontmap,
-[ --with-vfontmap=FILE Use FILE as default vfontmap (default ${texmf}/xdvi/vfontmap)],
+[ --with-vfontmap=FILE Use FILE as default vfontmap (default ${texmf}/pxdvi/vfontmap)],
[VFONTMAP="$withval"])
AC_SUBST(VFONTMAP)
--- texlive-2007/texk/pxdvik/xdvi-config.h.pxdvi 2007-02-22 11:12:58.000000000 +0900
+++ texlive-2007/texk/pxdvik/xdvi-config.h 2007-02-22 11:12:58.000000000 +0900
@@ -35,7 +35,7 @@
#define DEFAULT_FONTCONF ""
#define USE_VFONTMAP
#ifndef DEFAULT_FONTMAP
-#define DEFAULT_FONTMAP "/usr/local/share/texmf/xdvi/vfontmap"
+#define DEFAULT_FONTMAP "/usr/share/texmf/pxdvi/vfontmap"
#endif /* DEFAULT_FONTMAP */
#define NTTZEIT
#endif /* KANJI */
--- texlive-2007/texk/pxdvik/texmf/XDvi.pxdvi 2007-02-22 11:12:58.000000000 +0900
+++ texlive-2007/texk/pxdvik/texmf/XDvi 2007-02-22 11:12:58.000000000 +0900
@@ -137,7 +137,7 @@
!!!------------------------------------------------------------------------------
!!! note: when i18n'ed, *font and *fontSet should have same size of font
*international: true
-*inputMethod: kinput2
+*inputMethod: SCIM
*preeditType: OverTheSpot,OffTheSpot,Root
!!! note: xdviSelFile can not be i18n'ed (bug?)
xdviSelFile*international: false
--- texlive-2007/texk/pxdvik/Makefile.in.pxdvi 2007-02-22 11:12:57.000000000 +0900
+++ texlive-2007/texk/pxdvik/Makefile.in 2007-02-22 11:12:58.000000000 +0900
@@ -11,6 +11,9 @@
all_subdirs = gui
+dvipsdir = $(texmf)/pdvips
+psheaderdir = $(dvipsdir)
+
CPP = @CPP@
# Make `#include <X11/...>' and `-lX...' work.
@@ -140,8 +143,8 @@
rm -f $(scriptdir)/o@wrapper_script@
ln -s @wrapper_script@ $(scriptdir)/o@wrapper_script@
### fix wrong CVS permissions for shell script
- $(INSTALL_SCRIPT) $(srcdir)/xdvizilla $(scriptdir)/xdvizilla
- chmod +x $(scriptdir)/xdvizilla
+ $(INSTALL_SCRIPT) $(srcdir)/xdvizilla $(scriptdir)/pxdvizilla
+ chmod +x $(scriptdir)/pxdvizilla
uninstall-exec:
for p in @final_exec_name@; do rm -f $(bindir)/$$p; done
@@ -149,42 +152,42 @@
install-data: $(manpage).1 pixmaps/toolbar.xpm pixmaps/toolbar2.xpm
$(SHELL) $(top_srcdir)/../mkinstalldirs $(man1dir)
- $(SHELL) $(top_srcdir)/../mkinstalldirs $(texmf)/xdvi/pixmaps
+ $(SHELL) $(top_srcdir)/../mkinstalldirs $(texmf)/pxdvi/pixmaps
$(INSTALL_DATA) $(manpage).1 $(man1dir)/$(manpage).$(manext)
rm -f $(man1dir)/o$(manpage).$(manext)
ln -s $(manpage).$(manext) $(man1dir)/o$(manpage).$(manext)
- $(INSTALL_DATA) $(srcdir)/texmf/XDvi $(texmf)/xdvi/XDvi
- $(INSTALL_DATA) $(srcdir)/pixmaps/toolbar.xpm $(srcdir)/pixmaps/toolbar2.xpm $(texmf)/xdvi/pixmaps
+ $(INSTALL_DATA) $(srcdir)/texmf/XDvi $(texmf)/pxdvi/XDvi
+ $(INSTALL_DATA) $(srcdir)/pixmaps/toolbar.xpm $(srcdir)/pixmaps/toolbar2.xpm $(texmf)/pxdvi/pixmaps
if \
- grep 'original xdvi.cfg --' $(texmf)/xdvi/xdvi.cfg >/dev/null 2>&1 \
- || test ! -r $(texmf)/xdvi/xdvi.cfg; \
+ grep 'original xdvi.cfg --' $(texmf)/pxdvi/xdvi.cfg >/dev/null 2>&1 \
+ || test ! -r $(texmf)/pxdvi/xdvi.cfg; \
then \
- $(INSTALL_DATA) $(srcdir)/texmf/xdvi.cfg $(texmf)/xdvi/xdvi.cfg; \
+ $(INSTALL_DATA) $(srcdir)/texmf/xdvi.cfg $(texmf)/pxdvi/xdvi.cfg; \
else \
true; \
fi
$(INSTALL_DATA) $(srcdir)/xdvizilla.1 $(man1dir)/xdvizilla.$(manext)
- $(INSTALL_DATA) $(srcdir)/vfontmap.sample $(texmf)/xdvi/
+ $(INSTALL_DATA) $(srcdir)/vfontmap.sample $(texmf)/pxdvi/
if test ! -f $(VFONTMAP); then \
$(INSTALL_DATA) $(srcdir)/vfontmap.sample $(VFONTMAP); \
fi
uninstall-data:
rm -f $(man1dir)/$(manpage).$(manext) $(man1dir)/xdvizilla.$(manext) \
- $(scriptdir)/xdvizilla \
- $(texmf)/xdvi/pixmaps/toolbar.xpm $(texmf)/xdvi/pixmaps/toolbar2.xpm \
- $(texmf)/xdvi/XDvi
+ $(scriptdir)/pxdvizilla \
+ $(texmf)/pxdvi/pixmaps/toolbar.xpm $(texmf)/pxdvi/pixmaps/toolbar2.xpm \
+ $(texmf)/pxdvi/XDvi
if \
- head -n 1 $(texmf)/xdvi/xdvi.cfg | grep 'original xdvi.cfg --' >/dev/null 2>&1 \
- || test ! -r $(texmf)/xdvi/xdvi.cfg; \
+ head -n 1 $(texmf)/pxdvi/xdvi.cfg | grep 'original xdvi.cfg --' >/dev/null 2>&1 \
+ || test ! -r $(texmf)/pxdvi/xdvi.cfg; \
then \
- rm -f $(texmf)/xdvi/xdvi.cfg; \
+ rm -f $(texmf)/pxdvi/xdvi.cfg; \
else \
true; \
fi
- rmdir $(texmf)/xdvi/pixmaps
+ rmdir $(texmf)/pxdvi/pixmaps
-distname = xdvik
+distname = pxdvik
program_files = *.1.in *.ac xdvi.icon xdvi.FAQ psheader.txt mksedscript \
MOTIF
version_files = xdvi.c
--- texlive-2007/texk/pxdvik/xdvi-sh.in.pxdvi 2006-01-18 06:41:51.000000000 +0900
+++ texlive-2007/texk/pxdvik/xdvi-sh.in 2007-02-22 11:12:58.000000000 +0900
@@ -28,7 +28,7 @@
NAMEOPT='-name xdvi';;
esac
-xdviappfile=`kpsewhich -progname=xdvi --format='other text files' XDvi`
+xdviappfile=`kpsewhich -progname=pxdvi --format='other text files' XDvi`
if test -n "$xdviappfile"; then
xdviappdir=`dirname "$xdviappfile"`
xdviapppath="${xdviappdir}/%l_%t/%N:${xdviappdir}/%N"

View File

@ -1,36 +0,0 @@
--- tetex-src-3.0/texk/xdvik/events.c.xdvi-keepflag 2004-11-29 17:45:11.000000000 -0700
+++ tetex-src-3.0/texk/xdvik/events.c 2005-11-02 17:02:19.000000000 -0700
@@ -696,10 +696,12 @@ home(wide_bool scrl)
{
int value;
- value = (globals.page.w - mane.width) / 2;
- if (value > resource.sidemargin_int / mane.shrinkfactor)
- value = resource.sidemargin_int / mane.shrinkfactor;
- (void)set_bar_value(globals.widgets.x_bar, value, (int)(globals.page.w - mane.width));
+ if (!resource.keep_flag) {
+ value = (globals.page.w - mane.width) / 2;
+ if (value > resource.sidemargin_int / mane.shrinkfactor)
+ value = resource.sidemargin_int / mane.shrinkfactor;
+ (void)set_bar_value(globals.widgets.x_bar, value, (int)(globals.page.w - mane.width));
+ }
value = (globals.page.h - mane.height) / 2;
if (value > resource.topmargin_int / mane.shrinkfactor)
@@ -745,10 +747,12 @@ home_bottom(wide_bool scrl)
{
int value;
- value = (globals.page.w - mane.width) / 2;
- if (value > resource.sidemargin_int / mane.shrinkfactor)
- value = resource.sidemargin_int / mane.shrinkfactor;
- (void)set_bar_value(globals.widgets.x_bar, value, (int)(globals.page.w - mane.width));
+ if (!resource.keep_flag) {
+ value = (globals.page.w - mane.width) / 2;
+ if (value > resource.sidemargin_int / mane.shrinkfactor)
+ value = resource.sidemargin_int / mane.shrinkfactor;
+ (void)set_bar_value(globals.widgets.x_bar, value, (int)(globals.page.w - mane.width));
+ }
(void)set_bar_value(globals.widgets.y_bar, (int)(globals.page.h - mane.height), (int)(globals.page.h - mane.height));
}

View File

@ -1,13 +0,0 @@
--- tetex-src-3.0/texk/xdvik/configure.in.xprint 2006-05-05 16:31:52.000000000 -0400
+++ tetex-src-3.0/texk/xdvik/configure.in 2006-05-05 16:32:07.000000000 -0400
@@ -105,8 +105,8 @@
else
XLFLAG=
fi
- AC_CHECK_LIB(Xp, XpQueryVersion,
- x_ext_lib="-lXp -lXext", :, -lXext -lX11 $X_EXTRA_LIBS $XLFLAG)
+# AC_CHECK_LIB(Xp, XpQueryVersion,
+# x_ext_lib="-lXp -lXext", :, -lXext -lX11 $X_EXTRA_LIBS $XLFLAG)
fi
dnl
dnl If libXp not found, try libXext only:

View File

@ -1,38 +0,0 @@
--- texk/xdvik/translations.h
+++ texk/xdvik/translations.h 2005-02-07 14:07:44.000000000 +0100
@@ -119,15 +119,26 @@
"<Key>Escape: discard-number()\n"
#endif
#ifdef XK_KP_Left
- "<Key>KP_Home: home()\n"
- "<Key>KP_Left: left()\n"
- "<Key>KP_Up: up()\n"
- "<Key>KP_Right: right()\n"
- "<Key>KP_Down: down()\n"
- "<Key>KP_Prior: back-page()\n"
- "<Key>KP_Next: forward-page()\n"
- "<Key>KP_Delete: up-or-previous()\n"
- "<Key>KP_Enter: forward-page()\n"
+ "~@Num_Lock<Key>KP_Home:home()\n"
+ "~@Num_Lock<Key>KP_Left:left(0.015)\n"
+ "~@Num_Lock<Key>KP_Begin:center()\n"
+ "~@Num_Lock<Key>KP_Up:up(0.015)\n"
+ "~@Num_Lock<Key>KP_Right:right(0.015)\n"
+ "~@Num_Lock<Key>KP_Down:down(0.015)\n"
+ "~@Num_Lock<Key>KP_Prior:back-page()\n"
+ "~@Num_Lock<Key>KP_Next:forward-page()\n"
+ "<Key>KP_Enter:forward-page()\n"
+ "<Key>KP_Delete:up-or-previous()\n"
+ "<Key>KP_1:digit(1)\n"
+ "<Key>KP_2:digit(2)\n"
+ "<Key>KP_3:digit(3)\n"
+ "<Key>KP_4:digit(4)\n"
+ "<Key>KP_5:digit(5)\n"
+ "<Key>KP_6:digit(6)\n"
+ "<Key>KP_7:digit(7)\n"
+ "<Key>KP_8:digit(8)\n"
+ "<Key>KP_9:digit(9)\n"
+ "<Key>KP_0:digit(0)\n"
#endif
"";

View File

@ -1,13 +0,0 @@
--- texk/xdvik/xdvizilla
+++ texk/xdvik/xdvizilla 2005-02-07 14:18:11.000000000 +0100
@@ -61,8 +61,8 @@
trap 'do_cleanup' 1 2 3 7 13 15
### create a temporary directory only read/writable by user
-TMP_DIR=${TMPDIR-${TEMP-${TMP-/tmp}}}/$progname.$$
-(umask 077; mkdir "$TMP_DIR") || do_abort "Could not create directory \`$TMP_DIR'"
+TMP_DIR=${TMPDIR-${TEMP-${TMP-/tmp}}}/${progname}.XXXXXX
+TMP_DIR=$(mktemp -d "$TMP_DIR") || do_abort "Could not create directory \`$TMP_DIR'"
if [ $# -gt 1 -a "x$1" = "x-no-rm" ]; then
NO_RM=y

View File

@ -1,12 +0,0 @@
diff -up texlive-2007/texk/xdvik/dvi-draw.c.maxchar texlive-2007/texk/xdvik/dvi-draw.c
--- texlive-2007/texk/xdvik/dvi-draw.c.maxchar 2007-11-20 15:21:35.000000000 +0100
+++ texlive-2007/texk/xdvik/dvi-draw.c 2007-11-22 15:31:06.000000000 +0100
@@ -5911,6 +5911,8 @@ get_t1_glyph(
t1libid, currinf.fontp->scale,
size, currwin.shrinkfactor));
+ if (ch > maxchar)
+ return NULL;
/* Check if the glyph already has been rendered */
if ((g = &currinf.fontp->glyph[ch])->bitmap.bits == NULL) {
int bitmapbytes;

View File

@ -1,26 +0,0 @@
--- texlive-bin-2006.svn3816.orig/build/source/texk/xdvik/gui/search-dialog.c 2006-01-17 22:41:51.000000000 +0100
+++ texlive-bin-2006.svn3816/build/source/texk/xdvik/gui/search-dialog.c 2007-01-26 04:00:04.000000000 +0100
@@ -694,6 +694,11 @@
#ifdef MOTIF
XtAddCallback(searchbox_input, XmNactivateCallback, cb_search_get_term, settings);
#endif
+
+ /* Fix for #1499566: Force input focus for text input field */
+#ifndef MOTIF
+ XtSetKeyboardFocus(find_paned, searchbox_input);
+#endif
/*
* form for left row of options checkbuttons
--- texlive-bin-2006.svn3816.orig/build/source/texk/xdvik/dvi-draw.c 2006-01-17 22:41:51.000000000 +0100
+++ texlive-bin-2006.svn3816/build/source/texk/xdvik/dvi-draw.c 2007-01-26 04:00:04.000000000 +0100
@@ -1255,6 +1255,9 @@
do_color_change();
}
#endif
+ if (pixeltbl == NULL) {
+ do_color_change();
+ }
/* TODO: rounding errors causing color fringing (see HACK comment below):

View File

@ -8,7 +8,6 @@
%define dvipdfm_ver 0.13.2d
%define dvipdfmx_ver 0
%define dvipng_ver 1.9
%define xdvi_ver 22.84.12
%define enable_japanese 1
@ -27,7 +26,7 @@
Name: texlive
Version: %{texlive_ver}
Release: 9%{?dist}
Release: 10%{?dist}
Summary: Binaries for the TeX formatting system
Group: Applications/Publishing
@ -43,8 +42,6 @@ Source0: source-free.tar.bz2
#Source1: xpdf-3.02.tar.bz2
Source10: texlive.cron
# Source30 is http://xdvi.sourceforge.net/xdvi48x48.gif converted to png
Source30: xdvi48x48.png
# Filter out bad requirements (RH bug #59819).
Source99: texlive-filter-requires.sh
Source100: texlive-generate-tarball.sh
@ -53,7 +50,6 @@ Source100: texlive-generate-tarball.sh
Source1000: ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/tetex/ptex-src-%{ptex_src_ver}.tar.gz
Source1001: ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/dvips/dvipsk-jpatch-%{pdvipsk_ver}.tar.bz2
Source1002: ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/mendex/mendexk%{mendexk_ver}.tar.gz
Source1003: vfontmap
# Don't run brp-python-bytecompile
%define __os_install_post /usr/lib/rpm/redhat/brp-compress /usr/lib/rpm/redhat/brp-strip %{__strip} /usr/lib/rpm/redhat/brp-strip-static-archive %{__strip} /usr/lib/rpm/redhat/brp-strip-comment-note %{__strip} %{__objdump} %{nil}
@ -64,7 +60,6 @@ Source1003: vfontmap
# and sane defaults to build against can be inserted via sed
Patch5: texlive-2007-browser.patch
Patch8: texlive-2007-xprint.patch
Patch9: texlive-teckit.patch
Patch21: texlive-more_paths.patch
@ -77,12 +72,10 @@ Patch22: texlive-fedora_paths.patch
Patch10: texlive-2007-dvipdfm-security.patch
Patch11: texlive-2007-makej.patch
Patch12: texlive-2007-badscript.patch
Patch15: texlive-2007-xdvi-keepflag.patch
Patch17: texlive-2007-tmpcleanup.patch
Patch19: texlive-2007-kpse-extensions.patch
Patch20: texlive-CVE-2007-4033.patch
Patch23: texlive-CVE-2007-4352-5392-5393.patch
Patch24: texlive-xdvi-maxchar.patch
Patch25: texlive-dvipsoverflow.patch
Patch26: texlive-dviljktemp.patch
Patch27: texlive-poppler.patch
@ -108,7 +101,6 @@ Patch106: texlive-12c_fix_pdfcrop_invocation.patch
Patch107: texlive-12d_fix_ebong_invocation.patch
Patch108: texlive-12e_fix_vpe_invocation.patch
Patch109: texlive-texdoc.patch
Patch111: texlive-xdvi.patch
Patch114: texlive-dvips_fontbug_fix_upstream.patch
Patch115: texlive-maketexmf.patch
Patch117: texlive-fmtutil_keep_failedlog.patch
@ -128,16 +120,10 @@ Patch300: texlive-source-icu.patch
Patch301: texlive-source-t1lib.patch
Patch302: texlive-source-warns.patch
Patch303: texlive-source-x11r7.patch
Patch304: texlive-source-xdvi-numlock.patch
Patch305: texlive-source-xdvizilla.patch
Patch306: texlive-source-CVE-2007-0650.patch
# 1000-: Japanese pTeX
Patch1000: dvipsk-jpatch-pdvips.patch
# prepare from http://sourceforge.jp/projects/xdvi/
# remove patch for configure because it is regenerated from autoconf2.13.
Patch1002: xdvik-22.84.10-j1.34.patch
Patch1003: texlive-2007-pxdvi.patch
Patch1004: texlive-2007-jp-platex209.patch
Patch1005: texlive-2007-pdvips.patch
Patch1006: texlive-2007-ptex-3.1.10.patch
@ -153,10 +139,6 @@ BuildRequires: libSM-devel libICE-devel
BuildRequires: Xaw3d-devel
BuildRequires: poppler-devel >= 0.6.2-2
BuildRequires: teckit-devel
# pxdvi buildrequires freetype >= 2.1.10
%if %{enable_japanese}
BuildRequires: freetype-devel >= 2.1.10
%endif
Requires: xdg-utils ruby
Requires: texlive-texmf = %{version}
Requires: texlive-texmf-errata = %{version}
@ -173,7 +155,7 @@ Requires: dvipdfmx
# make sure fonts package installed before running post - since
# fmtutil-sys is symlink to fmtutil
Requires(post): %{_bindir}/fmtutil
Provides: tex
Provides: tex(tex)
Obsoletes: tetex < 3.0-99
Provides: tetex = 3.0-99
Obsoletes: tetex-fonts < 3.0-99
@ -214,7 +196,7 @@ system and PostScript files, you will need to install texlive-afm. You will
also need to install texlive-dvips (for converting .dvi files to PostScript
format for printing on PostScript printers), texlive-latex (a higher level
formatting package which provides an easier-to-use interface for TeX), and
texlive-xdvi (for previewing .dvi files in X).
xdvi (for previewing .dvi files in X).
The TeX documentation is located in the texlive-doc package.
@ -227,7 +209,7 @@ Provides: tetex-doc = 3.0-99
Obsoletes: texlive-doc < 2007-7
Provides: texlive-doc = %{version}-%{release}
Requires: texlive-texmf-doc = %{version}
Requires: texlive-texmf-doc-errata = %{version}
Requires: texlive-texmf-errata-doc = %{version}
%description doc
If you are installing texlive and need a documentation to describe
@ -244,7 +226,7 @@ Obsoletes: tetex-dvips < 3.0-99
Provides: tetex-dvips = 3.0-99
Requires: texlive-texmf-dvips = %{version}
Requires: texlive-texmf-errata = %{version}
Provides: tex-dvips
Provides: tex(dvips)
%description dvips
Dvips converts .dvi files, for example those produced by the TeX text
@ -282,7 +264,7 @@ Obsoletes: tetex-latex < 3.0-99
Provides: tetex-latex = 3.0-99
Requires: texlive-texmf-latex = %{version}
Requires: texlive-texmf-errata = %{version}
Provides: tex-latex
Provides: tex(latex)
%description latex
LaTeX is a front end for the TeX text formatting system. Easier to
@ -313,27 +295,6 @@ symbolic link.
You only need to install this package if you will be compiling software that
wants to link against the kpathsea library.
%package -n xdvi
Summary: An X viewer for DVI files
Group: Applications/Publishing
Requires: texlive-dvips = %{version}-%{release}
Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
Version: %{xdvi_ver}
#Url: http://xdvi.sourceforge.net/
#Source0: http://downloads.sourceforge.net/xdvi/xdvik-%{xdvi_ver}.tar.gz
Obsoletes: tetex-xdvi < 3.0-99
Provides: tetex-xdvi = 3.0-99
%description -n xdvi
Xdvik, the kpathsea version of xdvi, is a previewer for DVI files
produced e.g. by the TeX or troff typesetting systems.
If you are installing texlive and you use PlainTeX or you are using DVI files,
you will also need to install xdvi which allows you to view DVI files.
Consider installing texlive-dvips (for converting .dvi files to PostScript
format for printing on PostScript printers), and texlive-latex (a higher level
formatting package which provides an easier-to-use interface for TeX).
%package -n dvipng
Summary: DVI-to-PNG converter
Version: %{dvipng_ver}
@ -413,7 +374,6 @@ chmod -x texk/dvipdfm/encodings.c
######
# Use htmlview first
%patch5 -p1 -b .browser
%patch8 -p1 -b .xprint
%patch9 -p1 -b .teckit
%patch22 -p1 -b .fedora_paths
@ -427,8 +387,6 @@ chmod -x texk/dvipdfm/encodings.c
%patch11 -p1 -b .makej
# Don't use PID for temporary file names in scripts (RH bug #41269)
%patch12 -p1 -b .badscript
# Fix xdvi - navigation with a spacebar does not keep position (RH bug #168124)
%patch15 -p1 -b .xdvi-keepflag
# Always cleanup temporary directories for texconfig, updmap, fmtutil
# (RH #172534)
%patch17 -p1 -b .tmpcleanup
@ -436,7 +394,6 @@ chmod -x texk/dvipdfm/encodings.c
%patch20 -p1 -b .CVE-2007-4033
%patch21 -p1 -b .more_paths
#%patch23 -p1 -b .CVE-2007-4352-5392-5393
%patch24 -p1 -b .maxchar
%patch25 -p1 -b .dvipsoverflow
%patch26 -p1 -b .dviljktemp
%patch27 -p1 -b .poppler
@ -456,7 +413,6 @@ chmod -x texk/dvipdfm/encodings.c
%patch107 -p3
%patch108 -p3
%patch109 -p1
%patch111 -p3
%patch114 -p3
%patch115 -p3
%patch117 -p3
@ -470,8 +426,6 @@ chmod -x texk/dvipdfm/encodings.c
%patch301 -p0
%patch302 -p0
%patch303 -p0
%patch304 -p0
%patch305 -p0
%patch306 -p0
%patch1007 -p1 -b .ptex
@ -492,9 +446,6 @@ rm -rf lcdf-typetools
popd
%endif
# allow Xaw3d enabled build of xdvi
%{__sed} -i 's|/Xaw/|/Xaw3d/|' texk/xdvik/gui/*.[ch] texk/xdvik/*.[ch]
## Japanese pTeX
%if %{enable_japanese}
# create customized cid-x.map for dvipdfmx (#418091)
@ -535,16 +486,6 @@ patch -d texk/pdvipsk -p1 < pdvipsk/dvipsk-%{pdvipsk_ver}.patch
%patch1000 -p1 -b .pdvips
ln -s dvips.1 texk/pdvipsk/pdvips.1
# set up Japanese xdvi
cp -a texk/xdvik texk/pxdvik
cd texk/pxdvik
%patch1002 -p3
cd -
%patch1003 -p1 -b .pxdvi
mv texk/pxdvik/vfontmap.sample texk/pxdvik/vfontmap.sample.orig
install -p -m 644 %{SOURCE1003} texk/pxdvik/vfontmap.sample
# set up mendexk
tar xfz %{SOURCE1002} -C texk
%endif
@ -561,9 +502,9 @@ unset HOME ||:
# Japanese pTeX
%if %{enable_japanese}
for i in texk/xdvik texk/pxdvik texk ; do
( cd ${i} ; $RPM_BUILD_DIR/%{name}-%{version}/texk/autoconf2.13 -m $RPM_BUILD_DIR/%{name}-%{version}/texk/etc/autoconf )
done
pushd texk
$RPM_BUILD_DIR/%{name}-%{version}/texk/autoconf2.13 -m $RPM_BUILD_DIR/%{name}-%{version}/texk/etc/autoconf
popd
%endif
%configure \
@ -596,7 +537,7 @@ done
--with-lcdf-typetools=no \
%endif
--with-mf-x-toolkit=yes \
--with-xdvi-x-toolkit=xaw3d \
--without-xdvik \
--without-cxx-runtime-hack
# Remove everything except:
@ -604,14 +545,6 @@ done
# md5: the aladdin md5 code (not a library)
%{__rm} -r libs/{curl,expat,freetype,freetype2,gd,howto,jpeg,libgnuw32,libgsw32,libpng,libttf,ncurses,regex,unzip,zlib,type1,t1lib,xpdf}/
# Japanese pTeX
# configure pxdvi with more options
%if %{enable_japanese}
cd texk/pxdvik
sh `grep "# ./con" config.status |sed -e s/^#\ //` --program-prefix=p --with-default-dvips-path=pdvips
cd -
%endif
# %%{?_smp_mflags} does not work in texlive-2007/libs/icu-xetex/common
make
@ -645,20 +578,6 @@ export LD_LIBRARY_PATH=`pwd`/texk/kpathsea/.libs
texmf=%{buildroot}%{_texmf_main} \
texmfmain=%{buildroot}%{_texmf_main}
# desktop entry things
cat > xdvi.desktop <<EOF
[Desktop Entry]
Encoding=UTF-8
Name=DVI Viewer
Type=Application
Comment=DVI viewer for TeX DVI files
Icon=xdvi
MiniIcon=mini-doc1.xpm
Exec=%{_bindir}/xdvi
MimeType=application/x-dvi
NoDisplay=true
EOF
# remove all .la files
rm -f %{buildroot}%{_infodir}/dir
find %{buildroot} | grep -e "\\.la$" | xargs rm -f
@ -704,17 +623,6 @@ rm -rf %{buildroot}%{_texmf_main}/doc/tetex
# install cron file
install -p -D -m755 %{SOURCE10} %{buildroot}%{_sysconfdir}/cron.daily/texlive.cron
# install the xdvi desktop file
mkdir -p %{buildroot}%{_datadir}/{applications,pixmaps}
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/
install -p -m644 %{SOURCE30} %{buildroot}%{_datadir}/pixmaps/
install -p -m644 %{SOURCE30} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/xdvi.png
desktop-file-install --vendor tetex --delete-original \
--dir %{buildroot}%{_datadir}/applications \
--add-category Graphics \
xdvi.desktop
# remove pool files, they belong to texlive-texmf
rm -rf %{buildroot}%{_texmf_main}/web2c/*.pool
# ptex pool file is added later, and therefore kept
@ -725,8 +633,7 @@ rm -rf %{buildroot}%{_texmf_main}/web2c/*.pool
rm -f %{buildroot}%{_bindir}/platex
# Convert documents to UTF-8
mkdir -p %{buildroot}%{_texmf_main}/doc/ptex/ptex-src-%{name} \
%{buildroot}%{_texmf_main}/doc/pdvipsk \
%{buildroot}%{_texmf_main}/doc/pxdvik/READMEs
%{buildroot}%{_texmf_main}/doc/pdvipsk
cd texk/web2c/ptex-src-%{ptex_src_ver}
iconv -f ISO-2022-JP -t UTF-8 \
COPYRIGHT.jis \
@ -741,12 +648,6 @@ for i in ChangeLog.jpatch README.jpatch ; do
iconv -f EUC-JP -t UTF-8 ${i} -o %{buildroot}%{_texmf_main}/doc/pdvipsk/${i}
done
cd -
cd texk/pxdvik
for i in CHANGES.xdvik-jp README.xdvik-jp READMEs/* ; do
iconv -f EUC-JP -t UTF-8 ${i} \
-o %{buildroot}%{_texmf_main}/doc/pxdvik/${i}
done
cd -
cd texk/web2c/ptex-src-%{ptex_src_ver}
%makeinstall INSTALL="install -p" prefix=%{buildroot}%{_prefix} \
@ -756,8 +657,6 @@ cd texk/web2c/ptex-src-%{ptex_src_ver}
rm %{buildroot}%{_texmf_main}/web2c/texmf.cnf
cd -
install -p -m 644 texk/pxdvik/vfontmap.sample.orig %{buildroot}%{_datadir}/texmf/doc/pxdvik/vfontmap.sample
# mendexk install
cd texk/mendexk%{mendexk_ver}
install -p -m 755 mendex %{buildroot}%{_bindir}
@ -808,14 +707,6 @@ rm -rf %{buildroot}
%{_bindir}/texconfig-sys rehash 2> /dev/null || :
%{_bindir}/fmtutil-sys --all > /dev/null 2>&1 || :
%post -n xdvi
%{_bindir}/texconfig-sys rehash 2> /dev/null || :
%{_bindir}/update-desktop-database %{_datadir}/applications || :
touch --no-create %{_datadir}/icons/hicolor
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi
%post -n kpathsea
/sbin/ldconfig
[ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/kpathsea.info.gz %{_infodir}/dir || :
@ -862,13 +753,6 @@ fi
%postun latex
%{_bindir}/texconfig-sys rehash 2> /dev/null || :
%postun -n xdvi
%{_bindir}/texconfig-sys rehash 2> /dev/null || :
touch --no-create %{_datadir}/icons/hicolor
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi
%postun -n kpathsea
/sbin/ldconfig
@ -1273,29 +1157,6 @@ fi
%{_bindir}/platex209
%endif
%files -n xdvi
%defattr(-,root,root,-)
%{_bindir}/oxdvi
%{_bindir}/xdvi
%{_bindir}/xdvizilla
%{_bindir}/xdvi-xaw3d.bin
%{_texmf_main}/xdvi/
%{_mandir}/man1/oxdvi.1*
%{_mandir}/man1/xdvi.1*
%{_mandir}/man1/xdvizilla.1*
%{_datadir}/pixmaps/xdvi48x48.png
%{_datadir}/icons/hicolor/48x48/apps/xdvi.png
%{_datadir}/applications/tetex-xdvi.desktop
# Japanese pTeX
%if %{enable_japanese}
%{_bindir}/opxdvi
%{_bindir}/pxdvi
%{_bindir}/pxdvizilla
%{_bindir}/pxdvi-xaw3d.bin
%{_texmf_main}/pxdvi/
%doc %{_texmf_main}/doc/pxdvik/
%endif
%files -n kpathsea
%defattr(-,root,root,-)
%{_libdir}/libkpathsea.so.*
@ -1342,6 +1203,12 @@ fi
%{_texmf_main}/dvipdfm/
%changelog
* Tue Jan 15 2008 Jindrich Novy <jnovy@redhat.com> - 2007-10
- don't build/package xdvik/pxdvik, it's now separated
- fix texlive-doc requires, description
- use virtual provides with parentheses to avoid clashes
with real packages (#410401)
* Mon Jan 14 2008 Jindrich Novy <jnovy@redhat.com> - 2007-9
- unify texlive and texlive-fonts filelists
- package texdoc and texdoctk to a separate subpackage

View File

@ -1,94 +0,0 @@
%
% Sample "vfontmap"
%
% [single style]
% "tfm" "enc" "font"
% [multi style]
% "/font/file/name"
% "tfm1" "enc"
% "tfm2" "enc"
% "enc" is one of following.
% "JIS-H" "Unicode-H" "Identity-H"
% "JIS-V" "Unicode-V" "Identity-V"
rml JIS-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
rmlv JIS-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
gbm JIS-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
gbmv JIS-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
fmin JIS-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
fgoth JIS-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
maru JIS-H /usr/local/share/texmf/dvipdfm/CIDFont/HiraMaruPro-W4.otf
% UTF package
unijmin-h Unicode-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf % \UTF font
unijmin-v Unicode-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf % \UTF font
cidmin-h Identity-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf % \CID font
cidmin-v Identity-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf % \CID font
hmr JIS-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
hmrv JIS-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
unijgoth-h Unicode-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf % \UTF font
unijgoth-v Unicode-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf % \UTF font
cidgoth-h Identity-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf % \CID font
cidgoth-v Identity-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf % \CID font
hkb JIS-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
hkbv JIS-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
% OTF package
otf-ujmr-h Unicode-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-ujmr-v Unicode-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-cjmr-h Identity-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-cjmr-v Identity-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
hminr-h JIS-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
hminr-v JIS-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-ujgr-h Unicode-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-ujgr-v Unicode-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-cjgr-h Identity-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-cjgr-v Identity-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
hgothr-h JIS-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
hgothr-v JIS-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-ujmb-h Unicode-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-ujmb-v Unicode-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-cjmb-h Identity-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-cjmb-v Identity-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
hminb-h JIS-H /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
hminb-v JIS-V /usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf
otf-ujgb-h Unicode-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-ujgb-v Unicode-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-cjgb-h Identity-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-cjgb-v Identity-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
hgothb-h JIS-H /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
hgothb-v JIS-V /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
otf-ujmgr-h Unicode-H /usr/local/share/texmf/dvipdfm/CIDFont/HiraMaruPro-W4.otf
otf-ujmgr-v Unicode-V /usr/local/share/texmf/dvipdfm/CIDFont/HiraMaruPro-W4.otf
otf-cjmgr-h Identity-H /usr/local/share/texmf/dvipdfm/CIDFont/HiraMaruPro-W4.otf
otf-cjmgr-v Identity-V /usr/local/share/texmf/dvipdfm/CIDFont/HiraMaruPro-W4.otf
hmgothr-h JIS-H /usr/local/share/texmf/dvipdfm/CIDFont/HiraMaruPro-W4.otf
hmgothr-v JIS-V /usr/local/share/texmf/dvipdfm/CIDFont/HiraMaruPro-W4.otf
otf-utmr-h Unicode-H /usr/share/fonts/cjkunifonts-uming/uming.ttf
otf-utmr-v Unicode-V /usr/share/fonts/cjkunifonts-uming/uming.ttf
otf-utgr-h Unicode-H /usr/share/fonts/cjkunifonts-ukai/ukai.ttf
otf-utgr-v Unicode-V /usr/share/fonts/cjkunifonts-ukai/ukai.ttf
otf-ucmr-h Unicode-H /usr/share/fonts/cjkunifonts-uming/uming.ttf
otf-ucmr-v Unicode-V /usr/share/fonts/cjkunifonts-uming/uming.ttf
otf-ucgr-h Unicode-H /usr/share/fonts/cjkunifonts-ukai/ukai.ttf
otf-ucgr-v Unicode-V /usr/share/fonts/cjkunifonts-ukai/ukai.ttf
otf-ukmr-h Unicode-H /usr/share/fonts/baekmuk-ttf-batang/batang.ttf
otf-ukmr-v Unicode-V /usr/share/fonts/baekmuk-ttf-batang/batang.ttf
otf-ukgr-h Unicode-H /usr/share/fonts/baekmuk-ttf-dotum/dotum.ttf
otf-ukgr-v Unicode-V /usr/share/fonts/baekmuk-ttf-dotum/dotum.ttf

Binary file not shown.

Before

Width:  |  Height:  |  Size: 798 B

File diff suppressed because it is too large Load Diff