- don't build/package dvipdfm, it's now packaged separately (#445983),
thanks to Jonathan Underwood - remove F8 related chunks from spec
This commit is contained in:
parent
ec19c2f3d7
commit
9bf2beb07a
@ -1,20 +0,0 @@
|
||||
--- tetex-src-2.0.2/texk/dvipdfm/psimage.c.dvipdfm-security 2001-06-28 20:55:26.000000000 +0100
|
||||
+++ tetex-src-2.0.2/texk/dvipdfm/psimage.c 2003-03-12 18:12:56.000000000 +0000
|
||||
@@ -113,10 +113,15 @@
|
||||
{
|
||||
#ifdef HAVE_SYSTEM
|
||||
pdf_obj *result = NULL;
|
||||
- char *tmp, *cmd;
|
||||
+ char tmp[] = "/tmp/dvipdfm.XXXXXX", *cmd;
|
||||
+ int tfd;
|
||||
FILE *pdf_file = NULL;
|
||||
/* Get a full qualified tmp name */
|
||||
- tmp = tmpnam (NULL);
|
||||
+ tfd = mkstemp (tmp);
|
||||
+ if (tfd == -1) {
|
||||
+ fprintf (stderr, "\nCouldn't create temporary file for output\n");
|
||||
+ return NULL;
|
||||
+ } else close (tfd);
|
||||
if ((cmd = build_command_line (file_name, tmp))) {
|
||||
if (!system (cmd) && (pdf_file = MFOPEN (tmp, FOPEN_RBIN_MODE))) {
|
||||
result = pdf_include_page (pdf_file, p, res_name);
|
@ -1,36 +0,0 @@
|
||||
diff -ur tetex-src-3.0/texk/dvipdfm/dvipdft.1 tetex-src-3.0-kuesterei_man/texk/dvipdfm/dvipdft.1
|
||||
--- tetex-src-3.0/texk/dvipdfm/dvipdft.1 2004-05-14 17:42:14.000000000 -0700
|
||||
+++ tetex-src-3.0-kuesterei_man/texk/dvipdfm/dvipdft.1 2006-05-12 00:23:31.000000000 -0700
|
||||
@@ -29,7 +29,7 @@
|
||||
.PP
|
||||
\fBdvipdft\fP was written by Mark A. Wicks and Thomas Esser.
|
||||
.PP
|
||||
-This manual page was written by Frank Küster <frank@kuesterei\&.ch>,
|
||||
+This manual page was written by Frank Küster <frank@kuesterei\&.ch>,
|
||||
for the Debian GNU/Linux system\&. It may be used by others without
|
||||
contacting the author\&. Any mistakes or omissions in the manual page
|
||||
are my fault; inquiries about or corrections to this manual page
|
||||
diff -ur tetex-src-3.0/texk/dvipdfm/ebb.1 tetex-src-3.0-kuesterei_man/texk/dvipdfm/ebb.1
|
||||
--- tetex-src-3.0/texk/dvipdfm/ebb.1 2004-05-09 00:06:02.000000000 -0700
|
||||
+++ tetex-src-3.0-kuesterei_man/texk/dvipdfm/ebb.1 2006-05-12 00:24:22.000000000 -0700
|
||||
@@ -28,7 +28,7 @@
|
||||
.PP
|
||||
\fBebb\fP was written by Mark A. Wicks.
|
||||
.PP
|
||||
-This manual page was written by Frank Küster <frank@kuesterei\&.ch>,
|
||||
+This manual page was written by Frank Küster <frank@kuesterei\&.ch>,
|
||||
for the Debian GNU/Linux system\&. It may be used and modified by
|
||||
others without contacting the author\&. Any mistakes or omissions in
|
||||
the manual page are my fault; inquiries about or corrections to this
|
||||
diff -ur tetex-src-3.0/texk/tetex/kpsewhere.man tetex-src-3.0-kuesterei_man/texk/tetex/kpsewhere.man
|
||||
--- tetex-src-3.0/texk/tetex/kpsewhere.man 2005-01-31 09:51:58.000000000 -0800
|
||||
+++ tetex-src-3.0-kuesterei_man/texk/tetex/kpsewhere.man 2006-05-12 00:25:46.000000000 -0700
|
||||
@@ -42,7 +42,7 @@
|
||||
<te@dbs\&.uni-hannover\&.de>, in 2003 and 2004\&. \fBkpsewhere\fP
|
||||
is in the public domain\&.
|
||||
.PP
|
||||
-This manual page was written by Frank Küster <frank@kuesterei\&.ch>,
|
||||
+This manual page was written by Frank Küster <frank@kuesterei\&.ch>,
|
||||
for the Debian GNU/Linux system\&. It is also in the public domain
|
||||
and may be used and changed by others without contacting the author\&.
|
||||
Any mistakes or omissions in the manual page are my fault; inquiries
|
@ -1,59 +0,0 @@
|
||||
# 61_dvipdfm_timezone by "Mark A. Wicks" <mwicks@kettering.edu>
|
||||
#
|
||||
# fix crash of dvipdfm with 0.5 timezones
|
||||
|
||||
build/source/texk/dvipdfm/pdfdoc.c | 34 +++++++++++++++++++++++-----------
|
||||
1 file changed, 23 insertions(+), 11 deletions(-)
|
||||
|
||||
Index: texlive-bin-2007/build/source/texk/dvipdfm/pdfdoc.c
|
||||
===================================================================
|
||||
--- texlive-bin-2007.orig/build/source/texk/dvipdfm/pdfdoc.c 2006-01-17 22:41:51.000000000 +0100
|
||||
+++ texlive-bin-2007/build/source/texk/dvipdfm/pdfdoc.c 2007-02-15 15:53:08.000000000 +0100
|
||||
@@ -232,13 +232,7 @@
|
||||
|
||||
static char *asn_date (void)
|
||||
{
|
||||
-#ifndef HAVE_TIMEZONE
|
||||
- #ifdef TM_GM_TOFF
|
||||
- #define timezone (bdtime->gm_toff)
|
||||
- #else
|
||||
- #define timezone 0l
|
||||
-#endif /* TM_GM_TOFF */
|
||||
-#endif /* HAVE_TIMEZONE */
|
||||
+ long tz_offset;
|
||||
static char date_string[24];
|
||||
time_t current_time;
|
||||
struct tm *bd_time;
|
||||
@@ -247,10 +241,28 @@
|
||||
}
|
||||
time(¤t_time);
|
||||
bd_time = localtime(¤t_time);
|
||||
- sprintf (date_string, "D:%04d%02d%02d%02d%02d%02d%+03ld'%02ld'",
|
||||
- bd_time -> tm_year+1900, bd_time -> tm_mon+1, bd_time -> tm_mday,
|
||||
- bd_time -> tm_hour, bd_time -> tm_min, bd_time -> tm_sec,
|
||||
- -timezone/3600, timezone%3600);
|
||||
+
|
||||
+#ifdef HAVE_TM_GMTOFF /* Preferred way to get time zone offset */
|
||||
+ tz_offset = bd_time->tm_gmtoff;
|
||||
+#else
|
||||
+#ifdef HAVE_TIMEZONE /* Plan B --- use external variable 'timezone'
|
||||
+ /* (may not provide correct offset for daylight savings time) */
|
||||
+ tz_offset = - timezone;
|
||||
+#else /* Last resort --- without more information, set offset to zero */
|
||||
+ tz_offset = 0l;
|
||||
+#endif /* HAVE_TIMEZONE */
|
||||
+#endif /* HAVE_TM_GMTOFF */
|
||||
+
|
||||
+ if (tz_offset == 0l) {
|
||||
+ sprintf (date_string, "D:%04d%02d%02d%02d%02d%02dZ00'00'",
|
||||
+ bd_time -> tm_year+1900, bd_time -> tm_mon+1, bd_time -> tm_mday,
|
||||
+ bd_time -> tm_hour, bd_time -> tm_min, bd_time -> tm_sec);
|
||||
+ } else {
|
||||
+ sprintf (date_string, "D:%04d%02d%02d%02d%02d%02d%c%02ld'%02ld'",
|
||||
+ bd_time -> tm_year+1900, bd_time -> tm_mon+1, bd_time -> tm_mday,
|
||||
+ bd_time -> tm_hour, bd_time -> tm_min, bd_time -> tm_sec,
|
||||
+ (tz_offset>0)? '+':'-', labs(tz_offset)/3600, (labs(tz_offset)/60)%60);
|
||||
+ }
|
||||
return date_string;
|
||||
}
|
||||
|
94
texlive.spec
94
texlive.spec
@ -1,15 +1,10 @@
|
||||
# This spec file is based on texjive project created by Michael A. Peters.
|
||||
# Adopted and modified for Fedora by Jindrich Novy.
|
||||
%define f8_packaging 0
|
||||
|
||||
%define texlive_ver 2007
|
||||
%define ptex_src_ver 3.1.10
|
||||
%define pdvipsk_ver p1.7a
|
||||
%define mendexk_ver 2.6e
|
||||
%define dvipdfm_ver 0.13.2d
|
||||
%if %{f8_packaging}
|
||||
%define dvipng_ver 1.9
|
||||
%endif
|
||||
|
||||
%define desktop_file_utils_version 0.9
|
||||
%define default_letter_paper 0
|
||||
@ -26,7 +21,7 @@
|
||||
|
||||
Name: texlive
|
||||
Version: %{texlive_ver}
|
||||
Release: 30%{?dist}
|
||||
Release: 31%{?dist}
|
||||
Summary: Binaries for the TeX formatting system
|
||||
|
||||
Group: Applications/Publishing
|
||||
@ -68,7 +63,6 @@ Patch22: texlive-fedora_paths.patch
|
||||
# TeX patches
|
||||
######
|
||||
|
||||
Patch10: texlive-2007-dvipdfm-security.patch
|
||||
Patch11: texlive-2007-makej.patch
|
||||
Patch12: texlive-2007-badscript.patch
|
||||
Patch17: texlive-2007-tmpcleanup.patch
|
||||
@ -85,7 +79,6 @@ Patch29: texlive-man-context.patch
|
||||
# mpeters contributed patches
|
||||
######
|
||||
# fixes man pages to utf-8
|
||||
Patch41: texlive-2007-kuesterei-man.patch
|
||||
Patch42: texlive-2007-copyright-utf8-man.patch
|
||||
# use proper shellbang
|
||||
Patch43: texlive-2007-epstopdf-shellbang.patch
|
||||
@ -106,7 +99,6 @@ Patch114: texlive-dvips_fontbug_fix_upstream.patch
|
||||
Patch115: texlive-maketexmf.patch
|
||||
Patch117: texlive-fmtutil_keep_failedlog.patch
|
||||
Patch119: texlive-checklib_fixes.patch
|
||||
Patch120: texlive-dvipdfm_timezone.patch
|
||||
Patch123: texlive-fix_makempx_installation.patch
|
||||
|
||||
######
|
||||
@ -138,11 +130,7 @@ BuildRequires: ncurses-devel zlib-devel libpng-devel gd-devel t1lib-devel
|
||||
BuildRequires: libSM-devel libICE-devel
|
||||
# for non-modular xorg - use xorg-devel instead of above
|
||||
BuildRequires: Xaw3d-devel
|
||||
%if %{f8_packaging}
|
||||
BuildRequires: poppler-devel >= 0.6.2-1
|
||||
%else
|
||||
BuildRequires: poppler-devel >= 0.6.2-2
|
||||
%endif
|
||||
BuildRequires: teckit-devel
|
||||
Requires: texlive-texmf = %{version}
|
||||
Requires: texlive-texmf-fonts = %{version}
|
||||
@ -356,20 +344,6 @@ symbolic link.
|
||||
You only need to install this package if you will be compiling software that
|
||||
wants to link against the kpathsea library.
|
||||
|
||||
%if %{f8_packaging}
|
||||
%package -n dvipng
|
||||
Summary: DVI-to-PNG converter
|
||||
Version: %{dvipng_ver}
|
||||
Group: Applications/Publishing
|
||||
Requires(post,preun,postun): /sbin/restorecon
|
||||
#Url: http://savannah.nongnu.org/projects/dvipng/
|
||||
#Source0: http://download.savannah.gnu.org/releases/dvipng/dvipng-%{dvipng_ver}.tar.gz
|
||||
|
||||
%description -n dvipng
|
||||
This program makes PNG and/or GIF graphics from DVI files as obtained
|
||||
from TeX and its relatives.
|
||||
%endif
|
||||
|
||||
%package -n mendexk
|
||||
Summary: Replacement for makeindex with many enhancements
|
||||
Group: Applications/Publishing
|
||||
@ -380,20 +354,6 @@ Version: %{mendexk_ver}
|
||||
%description -n mendexk
|
||||
Replacement for makeindex with many enhancements.
|
||||
|
||||
%package -n dvipdfm
|
||||
Summary: DVI to PDF translator
|
||||
Version: %{dvipdfm_ver}
|
||||
Group: Applications/Publishing
|
||||
#Url: http://gaspra.kettering.edu/dvipdfm/
|
||||
#Source0: http://gaspra.kettering.edu/dvipdfm/dvipdfm-%{dvipdfm_ver}.tar.gz
|
||||
# for dvipdft
|
||||
Requires: ghostscript
|
||||
# for .enc files
|
||||
Requires: texlive-texmf-dvips = %{texlive_ver}
|
||||
|
||||
%description -n dvipdfm
|
||||
DVI to PDF translator.
|
||||
|
||||
# without this define, the version is overriden by separated subpackages
|
||||
# versions
|
||||
%define version %{texlive_ver}
|
||||
@ -418,8 +378,6 @@ chmod -x texk/dvipdfm/encodings.c
|
||||
# TeX patches
|
||||
######
|
||||
|
||||
# Don't use tmpnam() in dvipdfm.
|
||||
%patch10 -p1 -b .dvipdfm-security
|
||||
# Fix parallel builds.
|
||||
%patch11 -p1 -b .makej
|
||||
# Don't use PID for temporary file names in scripts (RH bug #41269)
|
||||
@ -439,7 +397,6 @@ chmod -x texk/dvipdfm/encodings.c
|
||||
%patch29 -p1 -b .man-context
|
||||
|
||||
# fix non utf man pages
|
||||
%patch41 -p1 -b .notutf8
|
||||
%patch42 -p1 -b .notutf8-2
|
||||
# user a proper shellbang
|
||||
%patch43 -p1 -b .perl
|
||||
@ -457,7 +414,6 @@ chmod -x texk/dvipdfm/encodings.c
|
||||
%patch115 -p3
|
||||
%patch117 -p3
|
||||
%patch119 -p3
|
||||
%patch120 -p3
|
||||
%patch123 -p3
|
||||
|
||||
%patch202 -p1 -b .pdftex
|
||||
@ -552,11 +508,10 @@ popd
|
||||
--without-xdvik \
|
||||
--with-mf-x-toolkit=yes \
|
||||
--without-cxx-runtime-hack \
|
||||
%if !%{f8_packaging}
|
||||
--without-dvipng \
|
||||
--without-dvipdfm \
|
||||
--without-dvipdfmx \
|
||||
--without-xdvipdfmx
|
||||
%endif
|
||||
|
||||
# Remove everything except:
|
||||
# icu: includes some changes
|
||||
@ -770,13 +725,6 @@ rm -rf %{buildroot}
|
||||
[ -x /sbin/restorecon ] && /sbin/restorecon -R %{_texmf_var}/
|
||||
:
|
||||
|
||||
%if %{f8_packaging}
|
||||
%post -n dvipng
|
||||
[ -x /sbin/install-info ] && /sbin/install-info %{_infodir}/dvipng.info.gz %{_infodir}/dir
|
||||
[ -x /sbin/restorecon ] && /sbin/restorecon -R %{_texmf_var}/
|
||||
:
|
||||
%endif
|
||||
|
||||
|
||||
%preun
|
||||
if [ "$1" = 0 ]; then
|
||||
@ -791,15 +739,6 @@ if [ "$1" = 0 ]; then
|
||||
fi
|
||||
:
|
||||
|
||||
%if %{f8_packaging}
|
||||
%preun -n dvipng
|
||||
if [ "$1" = 0 ]; then
|
||||
[ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/dvipng.info.gz %{_infodir}/dir
|
||||
fi
|
||||
[ -x /sbin/restorecon ] && /sbin/restorecon -R %{_texmf_var}/
|
||||
:
|
||||
%endif
|
||||
|
||||
%preun latex
|
||||
if [ "$1" = 0 ]; then
|
||||
[ -x /sbin/install-info ] && /sbin/install-info --delete %{_infodir}/latex.info.gz %{_infodir}/dir
|
||||
@ -855,13 +794,6 @@ fi
|
||||
[ -x /sbin/restorecon ] && /sbin/restorecon -R %{_texmf_var}/
|
||||
:
|
||||
|
||||
%if %{f8_packaging}
|
||||
%postun -n dvipng
|
||||
%{_bindir}/texconfig-sys rehash 2> /dev/null
|
||||
[ -x /sbin/restorecon ] && /sbin/restorecon -R %{_texmf_var}/
|
||||
:
|
||||
%endif
|
||||
|
||||
%postun -n kpathsea
|
||||
/sbin/ldconfig
|
||||
[ -x /sbin/restorecon ] && /sbin/restorecon -R %{_texmf_var}/
|
||||
@ -1186,29 +1118,12 @@ fi
|
||||
# against the shared. I can't name any, but so i hear.
|
||||
%{_libdir}/libkpathsea.a
|
||||
|
||||
%if %{f8_packaging}
|
||||
%files -n dvipng
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/dvipng
|
||||
%{_mandir}/man1/dvipng.1*
|
||||
%{_infodir}/dvipng.info*
|
||||
%endif
|
||||
|
||||
%files -n mendexk
|
||||
%defattr(-,root,root,-)
|
||||
%doc %{_texmf_main}/doc/mendexk-%{name}/
|
||||
%{_bindir}/mendex
|
||||
%{_mandir}/ja/man1/mendex.1*
|
||||
|
||||
%files -n dvipdfm
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/ebb
|
||||
%{_bindir}/dvipdfm
|
||||
%{_bindir}/dvipdft
|
||||
%{_mandir}/man1/ebb.1*
|
||||
%{_mandir}/man1/dvipdfm.1*
|
||||
%{_mandir}/man1/dvipdft.1*
|
||||
|
||||
%files east-asian
|
||||
%doc %{_texmf_main}/doc/pdvipsk/
|
||||
%doc %{_texmf_main}/doc/ptex/
|
||||
@ -1278,6 +1193,11 @@ fi
|
||||
%{_mandir}/man1/texutil.1*
|
||||
|
||||
%changelog
|
||||
* Mon May 12 2008 Jindrich Novy <jnovy@redhat.com> - 2007-31
|
||||
- don't build/package dvipdfm, it's now packaged separately (#445983),
|
||||
thanks to Jonathan Underwood
|
||||
- remove F8 related chunks from spec
|
||||
|
||||
* Mon May 05 2008 Jindrich Novy <jnovy@redhat.com> - 2007-30
|
||||
- fix SELinux contexts everywhere possible, don't allow restorecon
|
||||
to fail (#444922)
|
||||
|
Loading…
x
Reference in New Issue
Block a user