Update to texinfo-5.1

This commit is contained in:
Vitezslav Crhonek 2013-03-18 13:13:19 +01:00
parent 9a27f22ab7
commit e1f207322e
6 changed files with 38 additions and 49 deletions

2
.gitignore vendored
View File

@ -2,3 +2,5 @@ texinfo-4.13a.tar.lzma
texinfo-4.13a.tar.lzma.sig
/texinfo-5.0.tar.xz
/texinfo-5.0.tar.xz.sig
/texinfo-5.1.tar.xz
/texinfo-5.1.tar.xz.sig

View File

@ -1,2 +1,2 @@
ef2fad34c71ddc95b20c7d6a08c0d7a6 texinfo-5.0.tar.xz
a1e46e27d14467b05abe652bfc30684e texinfo-5.0.tar.xz.sig
52ee905a3b705020d2a1b6ec36d53ca6 texinfo-5.1.tar.xz
65c8c95799ea5905e03cee5825d3553f texinfo-5.1.tar.xz.sig

View File

@ -1,6 +1,6 @@
diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/install-info.c
--- texinfo-5.0/install-info/install-info.c.orig 2013-01-07 00:18:56.000000000 +0100
+++ texinfo-5.0/install-info/install-info.c 2013-02-18 16:36:37.016947532 +0100
diff -up texinfo-5.1/install-info/install-info.c.orig texinfo-5.1/install-info/install-info.c
--- texinfo-5.1/install-info/install-info.c.orig 2013-03-09 03:21:55.000000000 +0100
+++ texinfo-5.1/install-info/install-info.c 2013-03-18 12:47:02.721136885 +0100
@@ -22,6 +22,7 @@
#include <getopt.h>
#include <regex.h>
@ -9,7 +9,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
#define TAB_WIDTH 8
@@ -665,7 +666,7 @@ The first time you invoke Info you start
@@ -670,7 +671,7 @@ The first time you invoke Info you start
MAGIC number, not the filename. */
@ -18,7 +18,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
open_possibly_compressed_file (char *filename,
void (*create_callback) (char *),
char **opened_filename, char **compression_program, int *is_pipe)
@@ -673,7 +674,7 @@ open_possibly_compressed_file (char *fil
@@ -678,7 +679,7 @@ open_possibly_compressed_file (char *fil
char *local_opened_filename, *local_compression_program;
int nread;
char data[13];
@ -27,7 +27,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
/* We let them pass NULL if they don't want this info, but it's easier
to always determine it. */
@@ -681,42 +682,42 @@ open_possibly_compressed_file (char *fil
@@ -686,48 +687,48 @@ open_possibly_compressed_file (char *fil
opened_filename = &local_opened_filename;
*opened_filename = filename;
@ -51,6 +51,13 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
free (*opened_filename);
*opened_filename = concat (filename, ".bz2", "");
- f = fopen (*opened_filename, FOPEN_RBIN);
+ f = gzopen (*opened_filename, FOPEN_RBIN);
}
if (!f)
{
free (*opened_filename);
*opened_filename = concat (filename, ".lz", "");
- f = fopen (*opened_filename, FOPEN_RBIN);
+ f = gzopen (*opened_filename, FOPEN_RBIN);
}
if (!f)
@ -77,7 +84,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
}
#endif /* __MSDOS__ */
if (!f)
@@ -728,7 +729,7 @@ open_possibly_compressed_file (char *fil
@@ -739,7 +740,7 @@ open_possibly_compressed_file (char *fil
/* And try opening it again. */
free (*opened_filename);
*opened_filename = filename;
@ -86,7 +93,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
if (!f)
pfatal_with_name (filename);
}
@@ -738,12 +739,12 @@ open_possibly_compressed_file (char *fil
@@ -749,12 +750,12 @@ open_possibly_compressed_file (char *fil
/* Read first few bytes of file rather than relying on the filename.
If the file is shorter than this it can't be usable anyway. */
@ -102,7 +109,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
fatal (_("%s: empty file"), *opened_filename);
pfatal_with_name (*opened_filename);
}
@@ -802,20 +803,22 @@ open_possibly_compressed_file (char *fil
@@ -821,20 +822,22 @@ open_possibly_compressed_file (char *fil
if (*compression_program)
{ /* It's compressed, so fclose the file and then open a pipe. */
@ -130,7 +137,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
/* Since this is a text file, and we opened it in binary mode,
switch back to text mode. */
f = freopen (*opened_filename, "r", f);
@@ -840,7 +843,7 @@ readfile (char *filename, int *sizep,
@@ -859,7 +862,7 @@ readfile (char *filename, int *sizep,
char **compression_program)
{
char *real_name;
@ -139,7 +146,7 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
int pipe_p;
int filled = 0;
int data_size = 8192;
@@ -854,7 +857,12 @@ readfile (char *filename, int *sizep,
@@ -873,7 +876,12 @@ readfile (char *filename, int *sizep,
for (;;)
{
@ -147,13 +154,13 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
+ int nread;
+
+ if (pipe_p)
+ nread = fread (data + filled, 1, data_size - filled, f);
+ nread = fread (data + filled, 1, data_size - filled, f);
+ else
+ nread = gzread (f, data + filled, data_size - filled);
+ nread = gzread (f, data + filled, data_size - filled);
if (nread < 0)
pfatal_with_name (real_name);
if (nread == 0)
@@ -876,7 +884,7 @@ readfile (char *filename, int *sizep,
@@ -895,7 +903,7 @@ readfile (char *filename, int *sizep,
if (pipe_p)
pclose (f);
else
@ -162,10 +169,10 @@ diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/i
*sizep = filled;
return data;
diff -up texinfo-5.0/install-info/Makefile.in.orig texinfo-5.0/install-info/Makefile.in
--- texinfo-5.0/install-info/Makefile.in.orig 2013-02-16 18:23:16.000000000 +0100
+++ texinfo-5.0/install-info/Makefile.in 2013-02-18 16:36:09.633794780 +0100
@@ -168,7 +168,7 @@ am__installdirs = "$(DESTDIR)$(bindir)"
diff -up texinfo-5.1/install-info/Makefile.in.orig texinfo-5.1/install-info/Makefile.in
--- texinfo-5.1/install-info/Makefile.in.orig 2013-03-12 23:56:43.000000000 +0100
+++ texinfo-5.1/install-info/Makefile.in 2013-03-18 12:42:57.165767101 +0100
@@ -171,7 +171,7 @@ am__installdirs = "$(DESTDIR)$(bindir)"
PROGRAMS = $(bin_PROGRAMS)
am_ginstall_info_OBJECTS = install-info.$(OBJEXT)
ginstall_info_OBJECTS = $(am_ginstall_info_OBJECTS)

View File

@ -1,7 +1,7 @@
diff -up texinfo-5.0/install-info/install-info.c.orig texinfo-5.0/install-info/install-info.c
--- texinfo-5.0/install-info/install-info.c.orig 2013-02-18 13:12:08.367509306 +0100
+++ texinfo-5.0/install-info/install-info.c 2013-02-18 13:13:06.573834074 +0100
@@ -816,7 +816,7 @@ open_possibly_compressed_file (char *fil
diff -up texinfo-5.1/install-info/install-info.c.orig texinfo-5.1/install-info/install-info.c
--- texinfo-5.1/install-info/install-info.c.orig 2013-03-18 12:37:15.375860494 +0100
+++ texinfo-5.1/install-info/install-info.c 2013-03-18 12:37:42.589012295 +0100
@@ -835,7 +835,7 @@ open_possibly_compressed_file (char *fil
}
else
{ /* It's a plain file, seek back over the magic bytes. */

View File

@ -1,20 +0,0 @@
diff -up texinfo-5.0/tp/Texinfo/Parser.pm.orig texinfo-5.0/tp/Texinfo/Parser.pm
--- texinfo-5.0/tp/Texinfo/Parser.pm.orig 2013-02-15 00:01:44.000000000 +0100
+++ texinfo-5.0/tp/Texinfo/Parser.pm 2013-03-05 14:33:25.384193273 +0100
@@ -1631,9 +1631,13 @@ sub _close_current($$$;$$)
my $conditional = pop @{$current->{'parent'}->{'contents'}};
}
}
- my $context = pop @{$self->{'context_stack'}} if
- ($preformatted_commands{$current->{'cmdname'}}
- or $menu_commands{$current->{'cmdname'}});
+ if ($preformatted_commands{$current->{'cmdname'}}
+ or $menu_commands{$current->{'cmdname'}}
+ or $format_raw_commands{$current->{'cmdname'}}) {
+ my $context = pop @{$self->{'context_stack'}};
+ pop @{$self->{'raw_formats_stack'}}
+ if ($format_raw_commands{$current->{'cmdname'}});
+ }
pop @{$self->{'regions_stack'}}
if ($region_commands{$current->{'cmdname'}});
$current = $current->{'parent'};

View File

@ -2,8 +2,8 @@
Summary: Tools needed to create Texinfo format documentation files
Name: texinfo
Version: 5.0
Release: 3%{?dist}
Version: 5.1
Release: 1%{?dist}
License: GPLv3+
Group: Applications/Publishing
Url: http://www.gnu.org/software/texinfo/
@ -12,8 +12,6 @@ Source1: ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.xz.sig
Source2: info-dir
Patch0: texinfo-4.12-zlib.patch
Patch1: texinfo-4.13a-powerpc.patch
# Backported from upstream
Patch2: texinfo-5.0-parser.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
Requires: perl >= 5.7.3, perl(Text::Unidecode)
@ -59,7 +57,6 @@ for printing using TeX.
%setup -q
%patch0 -p1 -b .zlib
%patch1 -p1 -b .powerpc
%patch2 -p1 -b .parser
%build
%configure --with-external-Text-Unidecode \
@ -154,6 +151,9 @@ fi
%{_mandir}/man1/pdftexi2dvi.1*
%changelog
* Mon Mar 18 2013 Vitezslav Crhonek <vcrhonek@redhat.com> - 5.1-1
- Update to texinfo-5.1
* Tue Mar 05 2013 Vitezslav Crhonek <vcrhonek@redhat.com> - 5.0-3
- Fix bug in parser
Resolves: #917974