Update to texinfo-6.1

This commit is contained in:
Vitezslav Crhonek 2016-02-11 09:35:16 +01:00
parent 42c62beba7
commit bea7cd4cab
5 changed files with 92 additions and 28 deletions

2
.gitignore vendored
View File

@ -8,3 +8,5 @@ texinfo-4.13a.tar.lzma.sig
/texinfo-5.2.tar.xz.sig
/texinfo-6.0.tar.xz
/texinfo-6.0.tar.xz.sig
/texinfo-6.1.tar.xz
/texinfo-6.1.tar.xz.sig

View File

@ -1,2 +1,2 @@
02818e62a5b8ae0213a7ff572991bb50 texinfo-6.0.tar.xz
6fe30fbdabab79a55ebd0b2608fa6847 texinfo-6.0.tar.xz.sig
1d7ec1888fae00730693597852b00cde texinfo-6.1.tar.xz
d58158e37a901cff25d2cb4dab4a04a6 texinfo-6.1.tar.xz.sig

View File

@ -1,6 +1,6 @@
diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/install-info.c
--- texinfo-6.0/install-info/install-info.c.orig 2015-02-27 19:57:27.000000000 +0100
+++ texinfo-6.0/install-info/install-info.c 2015-06-29 16:28:05.570329815 +0200
diff -up texinfo-6.1/install-info/install-info.c.orig texinfo-6.1/install-info/install-info.c
--- texinfo-6.1/install-info/install-info.c.orig 2016-02-06 13:20:24.000000000 +0100
+++ texinfo-6.1/install-info/install-info.c 2016-02-11 09:19:15.646258510 +0100
@@ -22,6 +22,7 @@
#include <getopt.h>
#include <regex.h>
@ -18,7 +18,7 @@ diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/i
open_possibly_compressed_file (char *filename,
void (*create_callback) (char *),
- char **opened_filename, char **compression_program)
+ char **opened_filename, char **compression_program, int *is_pipe)
+ char **opened_filename, char **compression_program, int *is_pipe)
{
char *local_opened_filename, *local_compression_program;
int nread;
@ -94,7 +94,7 @@ diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/i
if (!f)
return 0;
}
@@ -767,12 +768,12 @@ open_possibly_compressed_file (char *fil
@@ -767,26 +768,26 @@ open_possibly_compressed_file (char *fil
/* Read first few bytes of file rather than relying on the filename.
If the file is shorter than this it can't be usable anyway. */
@ -103,14 +103,33 @@ diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/i
+ nread = gzread (f, data, sizeof (data));
+ if (nread != sizeof (data))
{
/* Empty files don't set errno. Calling code can check for
this, so make sure errno == 0 just in case it isn't already. */
- if (nread == 0)
+ if (nread >= 0)
errno = 0;
return 0;
}
@@ -838,35 +839,40 @@ open_possibly_compressed_file (char *fil
{
/* Try to create the file if its empty. */
- if (feof (f) && create_callback)
+ if (gzeof (f) && create_callback)
{
- if (fclose (f) != 0)
+ if (gzclose (f) < 0)
return 0; /* unknown error closing file */
if (remove (filename) != 0)
return 0; /* unknown error deleting file */
(*create_callback) (filename);
- f = fopen (*opened_filename, FOPEN_RBIN);
+ f = gzopen (*opened_filename, FOPEN_RBIN);
if (!f)
return 0;
- nread = fread (data, sizeof (data), 1, f);
- if (nread == 0)
+ nread = gzread (f, data, sizeof (data));
+ if (nread <= 0)
return 0;
goto determine_file_type; /* success */
}
@@ -857,35 +858,40 @@ determine_file_type:
*compression_program = NULL;
/* Seek back over the magic bytes. */
@ -158,7 +177,7 @@ diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/i
}
return f;
@@ -885,7 +891,8 @@ readfile (char *filename, int *sizep,
@@ -904,7 +910,8 @@ readfile (char *filename, int *sizep,
void (*create_callback) (char *), char **opened_filename,
char **compression_program)
{
@ -168,7 +187,7 @@ diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/i
int filled = 0;
int data_size = 8192;
char *data = xmalloc (data_size);
@@ -893,14 +900,20 @@ readfile (char *filename, int *sizep,
@@ -912,14 +919,20 @@ readfile (char *filename, int *sizep,
/* If they passed the space for the file name to return, use it. */
f = open_possibly_compressed_file (filename, create_callback,
opened_filename,
@ -191,7 +210,7 @@ diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/i
if (nread < 0)
return 0;
if (nread == 0)
@@ -919,8 +932,10 @@ readfile (char *filename, int *sizep,
@@ -938,8 +951,10 @@ readfile (char *filename, int *sizep,
/* We need to close the stream, since on some systems the pipe created
by popen is simulated by a temporary file which only gets removed
inside pclose. */
@ -203,10 +222,10 @@ diff -up texinfo-6.0/install-info/install-info.c.orig texinfo-6.0/install-info/i
*sizep = filled;
return data;
diff -up texinfo-6.0/install-info/Makefile.in.orig texinfo-6.0/install-info/Makefile.in
--- texinfo-6.0/install-info/Makefile.in.orig 2015-06-26 14:51:08.000000000 +0200
+++ texinfo-6.0/install-info/Makefile.in 2015-06-29 16:18:59.342902368 +0200
@@ -241,7 +241,7 @@ am__installdirs = "$(DESTDIR)$(bindir)"
diff -up texinfo-6.1/install-info/Makefile.in.orig texinfo-6.1/install-info/Makefile.in
--- texinfo-6.1/install-info/Makefile.in.orig 2016-02-06 13:24:05.000000000 +0100
+++ texinfo-6.1/install-info/Makefile.in 2016-02-11 09:17:14.660744184 +0100
@@ -215,7 +215,7 @@ am__installdirs = "$(DESTDIR)$(bindir)"
PROGRAMS = $(bin_PROGRAMS)
am_ginstall_info_OBJECTS = install-info.$(OBJEXT)
ginstall_info_OBJECTS = $(am_ginstall_info_OBJECTS)

View File

@ -1,7 +1,7 @@
diff -up texinfo-6.0/info/Makefile.in.orig texinfo-6.0/info/Makefile.in
--- texinfo-6.0/info/Makefile.in.orig 2015-07-14 13:17:44.298882856 +0200
+++ texinfo-6.0/info/Makefile.in 2015-07-14 13:18:13.082004108 +0200
@@ -1695,7 +1695,6 @@ TESTS = \
diff -up texinfo-6.1/info/Makefile.in.orig texinfo-6.1/info/Makefile.in
--- texinfo-6.1/info/Makefile.in.orig 2016-02-06 13:24:05.000000000 +0100
+++ texinfo-6.1/info/Makefile.in 2016-02-09 12:48:35.505942307 +0100
@@ -1342,7 +1342,6 @@ TESTS = \
t/end-of-line.sh \
t/goal-column.sh \
t/star-note-non-whitespace.sh \
@ -9,3 +9,41 @@ diff -up texinfo-6.0/info/Makefile.in.orig texinfo-6.0/info/Makefile.in
t/last-no-history.sh \
t/split-footnotes.sh \
t/window-split-dir.sh \
@@ -1365,10 +1364,6 @@ TESTS = \
t/replace-viewed.sh \
t/search-skip-screen.sh \
t/search-empty.sh \
- t/inc-sea-forward.sh \
- t/inc-sea-forward-nonregex.sh \
- t/inc-sea-insensitive.sh \
- t/inc-sea-history.sh \
t/gc-split.sh \
t/anchor-positions.sh \
t/quoted-label-as-target.sh \
diff -up texinfo-6.1/tp/tests/Makefile.in.orig texinfo-6.1/tp/tests/Makefile.in
--- texinfo-6.1/tp/tests/Makefile.in.orig 2016-02-09 12:49:19.741103869 +0100
+++ texinfo-6.1/tp/tests/Makefile.in 2016-02-09 12:50:34.780377935 +0100
@@ -1286,7 +1286,6 @@ one_test_files_generated_list = \
test_scripts/sectioning_top_node_up_explicit.sh \
test_scripts/coverage_texi_formatting.sh \
test_scripts/coverage_formatting.sh \
- test_scripts/coverage_formatting_fr.sh \
test_scripts/coverage_formatting_cr.sh \
test_scripts/indices_double_index_entry.sh \
test_scripts/indices_split_chapter_index.sh \
@@ -1391,7 +1390,6 @@ one_test_files_generated_list = \
test_scripts/layout_formatting_html32.sh \
test_scripts/layout_formatting_regions.sh \
test_scripts/layout_formatting_exotic.sh \
- test_scripts/layout_formatting_fr_icons.sh \
test_scripts/layout_formatting_chm.sh \
test_scripts/layout_formatting_nodes.sh \
test_scripts/formatting_texi_glossary.sh \
@@ -1421,7 +1419,6 @@ one_test_files_generated_list = \
test_scripts/formatting_simplest_test_prefix_info.sh \
test_scripts/formatting_simplest_test_css.sh \
test_scripts/formatting_simplest_test_date_in_header.sh \
- test_scripts/formatting_documentlanguage_set_option.sh \
test_scripts/formatting_documentlanguage_set_unknown.sh \
test_scripts/formatting_documentlanguage_set_option_info.sh \
test_scripts/formatting_float_copying.sh \

View File

@ -2,8 +2,8 @@
Summary: Tools needed to create Texinfo format documentation files
Name: texinfo
Version: 6.0
Release: 3%{?dist}
Version: 6.1
Release: 1%{?dist}
License: GPLv3+
Group: Applications/Publishing
Url: http://www.gnu.org/software/texinfo/
@ -13,6 +13,7 @@ Source2: info-dir
# Source5: macro definitions
Source5: macros.info
Patch0: texinfo-4.12-zlib.patch
# this is needed just for koji/mock, all test pass fine in local build
Patch1: texinfo-6.0-disable-failing-info-test.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
@ -68,7 +69,8 @@ for printing using TeX.
%build
%configure --with-external-Text-Unidecode \
--with-external-libintl-perl \
--with-external-Unicode-EastAsianWidth
--with-external-Unicode-EastAsianWidth \
--disable-perl-xs
make %{?_smp_mflags}
%install
@ -146,7 +148,6 @@ fi
%{!?_licensedir:%global license %%doc}
%license COPYING
%{_bindir}/info
%{_infodir}/info.info*
%{_infodir}/info-stnd.info*
/sbin/install-info
%{_mandir}/man1/info.1*
@ -166,6 +167,10 @@ fi
%{_mandir}/man1/pdftexi2dvi.1*
%changelog
* Thu Feb 11 2016 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.1-1
- Update to texinfo-6.1
Resolves: #1305316
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild