Backport patch to restore equality between cmake and autotools generated pkgconfig file

This commit is contained in:
Sandro Mani 2022-09-23 12:46:20 +02:00
parent 1c7b1feb9b
commit f671966b22
3 changed files with 20 additions and 3 deletions

11
aee19fcf8eb832.patch Normal file
View File

@ -0,0 +1,11 @@
diff -rupN --no-dereference tesseract-5.2.0/tesseract.pc.cmake tesseract-5.2.0-new/tesseract.pc.cmake
--- tesseract-5.2.0/tesseract.pc.cmake 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/tesseract.pc.cmake 2022-09-23 12:46:10.892721057 +0200
@@ -7,6 +7,7 @@ Name: @tesseract_NAME@
Description: An OCR Engine that was developed at HP Labs between 1985 and 1995... and now at Google.
URL: https://github.com/tesseract-ocr/tesseract
Version: @tesseract_VERSION@
+Requires.private: lept
Libs: -L${libdir} -l@tesseract_OUTPUT_NAME@ @libarchive_LIBS@ @libcurl_LIBS@ @TENSORFLOW_LIBS@
Libs.private:
Cflags: -I${includedir}

View File

@ -2,7 +2,7 @@
Name: tesseract
Version: 5.2.0
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Raw OCR Engine
License: ASL 2.0
@ -14,6 +14,8 @@ Source0: https://github.com/tesseract-ocr/tesseract/archive/%{version}%{?p
# Honour TESSDATA_PREFIX
# Build training libs statically
Patch0: tesseract_cmake.patch
# Backport patch to restore equality between cmake and autotools generated pkgconfig file
Patch1: https://github.com/tesseract-ocr/tesseract/commit/aee19fcf8eb832.patch
BuildRequires: cmake
@ -224,6 +226,10 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%changelog
* Fri Sep 23 2022 Sandro Mani <manisandro@gmail.com> - 5.2.0-5
- Backport patch to restore equality between cmake and autotools generated
pkgconfig file
* Fri Aug 05 2022 Sandro Mani <manisandro@gmail.com> - 5.2.0-4
- Rebuild (icu)

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0-new/CMakeLists.txt
--- tesseract-5.2.0/CMakeLists.txt 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/CMakeLists.txt 2022-07-07 09:35:17.943005144 +0200
+++ tesseract-5.2.0-new/CMakeLists.txt 2022-09-23 12:46:10.843721046 +0200
@@ -336,7 +336,7 @@ elseif(UNIX)
set(LIB_pthread pthread)
endif()
@ -40,7 +40,7 @@ diff -rupN --no-dereference tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0-new/C
# ##############################################################################
diff -rupN --no-dereference tesseract-5.2.0/src/training/CMakeLists.txt tesseract-5.2.0-new/src/training/CMakeLists.txt
--- tesseract-5.2.0/src/training/CMakeLists.txt 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/src/training/CMakeLists.txt 2022-07-07 09:35:17.943005144 +0200
+++ tesseract-5.2.0-new/src/training/CMakeLists.txt 2022-09-23 12:46:10.843721046 +0200
@@ -108,7 +108,7 @@ if(NOT DISABLED_LEGACY_ENGINE)
common/trainingsampleset.h)
endif()