Update to 5.2.0

This commit is contained in:
Sandro Mani 2022-07-08 10:06:33 +02:00
parent d57de79962
commit 7d573208d5
4 changed files with 19 additions and 15 deletions

1
.gitignore vendored
View File

@ -22,3 +22,4 @@ tesseract-2.00.eng.tar.gz
/tesseract-5.0.0.tar.gz
/tesseract-5.0.1.tar.gz
/tesseract-5.1.0.tar.gz
/tesseract-5.2.0.tar.gz

View File

@ -1 +1 @@
SHA512 (tesseract-5.1.0.tar.gz) = d874fc995182c2c7ce210ebd79ad36414fa73afc53063505bc0b0aa0f090dc48db09c650c86a727778584f34a421b7d64c129cefe282ea112560cd7ca24e7f59
SHA512 (tesseract-5.2.0.tar.gz) = 23ed931495e4ea793904f99a06a95a47873b923c4e5d8f3fc8f9203cac86b0e0013c416ab4d8d4a863a081eea00a196a0198c6fb17a39917a1baea2280d84794

View File

@ -1,8 +1,8 @@
#global pre beta.4
Name: tesseract
Version: 5.1.0
Release: 3%{?pre:.%pre}%{?dist}
Version: 5.2.0
Release: 1%{?dist}
Summary: Raw OCR Engine
License: ASL 2.0
@ -154,7 +154,7 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%license LICENSE
%doc AUTHORS ChangeLog README.md
%{_bindir}/%{name}
%{_libdir}/lib%{name}.so.5.1.0
%{_libdir}/lib%{name}.so.5.2.0
%{_datadir}/%{name}/
%{_mandir}/man1/tesseract.1*
@ -200,7 +200,7 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%files -n mingw32-%{name}
%license LICENSE
%{mingw32_bindir}/libtesseract-51.dll
%{mingw32_bindir}/libtesseract-52.dll
%{mingw32_includedir}/tesseract/
%{mingw32_libdir}/libtesseract.dll.a
%{mingw32_libdir}/pkgconfig/tesseract.pc
@ -212,7 +212,7 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%files -n mingw64-%{name}
%license LICENSE
%{mingw64_bindir}/libtesseract-51.dll
%{mingw64_bindir}/libtesseract-52.dll
%{mingw64_includedir}/tesseract/
%{mingw64_libdir}/libtesseract.dll.a
%{mingw64_libdir}/pkgconfig/tesseract.pc
@ -224,6 +224,9 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%changelog
* Thu Jul 07 2022 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
- Update to 5.2.0
* Fri Mar 25 2022 Sandro Mani <manisandro@gmail.com> - 5.1.0-3
- Rebuild with mingw-gcc-12

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference tesseract-5.1.0/CMakeLists.txt tesseract-5.1.0-new/CMakeLists.txt
--- tesseract-5.1.0/CMakeLists.txt 2022-03-01 17:25:45.000000000 +0100
+++ tesseract-5.1.0-new/CMakeLists.txt 2022-03-02 15:47:55.575671906 +0100
@@ -328,7 +328,7 @@ elseif(UNIX)
diff -rupN --no-dereference tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0-new/CMakeLists.txt
--- tesseract-5.2.0/CMakeLists.txt 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/CMakeLists.txt 2022-07-07 09:35:17.943005144 +0200
@@ -336,7 +336,7 @@ elseif(UNIX)
set(LIB_pthread pthread)
endif()
elseif(WIN32)
@ -10,7 +10,7 @@ diff -rupN --no-dereference tesseract-5.1.0/CMakeLists.txt tesseract-5.1.0-new/C
endif()
add_definitions("-DCMAKE_BUILD")
@@ -770,11 +770,14 @@ set_target_properties(libtesseract
@@ -807,11 +807,14 @@ set_target_properties(libtesseract
set_target_properties(libtesseract
PROPERTIES SOVERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH})
@ -26,7 +26,7 @@ diff -rupN --no-dereference tesseract-5.1.0/CMakeLists.txt tesseract-5.1.0-new/C
else()
set_target_properties(libtesseract PROPERTIES OUTPUT_NAME tesseract)
endif()
@@ -882,9 +885,9 @@ install(
@@ -926,9 +929,9 @@ install(
if(INSTALL_CONFIGS)
install(FILES ${TESSERACT_CONFIGS}
@ -38,9 +38,9 @@ diff -rupN --no-dereference tesseract-5.1.0/CMakeLists.txt tesseract-5.1.0-new/C
endif()
# ##############################################################################
diff -rupN tesseract-5.1.0/src/training/CMakeLists.txt tesseract-5.1.0-new/src/training/CMakeLists.txt
--- tesseract-5.1.0/src/training/CMakeLists.txt 2022-03-01 17:25:45.000000000 +0100
+++ tesseract-5.1.0-new/src/training/CMakeLists.txt 2022-03-11 11:14:25.962728696 +0100
diff -rupN --no-dereference tesseract-5.2.0/src/training/CMakeLists.txt tesseract-5.2.0-new/src/training/CMakeLists.txt
--- tesseract-5.2.0/src/training/CMakeLists.txt 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/src/training/CMakeLists.txt 2022-07-07 09:35:17.943005144 +0200
@@ -108,7 +108,7 @@ if(NOT DISABLED_LEGACY_ENGINE)
common/trainingsampleset.h)
endif()