Update to 5.3.0

This commit is contained in:
Sandro Mani 2022-12-23 16:02:49 +01:00
parent 7cabe1c16d
commit 51ab91d575
5 changed files with 28 additions and 31 deletions

1
.gitignore vendored
View File

@ -23,3 +23,4 @@ tesseract-2.00.eng.tar.gz
/tesseract-5.0.1.tar.gz
/tesseract-5.1.0.tar.gz
/tesseract-5.2.0.tar.gz
/tesseract-5.3.0.tar.gz

View File

@ -1,11 +0,0 @@
diff -rupN --no-dereference tesseract-5.2.0/tesseract.pc.cmake tesseract-5.2.0-new/tesseract.pc.cmake
--- tesseract-5.2.0/tesseract.pc.cmake 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/tesseract.pc.cmake 2022-09-23 12:46:10.892721057 +0200
@@ -7,6 +7,7 @@ Name: @tesseract_NAME@
Description: An OCR Engine that was developed at HP Labs between 1985 and 1995... and now at Google.
URL: https://github.com/tesseract-ocr/tesseract
Version: @tesseract_VERSION@
+Requires.private: lept
Libs: -L${libdir} -l@tesseract_OUTPUT_NAME@ @libarchive_LIBS@ @libcurl_LIBS@ @TENSORFLOW_LIBS@
Libs.private:
Cflags: -I${includedir}

View File

@ -1 +1 @@
SHA512 (tesseract-5.2.0.tar.gz) = 23ed931495e4ea793904f99a06a95a47873b923c4e5d8f3fc8f9203cac86b0e0013c416ab4d8d4a863a081eea00a196a0198c6fb17a39917a1baea2280d84794
SHA512 (tesseract-5.3.0.tar.gz) = fc0cfda980059390b7d6d3d8e475b4ecc9dcfee1abc3b16fc9ffc8904db0a0847a5f6f1b32bd2e1f6f5a714a8c4df0fb3dc7c6aa25ece6162bf52fe86b4d0f34

View File

@ -1,8 +1,8 @@
#global pre beta.4
Name: tesseract
Version: 5.2.0
Release: 6%{?dist}
Version: 5.3.0
Release: 1%{?dist}
Summary: Raw OCR Engine
License: Apache-2.0
@ -14,8 +14,6 @@ Source0: https://github.com/tesseract-ocr/tesseract/archive/%{version}%{?p
# Honour TESSDATA_PREFIX
# Build training libs statically
Patch0: tesseract_cmake.patch
# Backport patch to restore equality between cmake and autotools generated pkgconfig file
Patch1: https://github.com/tesseract-ocr/tesseract/commit/aee19fcf8eb832.patch
BuildRequires: cmake
@ -156,13 +154,15 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%license LICENSE
%doc AUTHORS ChangeLog README.md
%{_bindir}/%{name}
%{_libdir}/lib%{name}.so.5.2.0
%{_libdir}/lib%{name}.so.5.3.0
%{_datadir}/%{name}/
%{_mandir}/man1/tesseract.1*
%files devel
%{_includedir}/%{name}
%{_libdir}/lib%{name}.so
%{_libdir}/libcommon_training.a
%{_libdir}/libunicharset_training.a
%{_libdir}/cmake/%{name}/
%{_libdir}/pkgconfig/%{name}.pc
@ -202,9 +202,11 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%files -n mingw32-%{name}
%license LICENSE
%{mingw32_bindir}/libtesseract-52.dll
%{mingw32_bindir}/libtesseract-53.dll
%{mingw32_includedir}/tesseract/
%{mingw32_libdir}/libtesseract.dll.a
%{mingw32_libdir}/libcommon_training.a
%{mingw32_libdir}/libunicharset_training.a
%{mingw32_libdir}/pkgconfig/tesseract.pc
%{mingw32_libdir}/cmake/%{name}/
%{mingw32_datadir}/%{name}/
@ -214,9 +216,11 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%files -n mingw64-%{name}
%license LICENSE
%{mingw64_bindir}/libtesseract-52.dll
%{mingw64_bindir}/libtesseract-53.dll
%{mingw64_includedir}/tesseract/
%{mingw64_libdir}/libtesseract.dll.a
%{mingw64_libdir}/libcommon_training.a
%{mingw64_libdir}/libunicharset_training.a
%{mingw64_libdir}/pkgconfig/tesseract.pc
%{mingw64_libdir}/cmake/%{name}/
%{mingw64_datadir}/%{name}/
@ -226,6 +230,9 @@ cp -a doc/*.5 %{buildroot}%{_mandir}/man5/
%changelog
* Fri Dec 23 2022 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
- Update to 5.3.0
* Wed Dec 21 2022 Sandro Mani <manisandro@gmail.com> - 5.2.0-6
- Rebuild (leptonica)

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0-new/CMakeLists.txt
--- tesseract-5.2.0/CMakeLists.txt 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/CMakeLists.txt 2022-09-23 12:46:10.843721046 +0200
@@ -336,7 +336,7 @@ elseif(UNIX)
diff -rupN --no-dereference tesseract-5.3.0/CMakeLists.txt tesseract-5.3.0-new/CMakeLists.txt
--- tesseract-5.3.0/CMakeLists.txt 2022-12-22 14:57:57.000000000 +0100
+++ tesseract-5.3.0-new/CMakeLists.txt 2022-12-23 10:33:09.303707322 +0100
@@ -345,7 +345,7 @@ elseif(UNIX)
set(LIB_pthread pthread)
endif()
elseif(WIN32)
@ -10,7 +10,7 @@ diff -rupN --no-dereference tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0-new/C
endif()
add_definitions("-DCMAKE_BUILD")
@@ -807,11 +807,14 @@ set_target_properties(libtesseract
@@ -812,11 +812,14 @@ set_target_properties(libtesseract
set_target_properties(libtesseract
PROPERTIES SOVERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH})
@ -26,7 +26,7 @@ diff -rupN --no-dereference tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0-new/C
else()
set_target_properties(libtesseract PROPERTIES OUTPUT_NAME tesseract)
endif()
@@ -926,9 +929,9 @@ install(
@@ -931,9 +934,9 @@ install(
if(INSTALL_CONFIGS)
install(FILES ${TESSERACT_CONFIGS}
@ -38,10 +38,10 @@ diff -rupN --no-dereference tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0-new/C
endif()
# ##############################################################################
diff -rupN --no-dereference tesseract-5.2.0/src/training/CMakeLists.txt tesseract-5.2.0-new/src/training/CMakeLists.txt
--- tesseract-5.2.0/src/training/CMakeLists.txt 2022-07-06 22:15:49.000000000 +0200
+++ tesseract-5.2.0-new/src/training/CMakeLists.txt 2022-09-23 12:46:10.843721046 +0200
@@ -108,7 +108,7 @@ if(NOT DISABLED_LEGACY_ENGINE)
diff -rupN --no-dereference tesseract-5.3.0/src/training/CMakeLists.txt tesseract-5.3.0-new/src/training/CMakeLists.txt
--- tesseract-5.3.0/src/training/CMakeLists.txt 2022-12-22 14:57:57.000000000 +0100
+++ tesseract-5.3.0-new/src/training/CMakeLists.txt 2022-12-23 10:33:09.303707322 +0100
@@ -115,7 +115,7 @@ if(NOT DISABLED_LEGACY_ENGINE)
common/trainingsampleset.h)
endif()
@ -50,7 +50,7 @@ diff -rupN --no-dereference tesseract-5.2.0/src/training/CMakeLists.txt tesserac
target_include_directories(common_training PUBLIC common
${CMAKE_CURRENT_BINARY_DIR})
target_link_libraries(common_training PUBLIC libtesseract)
@@ -242,7 +242,7 @@ if(ICU_FOUND)
@@ -254,7 +254,7 @@ if(ICU_FOUND)
file(GLOB unicharset_training_src unicharset/*)
@ -59,7 +59,7 @@ diff -rupN --no-dereference tesseract-5.2.0/src/training/CMakeLists.txt tesserac
if(SW_BUILD)
target_link_libraries(unicharset_training
PUBLIC common_training org.sw.demo.unicode.icu.i18n)
@@ -361,7 +361,7 @@ if(ICU_FOUND)
@@ -378,7 +378,7 @@ if(ICU_FOUND)
file(GLOB pango_training_src pango/*)